ratzekahl1
Goto Top

UDP bei RDP abstellen

Halllo zusammen,
ich habe eine Frage: Gegeben ist ein Widndows 2019 Server, ein RDP Server und einige WIndows 10 Clients mit aktuellen Updates.
Nun habe ich das Problem, wie viele andere auch, dass RDP alle Naselang einfriert.
Google sagt mir, dass die Deaktivierung von UDP auf den Clients zum Erfolg geführt. Gleichzeitig könne man auf dem Zielrechner, aso dem TS
Den Schlüssel “HKEY_LOCAL_MACHINE -> Software -> Policies -> Microsoft -> Windows NT -> Terminal Services -> Client” öffnen.

Einen neuen “DWORD 32” Eintrag mit dem Namen “fClientDisableUDP” erstelle und den Wert 1 zuweisen.
In den lokalen GPOs des Clients:
Zu “Computer Configuration > Administration Templates > Windows Components > Remote Desktop Services > Remote Desktop Connection Client” navigieren.

Die Option "Turn Off UDP On Client" aktivieren. Und dann noch unter Administrative Vorlagen Remotedesktopdienste RDP Host Verbindungen Transportprotokoll auswählen und auf TCP gestellt-
Einen Testclient genommen und seit dem keine Abstürze mehr.

Aber die Einstellung auf dem TS alleine brachte keinen Erfolg. Erst die Änderung der lokalen GPO-
Nun liegt die Idee recht nahe, das Ganze via GPos zu verteilen. Also fix gpo angelegt.
Die beiden Einträge angelegt und an die Domänen-Computer delegiert.
Zur Sicherheit noch einmal gpupdate /force hinterhergeschickt. PC neu gestartet.

Klicke ich dann im rdp auf das Balkendreieck, sagt er mir immer noch udp aktiviert...
Wo ist der Fehler`?
mfG
ratzekahl

Content-Key: 1292288014

Url: https://administrator.de/contentid/1292288014

Printed on: February 8, 2023 at 10:02 o'clock

Member: psannz
psannz Sep 22, 2021 at 13:50:48 (UTC)
Goto Top
Sers,

verwendet ihr ein RDS Gateway? Dann musst du UDP auf diesem auch verbieten. Geht etwa in der GUI über die Eigenschaften und Transporteinstellungen.

Grüße,
Philip
Member: ratzekahl1
ratzekahl1 Sep 22, 2021 at 14:24:20 (UTC)
Goto Top
Waow, das war schnell. Danke!
Nein. Ganz simples RDP über VPN.
Wenn ich von Hand an den Client gehe und es dort eintrage funktionert es. Nur halt nicht nicht verteilt.
mfG
ratzekahl
Member: psannz
psannz Sep 22, 2021 updated at 15:20:09 (UTC)
Goto Top
Neustart vom RDSH dürftest du schon gemacht haben.
Ob die Einstellung der lokalen Richtlinien durch GPO überschrieben werden hast du sicher schon getestet, oder? rsop.msc zeigt dir an welche Settings via GPO gesetzt werden. GPO > LPO.

Einfachster alternativer Weg: Mach den RDP via UDP Zugang in der Firewall auf dem RDSH dicht.
"Remotedesktop - Benutzermodus (UDP eingehend)" deaktivieren & gut sollte es sein.
Member: ratzekahl1
ratzekahl1 Sep 25, 2021 at 07:56:33 (UTC)
Goto Top
Hallo, ich habe es nun gelöst
via Registry.
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\Terminal Services\Client
Dem neuen DWORD 32-Bit Wert „fClientDisableUDP“ dann noch den Wert „1“ zuweisen.
Via gpo verteilt und keine Beschwerden mehr.