UltraVNC: authentification rejected

stefanmuc
Goto Top
Hallo,

ich möchte von einem Win10 zu enem anderen Win10-Rechner innerhalb des gleichen Netzwerks eine VNC-Verbindung aufbauen. Leider kommt nach Eingabe des VNC-Passworts im Client immer die Fehlermeldung: authentification rejected

Server:
Download und Installation von UltraVNC (Version 1.2.40 bzw 1.2.50).
Unter "Admin Properties"/"Authentification" das individuelle VNC-Passwort hinterlegen
Start des VNC-Servers

Client:
Download und Installation von UltraVNC (Version 1.2.40 bzw 1.2.50).
Start des Clients
Login-Versuch, Abbruch mit der Fehlermeldung "authentification rejected"

Der Port 5900 am Server ist von außen erreichbar, per telnet vom Client aus getestet. VNC meldet sich.

mslogon.log am VNC-Server:
11/9/2020 0:18 Connection received from 192.168.1.xx
11/9/2020 0:19 Invalid attempt from client 192.168.1.xx


Was mache ich falsch, dass ich ständig "authentification rejected" bekomme?

Content-Key: 603650

Url: https://administrator.de/contentid/603650

Ausgedruckt am: 29.05.2022 um 14:05 Uhr

Mitglied: brammer
brammer 11.09.2020 um 12:03:44 Uhr
Goto Top
Hallo,

entweder ein Tippfehler im Passwort oder du versuchst es mit einem User der auf dem Zielsystem nicht bekannt ist.

brammer
Mitglied: DerWoWusste
DerWoWusste 11.09.2020 um 13:07:20 Uhr
Goto Top
Hi.

Hast Du dich denn mit den Logonmethoden auseinandergesetzt und sichergestellt, dass Du weißt, was einzutippen ist?
https://www.uvnc.com/features/authentication.html
Mitglied: StefanMUC
StefanMUC 14.09.2020 um 00:17:07 Uhr
Goto Top
Hallo,
ja, ich habe mich mit den Login-Methoden auseinandergesetzt. Ich will die klassische Authentifizierung, bei der nur ein VNC-Passwort vom Server hinterlegt wird.

Client und Server haben unterschiedliche MS-Logins und befinden sich in keiner Domäne und auch nicht in der gleichen Workgroup. Ich habe am Server unter "Admin Properties"/"Authentification" das individuelle VNC-Passwort hinterlegt. Weder eines mit Sonderzeichen noch eine ganz einfache Ziffernkolonne funktionieren.
Wenn ich das gleiche Passwort dann im Client eingeben, kommt die Fehlermeldung. Ich bin am Verzweifeln ...
Mitglied: brammer
brammer 14.09.2020 um 07:07:07 Uhr
Goto Top
Hallo,

Was passiert wenn du dich mit einem netzwerkkabel direkt an den anderen win 10 rechner hängst und dann versuchst dich per VNC zu verbinden?
Wenn es mit einer direkten Verbindung geht blockiert irgendwas im Netzwerk die Authentifizierung. Wenn es so auch nicht geht, kannst du dann bitte mal die admin property Seite als Screenshot posten.

brammer
Mitglied: DerWoWusste
DerWoWusste 14.09.2020 um 09:02:46 Uhr
Goto Top
Ich will die klassische Authentifizierung
Mach mal einen Screenshot von deinen "Admin properties" (siehe mein Link). Laut Log benutzt du doch gar nicht klassisch, sondern hast MS-Logon angefordert.
Mitglied: StefanMUC
StefanMUC 14.09.2020 um 09:03:31 Uhr
Goto Top
Hallo,

anbei der Screenshot der admin property Seite des UltraVNC-Servers. In der Zeile VNC-Passwort hinterlege ich ein Passwort. (Anschließend Bestätigung der Benutzerkontensteuerung.) Beim VNC-Server ist stets der Port 5900 von außen erreichbar und UltraVNC antwortet (per telnet getestet). Im VNC-Log auf dem Server werden die Anmeldeversuche protokolliert:
14/9/2020 9:01 Connection received from 192.168.1.xx
14/9/2020 9:01 Invalid attempt from client 192.168.1.xx
Selbst einfache Testpasswörter wie 123456 klappen nicht. Auf Client und Server ist jeweils deutsche Tastatur eingestellt, Caps Lock ist definitiv aus.

Ich habe verschiedene Kostellationen getestet:

Win10 Pro als Hyperv-Host (UltraVNC Client) - darauf virtualisierter Win10 Pro Hyperv-Rechner (UltraVNC Server)
Win10 Pro Rechner (UltraVNC Client) - Win10 Pro Rechner (UltraVNC Server) im gleichen Netzwerk
Win10 Pro Rechner (UltraVNC Client) - Win10 Pro Rechner (UltraVNC Server) Netzwerke via OpenVPN zusammengeschaltet

Woren könnte es liegen, dass ich noch immer ein "authentification rejected" erhalte?
ultravnc-problem
Mitglied: DerWoWusste
DerWoWusste 14.09.2020 um 09:14:08 Uhr
Goto Top
Oh, da musst Du wohl zum UVNC-Forum und dort fragen. Evenrtuell ein Versionskonflikt (Du schreibst von 2 verschiedenen Versionen).
Mitglied: 145916
145916 14.09.2020 aktualisiert um 11:02:08 Uhr
Goto Top
Habe das gerade mal selbst mit beiden Versionen aufgesetzt, funktioniert hier problemlos zwischen zwei W10 einmal 1909 und der andere 2004 ...
Wohl beim Aufsetzen einen Fehler gemacht oder das Ding rennt nicht mit genügend Rechten.
Mitglied: brammer
brammer 14.09.2020 um 13:00:56 Uhr
Goto Top
Hallo,

wenn du oben rechts bei den Admin Properties "Query on incoming connection" den Haken setzt bei "Display Query Windows" Timeout "1" Default Action "Accept" bekommst du dann auf der Ziel Maschine eine Meldung?

brammer
Mitglied: StefanMUC
StefanMUC 15.09.2020 um 00:21:14 Uhr
Goto Top
Ich habe das Problem nun gelöst:
Solange ich nur 6stellige Passwörter aus Ziffernfolgen am Server hinterlege, klappt die Verbindung. Sobald das Passwort nur einen Buchstaben beinhaltet, wird die Verbindung abgelehnt.
Mitglied: 145916
145916 15.09.2020 aktualisiert um 07:29:34 Uhr
Goto Top
Sobald das Passwort nur einen Buchstaben beinhaltet, wird die Verbindung abgelehnt.
Also hier kann ich an Zeichen benutzen was ich will, auch Sonderzeichen im Mix sind kein Problem.
Mitglied: brammer
brammer 15.09.2020 um 09:59:48 Uhr
Goto Top
Hallo,

sind die beiden Win10 Rechner in unterschiedlichen Sprachen aufgesetzt?
Ist eine der Rechner eventuell in Englisch, Spanisch oder Französisch aufgesetzt?

brammer
Mitglied: StefanMUC
StefanMUC 15.09.2020 um 11:10:51 Uhr
Goto Top
Hallo,
es sind zwei Win 10 Pro in deutsch, beide sogar von der gleichen iso installiert. Bei beiden Rechnern deutsche Tastatur eingestellt, Feststelltaste kontrolliert.