Ungewolltes WoL am Home-PC

Mitglied: MichaLeipzig

MichaLeipzig (Level 1) - Jetzt verbinden

21.01.2019, aktualisiert 18:00 Uhr, 3560 Aufrufe, 2 Kommentare

Hallo,

ich habe folgendes Problem: Ich verbinde mich ab und an auf meinen heimischen PC per remote mittels TeamViewer. Um den Rechner aus dem Standby (S4) aufzuwecken, nutzte ich die "Computer starten"-Funktion der Fritzbox, neuerdings habe ich die FritzBox so konfiguriert, dass ich über einen bestimmten Port (<7000) ein magic packet über eine iPhone app an sie sende (über die dynamische IP), und dieses dann an meinen PC an dessen IP-Adresse und Port 9 weitergeleitet wird. Das ganze funktioniert soweit wie gewünscht.

Ich habe aber folgendes Problem: jedes mal, wenn ich meinen PC entweder direkt oder über Remote in den Standby schicke, wacht dieser nach unbestimmter Zeit, manchmal sogar gleich nach dem Sleep Mode sofort wieder auf. ich habe unzählige Foren abgesucht und mein eigenes Wissen angewendet, aber ich finde einfach keine Lösung. Folgendes habe ich probiert, bzw umschreibt meine momentane Konfiguration:

- cmd -> powercgf lastwake zeigt unmittelbar nach unbeabsichtigtem awake meinen LAN-Adapter an
- auch event viewer / power troubleshooter zeit beim jeweils letzten eintrag den LAN-adapter als source an
- Adapter selbst ist mit WoL=enabled und WoL pattern match=enabled konfiguriert
- powercfg requestoverride des teamviewer services
- kein scheduled task ist aktiv
- advanced power options -> sleep -> allow wake timers ist disabled
- in meinem Netzwerk befindet sich, soweit ich weiß, kein einziges Gerät, welches magic packets versendet
- als Firewall/Antivirus Lösung nutze ich Comodo Internet Security 10

WireShark zeigt mit WoL filter alle paar Sekunden folgenden Eintrag:

Frame 1191: 116 bytes on wire (928 bits), 116 bytes captured (928 bits) on interface 0
Interface id: 0 (\Device\NPF_{8F5BE763-7A1A-455E-B359-3114D5F98BC9})
Interface name: \Device\NPF_{8F5BE763-7A1A-455E-B359-3114D5F98BC9}
Encapsulation type: Ethernet (1)
Arrival Time: Jan 21, 2019 17:22:17.645902000 W. Europe Standard Time
[Time shift for this packet: 0.000000000 seconds]
Epoch Time: 1548087737.645902000 seconds
[Time delta from previous captured frame: 0.010979000 seconds]
[Time delta from previous displayed frame: 0.000000000 seconds]
[Time since reference or first frame: 21.417746000 seconds]
Frame Number: 1191
Frame Length: 116 bytes (928 bits)
Capture Length: 116 bytes (928 bits)
[Frame is marked: False]
[Frame is ignored: False]
[Protocols in frame: eth:ethertype:wol]
[Coloring Rule Name: Broadcast]
[Coloring Rule String: eth[0] & 1]
Ethernet II, Src: AvmAudio_96:a3:75 (MAC Adresse meines Router), Dst: Broadcast (ff:ff:ff:ff:ff:ff)
Destination: Broadcast (ff:ff:ff:ff:ff:ff)
Source: AvmAudio_96:a3:75 (MAC Adresse meines Router)
Type: Wake on LAN (0x0842)
Wake On LAN, MAC: AsrockIn_c2:31:5a (hier steht die MAC meines PCs)
Sync stream: ffffffffffff
MAC: AsrockIn_c2:31:5a (hier steht die MAC meines PCs)

Warum schickt der Router regelmäßig WoL Pakete zu meinem Rechner? Ich kann auch mit AvmAudio nichts anfangen. Hat irgend jemand eine Idee? Ich bin mit meinem Latein am Ende.

Gruß, Micha
Mitglied: GrueneSosseMitSpeck
21.01.2019, aktualisiert um 18:16 Uhr
AvmAudio - habt ihr zufälllig eine Fritzbox (der Hersteller heißt ja AVM)? Du schreibst da nur "mein Router", aber nicht welcher.

Und ist die für VOIP fähige Endgeräte konfiguriert? Dann pingt der Router die Endgeräte wohlmöglich tatsächlich regelmäßig an, und lt deinem Protokoll tut dein Router das mit einem Broadcast. Sprich dein PC wird nicht gezielt angepingt, sondern er empfängt einen Broadcast und reagiert dann dementsprechend. Hättest du noch 3 weitere PCs, dann würden die davon auch aufwachen, wenn sie denn WoL im Bios aktiv haben.

Richtig wirksam bekämpfen kann man das nur mit einem TCP Level3 router oder einer Firewall dazwischen, oder man gewöhnt das der Fritzbox ab. Wie, müßten dir aber Fritzbox-Nerds verzählen.
Bitte warten ..
Mitglied: MichaLeipzig
22.01.2019 um 07:30 Uhr
Ja, wie oben erwähnt, eine 7490. "AvmAudio" ist in der Tat die device Kennung der FB. Lasse ich wireshark laufen und sende mit der App das WoL-Packet, erscheint auch derselbe Logeintrag. Nur kommen darüber hinaus noch einige mehr. Vielleicht arbeitet sich ja auch ein Portscanner an meiner WAN-Adresse ab.

DECT ist auf der Fritze deaktiviert, ich habe mein analoges Telefon nur über den dafür vorgesehenen Stecker/Buchse an die Box geklemmt, es ist ein Gigaset C430. So langsam nervt dieses wake up, ich hoff,e dafür bald eine andere Lösung als das deaktivieren von WoL zu finden.
Bitte warten ..
Heiß diskutierte Inhalte
Windows Server
Server 2019 TS Installation Lizenzproblem
gelöst griffinVor 1 TagFrageWindows Server15 Kommentare

Hallo, hänge hier bei der Einrichtung des Terminal Servers eines Server 2019 der ist als VM installiert und hängt in einer Domäne, die Remotedesktopdienste ...

Netzwerke
Was passiert wenn ich zeitgleich PoE und Strom vom Netzteil an einen Access Point (Mikrotik) lege?
kartoffelesserVor 1 TagFrageNetzwerke3 Kommentare

Hallo Experten und Admins Ich habe einen Mikrotik wAP ac (RB-WAPG-5HACD2HND) an einem Laptopwagen im Einsatz. Leider ist die vorhandene Stromversorgung für den AP ...

Windows 10
Installation von Geräten per GPO steuern
DoskiasVor 1 TagFrageWindows 1010 Kommentare

Hallo liebe Liebenden :-) heute ist nicht Freitag, also kommt hier keine Freitagsfrage. Heute ist Donnerstag, also kommt hier eine Donnerstags-Knobelaufgabe. Die Situation: Die ...

Netzwerkprotokolle
Proxy Zugang von Extern
Jannik2018Vor 19 StundenFrageNetzwerkprotokolle13 Kommentare

Hallo zusammen, ich habe mir einen Squid Proxy auf einer Linux VM aufgesetzt und möchte das man aus allen netzen drauf zugreifen kann allerdings ...

Windows Server
Veeam Endpoint Backup FREE zur Sicherung eines DCs
gelöst takvorianVor 1 TagFrageWindows Server7 Kommentare

Hallo zusammen, ich habe hier bei mir 1 Hypervisor mit 4 VMs (darunter 1 DC) welche ich mittels backupAssist alle wegsichere. Klappt soweit auch ...

Windows Server
Windows 10 VM auf Server 2019 Essentials
jhuedderVor 21 StundenFrageWindows Server8 Kommentare

Hallo, einer meiner Kunden möchte aus Kostengründen einen Windows Server 2019 (direkt auf einer physikalischen Maschine installiert) erwerben und dort für einen Außendienstler mit ...

Microsoft
Immer noch Druckerprobleme nach Windows Updates
Disse1987Vor 1 TagFrageMicrosoft8 Kommentare

Hallo zusammen, evtl. hat ja jemand von euch noch eine Bahnbrechende Idee Wie soviele andere auch, hatten wir bei unseren Kunden jede Menge Arbeit ...

LAN, WAN, Wireless
VLAN trunk IP-Adressvergabe klappt nicht
gelöst ChristianM75Vor 1 TagFrageLAN, WAN, Wireless14 Kommentare

Hallo in die Runde, zu allererst hoffe ich das ihr alle ein schönes Osterfest, und ein paar erholsame Tage hattet. Nun zu meinem Testaufbau ...