VLAN Konfiguration Verständnis

kalle007

Hallo Administrator Forum,

ich habe einige Fragen an euch. Ich hoffe Ihr könnt mir behilflich sein.

Ich habe noch nicht sehr viel mit VLANS gearbeitet und habe eine Verständnis Frage an euch.

Ich habe bis jetzt mit HP Switchen gearbeitet. Dort ist die Syntax recht einfach.

Wenn man ein Port antagged haben möchte, geht man in das gewünschte VLAN und schreibt " untagged 1-3, 5-10" oder das selbe mit tagged.

Aber wir haben jetzt ein Cisco Switch bekommen. Dort ist das bisschen anders.

Ich habe auch ein bisschen bei Cisco gelesen aber irgendwie verstehe ich das nicht ganz.

Kann mir vielleicht jemand in kurzen Worten erklären was folgende Befehle bedeuten.

switchport mode trunk
switchport access vlan 2
switchport trunk allowed vlan 4
switchport mode access
no switchport access vlan 1
switchport trunk pruning vlan 2
switchport trunk native vlan 3
!


Wann ist ein Port untagged bzw /tagged ?

Content-Key: 169129

Url: https://administrator.de/contentid/169129

Ausgedruckt am: 19.01.2022 um 10:01 Uhr

Mitglied: aqui
aqui 05.07.2011, aktualisiert am 18.10.2012 um 18:47:27 Uhr
Goto Top
switchport mode trunk
A: Damit wird dieser Port ein Port der alle VLANs aus der VLAN Database dort tagged überträgt !

switchport access vlan 2
A: Dieser Port arbeitet untagged in VLAN 2

switchport trunk allowed vlan 4
A: Auf diesem Port werden ausschliesslich tagged Frames aus dem VLAN 4 übertragen alle anderen VLANs nicht

no switchport access vlan 1
A: VLAN 1 untagged Access wird abgeschaltet (ist immer per Default dran)

switchport trunk pruning vlan 2
A: An diesem Trunk wird alles außer VLAN 2 tagged übertragen, Das "inverse" zu "allowed vlan 4"

switchport trunk native vlan 3
A: An diesem Trunk Port (tagged Port) wird alles was untagged reinkommt ins VLAN 3 geforwardet statt ins VLAN 1 (was der Default wäre).

Zu deiner Frage wann ein Port tagged oder untagged ist:
Bei einem switchport trunk Kommando ist es immer tagged ! switchport access xy oder switchport mode access ist er immer untagged. (Siehe auch u.a. Command Line Reference) !
Alle detailierten Beschreibungen zu diesen Kommandos findest du im Switch Command Line Reference auf der Cisco Webseite z.b.:
http://www.cisco.com/en/US/docs/switches/lan/catalyst3750/software/rele ...

Eine vergleichende HP zu Cisco Konfig findest du u.a. auch hier im Forum unter:
https://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
und
https://www.administrator.de/wissen/vlan-routing-%c3%bcber-802.1q-trunk- ...

Ein Beispiel für einen HP Zu Cisco Kopplung sähe dann so aus:

948de2822c40710812e53fa19a07420f

Die dazu korrespondierenden Switch Konfigs:
Cisco Switch:
Cisco_Switch#

clock timezone MET 1
clock summer-time MEST recurring last Sun Mar 2:00 last Sun Oct 3:00
!
interface FastEthernet0/24
description Tagged Link zum HP Procurve
switchport mode trunk
switchport trunk encapsulation dot1q
!
interface FastEthernet0/10
description Enduser Ports in VLAN 1
switchport access vlan 1
spanning-tree portfast
!
interface FastEthernet0/11
description Enduser Ports in VLAN 2
switchport access vlan 2
spanning-tree portfast
!
interface FastEthernet0/12
description Enduser Ports in VLAN 3
switchport access vlan 3
spanning-tree portfast
!

HP ProCurve Switch:
HP_Switch#

time timezone 60
time daylight-time-rule Middle-Europe-and-Portugal
spanning-tree protocol-version rstp
spanning-tree force-version rstp-operation
exit
interface 24
name "VLAN Tagged Link zum Cisco Switch"
exit
vlan 1
name "DEFAULT_VLAN"
untagged 1-9
ip address 172.16.1.254 255.255.255.0
exit
vlan 2
name "VLAN-2"
untagged 11
tagged 24
exit
vlan 3
name "VLAN-3"
untagged 12
tagged 24
exit

ACHTUNG: Es lautert noch eine sehr gefährliche Falle im Detail wenn du gerade mit HP Produkten ein redundantes Szenario aufbaust mit Spanning Tree !!
Cisco hat per Default PVSTP+ aktiviert. Ein per VLAN Spanning Tree verfahren was andere BPDU Multicast Mac Adressen benutzt als der Rest der Switchwelt. Viele andere Premium Switchhersteller (wie z.B. Brocade, Extreme usw.) passen sich dem an wenn sie Cisco BPDUs an einem Link sehen. Nicht aber HP, die nur ein einfaches und primitives Single Span Verfahren global über alle VLANs implementiert haben !
HP supportet in seinem ProCurve Billigsektor generell KEIN per VLAN Spanning Tree Verfahren PVSTP oder PVSTP+ und in redundanten Netzwerk Designs kommt es somit immer zu ernsthaften STP Problemen mit teilweise nicht funktionierenden Netzen wenn man unwissentlich diese STP Verfahren mischt !!
Hier hilft dann nur STP auf dem HP generell auszuschalten und es vom Cisco "durchzuschleifen" oder sich auf das kleinste Gemeinsame zu einigen, das ist MSTP (Multiple Spanning Tree) was Cisco und HP supporten. Vorsicht aber auch hier: Nicht alle Billigst Procurves von HP supporten MSTP ! Also immer "Augen auf" in redundanten Designs mit gemischter HP / Cisco Hardware oder generell nicht Cisco PVSTP+ konformen Switches mit Cisco Switch HW !
Ein redundantes Szenario sieht z.B. so aus:

cbd02541153fdaf4376026b03fd512a5-switchnetz
Mitglied: kalle007
kalle007 05.07.2011 um 13:27:50 Uhr
Goto Top
Hallo aqui,

verdammt, das war mal eine ausführliche Antwort. Jetzt sind alle meine Fragen beantwortet. Ich danke dir...

Der Beitrag ist dann gelöst...
Mitglied: kalle007
kalle007 11.07.2011 um 15:52:36 Uhr
Goto Top
Hallo aqui,

ich hätte doch nochmal eine Frage an dich, jetzt ist noch ein alter Netgear Switch aufgetaucht.
Dort habe ich folgendes:

switchport access vlan untagged 5
switchport access vlan untagged 101
switchport access vlan tagged 102
switchport access native 5

die letzte Zeile wäre mein Problem, dort steht jetzt anstatt Trunk | access, also wieder anders wie bei einem Cisco.

switchport trunk native vlan
switchport access native 5

Was hätte das für eine Bedeutung ?
Mitglied: aqui
aqui 11.07.2011 um 22:09:27 Uhr
Goto Top
Normalerweise hängt an einen Trunk also an einem Port wo getaggte VLANs draufhängen IMMER das default VLAN untagged mit drauf.
Sprich: alle Pakete die untagged an diesem Port ankommen werden ins Default VLAN geforwardet. In der Regel ist das immer das VLAN 1 wenn man nichts anderes konfiguriert.

Mit dem o.a. Kommando switchport access native 5 werden alle untagged Packete an diesem Port statt ins VLAN 1 dann ins VLAN 5 geforwardet !
switchport trunk native vlan bedeutet nur das überhaupt an diesem tagged Port untagged Frames verstanden werden. Wäre das nicht da würde der Switch untagged Paketet vollkommen ignorieren am tagged Port !
Eigentlich ganz easy... ;-) face-wink
Heiß diskutierte Beiträge
question
Kaufempfehlung Switch für RZFenris14Vor 1 TagFrageSwitche und Hubs23 Kommentare

Hallo, ich bin auf der Suche nach zwei Switchen für ein relativ kleines aber feines Setup das in ein Rechenzentrum ausgelagert wird. Leider werde ich ...

question
USB-Datenträger vor Viren schützenrecon2021Vor 1 TagFrageWindows 1017 Kommentare

Hallo Freunde der IT, ich suche eine Software, mit der ich USB Stick oder USB Festplatten vor Viren schützen kann, falls ein Virus auf dem ...

question
Mögliches Sicherheitsrisiko erkannt - eigener Server wird abgelehnt gelöst napoleon123Vor 1 TagFrageWindows 104 Kommentare

Hallo, ich habe in meinem eigenen Netzwerk einen älteren Server. Bis vor Kurzem wurde er nur als Sicherheitsrisiko eingestuft, da: IP Adresse verwendet ein ungültiges ...

question
Windows XP: IE 8 zeigt keine Seiten mehr an :-) gelöst altmetallerVor 19 StundenFrageWindows XP15 Kommentare

Huhu, ich habe hier tatsächlich noch einen Dell Dimension 9100 (Pentium IV, 3Ghz) stehen, den ich mit einer NVIDIA Quadro FX 540 und 4GB RAM ...

question
Windows-Updates, spez. Server, wann macht ihr das?winackerVor 1 TagFrageWindows Server6 Kommentare

Hallo, ich habe mir abgewöhnt, die monatlichen Updates auf den Servern zu machen - ich hole mir meinen Nervenkitzel lieber woanders. Aber alle 3 Monate ...

question
Windows Server 2019 Hyper-V LizenzVanGoneVor 1 TagFrageWindows Server10 Kommentare

Guten Tag zusammen, ich habe einen frisch aufgesetzten Windows Server 2019 - Hyper-V Host mit 3 VM's VM1: Windows Server 2019 (DC, AD; DHCP) VM2: ...

question
Zu lange Glasfaserkabel in Netzwerkschrank - wie organisieren?HerrITVor 1 TagFrageNetzwerke5 Kommentare

Hallo liebe Administratoren, ich hätte eine Frage an euch Experten, für die ich - selbst nach stundenlanger Suche - keine richtige bzw. zufriedenstellende Antwort gefunden ...

question
Ethernet über Telefonleitung gelöst Net-ZwerKVor 19 StundenFrageLAN, WAN, Wireless7 Kommentare

Moin! Ich suche einen Konverter, mit dem ich auf eine Telefonleitung (2 Draht) ein Netzwerksignal legen kann. Geht darum, dass ich beim einem Kunden einen ...