goscho
Goto Top

VLAN-Problem nach Wechsel des Routers von Netgear zu Lancom

Hallo Leute,

ich habe eine Firmennetzwerk mit mehreren VLANs.
Switches sind smartmanaged Geräte von Dlink bzw Netgear.
Als Router wird eine Netgear SRX-5308 genutzt (4xWAN, davon 3 genutzt; 15 aktive VPNs).

Default: VLAN-ID 1
Gastnetz: VLAN-ID 22
Privat: VLAN-ID 5

Auf den Switches sind die Ports zu den anderen Switches, den Unifi Accesspoints und zum Router jeweils tagged in den 3 VLANs.

Im VLAN 1 ist ein Windows-Server als DHCP-Server aktiv.
In den VLANs 5 bzw. 22 verteilt der Netgear Router die IPs als DHCP-Server.

Alles läuft, wie es soll. face-smile

Jetzt wird der Router ersetzt.
Statt des Netgears nutze ich nun einen Lancom 1906VA.

Der Lancom-Router bekommt die selbe IP-Adresse wie der Netgear.
In den VLANs 22 und 5 soll er als DHCP-Server die Adressen verteilen.

Im VLAN 1 funktioniert alles, wie es soll.

Leider klappt die Kommunikation in den anderen VLANs nicht, wie sie soll.
Verbinde ich ein Gerät mit dem Gastnetz (VLAN 22), so schickt dieses Gerät einen DHCP-Request zum DHCP-Server (Lancom).
Der Lancom antwortet mit einem DHCP-Offer.
Im LANmonitor ist zu sehen, dass die Clients IP-Adresse zugewiesen bekommen haben.

Diese Antwort kommt aber nicht am Client an (Wireshark läuft am Client mit).
Ein Windows-Client vergibt sich dann eine APIPA-Adresse, ein Android-Gerät bleibt im Modus (IP-Adresse wird abgerufen).


Tausche ich zu Testzwecken den Lancom-Router mit dem Netgear-Router, klappt es sofort und ohne Probleme.

Für mich sieht es nach einem Fehler bzw. einer Fehlkonfiguration auf dem Lancom-Router aus.
Mit dem Support von Lancom habe ich diese Konfiguration bereits stundenlang überprüft und sie haben keinen Fehler feststellen können.

Stattdessen wird mir erklärt, dass es etwas mit den Geräten (Switches bzw. Accesspoints) der anderen Hersteller zu tun haben soll.
Wenn ich die Accesspoints aber direkt an den Lancom hänge, klappt es ebenso wenig.

Hat jemand von euch eine Idee, wo ich einen Konfigurationsfehler haben könnte?

Content-Key: 439448

Url: https://administrator.de/contentid/439448

Printed on: July 18, 2024 at 18:07 o'clock

Member: aqui
aqui Apr 11, 2019 updated at 09:47:02 (UTC)
Goto Top
Riecht so ein bischen nach Firewall am Lancom. Allerdings ja dann outbound (in Richtung LAN) was dann aber sehr sehr ungewöhnlich wäre das er seine eigenen Pakete filtert.
Vermutlich kann der Lancom den eigenen Paketen dann nicht das richtige Ausgangs VLAN zuweisen.
Hast du mal versucht den Clients im VLAN 22 eine statische IP im richtigen Bereich zuzuweisen und die Lancom IP in dem VLAN zu pingen ? Und auch vice versa.
Vermutlich wird das dann aber auch nichts nützen und keine Kommunikation möglich sein wenn die VLAN Zuordnung scheitert.
Schon alt aber vielleicht hilft es:
Lancom 1711 VLAN einrichten
Member: goscho
goscho Apr 11, 2019 at 10:11:41 (UTC)
Goto Top
Moin aqui,

ich bin jetzt etwas weiter.
Kabelgebundene Clients beziehen jetzt IP-Adressen vom Lancom, sowohl VLAN5 als auch VLAN 22.
Ich hatte da Zahlendreher in einem Switchport, den ich zum Test verwendet habe.

Leider bekommen die WLAN-Clients keine IP-Adresse.
Als nächstes habe ich die Firmware des Unifi-Controllers auf die 5.10.20 aktualisiert und die APs mal neugestartet.

Womöglich haperst es nur an der Kommunikation zwischen dem Lancom Router und den Unifi APs.
Vielleicht muss ich auf dem Unifi Controller was ändern.

Ich weiß aber nicht, was.
Hat da jemand noch einen Tipp?

Die Firewall am Lancom-Router kann ich ausschließen.
Member: aqui
Solution aqui Apr 11, 2019 updated at 10:19:02 (UTC)
Goto Top
Wenn du noch einen kleinen VLAN Switch über hast kannst du den ja mal testweise mit einem Tagged Port (VLANs 5 und 22) und PVID 1 an einen der UniFy AP Ports hängen.
Am Test Switch splittest du das dann auf in 3 Untagged Endgeräte Ports 1, 5 und 22 und testest das mal mit einem Client wasserdicht das dort alle VLANs erreichbar sind.
So weisst du wenigstens wasserdicht das Netzwerk technisch die AP Ports dann sauber funktionieren und der Fehler dann nur in den APs bzw. deren (Controller)Konfig liegen kann.
Das reduziert dann den Suchaufwand. face-wink
Member: goscho
goscho Apr 11, 2019 updated at 10:28:05 (UTC)
Goto Top
Zitat von @aqui:

Wenn du noch einen kleinen VLAN Switch über hast kannst du den ja mal testweise mit einem Tagged Port (VLANs 5 und 22) und PVID 1 an einen der UniFy AP Ports hängen.
Am Test Switch splittest du das dann auf in 3 Untagged Endgeräte Ports 1, 5 und 22 und testest das mal mit einem Client wasserdicht das dort alle VLANs erreichbar sind.
Habe ich getestet und das Endgerät (Notebook per LAN) bezieht sofort eine IP-Adresse von Router.

VLAN-Switch, Port 1 tagged in 2,5,22
Port 6 untagged in VLAN 1
Port 7 untagged in VLAN 22
Port 8 untagged in VLAN 5

Nur per WLAN bekommen die Clients im VLAN 22 keine IP vom Router.
Member: aqui
Solution aqui Apr 11, 2019 at 11:37:18 (UTC)
Goto Top
Bedeutet ja dann klar das der AP der böse Buhmann ist.
Ggf. WLAN Isolation aktiviert so das Broadcasts nicht geforwardet werden ?
Die DHCP Requests kommen aber am Lancom an von den WLAN Clients, oder ?
Member: goscho
goscho Apr 11, 2019 at 12:53:52 (UTC)
Goto Top
Zitat von @aqui:

Bedeutet ja dann klar das der AP der böse Buhmann ist.
Ggf. WLAN Isolation aktiviert so das Broadcasts nicht geforwardet werden ?
Das ist es gewesen.

Im Gast-Netzwerk auf dem Unifi Controller gibt es einen Punkt -> Multicast und Broadcast Filterung
Wenn dieser auf "Sperren von LAN zu WLAN Multicast-und Broadcastverkehr" steht, bekommt der WLAN-Client im Gastnetz keine IP.

Ich muss diese Option also deaktivieren.

Mit dem anderen Router gab es da keine Probleme.

Okay, Problem gefunden und gelöst.
Member: aqui
aqui Apr 11, 2019 at 17:41:22 (UTC)
Goto Top
Ja, das macht der eine so der andere so. Manche wollen per Default keine Any zu Any Kommunikation der Clients im WLAN, manche schon. Das macht jeder Hersteller anders. Sollte man also immer auf dem Radar haben.
Gut wenns nun rennt wie es soll. Case closed ! face-smile