VOIP Probleme mit O2

Mitglied: felixhuth-it

felixhuth-it (Level 1) - Jetzt verbinden

22.02.2021 um 12:25 Uhr, 544 Aufrufe, 6 Kommentare

Hallo liebe Gemeinde

Ich wende mich gern wieder an euch, da ich hier ein sehr komisches Fehlerbild habe.

Der Kunde hat einen Draytek 2860 Router und dahinter ein kleines Gigaset DX800A welches die SIP Einwahlen für den VoIP Provider O2 macht. Bis zum 11.1. diesen Jahres funktionierte es auch ohne Probleme. An dem genannten Tag (oder vielleicht schon am Wochenende davor) hat der nette Provider O2 irgendwelche Datenbanken zusammengeführt, sodass zunächst das ganze VoIP nicht mehr sauber lief - sporadische Verbindungsabbrüche, innerorts musste man auch eine Vorwahl nutzen, Nichterreichbarkeit ... halt das ganze Programm

Zwei Wochen später waren dann die ganzen großen Probleme weg und dann wurde es eigenartig. Wurde der Kunde aus dem Festnetz angerufen kamen alle Anrufe ordnungsgemäß durch, allerdings bei Anrufen aus dem Mobilfunknetz kam es zu Auffälligkeiten - der Kunde selbst (ehemalige D1 Nummer aber inzwischen bei O2) konnte sich selbst nicht mehr in der Firma anrufen - Fehlermeldung "Die Verbindung konnte nicht hergestellt werden". Seine Ehefrau (auch bei O2 mit einer O2 Vorwahl) konnte problemlos jederzeit anrufen. Ein Kollege von ihm (Vodafone Kunde) und ich (D1 Kunde) bekamen nach 6x Klingeln die Meldung, dass der Kunde derzeit nicht erreichbar sei (spaßighalber habe ich das Fax angerufen, wo die Konfiguration des DX800A so ist, dass alle Anrufe auf dieser Nummer gleich zum Fax rübergestellt werden sollten. Sprich das Fax wollte nicht mir reden bzw. der Ruf kam nie beim Fax an. Parallel habe ich auch mal Gigaset reingeschaut ob sich just in diesem Moment der Provider oder das Telefon selbst sich aus dem O2 Netz abmeldet - dem war nicht so.

Habe mich dahingehend dann an O2 gewandt und die Aussage von denen war dass der Ruf angeblich vom Draytek geblockt wird. Dies stelle ich mal ernsthaft in Zweifel, da diese Pappnasen vom First-Level-Support (ja ich war und bin wirklich sauer auf die) einfach sagen "Ja nicht unser Problem, sie können ja den Router von uns nehmen". Eine Fritzbox! - noch dazu eine gebrandete von O2 - gehört meines Erachtens nicht unbedingt in ein Unternehmen. Weiterhin konnten die mit der Konstellation aus Draytek und dahinterliegendem Gigaset auch nichts anfangen und nachdem ich ihnen erzählt habe dass die SIP Einwahlen nicht der Router vornimmt waren die mehr als nur verwirrt - aber egal. Die Aussage dass der Router schuld sei habe ich mit professionellem Sarkasmus erwiedert so unter dem Motto "ja der Router mag einige Mobilfunknummern nicht und deshalb werden die gleich abgeblockt". Auf die Frage was denn genau gemacht worden sei und was ggf. jetzt anders zu machen ist, habe ich bis heute von O2 keine Antwort. Auch dass man mit einem Techniker direkt sprechen kann war nicht möglich ....

Meine Vermutung ist dass O2 etwas im Backend des VoIP Netzes gemacht hat und dies nun Auswirkung auf das bis dahin laufende System hatte (Port Änderung etc.)

Was wurde bisher gemacht:
0) Syslog -> bei Anrufen aus dem Festnetz wurden die im Syslog aufgezeichnet - bei den "problematischen" Nummern war kein Eintrag diesbezüglich im Syslog zu finden
1) DX800A neu initialisiert -> kein Erfolg
2) Im Draytek DMZ eingerichtet mit Ziel IP des DX800A -> kein Erfolg
3) Im Draytek LAG eingerichtet für SIP Port 5060 -> kein Erfolg
4) Draytek neu initialsiert -> kein Erfolg
5) O2 Box rangeklemmt, per S0 Bus das Gigaset rangehangen -> Erfolg

Jetzt kommen wir zur eigentlichen Frage - hat jemand ähnliche Erfahrungen oder Probleme mit dem Provider und wenn ja wie wurden die gelöst? Ich würde bei dem Kunden gern wieder die Kombination aus Draytek und Gigaset fahren (die hat sich bei vielen kleinen Kunden wirklich bewährt).

Was ich noch testen werde ist der Draytek selbst - habe zwar nur Kunden die bei der Telekom oder Vodafone sind, aber ein Versuch ist es Wert (an sich bräuchte ich nen O2 Anschluss). Der Draytek Techniker selbst geht nicht davon aus dass es am Gerät liegt, da ja Festnetzanrufer und bestimmte O2 Mobilfunknummern ornungsgemäß an den DX800A durchgestellt werden.

Mit freundlichen Grüßen
Felix
Mitglied: aqui
22.02.2021, aktualisiert um 13:13 Uhr
Lege dir einen kostenlosen SIPgate Basic Account an oder den eines anderen freien SIP Providers deiner Wahl und lade dir ein Softphone runter wie Phoner oder Phoner-lite was du auf einem Testrechner installierst und mit dem SIPgate Account verbindest.
Dann testest du alle Nummern wie du sie auch mit dem Gigaset getestet hast.
Dasgleiche machst du dann nochmal mit dem Gigaset. So kannst du mit Gewissheit den Router oder das Telefon selber als Fehlerquelle ausschliessen...oder auch nicht.
Arbeitest du mit aktiviertem STUN auf dem Telefon ? Wenn nicht solltest du das aktivieren.
Sollte es wirklich am Router liegen würde VoIP entweder ganz oder gar nicht funktionieren. Das es generell geht aber nur mit wenigen Nummern nicht sieht de facto nicht nach einem Router Problem aus.
Bitte warten ..
Mitglied: Luci0815
22.02.2021 um 13:20 Uhr
Ähnliches Problem mit einem TP-Link gehabt. Dann eine Fritzbox genommen und nie wieder Probleme bekommen.
Bitte warten ..
Mitglied: erikro
22.02.2021 um 16:01 Uhr
Moin,

solche Probleme hatten wir bei Vodafone auch mal. Da stimmt was nicht beim Routing. Allerdings nicht bei Dir, sondern bei O2. Damals hat Vodafone auch erst einmal behauptet, es läge an uns. Aber unser TK-Dienstleister konnte ihnen klar nachweisen, dass die Routen nicht korrekt waren und deshalb die Rufe nicht bei unserer TK-Anlage ankamen. Da bringt Dich der 1st-Level-Support allerdings keinen Schritt weiter. Die wissen in der Regel nicht einmal, was Routing ist, sondern lesen Standardantworten aus dem Handbuch vor.

BTW: O2 im professionellen Bereich??? ;-) face-wink

Liebe Grüße

Erik
Bitte warten ..
Mitglied: commodity
LÖSUNG 23.02.2021 um 15:28 Uhr
Willkommen im Club ;-) face-wink

Gleiches Problem zur gleichen Zeit auch bei einem von mir betreuten Anschluss: O2 Businessanschluss mit Draytek 165 (nur Modem), Pfsense und Asterisk dahinter. Exakt das von Dir beschriebene Ausfall- und Supportszenario. Immerhin rief mich die Business-Hotline zurück und entschuldigte sich. Man habe festgestellt, dass ausschließlich Kunden mit eigenen (nicht Fritzbox) Endgeräten betroffen seien, das seien aber erstaunlich viele. Man wisse aber die Ursache nicht, ich solle warten. Es werde entweder wieder von allein gehen, oder eben nicht. Schulterzucken am anderen Ende. Ich habe gewartet und parallel ausgetestet. War offenbar eine größere Änderung: Neben der mitgeteilten Datenbankänderung sind auch Sip-Konnektivität und Serverstruktur verändert. Infos von o2: Null

Ich habe es dann selbst wieder zum Laufen gebracht und zugleich den Anschluss gekündigt und ihn zu Easybell transferiert. Da haben einige Kunden von mir seit Jahren ruhige Verhältnisse, schnellen, freundlichen und vor allem kompetenten Support. Die letzten Tage des betroffenen Anschlusses bei o2 laufen und dieser ging irgendwann wieder mit Originalsetup (dennoch auch nach zwei Wochen teilweise Ausfälle), aber ich habe keine Lust mehr auf Rätselraten über die Anschlusseinstellungen. Anschlussparameter müssen Standard oder offen sein. Deshalb: Business-VOIP (ohne Fritzbox) nur noch mit Anbietern, die das offen unterstützen. Und das sind Vodafone und o2 eben nicht. Vielleicht bei Großkunden...

Dein Post lässt mich annehmen, dass es in meinem Fall nicht nur an o2 lag, dass es überhaupt wieder geht, sondern auch an den von mir vorgenommenen Anpassungen. Die bekomme ich nicht mehr ganz zusammen und es gilt natürlich für Asterisk, aber vielleicht kannst Du das Folgende verwerten:
Am wichtigsten war, nun SIP-qualify zu aktivieren. Das führte früher dazu, dass o2 die Verbindung ablehnte, nun ist es offenbar erforderlich. Das ist gut, denn früher musste man sich da anderer Krücken bedienen, um die Firewall offen zu halten.
Wichtig ist auch, kein pai aktiviert zu haben. Das mochte der Anschluss auch nicht mehr. Auch die zulässigen Codecs habe ich m.E. angepasst, glaube ich. Nach Auswertung der Debugs gehen jedenfalls g722, alaw und ulaw.
Vielleicht kannst Du damit was anfangen. Insgesamt aber finde ich das Gefummel mit unbekannten SIP-Parametern auf der Gegenseite meines Dienstleisters zu viel. Letztlich ist das ein Unterlaufen der Endgerätefreiheit durch die Hintertür. Man übermittelt die richtigen Parameter eben an AVM und alle anderen gucken in die Röhre. Mag für den Massenmarkt funktionieren. Für Business sicher nicht.
Bitte warten ..
Mitglied: felixhuth-it
24.02.2021 um 14:19 Uhr
Vielen Dank für den Input

ich werde diese Einstellungen mal gegen testen sobald ich wieder beim Kunden bin - vieles kann ich auch so beim Gigaset einstellen, wie zum Beispiel die Codecs.

Aber denk zum Ende des Jahres wechselt er so und so den Provider - da ich von O2 genau wegen solcher Fälle die Nase voll habe. Vorher war der Kunde auch größer und hatte eine Auerswald und da waren die schon richtig sauer, als ich die SIP Serverdaten und Parameter wissen wollte.

LG
Felix
Bitte warten ..
Mitglied: commodity
24.02.2021 um 15:00 Uhr
Zitat von @felixhuth-it:

Aber denk zum Ende des Jahres wechselt er so und so den Provider - da ich von O2 genau wegen solcher Fälle die Nase voll habe.

Ja, nur so geht es. Gibt auch überhaupt keinen Grund die Konfig "geheim" zu halten. Sie müssen ja nicht supporten. Aber wenigstens die nicht standardkonformen Einstellungen kommunizieren sollte schon sein.

Noch was: Die von mir genannten Einstellungen beziehen sich auf PJSIP. Aber qualify und Codecs gibts ja auch bei SIP.
Da aber das Problem der teilweise nicht durchgehenden Anrufe wohl mit der Nutzung verschiedener SIP-Server bei o2 zu tun hat, habe ich auch noch den line - Parameter gesetzt.

https://community.asterisk.org/t/solved-pjsip-no-matching-endpoint-found ...">https://community.asterisk.org/t/solved-pjsip-no-matching-endpoint-found ...
https://www.asterisk.org/the-pjsip-outbound-registration-line-option/">https://www.asterisk.org/the-pjsip-outbound-registration-line-option/

Musst vielleicht mal gucken, wie man das mit SIP löst. Wenn Du an Debug-Logs rankommst: Ist auf jeden Fall hilfreich. Aber für den Kunden unbezahlbar, was o2 da treibt.
Bitte warten ..
Heiß diskutierte Inhalte
HTML
Ich brauche dringend Hilfe !
gelöst JulianpustVor 16 StundenFrageHTML16 Kommentare

Hallo erstmal, ich habe großen Mist gebaut in der Firma wo ich gerade mal 2 Tage arbeite. Was ist passiert: Ich sollte von Gmail ...

Exchange Server
0-day Exploit Chain für Exchange Server - Patches verfügbar
kgbornVor 1 TagInformationExchange Server6 Kommentare

Zur Info: Microsoft warnt vor einer Exploit-Chain, bei der vier 0-day-Schwachstellen für gezielte Angriffe auf Exchange per Outlook Web App kombiniert werden (eine chines. ...

Windows 10
Windows 10 schickt lokale Anfragen an das Gateway - was tun?
gelöst runthegaunzVor 1 TagFrageWindows 1015 Kommentare

Hallo! Ich bin vor ein paar Tagen wieder von Linux auf Windows umgestiegen. Ich hab die Windows 10 Version 20H2 installiert, wurde von Windows ...

Switche und Hubs
23 Cisco Switch einrichten - Wie am einfachsten?
gelöst Freak-On-SiliconVor 1 TagFrageSwitche und Hubs18 Kommentare

Hallo; Ich habe hier 4stk Cisco SX350X-24 9Stk Cisco SG350X-48P 10Stk Cisco SG350X-48 Diese werden aufgeteilt auf 9 Racks, und ersetzen alte HP Switches. ...

Exchange Server
Aktuelle Exchange Sicherheitslücke
jojo0411Vor 1 TagAllgemeinExchange Server11 Kommentare

Hallo Leute, Momentan gibt es da wieder einmal ein schönes neues Thema. Sehe ich das richtig das ich mit Exchange 2016 und CU 19 ...

Hardware
Fritzbox 7590 ändert selbständig die FTP-Adresse nach ca. 24h
Wicky1Vor 1 TagFrageHardware15 Kommentare

Hallöchen, ich habe da ein sehr kurioses Problemchen mit meiner Fritzbox. Doch erst mal eine kurze Beschreibung des Aufbaus: - Fritzbox 7590 (1&1 Edition) ...

Netzwerke
Smarthome Heimnetzwerk absichern
hell.wienVor 1 TagFrageNetzwerke12 Kommentare

Hallo. Ich mach mir gerade gedanken wie ich meine neue Wohnung sicher mache Überischthalber zur Hardware: Vorhanden: Modem APU4D4 Cisco SG250X-24P Mikrotik cAP ac ...

Windows Server
Windows Firewall: Alle öffentliche IPs sperren bis auf eine
SabSchapVor 1 TagFrageWindows Server7 Kommentare

Hallo, wir haben einen Windows 2019 Server. Wir nutzen diesen als Webserver. Nun haben wir die Webadresse www.test.de und möchten diese für alle öffentlichen ...