derwowusste
Goto Top

Win10 Timeline zickt

Moin Kollegen.

Wer ist firm im Thema Timeline/Aktivitätsverlauf?
Problem: nach Upgrade auf 1903 ist die Timeline zwar weiterhin generell funktionstüchtig, jedoch ist alles, was mit dem Edge geöffnet wurde, darüber nicht mehr aufrufbar.
Also: alles ist sichtbar, auch neue Websites, die ich mit Edge aufrufe, werden dort abgelegt, jedoch passiert nichts, wenn ich in der Timeline auf diese klicke (das ist kein Problem von 1903, bei anderen upgegradeten Installationen geht es).

Websites, die ich mit dem IE öffne, kann ich weiterhin über Timeline aufrufen. Auch alle anderen Dokumenttypen funktionieren in den jeweiligen Programmen.

Ich habe leider keinen Ansatz für die Lösung, da ich nicht weiß, wo Timeline seine Dateizuordnungen aufzeichnet.

Content-Key: 448184

Url: https://administrator.de/contentid/448184

Printed on: June 15, 2024 at 13:06 o'clock

Member: Bem0815
Bem0815 May 07, 2019 updated at 08:53:26 (UTC)
Goto Top
Naja, was erwartest du auch wenn du ein Release Preview Build von 19H1 verwendest?
Bugs wird es da definitiv noch geben.

Aber grundsätzlich wäre es bei Problemen mit einem Insider Preview Build auch relevant zu wissen um welches Build es genau geht, 1903 (mittlerweile eigentlich 19H1) gibt es ja in verschiedenen Build Versionen.

Im Zweifel warten bis das ding veröffentlicht ist und hoffen, dass der Bug dann behoben ist.
Member: DerWoWusste
DerWoWusste May 07, 2019 updated at 07:26:26 (UTC)
Goto Top
Es ist immer das Selbe...

Ich frage, "wer kennt sich aus" und außer Sachen wie "ich nicht!" oder "warum machst Du das" kommt nichts
Tu mir den Gefallen und antworte nicht weiter auf diesen Thread, damit er frei bleibt.

1903 ist schon einige Zeit final und via MSDN erhältlich.
Member: Bem0815
Bem0815 May 07, 2019 updated at 07:46:06 (UTC)
Goto Top
Hast du irgendwie schlecht geschlafen oder was soll dieser völlig unqualifizierte Angriff?
Was du mir hier vorwirfst stimmt überhaupt nicht.

1. Habe ich nicht gesagt ich habe keine Ahnung sondern um evtl. überhaupt helfen zu können dich erst einmal konkret nach einer Build Nummer gefragt damit man hier erst einmal einen Ansatzpunkt findet um dir helfen zu können. Die Antwort auf diese Frage bist du immer noch Schuldig. Als Level 5 User solltest du eigentlich wissen, dass in so einem Fall eine Build Nummer definitiv relevant ist zur Problemlösung.

2. Ist 19H1 (1903 gibt es nicht) definitiv noch nicht Final sonst gäbe es von Microsoft einen "release candidate" gibt es aber nicht.
Das Ding ist im Fast Ring. Das ist nicht Final.
MSDN heißt auch nicht umsonst Microsoft Developer Network. Was dort zum runterladen ist, ist zum testen nicht für Produktumgebungen.

2. Wenn man eine Software oder OS verwendet das nicht Final ist dann sollte man grundsätzlich damit klar kommen dass noch vermehrt Bugs auftreten können, bzw auch noch nach Release.

Kurzum nenne doch endlich zumindest mal die Build Nummer damit man dir evtl. helfen kann.
Member: departure69
Solution departure69 May 07, 2019 at 07:52:41 (UTC)
Goto Top
@DerWoWusste:

Hallo.

Ich bezweifle, daß ich mich damit besser auskenne als Du, aber ich hab's für Dich hier mal getestet. Ich bin auf Version 1903 Build18362.86 (dürfte momentan die neueste aus der Version 1903 sein).

Ich habe auch ein Fehlerbild, aber ein anderes als Du. IE11-Aufrufe von Webseiten werden gelistet und funktionieren auch, wenn ich in der Timeline nochmal darauf klicke. Edge-Aufrufe jedoch gar nicht (bei Dir sind die Edge-Aufrufe wenigstens sichtbar, aber nicht klickbar bzw. es passiert nichts nach einem Klick).

Nutzt Du (oder die von Dir betreuten User/Kunden) dieses Timeline-Feature tatsächlich? Meine Leute haben das bis heute noch nicht mal entdeckt face-wink.

Ich kann hierzu bloß empfehlen, dies per Feedback-Hub zu melden.


Viele Grüße

von

departure69
Member: DerWoWusste
DerWoWusste May 07, 2019 at 07:58:59 (UTC)
Goto Top
Moin @departure69.

Danke soweit. Wir nutzen beide die Selbe Build. Hast Du upgegradet und hattest Du vorher Timeline auch schon aktiv, oder nicht aktiv/nicht upgegradet, sondern clean installiert?

Ja, wir nutzen das doch ausgiebig, dank Sharepoint. Der Verlauf im Edge ist ja nicht durchsuchbar, deshalb spielt die Timeline für viele Nutzer tatsächlich eine Rolle, denn die ist durchsuchbar.
Member: departure69
departure69 May 07, 2019 updated at 08:06:45 (UTC)
Goto Top
Hatte im letzten Herbst einen neuen Rechner bekommen, auf dem nackig mit 1809 begonnen wurde. Die jetzt genutzte 1903 ist ein Inplace-Upgrade davon.

Hab' jetzt aber zwischenzeitlich einen anderen 1903er bei uns angesehen, der von Windows 7 per Inplace-Upgrade kam (damals zuerst auf 1709) und seither alle Inplace-Upgrades bis heute 1903 erhielt. Bei dem besteht das gleiche Problem wie bei Dir, die Edge-Aufrufe sind gelistet, aber nicht erneut aufrufbar.

Falls das hilft, ein klareres Bild der Lage zu bekommen, ansonsten kann ich leider nichts weiter zu Deiner Frage beitragen. Vielleicht meldet sich noch wer anderes.

Viele Grüße

Edit: Timeline auf beiden beschriebenen Systemen schon aktiv, seit die TL existiert (1803? 1809? - weiß es nicht mehr, wann es die TL erstmals gab).
Member: DerWoWusste
DerWoWusste May 07, 2019 at 08:08:16 (UTC)
Goto Top
Vielen Dank.

Oha, gleich 2 von 2 betroffen bei Dir. Ich fürchte, das wird zum Problem werden... deshalb fange ich immer so früh an zu testen.
Mal sehen, ob sich noch jemand findet, der die Internals von Timeline kennt, sonst bleibt nur Procmon.
Member: Bem0815
Solution Bem0815 May 08, 2019 at 07:03:22 (UTC)
Goto Top
Gestern Abend noch auf zwei Test VMs ein Upgrade von 1809 zu 1903 Build 18362.86 installiert.
Problem taucht auf einer der zwei VMs auf, auf der anderen nicht.
Also definitiv wie gedacht ein genereller 1903 Bug, unklar wodurch genau er auftritt.

Am besten wie departure69 schon gesagt hat per Feedback-Hub melden.
Mehr wird man da wohl aktuell nicht machen können. Ich bezweifel, dass es für so etwas ein bekanntes Workaround gibt.
Member: DerWoWusste
DerWoWusste May 08, 2019 at 07:48:21 (UTC)
Goto Top
Moin Bem0815 und danke auch Dir für's Nachstellen.

Ich suche weiterhin nach Infos, wie Timeline überhaupt funktioniert (wor wird eingespeichert, was wann mit welcher App geöffnet wurde). Wer also dazu infos hat, immer her damit, sonst werfe ich morgen procmon an.

PS: Sorry wegen gestern - ja, auch schlecht geschlafen face-wink aber vor allem frustriert, da ich bei fast allen meiner Fragen einen Anteil von >70% Kommentaren habe, die nichts mit dem Thema zu tun haben, selbst wenn ich ausdrücklich schreibe "bitte nur teilnehmen, wenn Ihr euch in der Materie auskennt". Sprich: nichts gegen Deinen Kommentar. Versionen sind immer wichtig zu nennen, ja, aber unabhängig von der Version könnte sich hier doch jemand finden, der Timeline mal durchleuchtet hat.
LG
Member: Bem0815
Bem0815 May 08, 2019 updated at 08:22:43 (UTC)
Goto Top
Von mir auch sorry, hab dann auch etwas giftig reagiert.

Die Sache ist nur die, dass ich in dem Fall fast davon ausgehe, dass hier der Hund im Programmcode für die Timeline selbst begraben ist und nicht z.B. über die Registry oder einer Config oder XML Datei sich da was beheben lässt. Jedenfalls wäre es mir bisher nicht bekannt, dass es grundsätzlich für die Timeline hier Möglichkeiten gibt etwas über eine Config zu ändern.

Ich gehe also davon aus, dass man den Fehler selbst gar nicht beheben kann.

Daher lag hier halt mein Verdacht auf einen Bug im aktuellen 1903 Build bei dem man nur warten kann, dass Microsoft das fixed bzw. dass man überhaupt den Bug erst einmal MS meldet, sollte der noch nicht bekannt sein.

Was ich jetzt leider nicht testen konnte ist ob der Bug bereits im letzten "ISO Build" also 18362.30 enthalten war oder ob der erst durch das Kumulative Update auf das neueste Build 18362.86 entstanden ist.

Ich hatte nämlich bereits meine ISO per Script auf 18362.86 gepatched vor der Upgrade installation.
Beide Testsysteme waren übrigens vor dem Upgrade von 1809 auf 1903 nahezu blank.
Kann hierdurch leider kein Muster erkennen warum bei einem System der Fehler auftritt und beim anderen nicht.
Member: DerWoWusste
DerWoWusste May 08, 2019 updated at 09:45:06 (UTC)
Goto Top
Schon beim Upgrade 1703->1803 (timeline war mit 1803 von Microsoft eingeführt worden) gab es hier ein paar Fälle, wo timeline nicht gearbeitet hat, wie es soll. Auch da habe ich mich schon gefragt, wie das Ding eigentlich funktioniert - konnte die Probleme aber durch Reparaturinstallationen (inplace-Upgrade 1803->1803) lösen.

Bei meinem Privatsystem ist es mir erstmalig aufgefallen. Die beiden Konten, die ich nutze, hatten beide nach dem Upgrade auf 1903 das Problem. Ich habe daraufhin ein frisches Konto erstellt - dort geht es. Ist also kein Systemproblem, sondern ein Profilproblem. (siehe voriger Absatz) - Das Profilprobleme jedoch mit inplace-Upgrades zu kitten sind, ist äußerst ungewöhnlich!

Ich lass Euch wissen, was ich noch finde. Die Feedback App kann ich ja auch mal anwerfen heute Abend.
Mitglied: 139708
139708 May 08, 2019 updated at 09:22:15 (UTC)
Goto Top
Moin,
nach meiner testweisen Analyse nutzen die für die Timeline die selbe Speichertechnik wie für das Startmenü von Windows. Das sich das oft nach Updates verhaspelt kennt sicher jeder. Die bekommen es einfach nicht in den Griff eine simple Datenbank zu entwerfen, es müssen immer welche proprietären DBs sein die man selbst so gut wie nicht handeln kann außer man kennt die Windows-Interna.
Zurück in mein Arch-Linux verkriech, da kommen mir solche Dinge Gott sein Dank nicht unter und kann im Zweifelsfall selbst Hand anlegen face-wink...

Gruß wireguard
Member: DerWoWusste
DerWoWusste May 08, 2019 at 09:25:34 (UTC)
Goto Top
Ja, danke für das Beileid... kannst Du mir sagen, was Du an Pfaden gefunden hast?
Mitglied: 139708
139708 May 08, 2019 updated at 09:38:05 (UTC)
Goto Top
%LOCALAPPDATA%\ConnectedDevicesPlatform

inkl. Unterordner.
Das eine ist zumindest noch eine SQLITE DB.
Member: DerWoWusste
DerWoWusste May 08, 2019 at 09:37:42 (UTC)
Goto Top
Iih. Das ist nichts für meines Vaters Sohn.
Hast Du schon Tests gemacht mit Löschen dieser .db..xxx files? Würde ich mal testen wollen.

Danke!
Mitglied: 139708
139708 May 08, 2019 updated at 09:45:31 (UTC)
Goto Top
Zitat von @DerWoWusste:

Iih. Das ist nichts für meines Vaters Sohn.
Hast Du schon Tests gemacht mit Löschen dieser .db..xxx files? Würde ich mal testen wollen.
Noch nicht, überlasse ich dir face-smile, die ActivitiesCache.db ist aber wohl eine SQLITE DB, das andere ein binärer Mülleimer für die Bildchen und Texte

screenshot
Member: DerWoWusste
DerWoWusste May 09, 2019 at 17:40:46 (UTC)
Goto Top
Sch… ich habe eben bei meinem Zweitnutzer mal die große Keule rausgeholt, und sein Verzeichnis %localappdata%\ConnectedDevicesPlatform umbenannt. Es wird bei Neuanmeldung sogleich auch neu erstellt - Fehler bleibt jedoch bestehen und alte Seiten in Timeline weiterhin sichtbar. Wo könnte noch was zu Timeline drinstehen?
Member: DerWoWusste
DerWoWusste May 09, 2019 at 19:32:19 (UTC)
Goto Top
Ich fürchte, ich werde mir mal https://kacos2000.github.io/WindowsTimeline/WindowsTimeline.pdf reinziehen müssen.
Mitglied: 139708
139708 May 09, 2019 at 20:17:12 (UTC)
Goto Top
Wo könnte noch was zu Timeline drinstehen?
In der Cloud.
Member: DerWoWusste
DerWoWusste May 09, 2019 at 21:12:44 (UTC)
Goto Top
Wohl wahr. Der Rechner, der Probleme hat, hat wie gesagt zwei Konten (beide mit Problemen) - eines ist ein MS Account, das andere ein lokales.
Das ist doch alles Grütze. Ich lass nach Lektüre dieser unsäglichen 57 Seiten jetzt erstmal locker und warte, ob das Problem bei den Testern, welche nächste Woche loslegen, überhaupt auftritt.

Beim letzten Mal konnte ich Timeline-Probleme durch erneutes inplace-Upgrading erschlagen, vielleicht so auch hier. Werde berichten.
Member: Bem0815
Bem0815 May 10, 2019 at 07:02:42 (UTC)
Goto Top
Daran könnte es tatsächlich liegen. Ich habe von meinen zwei Testclients auch denjenige bei dem das problem nicht auftritt nicht mit einem MS Konto verbunden (also die verkürzte Timeline) und beim anderen habe ich die verlängerte Timeline mit Cloud Anbindung durch ein MS Konto.

Sollte wirklich hier der Hund begraben sein, kann man tatsächlich nichts machen, dann ist definitiv MS gefragt dieses Problem zu fixen.


Das mit der Cloud Anbindung finde ich bei der Timeline eh grundsätzlich etwas doof gelöst.
Das funktioniert nämlich auch mit einem Domänenkonto nicht wirklich, auch wenn man sich z.B. für den MS Store mit einem MS Account verbunden hat bekommt man nur die verkürzte Timeline angezeigt. Hat aber in den Windows Einstellungen an der Stelle an der man gewöhnlich seinen Benutzeraccount mit einem MS Konto verbindet keine Möglichkeit das zu tun sofern man mit einem Domänenkonto eingeloggt ist.

Dennoch verweist der Button bei (mehr Tage auf der Zeitleiste anzeigen) per Link genau auf diesen Bereich in den Einstellungen. Dieses Problem besteht auch schon mit 1809.
Member: DerWoWusste
DerWoWusste May 10, 2019 at 08:23:39 (UTC)
Goto Top
Ich sagte schon: ich nutze lokal und MS Account - beide betroffen.
Member: Bem0815
Bem0815 May 10, 2019 at 08:40:36 (UTC)
Goto Top
Sry mein Fehler.
Member: DerWoWusste
DerWoWusste May 14, 2019 at 19:29:42 (UTC)
Goto Top
Das heutige kumulative Update auf 18362.113 hat das Problem für alle Profile behoben face-smile
Und bei Euch? http://www.catalog.update.microsoft.com/Search.aspx?q=2019-05%201903
Member: Bem0815
Bem0815 May 15, 2019 updated at 07:18:39 (UTC)
Goto Top
Dito, ist halt doch noch nicht ganz fertig die Version.
Das Image soll zwar soweit ich das gelesen habe als RC dienen aber es soll dann quasi noch mit einem CU ein Day 0 Patch geben sobald 1903 Final ausgerollt wird. Da werden denke ich noch einige solcher Bugs behoben werden. ;)

Hoffe du nimmst mir deshalb meinen ersten Beitrag auch nicht böse. Hab ja das genauso vermutet, dass mit einem Patch das Problem behoben wird.
Member: DerWoWusste
DerWoWusste May 15, 2019 at 07:52:04 (UTC)
Goto Top
Ich nehm nichts böse, keine Sorge. Es ist nur so, dass die RTM seit dem 18. April steht. MSDN ist kein Tester-Forum, es ist eine Quelle für Entwickler und die hat schon immer die RTMs als Erstes bekommen, da die Leute das beste Feedback liefern.

Dass Kinderkrankheiten da sind, ist schon klar - dazu testet man früh, um MS früh ein Feedback geben zu können und dann zeitig zum Rollout gehen zu können.

Zudem hatte Timeline schon unter 1803 ähnliche Probleme face-smile
Member: departure69
departure69 May 15, 2019 at 09:13:14 (UTC)
Goto Top
Zitat von @Bem0815:

Dito, ist halt doch noch nicht ganz fertig die Version.
Das Image soll zwar soweit ich das gelesen habe als RC dienen aber es soll dann quasi noch mit einem CU ein Day 0 Patch geben sobald 1903 Final ausgerollt wird. Da werden denke ich noch einige solcher Bugs behoben werden. ;)

Hoffe du nimmst mir deshalb meinen ersten Beitrag auch nicht böse. Hab ja das genauso vermutet, dass mit einem Patch das Problem behoben wird.


Hallo.

Seit Windows 10 ist das ja generell so eine mehr oder weniger fließende Sache, wann man ein neues Build als wirklich "Final" ansehen kann. Meines Erachtens ist aber ein sicheres Indiz dafür, daß die 1903 - 18362 die nächste bzw. nächste halbjährliche, offizielle Version ist, der Fakt, daß die 1903 schon seit knapp 2 Wochen unter "Produkten" im WSUS auswählbar ist und der WSUS die weiteren Updates dafür auch wirklich zieht und bereitstellt. Und im WSUS waren meines Wissens noch nie Versionen drin, die Beta, Insider oder sonstig vorübergehendes, testweises Zeug waren.

@DerWoWusste:

Timeline funktioniert hier aktuell mit Build 18362.113 einwandfrei, sowohl mit dem IE11 als auch mit dem Edge. Nicht nur die Einträge sind gelistet, sondern diese sind auch nachträglich nochmal aufrufbar. Allerdings bisher bloß an einem Rechner ausprobiert.


Viele Grüße

von

departure69
Member: Bem0815
Bem0815 May 15, 2019 at 10:23:59 (UTC)
Goto Top
Microsoft lässt sich denke ich nach dem 1809 Desaster schlichtweg etwas mehr Zeit das offiziell als Final zu betiteln.
Dass so eine Version dann im WSUS ist, ist in der Tat eine Premiere, sorgt aber dann bei mutigen dennoch für eine frühere Verbreitung die dann ja quasi der Test beim Endkunden selbst ist. Wer das installiert macht das aber dann quasi noch auf eigene Verantwortung, da noch nicht offiziell "Final".

Wann man sich die Upgrades jeweils installieren kann kommt denke ich immer auf die Situation an.
Wenn man relativ früh Upgraden will würde ich grob folgende Zeiträume nutzen:

Home PC - 0815 Nutzer: Frühestens 1-2 Wochen nach offiziellem Upgrade Release.
Home PC - Computeraffiner Nutzer: Von Release bis 2 Wochen nach Release Date.
Home PC - IT Profi: Von "Ready to Manufacture" bis 2 Wochen nach Release Date.

Arbeitsplatzrechner: entweder grob 6 Monate nach Release oder wenn die Ready for Business Freigabe von Microsoft da ist.
Arbeitsplatzrechner Thin Client: 1-2 Wochen nach offiziellem Upgrade Release bis 6 Monate oder Ready for Business.
Member: PC-Schrotti
PC-Schrotti Jul 13, 2019 at 15:01:07 (UTC)
Goto Top
Neues von der Timeline
"Lustiger" Fehler bei der Timeline: Beim Aufruf erscheint kein Zeitstrahl am rechten Bildschirmrand, der "Rest" ist da. (nach 1903-Feature-Update gestern Abend). Aktiviere ich das Snipping Tool mit 5 sec. Verzögerung und rufe dann die Timeline auf, wird nach ca. 5 sec im Hintergrund das Snipping Tool gestartet und nach weiteren 3 sec ist der Zeitstrahl plötzlich da. Nach Klicken auf das Snipping Tool verschwindet der Zeitstrahl wieder!
Eine bestimmungsgemäße Nutzung der Timeline ist so wohl eher nicht möglich.
Getestet auf einem Desktop-PC, da noch kein Tag seit dem Featureupdate vergangen ist, werden nur Dateien von heute angezeigt. Aber zu einem anderen Tag scrollen ist ohne Zeitstrahl wohl kaum möglich.
Werde das auch noch auf meinem Arbeitsnotebook und meinem Surface 4 Pro testen - mal sehen, was die dazu sagen. (Kopfschüttel)
Member: Bem0815
Bem0815 Jul 15, 2019 at 07:52:47 (UTC)
Goto Top
Kann dein Problem nicht nachvollziehen.
Tritt bei mir so nicht auf.

Wurde auf dem Gerät denn nach dem 1903 Upgrade noch die Windows Updates bis einschließlich Juli 2019 installiert?
Member: PC-Schrotti
PC-Schrotti Jul 16, 2019 at 11:36:49 (UTC)
Goto Top
Hallo Bem0815
Nach dem Feature-Update wurden noch die Quality-Updates KB4506991 (.NET Framework) und KB 4503308 (Adobe Flash Player) gezogen.

Problem tritt auch bei meinem Notebook auf (Lenovo mit Windows 10 Home) .
Auf meinem Surface 4 Pro (Windows 10 Pro) trat das Problem nur kurz auf, nach Erstellen eines neuen virtuellen Desktop wurde die Timeline eingeblendet.
Beim Lenovo funktioniert der "Trick" mit dem neuen virtuellen Desktop nicht, die Timeline bleibt "verschwunden".

Gerade nochmal gecheckt: Auf dem Tower hilft jetzt auch der "Trick" mit dem Snipping Tool nicht mehr - die Timeline bleibt verschwunden.
Member: Bem0815
Bem0815 Jul 16, 2019 at 11:48:23 (UTC)
Goto Top
Und was ist mit: 2019-07 Cumulative Update for Windows 10 Version 1903 for x64-based Systems (KB4507453)?
Member: PC-Schrotti
PC-Schrotti Jul 16, 2019 at 12:58:41 (UTC)
Goto Top
@Bem0815

Hab vor dem posting vorhin auf allen PCs einmal auf neue Updates checken lassen - "Sie sind auf den neuesten Stand" war jeweils seine freudige Mitteilung