Windows Server 2012 R2 frisst SSDs (cbs.log)

Mitglied: drahtbruecke
Hallo,

ich habe vor etwa 2 Monaten eine nur etwa 3 Monate alte SSD gegen eine neue getauscht (Samsung OEM Datacenter SSD SM883) in einem Windows Server 2012 R2. Die ist für das System (Laufwerk C:) face-smile, die Daten sind alle auf einem RAID. Damals hatte ich ein 20 GB CBS.log und der bekannte, uralte Windowsbug "cbs.log größer als 2 GB" schlug zu. Dabei wird die Datei dann immer eine WER kopiert, sobald er fertig ist, fängt er neu an. SSD nach zwei Monaten Dauerschreiben durch, 300 Euro weg, Danke Microsoft. Hab die also gewechselt. Ich habe mehrere der entsprechenden Anleitungen (SoftwareDistribution neu machen, SFC/CSB neu machen usw) durchgearbeitet und bis vorhin dachte ich, damit wäre das Problem erledigt. So zwei Monate war ja auch alles OK - bis vorhin...

Ich hatte immer wieder mal geguckt und vorhin wunder mich plötzlich über viel Last auf C: und tatsächlich:
wieder hab ich eine riesige CBS.log (5 GB). Ich konnte im Taskmanager beobachten, wie ständig WER Reports erzeugt und gelöscht werden.

Laut HDD Sentinel Pro waren 15 TB gelesen und 30 TB geschrieben (nichts auf C: gemacht, alles nur Microsoft Overhead!). Gut, dass ich das diesmal schnell gemerkt hab! Jetzt hab ich Windows Module Installer Service beendet und die cbs.log gelöscht. Jetzt ist die Transferrate immerhin schon mal auf 20 MB/sec runter gegangen (laut Taskmanager wird die ganze Zeit an C:\$Mft und C:\$LOGFILE rumgeschrieben, warum auch immer). Wenn ich mich nicht verrechnet habe, wäre sonst bei 300-500 MB/sec Schreiblast die SSD wieder in zwei Monaten durch gewesen.

Das ist doch jetzt aber kein Zustand, dass ich zweimal täglich auf dem Server gucken muss, ob da so ne Datei ausrastet. Eigentlich erwarte ich, dass so ein Server einfach nur funktioniert, ohne ständig gestreichelt zu werden.

Was kann ich dagegen tun, dass das nochmal passiert?

(Das Microsoft den Bug löst, werden wir ja nicht mehr erleben - die pushen ja gerade "passwordless", was die Azure Jungs ein bisschen zu wörtlich genommen haben.)

Content-Key: 1269513105

Url: https://administrator.de/contentid/1269513105

Ausgedruckt am: 26.10.2021 um 17:10 Uhr

Mitglied: Vision2015
Vision2015 16.09.2021 um 20:48:31 Uhr
Goto Top
Moin...

Was kann ich dagegen tun, dass das nochmal passiert?
was hindert dich auf Server 2019 /2022 umzusteigen?
oder gar auf Linux etc.... macOS Server!

(Das Microsoft den Bug löst, werden wir ja nicht mehr erleben - die pushen ja gerade "passwordless", was die Azure Jungs ein bisschen zu wörtlich genommen haben.)
nun, du kannst ihn ja lösen, einfach das OS wechseln... und gut Ist!

Frank
Mitglied: Xolger
Xolger 16.09.2021 um 21:07:48 Uhr
Goto Top
Hallo,

mach dir doch ein Skript oder eine Batch Datei und lege im Aufgabenplaner alle X Tage/Monate einen Task an der dir
das Skript ausführt. Dann wird reglmäßig gelösche und deine SSD geschont.

Batchdatei siehe 3. Kommentar unter: https://www.borncity.com/blog/2018/10/26/windows-7-cbs-log-bug-mllt-fest ...

Gruß Xolger
Mitglied: drahtbruecke
drahtbruecke 16.09.2021 um 21:56:40 Uhr
Goto Top
Danke für deine schnelle Antwort.

Ist dann nicht zu befürchten, dass zb Updates schief gehen, weil zufällig gerade der installer Dienst neu gestartet wird? Das Windows Update ist ja so empfindlich...
Aber sonst klingt die Idee schon mal gar nicht schlecht, danke!
Mitglied: Lochkartenstanzer
Lochkartenstanzer 16.09.2021 um 22:24:45 Uhr
Goto Top
Moin,

häng doch eine normale Platte rein und mounte die in das Verzeichnis hinein, so daß die Ligs auf HDD statt SSD geschrieben werden.

lks
Mitglied: anteNope
anteNope 17.09.2021 aktualisiert um 08:10:34 Uhr
Goto Top
Moin,
ja das kenne ich leider auch ... Bei einem Kunden haben sich die SSDs im RAID totgeschrieben. Der Controller hatte davon nix mitbekommen. Teile der SSDs waren nicht mehr lesbar, dennoch lief die Kiste wochenlang weiter. Das Backup hatte davon auch nichts mitbekommen und fröhlich Datenmüsli gesichert. Ist dann erst aufgefallen als essentielle Dienste versagt haben. Backup war natürlich unbrauchbar ... Die Daten lagen auf HDDs, aber AD alles andere waren einfach tot. War eine stressige Woche...

Habe das dann bei anderen Kunden überprüft und ähnliches festgestellt. Server 2012 R2 frisst SSDs.
Mitglied: em-pie
em-pie 17.09.2021 aktualisiert um 10:36:32 Uhr
Goto Top
Moin,

kann das hier nicht bestätigen.
Seit ~ 2015 läuft hier ebenfalls ein Server 2012R2 - aber als VM
Drunter ein SAN, mittlerweile voll mit SSDs, vorher ein 2-Tier-SAN mit SSD-Cache und HDDs
IBM hat nur einmal eine von 96 Disks tauschen dürfen, das war aber 'ne HDD und keine SSD

Auf dem Server hier ist die CBS-Log 15MB groß und beinhaltet ~ 85k Zeilen, gelistet seit dem 23.08...

Vielleicht macht es einen Unterschied, ob die Kiste als VM oder auf Blech läuft!?

Gruß
em-pie
Mitglied: VARLIK
VARLIK 17.09.2021 um 09:51:21 Uhr
Goto Top
Server 2012R2 Hatte das gleiche Problem. SSD war Schrot nach 18 Monaten. Bin auf W19 und jetzt auf W22 umgestiegen.
Mitglied: Tektronix
Tektronix 17.09.2021 um 10:38:33 Uhr
Goto Top
Moin,
ich habe hier Fujitsu RX300S8 mit LSI SAS 6G (D3116C) und Samsung MZ7KM1T9HAJM-00005 - 1.92TB SM863 unter Server 2012 R2 seit 5 Jahren am laufen. Betriebssytem läuft auf extra SAS RAID. Da ich den Server aber auch nicht ständig neustarte reicht mir dafür auch das SAS RAID. Auf den Samsung Platten sind mehrere Server VM's.
Mitglied: drahtbruecke
drahtbruecke 17.09.2021 um 20:43:22 Uhr
Goto Top
Zitat von @anteNope:

Moin,
ja das kenne ich leider auch ... Bei einem Kunden haben sich die SSDs im RAID totgeschrieben. Der Controller hatte davon nix mitbekommen. Teile der SSDs waren nicht mehr lesbar, dennoch lief die Kiste wochenlang weiter. Das Backup hatte davon auch nichts mitbekommen und fröhlich Datenmüsli gesichert. Ist dann erst aufgefallen als essentielle Dienste versagt haben. Backup war natürlich unbrauchbar ... Die Daten lagen auf HDDs, aber AD alles andere waren einfach tot. War eine stressige Woche...

Habe das dann bei anderen Kunden überprüft und ähnliches festgestellt. Server 2012 R2 frisst SSDs.

Ohh mein Gott, ich stelle fest, ich hab ja noch richtig Glück!
Das raid ist ein mit so nem PC Server Controller (LSI/broadcom)? Prüfen die smart Werte nicht richtig?

Oh man, Du hast rückwirkend mein Volkes Beileid!
Mitglied: drahtbruecke
drahtbruecke 17.09.2021 um 20:47:33 Uhr
Goto Top
Zitat von @em-pie:

Moin,

kann das hier nicht bestätigen.
Seit ~ 2015 läuft hier ebenfalls ein Server 2012R2 - aber als VM
Drunter ein SAN, mittlerweile voll mit SSDs, vorher ein 2-Tier-SAN mit SSD-Cache und HDDs
IBM hat nur einmal eine von 96 Disks tauschen dürfen, das war aber 'ne HDD und keine SSD

Auf dem Server hier ist die CBS-Log 15MB groß und beinhaltet ~ 85k Zeilen, gelistet seit dem 23.08...

Vielleicht macht es einen Unterschied, ob die Kiste als VM oder auf Blech läuft!?

Gruß
em-pie

Die anderen Server (und Workstations) haben ja kein Problem mit cbs.log. Hab auch welche mit 6 Jahre alter SSD, also "Erstausstattung", die super laufen und keine Probleme machen.

Das blöde ist ja nur, wenn man so Probleme kriegt, ist es manchmal schwer zu reparieren. Leider haben wir manchmal so (alte) Spezialsoftware drauf, die sich nicht so einfach neu installieren lässt.
Mitglied: drahtbruecke
drahtbruecke 17.09.2021 um 20:51:05 Uhr
Goto Top
Zitat von @Lochkartenstanzer:

Moin,

häng doch eine normale Platte rein und mounte die in das Verzeichnis hinein, so daß die Ligs auf HDD statt SSD geschrieben werden.

lks

Sind ja mindestens zwei verzeichnisse (logs und WER), aber ich könnte vielleicht auf die backup HDD linken. Das ist auch ne gute Idee. Danke!
Mitglied: Vision2015
Vision2015 17.09.2021 um 21:10:24 Uhr
Goto Top
Zitat von @drahtbruecke:

Zitat von @anteNope:

Moin,
ja das kenne ich leider auch ... Bei einem Kunden haben sich die SSDs im RAID totgeschrieben. Der Controller hatte davon nix mitbekommen. Teile der SSDs waren nicht mehr lesbar, dennoch lief die Kiste wochenlang weiter. Das Backup hatte davon auch nichts mitbekommen und fröhlich Datenmüsli gesichert. Ist dann erst aufgefallen als essentielle Dienste versagt haben. Backup war natürlich unbrauchbar ... Die Daten lagen auf HDDs, aber AD alles andere waren einfach tot. War eine stressige Woche...

Habe das dann bei anderen Kunden überprüft und ähnliches festgestellt. Server 2012 R2 frisst SSDs.
nein... eigentlich frisst Server 2012 R2 keine SSDs.....

Ohh mein Gott, ich stelle fest, ich hab ja noch richtig Glück!
glück ist mit den .....
Das raid ist ein mit so nem PC Server Controller (LSI/broadcom)? Prüfen die smart Werte nicht richtig?
gute Frage... möchtest du uns nicht sagen- welcher "PC Server Controller (LSI/broadcom)" den verbaut worden ist!
Prüfen die smart Werte nicht richtig?
doch das tun sie, allerdings nur- wenn der richtige Controller verbaut wird, und vor allem die dazu passenden SSDs...
wenn ich Server 2012R2 lese, denke ich an einen LSI 9240 oder so... der kann das natürlich nicht!


Oh man, Du hast rückwirkend mein Volkes Beileid!
oha...

Frank
Mitglied: Lochkartenstanzer
Lochkartenstanzer 18.09.2021 um 01:20:55 Uhr
Goto Top
Zitat von @drahtbruecke:

Sind ja mindestens zwei verzeichnisse (logs und WER), aber ich könnte vielleicht auf die backup HDD linken. Das ist auch ne gute Idee. Danke!

Dann machst Du zwei (oder mehr) Partitionen und hängst die in die jeweiligen Verzeichnisse.

lks
Mitglied: anteNope
anteNope 18.09.2021 aktualisiert um 08:22:00 Uhr
Goto Top
Ich hatte bis vor kurzem noch zwei beim Kunden laufen. Auf dem einen nur Lexware und AD, während der andere nur sekundärer AD war. Bei beiden beobachtete ich eine Schreibleistung von ca. 50 GB pro Tag. Mit dem Process Explorer konnte ich zumindest die Prozesse identifizieren, aber das bringt nicht viel wenn diese svhost.exe und system.exe sind.

Ich hatte diverse Logs deaktiviert und das Schreibvolumen ist tatsächlich zurückgegangen. Ich hatte damals das hier geschildert: https://administrator.de/forum/hohe-schreibleistung-unbekannter-herkunft ...

Trotzdem wurden laut SMART 50-100 GB Pro Tag auf die Zellen geschrieben. Verwunderlich war, dass dies erst NACH dem Austausch der SSDs durch größere angefangen hatte. Die alten SSDs hatten über ihre gesamte Arbeitszeit von 4 Jahren gerade mal 300 GB geschrieben.

nein... eigentlich frisst Server 2012 R2 keine SSDs.....
Also nein, ich widerspreche entscheiden! Irgendetwas kann dazu führen, dass Windows Server 2012 R2 SSDs frisst! Dieses Problem habe ich exklusiv nur mit dieser Server Version beobachtet.

@drahtbruecke
Du wirst das gleiche Problem haben, was ich hatte. Symptome passen, zuvor SSDs getauscht. Wird mal den Prozess Explorer an und lass den ein paar Tage laufen.

Was kann ich dagegen tun, dass das nochmal passiert?
Wenn es die gleiche Ursache wie bei mir ist: Logging in vielen Bereichen deaktivieren

Das blöde ist ja nur, wenn man so Probleme kriegt, ist es manchmal schwer zu reparieren. Leider haben wir manchmal so (alte) Spezialsoftware drauf, die sich nicht so einfach neu installieren lässt.
Kenne ich zu genüge. Nervt. Aber mit etwas Glück läuft das auch auf etwas aktuellem. Ich habe bei einem Kunden WISO 2002 auf Windows 10 laufen ... einfach mal ausprobieren 😉
Heiß diskutierte Beiträge
question
Suche guten Virenscanner für Windows Server 2019 bzw Exchange 2019Nummer-5Vor 1 TagFrageExchange Server16 Kommentare

Hallo, ich habe leider das Problem, das von unserem Exchange Server 2019 Spam Mails versendet werden. Ich habe jetzt den Relais-Server erst einmal stillgelegt, es ...

question
Firewall Hardware (VM)v4rrimka-sanVor 1 TagFrageNetzwerkmanagement10 Kommentare

Hey, Ich habe eine Frage, die wahrscheinlich schon öfter gestellt wurde, zum Thema Hardware Anforderung für eine Firewall in einer VM. Zur Auswahl stehen OPNsense ...

question
Mail-Relay für interne AnwendungenredhorseVor 1 TagFrageExchange Server10 Kommentare

Hallo, wir verwenden einen Exchange 2016 mit einer Sophos UTM als Smarthost. Der Exchange wird u.a. als SMTP-Relay von internen Anwendungen benutzt, für den anonymen ...

question
Teamviewer stürzt ab unter Win 11ben1300Vor 1 TagFrageWindows 118 Kommentare

Hallo zusammen, habe mein Notebook auf Windows 11 umgestellt. Seitdem kann ich den Teamviewer (aktuellste Version) nicht mehr nutzen. Programm startet, aber sobald ich z.B. ...

question
Speicherkarten (SD) im Netzwerk verfügbar machen (NAS) gelöst mathuVor 1 TagFrageSpeicherkarten7 Kommentare

Guten Morgen liebe Gemeinde :-) Ich habe eine Frage zu NAS Speichersystemen mit Speicherkartenkunktion. Bisher haben wir die folgenden Geräte von Synology (EDS14) genutzt. Diese ...

question
Intune Geräte DESKTOP vs. LAPTOPmarkaurelVor 1 TagFrageMicrosoft2 Kommentare

Hallo zusammen und bitte um eure Hilfe! Ich hab zwei Geräte: 1x Dell Inspiron 5301 1x Lenovo 20VD Beide Geräte eindeutig Kategorie Laptop/Notebook. Wenn ich ...

question
Datenreplikation unabhängige Domänensupport-itVor 1 TagFrageWindows Server8 Kommentare

Hallo zusammen, kann mir jemand ein Programm empfehlen, das sich so ähnlich verhält wie die DFS-Replikation von Windows, blos zwischen verschiedenen Domänen? Ich habe die ...

question
Linux End-to-Site VPN mit Sophos SGukulele-7Vor 1 TagFrageLinux Netzwerk12 Kommentare

Hallo und Hilfe. Ich habe eine Sophos SG, die unterstützt laut Menü "Remote Access" SSL PPTP L2TP over IPsec IPsec Cisco™ VPN Client Dabei ist ...