jojo0411
Goto Top

Windows Server 2016 RDS extrem langsam nach Neustart

Hallo Leute,

Ich habe bei uns 2 Windows Server 2016 Terminalserver in Betrieb.

Am Mittwoch Abend habe ich Windows Updates eingespielt wobei nur die Defender Updates zum einspielen waren. Nach dem Neustart lief einer der beiden Terminalserver nicht mehr Rund. Ich konnte mich nicht mehr anmelden über RDP und habe dassomit über die Hyper V Konsole erledigt. Dort viel mir auf das alles extrem langsam ist. Das hat sich auch 2 Tage später noch nicht verändert. Die Applikationen starten extrem langsam und ganz egal was ich starte (Ereignisanzeige etc.) es stürzt ab. Im Taskmanager kann ich keine spezielle Last etc. erkennen. Mittlerweile habe ich auch schon einen Restor durchgeführt von einer alten Version. Am Anfang funktioniert noch alles normal doch plötzlich fällt das System wieder in das alte Muster. Der Server ist praktisch nicht mehr zugebrauchen. Am 2. Server der genau die gleichen Applikationen hat funktioniert alles normal.

Hat jemand von euch eine Idee was ich noch tun könnte?

nice greetz jojo

Content-Key: 338969

Url: https://administrator.de/contentid/338969

Printed on: December 8, 2022 at 05:12 o'clock

Member: jojo0411
jojo0411 May 26, 2017 at 07:44:22 (UTC)
Goto Top
Hallo Leute,

Ich konnte die Quelle jetzt eindeutig identifizieren. Der Trend Micro Office Scan ist Schuld... sobald dieser Ausgeschaltet ist funktioniert alles einwandfrei... warum der 2. Server das Problem nicht hat ist mir ein Rätsel.

Ich werden den Trend Micro am Abend deinstallieren und neu installieren. Vielleicht löst sich das Probleme dann von alleine.

nice greetz jojo
Member: SeaStorm
SeaStorm May 26, 2017 at 07:46:53 (UTC)
Goto Top
Hi

erst mal halbwegs identifizieren was die Performance so drückt.

-> perfmon mal anschmeissen und den Verursacher identifizieren.
Member: jojo0411
jojo0411 May 26, 2017 at 07:49:27 (UTC)
Goto Top
Das war das eigenartige... ich hatte in der Ressourcenanzeige nichts was irgendwo ausgeschlagen ist. Auch der Trend Micro war unaffällig. Ich habe dann einfach auf gut Glück im abgesicherten Modus den Virenschutz deaktiviert und jetzt läuft es wieder. Es könnte sein das sich der Windows Defender und Trend Micro nicht verstehen. Das werde ich am Wochenende einmal überprüfen.

nice greetz jojo
Member: chrisiweber
chrisiweber May 27, 2017 at 18:53:31 (UTC)
Goto Top
Wird der Windows Defender nicht automatisch deaktiviert wenn ein anderer Schutz zum Einsatz kommt?

LG
Member: XPFanUwe
XPFanUwe May 28, 2017 at 18:35:27 (UTC)
Goto Top
Windows Defender und Trend Micro nicht verstehen.

Windows 10 und fremde Virendinger sind eine Katastrophe! Server 2016 IST Windows 10. W10 ist von Haus aus nix...
Member: SeaStorm
SeaStorm May 28, 2017 at 18:48:20 (UTC)
Goto Top
so ein Blödsinn ...
Member: PhaseIV
PhaseIV May 30, 2017 at 07:31:55 (UTC)
Goto Top
Selbes verhalten ist auf einem meiner 2016er Server auch aufgetreten. Habe mehrere Windows Server 2016 im Einsatz, alle mit TrendMicro.
Jedoch nur auf einem (Domaincontroller) dieses Verhalten. Im Eventlog war nichts auffälliges und auch der Taskmanager gab wenig Auskunft.
Nach der Deinstallation von Trend Micro läuft wieder alles wie gehabt.
Member: SeaStorm
SeaStorm May 30, 2017 at 10:12:54 (UTC)
Goto Top
Hast du mal geguckt ob deine TM Version überhaupt mit Server2016 kompatibel ist?
Member: PhaseIV
PhaseIV May 31, 2017 at 10:04:34 (UTC)
Goto Top
Trend Micro WFBS V9 ist ab SP2 zumindest mit Windows10 kompatibel. Ob er explizit für Server 2016 kompatibel ist weiss ich nicht, jedoch war das ganze schon ein paar Monate in Betrieb.
Member: jojo0411
jojo0411 May 31, 2017 at 10:55:14 (UTC)
Goto Top
Hallo Leute,

Also ich hatte mittlerweile das Problem auf diversen Windows 10 Rechnern und Windows Server 2016 Geräten. Ich habe das Upgrade auf die Office Scan XGEN Linie (plus neuesten Patch) durchgezogen und überall den Client deinstalliert und neu installiert. So scheint es sich lösen zu lassen. Momentan läuft alles gut.
Member: PhaseIV
PhaseIV Jun 01, 2017 updated at 07:24:52 (UTC)
Goto Top
Achtung das ganze betrifft nicht nur den Windows Server 2016 sondern auch Windows 10!

Hab jetzt die ersten Clients mit selben Symptom. Nach der Deinstallation von Trend Micro Office Scan läuft wieder alles.

Trend Micro Kompatibel Windows 10 Creators Update
Member: PhaseIV
PhaseIV Jun 06, 2017 at 06:06:25 (UTC)
Goto Top
Hotfix von TrendMicro ist jetzt erhältlich!
Member: Delphis1982
Delphis1982 Jun 09, 2020 at 07:56:16 (UTC)
Goto Top
Der Domaincontroller ist ein Sonderfall.
Auf dem Laufwerk, auf welchem die NTDS Datenbank liegt, wird grundsätzlich der Schreibcache des jeweiligen Laufwerks deaktiviert.
Ich hatte es auf meinem DC genauso. Eine 1TB HDD war in 3 Partitionen aufgeteilt.
Auf C: lag Windows Server 2016 inkl. Exchange Server 2016, auf D: lagen die Datenbank, die Logs und SYSVOL. Auf E: lag die Mailbox.
Das System wurde aber schon ab DEM Moment quäkend lahm, als ich ihn zum DC hochgestuft hatte.
Habe dann irgendwann festgestellt, dass der Schreibcache der HDD deaktiviert wurde.
Den Schreibcache habe ich manuell aktiviert, aber er wird bei jedem Start wieder deaktiviert
und ich bin der Meinung, dass er gar nicht erst aktiviert WIRD, auch wenn es so angezeigt wird.
Hatte dann eine zweite HDD eingebaut und zumindest die NTDS.dit, die Logs und SYSVOL auf eben jenes Laufwerk verschoben.
Siehe da, das System war wieder flott, da die Datenbank jetzt auf einem ANDEREN Laufwerk lag.
Ich würde also mal die AD Datenbank auf ein separates Laufwerk legen, das macht einiges aus.