Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows Server erforderlich

Mitglied: 24445

24445 (Level 1)

01.02.2006, aktualisiert 18:34 Uhr, 2996 Aufrufe, 1 Kommentar

Datenbankprogramm kriecht zum teil

Hallo!

Habe folgendes Problem.

Ich betreue für eine kleine Firma die Computer. Damit ihr euch ein Bild von der Situation machen könnt beschreib ich erstmal den Istzustand.

Reines Windowsnetzwerk, peer-to-peer, Cat5e, 100Mbit-Karten, 100Mbit Switch
feste Ip´s, Telefonanlage als Router, Netzwerk- und lokale Drucker

Server(gibts natürlich net bei p2p)
Athlon 1800+, 1GB RAM, 2x 60GB IDE als Raid1, Fritz Card,
auf diesem rechner ist eine Partition(Ordner) freigegeben.Diese wird bei den "Clients" als Netzlaufwerk verbunden. In dem Ordner befinden sich alle "Eigene Dateien" der Clients und das Programmverzeichniss des Datenbankprogrammes (labelwin). Dies habe ich so eingerichtet um die daten zentral zu speichern, um eine einfache Sicherung zu ermöglichen.
Außerdem läuft AVM Ken3 auf dem Server um Email und ISDN-Dienste den Clients zur verfügung zu stellen. In Ken ist Antivir aktiviert(für Server und Klienten).

Clients
Als Arbeitsplätze dienen je ein Athlon 1800+XP-Pro, PIII 800 XP-Pro, Athlon 600XP-Pro, 2x PIII450 Win98se.
Außerdem kommen ab und zu noch 2 Notebooks und ein PIV hinzu alle Win-XP. Diese werden aber nur zum Internetsurfen, bzw Datensichern und nur selten zur Arbeit benutzt.
Für den täglichen gebrauch kann man sagen das zur Zeit 5-6 Rechner gleichzeitig angemeldet sind.

Eigentlich funktioniert alles. Nur mit dem Datenbankprogramm gibt es ein Problem.Das Programmverzeichniss und die Datenbanken (Projektdatenbank, Datanorm-Kataloge, ... alles *.mdb) liegen auf dem Server. Auf den Clients sind zur ausführung der Programme nur ein paar dll´s installiert.
Also wenn man z.B. das Kundendienstprogramm lädt, wird es aus dem Netzlaufwerk geladen.
Dieses dauert relativ lang(ca.7sek). Andere Programmmodule dagegen, die die gleiche Datenbank nutzen gehen um weiten schneller(1sek). Dazu muss ich sagen das das Kundendienstmodul wenn es geladen ist gut 30MB auf dem Client benötigt.
Wenn das Modul geladen wird, hab ich beobachtet das die Netzwerkauslastung am Server nicht über 25% liegt. Die Prozessorauslastung bei Zugriff liegt bei max. 10%.
Wenn ich große Dateien im Netz kopiere funktioniert dies tadellos. NetIO sagt auch alles OK.
Wenn das Modul erstmal geladen ist bleibt es natürlich auch den ganzen Tag an. Daher ist die ladezeit nicht so entscheidend.
Allerdings gibt es in diesem Modul eine Tagesübersicht (Kalenderfunktion) die sehr oft benutzt wird. Und dies kriecht förmlich beim öffnen, mal 1sek mal 7sek. Da ja mehrere Leute mit dem gleichen Modul arbeiten ändert sich viel an den Terminen. Das heisst man muss aktualisieren. Dies geht nur indem man den kalender schließt und wieder öffnet. Und beim schließen dauert es manchmal bis 10sek. manchmal aber nur 1sek!

Dies ist das eigentliche Problem! Und zwar tritt es unregelmäßig, unabhängig von Anzahl der angemeldeten Rechner, Benutzer, ob Virenscanner ein oder aus, ob Multitasking oder nicht auf. Also auch wenn nur der Server und ein Client(der schnellste) am Netz sind!
Laut Hersteller der Software sind 3 Rechner im p2p-Netzwerk Ok! Es funktioniert aber nichtmal mit 2 (jedenfalls nicht diese funktionen).
Wenn man das Modul auf dem server öffnet dauert das laden nicht ganz so lang und der rest ist schneller.

Zurzeit richte ich eine testversion von win2003server ein. diese läuft bereits parallel auf dem server zum testen. Habe eine Domäne eingerichtet, server als fileserver eingerichtet, Active D. und DNS installiert. Oder ist DNS uns AD bei 5-10 Rechnern nicht unbedingt notwendig???
Erste Testergebnisse post ich dann später.

Das riecht nach Nadel im Heuhaufen!
Vielen dank schonmal im Voraus!
Gruß Loopie
Mitglied: verkehrsberuhigt
01.02.2006 um 18:34 Uhr
*.MDB-DBs in einem P2P-Netzwerk hört sich in meinen
Ohren richtig Schei..e an.

Ich habe mir neuerdings angewöhnt, bei Performance-
Problemen immer zuerst nach einem mitspielenden
Anti-Viren-Programm oder -Scanner zu fragen...
Bitte warten ..
Ähnliche Inhalte
Netzwerkgrundlagen

Separates Erdungskabel zur Netzwerkdose erforderlich

gelöst Frage von chris-90Netzwerkgrundlagen8 Kommentare

Hallo zusammen, ich habe gehört, dass es Netzwerkdosen gibt, an der ein separates Erdungskabel angeschlossen werden kann. Das würde ...

Netzwerke

UniFi Security Gateway unbedingt erforderlich?

Frage von Erikson.netNetzwerke9 Kommentare

Moin Leute! Ich möchte eine Netzwerk-Installation mit UniFi von Ubiquiti machen.Es ist ein relativ aufwändiges Projekt (mehrere Häuser sollen ...

Sicherheit

Nacharbeiten nach Patch für Domänencontroller erforderlich

Information von DerWoWussteSicherheit4 Kommentare

Falls es jemand noch nicht mitbekommen haben sollte: seit etwa 2 Wochen gilt mal wieder "Alarmstufe rot" für Windows ...

Verschlüsselung & Zertifikate

Biltocker: Wodurch Eingabe Widerherstellungschlüssel erforderlich - Einbrucfh

Frage von KevinFreeVerschlüsselung & Zertifikate7 Kommentare

Moin, vor drei Wochen konnte ich feststellen, dass jmd versucht hat mein mit Bitlocker und TPM gesichertes System zu ...

Neue Wissensbeiträge
Humor (lol)
Und wie seid Ihr gegen Cyberattacken gewappnet?
Information von DerWoWusste vor 10 StundenHumor (lol)4 Kommentare

aber wo ist der Hammer? :-)

Sicherheit
Ein weiterer Microsoft-Stirnklatscher
Information von DerWoWusste vor 1 TagSicherheit7 Kommentare

Habe gerade einen Artikel zu einem Sicherheitsproblem gefunden, welches mir zu seiner Zeit (gepatcht 2015) wohl durchgerutscht ist. Es ...

Windows 10
Upgradepfade Windows 10 LTSC
Erfahrungsbericht von Datenreise vor 1 TagWindows 10

Nur eine kurze Info, für diejenigen, die es interessiert, da es hierzu im Netz aus nachvollziehbaren Gründen nicht allzu ...

Administrator.de Feedback
Wartungsarbeiten heute Nacht (Update)
Information von Frank vor 1 TagAdministrator.de Feedback10 Kommentare

Hallo User, durch Umbauarbeiten in unserem Rechenzentrum (am Backbone) kann es heute Nacht (14-15.01.2019) zu kurzen Ausfällen unserer Seite ...

Heiß diskutierte Inhalte
Windows 10
Windows 10 - kein Boot mehr nach Domänenaustritt
gelöst Frage von Ghost108Windows 1025 Kommentare

Hallo zusammen, habe hier eine Windows 10 Maschine, die ich gerne aus der Domäne austreten lassen möchte. Nach Austritt ...

Windows 10
Windows 10 1803 - nicht identifiziertes Netzwerk - kein Login an Domäne möglich
Frage von Tomy389Windows 1021 Kommentare

Hallo Zusammen, ich hoffe zu dem Thema gibt es nicht schon einen Thread aber ich sollte eigentlich schon alles ...

Exchange Server
Microsoft Exchange Ser ver 2016 CU 8 auf den neuesten Stand bringen
gelöst Frage von Hendrik2586Exchange Server20 Kommentare

Hallo an euch alle. :) Kurze Frage. Ich habe hier einen Exchange Server wie o.g. Problem ist das wir ...

Microsoft
SFirm 4.0 auf Terminalserver startet für jeden angemeldeten Benutzer diverse Dienste
Frage von Frank84Microsoft17 Kommentare

Hallo zusammen, wir verwenden Sfirm 4.0 auf einem Terminalserver (der SQL Server ist auf einem separaten Server), das Problem ...