WindowsUpdate bricht mit 0x8007000d ab

josephusflavius
Goto Top
Hallo,

ich habe seit ca. 3 Monaten Probleme die automatischen Windowsupdates einzuspielen. Defender-Updates funktionieren aber die Cumulative Updates scheitern. Die Updatedateien werden jeweils heruntergeladen, aber die Installation scheitert jeweils bei ca. 5% mit dem Fehler:

“Einige Updatedateien fehlen oder weisen Probleme auf. Wir versuchen, das Update später erneut herunterzuladen. Fehlercode: (0x8007000d)”

Eine Bereinigung der Updatedateien hilft nicht weiter.

Ich habe die Hoffnung aufgegeben, dass sich dieses Problem von alleine durch das nächste Update löst und bitte daher um Unterstützung.

Ich habe folgendes probiert:

Verwenden von SFC

Offenheit Eingabeaufforderung indem cmd in das Suchfeld neben dem Start Menu .
Klicken Sie mit der rechten Maustaste auf Eingabeaufforderung und wählen Sie Als Administrator ausführen.
Geben Sie nach dem Öffnen der Konsole Folgendes ein: sfc /scannow Befehl und klicken Weiter.
Starten Sie Ihren Computer nach Abschluss des Reparaturvorgangs neu.

DISM verwenden

Offenheit Eingabeaufforderung wie wir es im vorherigen Schritt getan haben.
Kopieren Sie diesen Befehl und fügen Sie ihn ein DISM.exe /Online /Cleanup-image /Restorehealth.
Klicken Sie Weiter und warten Sie, bis Windows das Scannen und Korrigieren beendet.
Starten Sie anschließend Ihren PC neu und installieren Sie das Update erneut.


CMD mit Admin-rechten:

net stop wuauserv & net stop cryptSvc & net stop bits & net stop msiserver
Ren C:\\Windows
SoftwareDistribution SoftwareDistribution.ALT
Ren C:\\Windows\\System32
catroot2 Catroot2.ALT
net start wuauserv & net start cryptSvc & net start bits & net start msiserver
Anschließend probieren, ob der Fehler beim Update erneut auftritt ...“

Ich habe diese Schritte durchgeführt. Das Update wurde danach erneut vollständig heruntergeladen, jedoch kommt es zum gleichen Fehler.


Ich würde mit DISM erneut probieren. Es fehlt leider die Angabe der Quelldatei. Wo liegt die Datei, die DISM für korrektur braucht?

Vielen Dank für eure Hilfe.

Danke!

JoFlo

Content-Key: 1732822620

Url: https://administrator.de/contentid/1732822620

Ausgedruckt am: 10.08.2022 um 15:08 Uhr

Mitglied: SeaStorm
SeaStorm 17.01.2022 um 17:39:35 Uhr
Goto Top
Hi

steht denn was interessantes im Windowsupdatelog ?
https://docs.microsoft.com/en-us/powershell/module/windowsupdate/get-win ...
Mitglied: dertowa
dertowa 18.01.2022 um 10:09:09 Uhr
Goto Top
Zitat von @JosephusFlavius:
CMD mit Admin-rechten:

net stop wuauserv & net stop cryptSvc & net stop bits & net stop msiserver
Ren C:\\Windows
SoftwareDistribution SoftwareDistribution.ALT
Ren C:\\Windows\\System32
catroot2 Catroot2.ALT
net start wuauserv & net start cryptSvc & net start bits & net start msiserver
Anschließend probieren, ob der Fehler beim Update erneut auftritt ...“

Wenn das nicht hilft, nicht lang fackeln und ein Inplaceupgrade (bspw. via MediaCreationTool) ausführen.
Mitglied: JosephusFlavius
JosephusFlavius 18.01.2022 um 16:42:03 Uhr
Goto Top
Hi SeaStorm,

hier sind die Logs: https://www.codepile.net/pile/Qbd1dxNG

hier ist die Stelle mit dem Fehlercode:


Leider nicht besonders aussagekräftig. Ich werde mal die Kollegen bitten, sich auch den WSUS-Server anzuschauen.
Möglicherweise sieht man dort etwas mehr.

LG

JoFlo
Mitglied: SeaStorm
SeaStorm 18.01.2022 um 17:38:10 Uhr
Goto Top
ne sehe ich jetzt so auch nichts.
Lade mal C:\Windows\Logs\CBS\CBS.log hoch. Da stehen auch noch Dinge zu den Updates drin
Mitglied: JosephusFlavius
JosephusFlavius 19.01.2022 aktualisiert um 16:02:52 Uhr
Goto Top
Hi Seastorm.

hier sind die aktuellen Update-Logs:
https://www.codepile.net/pile/ogYek0gP


und hier sind die CBS-Logs:
https://www.codepile.net/pile/PLleAM0z



Update gestartet um 13:10 Uhr
Fehler trat um ca. 13:17/13:18 Uhr auf
Der Fehler ist in WindowsUpdate-Log ab Zeile 11591 zu finden.
Die Ursache könnte aber Zeile 167300 im CBS-Log sein: Hash für kerberos.dll stimmt nicht -> Installation ist wahrscheinlich defekt.

Wie schätzt du diesen Punkt als mögliche Fehlerquelle ein?

LG

JoFla
Mitglied: SeaStorm
SeaStorm 19.01.2022 um 18:36:54 Uhr
Goto Top
die site kann wohl nicht mehr als 20k Zeilen.
Der interessante Part ist nicht im Log face-smile
Mitglied: JosephusFlavius
JosephusFlavius 19.01.2022 um 19:11:11 Uhr
Goto Top
Ok, vielen Dank.
Ich habe dir eine PM geschickt.
Mitglied: SeaStorm
SeaStorm 19.01.2022 um 21:31:35 Uhr
Goto Top
Sieht aus als ob dein Componentstore kaputt ist

Ich würde erst mal ein Cleanup machen:
DISM /Online /Cleanup-Image /StartComponentCleanup
dann reboot und noch mal probieren.
Wenn das nichts hilft brauchst du eine Win10 ISO deiner Version. Die mounten und dann
Dism /Online /Cleanup-Image /RestoreHealth /Source:wim:X:\sources\install.wim:1 /limitaccess

Ansonsten könnte SFCFix helfen:
https://www.sysnative.com/forums/downloads/sfcfix/
Ob du denen vertraust musst du entscheiden face-smile


Und prüfe bitte mal ob bei dir der AppReadiness-Dienst (App-Vorbereitung) Auf Manuell steht und auch auf Anfrage startet
Mitglied: JosephusFlavius
JosephusFlavius 19.01.2022 um 21:59:08 Uhr
Goto Top
Vielen Dank für deine Unterstützung.

DISM mit /Online funktioniert in Verbindung mit unserem Firmen-WSUS-Server wohl nicht. Auch ein Punkt was ich am Anfang auch nicht verstanden habe.

Ich frage mal die Kollegen, ob das Image so via DISM erreichbar ist.

Mit dem "Componentenstore" meinst du den Dienst auf dem Client oder auf dem WSUS-Server?

Bei mir persönlich steht AppReadiness auf "manuell". Da jedes dasselbe Image bekommt, gehe ich davon aus, dass es auch beim betroffenenen Kollegen so ist.

Wie schätzt du sonst dieses Kerberos-Hash-Problem ist? Kann es mit dem kaputten Componentenstore in Verbindung stehen?:


LG

JoFla
Mitglied: SeaStorm
SeaStorm 19.01.2022 um 22:57:56 Uhr
Goto Top
DISM mit /Online funktioniert in Verbindung mit unserem Firmen-WSUS-Server wohl nicht. Auch ein Punkt was ich am Anfang auch nicht verstanden habe.
Dann lösche mal die Registry Werte unter HKLM\Software\Policies\Microsoft\Windows\WindowsUpdate
und starte dann den Windows Update Dienst neu. Braucht es hier aber eigentlich nicht weil der erste Befehl nur WinSxS aufrämen soll, falls da drin irgendwas kaputtes rumfliegt.
und der zweite Befehl repariert dann alles mit den Daten von der ISO.

Mit dem "Componentenstore" meinst du den Dienst auf dem Client oder auf dem WSUS-Server?
Client. Der ist ja kaputt face-smile
Bei mir persönlich steht AppReadiness auf "manuell".
Ja passt. Hatte nur vor kurzem ein Problem mit Updates und da war warum auch immer der Dienst auf Disabled. Sobald der wieder auf manuell gestellt wurde ging alles.

Wie schätzt du sonst dieses Kerberos-Hash-Problem ist? Kann es mit dem kaputten Componentenstore in Verbindung stehen?:

Bin mir da jetzt nicht sicher. Aber ich würde sagen das ist eine Auswirkung des defekten Stores. Er hat vermutlich irgendwo falsche\alte Daten und erwartet nun andere Hashes und failed deshalb.

Aber wenn ihr eh alles von einem Image abtankt ... macht die Kiste doch platt?!

Oder betrifft das Problem nicht nur einen Rechner sondern alle bzw viele ?
Mitglied: JosephusFlavius
JosephusFlavius 20.01.2022 aktualisiert um 09:30:16 Uhr
Goto Top
Zitat von @SeaStorm:
Dann lösche mal die Registry Werte unter HKLM\Software\Policies\Microsoft\Windows\WindowsUpdate

Hier ist der Inhalt von Windows Update ... Soll ich wirklich alle Keys löschen?

2022-01-20 09_06_21-registrierungs-editor

Mit erstem und zweitem Befehl meinst du diese oder?


Aber wenn ihr eh alles von einem Image abtankt ... macht die Kiste doch platt?!
Oder betrifft das Problem nicht nur einen Rechner sondern alle bzw viele ?

Er meinte ihm kommt es zeitlich nicht in Frage, er hat den Rechne schon zu sehr auf seine eigene Bedürfnisse angepasst ...

LG

JoFla