Wireguard - Drucker vom VPN-Client für das gesamte Netz freigeben

kmartins
Goto Top
Hallo Zusammen,


ich wäre so froh, wann mir jemanden helfen würde face-smile
Ich habe folgende Probleme:

Ich habe ein VPN-Server unter Windows 11 mit Wireguard eingerichtet, das funktioniert auch einwandfrei.

IP Addresse interne Netzwerk: 192.168.49.1
Wireguard Netz: 10.253.0.0

Die Verbindung zwischen Server und VPN-Client funktioniert auch einwandfrei.
Ich will aber jetzt ein Drucker die Über USB an ein VPN-Client angeschlossen ist, für die gesamte Netzwerk freigeben.
Ich kann der Drucker am Wireguard Server problemlos finden und installieren.
Aber die Clients im interne Netzwerke können die VPN-Client nicht erreichen und damit den Drucker nicht finden.

Ich kann aber über VPN, die interne Client pingen.

Ich habe schon die Routing Tabelle vom Server angepasst, aber ich denke ich mach da was Falsch.

Am Router selbst kann ich die Einstellung nicht vornehmen. (HomeSpot O2) ....


Sorry, für die Rechtschreibfehler.


Danke euch im Voraus

Gruß
Kevin Martins

Content-Key: 3221552735

Url: https://administrator.de/contentid/3221552735

Ausgedruckt am: 15.08.2022 um 18:08 Uhr

Mitglied: Visucius
Visucius 30.06.2022 um 21:16:26 Uhr
Goto Top
Wärs möglich das mal kurz zu skizzieren?
(Handschriftlich und Foto können genügen)
Hängt der Drucker am "Server" oder am "Client"?
Mitglied: Kmartins
Kmartins 30.06.2022 um 21:47:52 Uhr
Goto Top
Der Drucker hängt am VPN-Client und ist dort freigeben.
Am Server kann ich es einbinden, aber über den Client im Netzwerk (192.168.49...) nicht.
Ich kann vom VPN-Client ( 10.253.0.3) alle Netzwerk Geräte anpingen, aber nicht andersrum.
Ich werde es mal skizzieren.

Danke schonmal.
Mitglied: Avoton
Avoton 01.07.2022 um 07:44:49 Uhr
Goto Top
Hi,

Wissen die restlichen Clients aus deinem Netz denn auch, dass sie das wireguard Netzwerk über deinen Server Routen müssen?

Firewallregeln am Client Mal geprüft?

Gruß,
Avoton
Mitglied: Kmartins
Kmartins 01.07.2022 um 08:19:13 Uhr
Goto Top
Hallo,

Ich habe auf den clients als Standart gateway den wireguard server angegeben. Damit kann ich den wireguard server erreichen (10.253.0.1) erreichen, aber nicht die vpn client.

Oder muss ich die Route am Client noch eintragen?

Gruß
Kevin Martins
Mitglied: TomTomBon
TomTomBon 01.07.2022 um 09:36:20 Uhr
Goto Top
Moin Moin,

Das wird so nichts werden.
Win 11 will keine SMB-Print Verbindung nutzen, Print Nightmare läßt grüßen.

Diese Verbindung, Drucker über USB verbunden und dann diesen Drucker frei geben, ist gleich zu setzen mit jedem anderen frei gegebenen Drucker der versucht wird einzubinden.
Win10 kann das, Win 11 nicht.

Es gibt unter Win11, bei mir, keinerlei Probleme den Drucker selbst einzubinden.
Wenn Ich den Druckserver mit einer Warteschlange über LPR einbinde ist das auch kein Problem.
Bsp: Druckserver als Ziel eingeben, Druckertreiber und Modell auswählen, zu Ende einrichten. Anschließend unter
Drucker Eigenschaften --> Anschlüsse --> Konfigurieren
das Protokol auf LPR wechseln und die, auf dem Printserver vorhandene, LPR Druckwarteschlange unter LPR Einstellungen angeben.
ACHTUNG
Die Druck-Warteschlange ist Case-sensitiv !
Mitglied: Kmartins
Kmartins 02.07.2022 um 13:17:13 Uhr
Goto Top
Moin,

das muss funktionieren.
Ich kann den Drucker am Server einbinden.
Ich glaube, ich habe es falsch erklärt.
Werde es noch mal versuchen.


Ich kann die VPN-Clients über den Server erreichen und ich kann auch über den VPN-Client, den Server und alle Geräte unter der 192.168.49.1 inklusive alle andere VPN-Clients unter der 10.253.0.1 erreichen.

Das Problem ist da die Client im Heimnetzwerk, nicht die VPN-Client erreichen können und damit kann ich die Freigeben Drucker nicht einbinden. ( Server 10.253.0.1 ist aber erreichbar )

Ich habe bereits, das Gateway vom Client auf 192.168.49.8 ( Wireguard ) Server geändert. Damit anfrage auf 10.253.0.... über den WG Server laufen, aber trotzdem, werden die nicht weitergeleitet. Die Pakete erreichen den Server 192.168.49.8 aber danach passiert nichts mehr.
Routing Dienst ist aktiv und habe bereits verschiedene Route getestet, aber ohne Erfolg.

Das Problem muss am Server liegen, ich komme aber leider nicht weiter ace-sad"
Mitglied: aqui
aqui 02.07.2022 aktualisiert um 15:24:36 Uhr
Goto Top
Das Problem ist da die Client im Heimnetzwerk, nicht die VPN-Client erreichen können
Da hast du dann aber schon ein grundsätzliches Problem. Ein LAN Client MUSS einen VPN Client pingen können und vice versa bei einem aktiven VPN Tunnel. Das ist ja eine Grundvoraussetzung für dein Drucker Setup!
Vermutlich also eine falsche Client- oder auch Server VPN Konfig Datei mit fehlerhaften Adressen unter AllowedIPs und/oder eine falsche oder fehlende lokale Firewall Konfig der VPN oder lokalen Clients zumindestens wenn es Windows Clients sind.
Da die lokale Windows Firewall alle fremden IP Netze generell blockt und auch ICMP Traffic (Ping) musst du diese ggf. entsprechend anpassen im Datei- und Drucker Sharing.
https://www.windowspro.de/wolfgang-sommergut/ping-windows-10-erlauben-gu ...

Leider fehlt hier einmal eine VPN Client Konfig als Beispiel und die dazu korrespondierende VPN Server Konfig. Ein Screenshot der FW Konfig wäre ebenso hilfreich für eine zielführende Lösung.
Das IPv4 Forwarding am Server und eine statische Route auf dem Internet Router der Server Seite zwingend ist sollte klar sein!!
Ohne diese Information ist alles Kristallkugelei! face-sad

Wie so eine WG Konfig richtigerweise auszusehen hat beschreibt z.B. dieser Thread.
Bzw. alle Grundlagen das hiesige Wireguard Tutorial.
Mitglied: Kmartins
Kmartins 02.07.2022 um 20:00:40 Uhr
Goto Top
Anbei dir Konfiguration von Wireguard

Client
2022-07-02 19_41_50-lavabis [wird ausgeführt] - oracle vm virtualbox
Server
2022-07-02 19_42_11-lavabis [wird ausgeführt] - oracle vm virtualbox

Firewall habe ich bereits geprüft. Ich kann von jeder Lan-Client den WG Server anpingen (10.253.0.1)
2022-07-02 19_49_36-lavabis [wird ausgeführt] - oracle vm virtualbox

Wann ich vom LAN Client die Route verfolge, wird auch an den WG Server weitergegeben aber danach passiert nichts mehr.

2022-07-02 19_53_38-lavabis [wird ausgeführt] - oracle vm virtualbox

Bei 10.253.0.1 funktioniert es aber direkt.
2022-07-02 19_54_12-lavabis [wird ausgeführt] - oracle vm virtualbox


Vermutlich liegt es wirklich am Allowed IP, aber ich weiß noch nicht wo......

Danke euch

Gruß
Kevin Martins
Mitglied: aqui
aqui 03.07.2022 aktualisiert um 10:41:16 Uhr
Goto Top
Client hat eine falsche Maske bei der internen IP. Muss /24 sein. Du solltest das Tutorial einmal genau lesen! face-sad
https://administrator.de/tutorial/merkzettel-vpn-installation-mit-wiregu ...
Was nützt es wenn du hilfreiche Tips hier schlicht und einfach ignorierst. face-sad
Auch eine falsche Maske bei dem Allowed IPs. Der Server hat /32 (Hostmaske)

Richtig für den Client ist:
[Interface]
Address = 10.253.0.101/24
PrivateKey = OMjSCv6e/...

[Peer]
PublicKey = cA+myn....
Endpoint = X.Y.Z.H:51820
AllowedIPs = 10.253.0.1/32, 192.168.49.0/24
PersistentkeepAlive = 25


2ter Kardinalsfehler:
Server hat eine völlig sinnfreie eigene interne Adresse. Dort hast du fälschlicherweise ein IP Netzwerk angegeben statt einer Hostaddresse ! Richtig wäre hier 10.253.0.1 /24
https://administrator.de/tutorial/merkzettel-vpn-installation-mit-wiregu ...
Allowed IP des Clients intern ist wieder /32
aber danach passiert nichts mehr.
Das IPv4 Forwarding auf dem Server hast du aktiviert??
https://administrator.de/tutorial/merkzettel-vpn-installation-mit-wiregu ...
Auch diese Punkte zeigen leider wieder das du das WG Tutorial NICHT gelesen hast! face-sad

Richtig für den Server ist:
[Interface]
Address = 10.253.0.1/24
PrivateKey = AB12345....
ListenPort = 51820

[Peer]
PublicKey = 4321ABC...
AllowedIPs = 10.253.0.101/32


Der Client benötigt keine DNS IP Adresse und schon mal gar keine von Google! Jeder Dummie weiss heutzutage das Google davon perönliche Nutzerprofile erstellt und diese weltweit an Dritte vermarktet. Wenn dir also deine eigene Datensicherheit etwas wert ist unterlässt du diesen Unsinn!
Als DNS nimmt der VPN Client immer automatisch die lokale.

Logisch das es mit solchen gravierenden Fehlern scheitern muss.
Warum siehst du also nicht einmal wirklich ins Tutorial?! Lesen und verstehen...
Da hilft dann auch das beste Forum nicht wenn du eh alles ignorierst.
Mitglied: TomTomBon
TomTomBon 04.07.2022 um 08:40:07 Uhr
Goto Top
Zitat von @Kmartins:

Moin,

das muss funktionieren.
Ich kann den Drucker am Server einbinden.
Ich glaube, ich habe es falsch erklärt.
Werde es noch mal versuchen.


Moin,

warum?

Ich erklärte das Win 11 Probleme hat mit frei gegebenen Druckern.
Das die nicht gemountet werden können.
Als Freigabe Quelle habe Ich W10/W11/Srv2016/Srv2019 getestet.
Einfach einen Drucker freigegeben und den aus W11 versucht zu mounten.
Njet.
Das geht nicht aus Win 11.
Nehme Ich Win 10 / ein Server bis 2019 ist das kein Problem.
Mitglied: TomTomBon
TomTomBon 07.07.2022 um 08:13:54 Uhr
Goto Top
Moin noch einmal,

Ich habe mir Aqui´s Kommentar vor mir einmal richtig durch gelesen.
Ich bin immer noch der meinung das es wegen Win 11 nicht gehen wird.
ABER,
Wenn das Netzwerk nicht richtig konfiguriert wird, wird das nicht das einzige Problem sein.
Aqui hat deine Probleme seziert.
Unschön für einen persönlich, aber Aqui ist fachlich dabei.

Nutze die Unterstützung !

Keiner will "böses", auch wenn manche genervt sind face-wink
Aber wenn dir gesagt wird wo das Problem ist, Du dies nicht annimmst und weiter fragst, ist das noch das eine.
Manchmal gibt es Gründe warum das nicht genommen werden kann.
Aber das sollte man erklären wenn man Hilfe möchte!
Spätestens wenn darauf angesprochen wird.
Mitglied: aqui
aqui 07.07.2022 aktualisiert um 08:37:31 Uhr
Goto Top
Ich habe mir Aqui´s Kommentar vor mir einmal richtig durch gelesen.
Der bezog sich aber rein nur auf die Wireguard Fehlkonfiguration des TOs und nicht auf irgendwelche Winblows Druckerproblematiken.
Wenn generell in Win 11 keine lokale Druckerfreigabe mehr supportet ist oder diese mit einem fatalen Bug behaftet ist dann nutzt natürlich auch das beste VPN nichts, das ist klar.

Ob M$ dann so eine grundlegende Funktion wie das Druckersharing in Win 11 deaktiviert oder mit einem fatalen Bug behaftet lässt ist für einen Apple Mac Nutzer schwer zu beurteilen.
Zumindestens Wireguard an sich rennt aber völlig fehlerfrei auch mit Win 11 und man kann auch auf ein freigegebenes Share (Dateiverzeichnis) auf einem Win 11 Rechner mit WG Client über das VPN problemlos zugreifen. Das Dateisharing an einem WG Client funktioniert also zumindestens fehlerlos mit Win 11.
Mitglied: TomTomBon
TomTomBon 08.07.2022 um 08:34:05 Uhr
Goto Top
Wie Ich sagte, Win 11 ist nicht schlecht.

Aber Printer Sharing ist nicht trivial.
LPR klappt Problemlos. Aber nicht Sharing, was SMB nutzt.
Was Probleme hat..
Mitglied: aqui
aqui 08.07.2022 um 08:38:25 Uhr
Goto Top
LPR wäre sowieso das Verfahren der Wahl bei Drucken über geroutete Verbindungen. Anyway...kommt ja eh kein Feedback mehr zu dem Thema vom TO selber. face-sad
Hoffentlich reichts dann bei ihm noch zum Schliessen seines Threads?!
https://administrator.de/faq/32
Mitglied: TomTomBon
TomTomBon 08.07.2022 um 15:46:53 Uhr
Goto Top
Schönes Wochenende face-smile
Mitglied: micneu
micneu 14.08.2022 um 00:17:46 Uhr
Goto Top
Zitat von @Kmartins:

Moin,

das muss funktionieren.
Ich kann den Drucker am Server einbinden.
Ich glaube, ich habe es falsch erklärt.
Werde es noch mal versuchen.


Ich kann die VPN-Clients über den Server erreichen und ich kann auch über den VPN-Client, den Server und alle Geräte unter der 192.168.49.1 inklusive alle andere VPN-Clients unter der 10.253.0.1 erreichen.

Das Problem ist da die Client im Heimnetzwerk, nicht die VPN-Client erreichen können und damit kann ich die Freigeben Drucker nicht einbinden. ( Server 10.253.0.1 ist aber erreichbar )

Ich habe bereits, das Gateway vom Client auf 192.168.49.8 ( Wireguard ) Server geändert. Damit anfrage auf 10.253.0.... über den WG Server laufen, aber trotzdem, werden die nicht weitergeleitet. Die Pakete erreichen den Server 192.168.49.8 aber danach passiert nichts mehr.
Routing Dienst ist aktiv und habe bereits verschiedene Route getestet, aber ohne Erfolg.

Das Problem muss am Server liegen, ich komme aber leider nicht weiter ace-sad"

ich habe jetzt zigfach deinen text gelesen, leider verstehe ich nicht wirklich alles, bitte erstelle doch mal einen grafischen netzwerkplan, das hilft wirklich ungemein, so kann auch ein ahnungsloser wie ich dein problem verstehen oder ist das thema gelöst (das steh hier aber nirgends)