mhard666
Goto Top

WLAN Karte in pfSense einrichten und aktivieren

Hallo allerseits,
Ich habe in eine pfSense (v2.0.3 Release) auf PC Engines ALIX.2D13 Board um einen Mini PCI Netzwerkadapter (Wistron DNMA92 mit Atheros AR9220 Chipsatz) erweitert. Bei der Konfiguration gibts allerdings ein paar Schwierigkeiten...
Ich bin folgendermaßen vorgegangen:
- Interface assigned (ath0 - der WLAN-Adapter)
- das neue Interface (bei mir OPT2) aktiviert, umbenannt in WLAN
- Type: None
- Standard: b oder g (beides probiert)
- Channel: verschiedene probiert
- Regulatory Domain: ETSI
- Country: Germany (DE - ETSI)
- Mode: AccessPoint
- SSID: hab ich eine eingetragen
- Sicherheit hab ich WPA/WPA2 eingestellt und wieder ausgestellt

Gespeichert das Ganze, aber ich bekomme im Dashboard angezeigt das Interface ist down.

- Type: Static eingetragen
- Feste IP eingetragen

Gespeichert, das Interface ist up, aber das WLAN wird nicht gefunden.

Leider gibt die Doku nichts Konkretes für die v2.0.x her, alles für die v1.xx und da hat sich offenbar einiges geändert.
Ist die WLAN-Karte möglicherweise inkompatibel? Ansich werden die Atheros Chips ja alle unterstützt. Oder hab ich etwas übersehen? Bin für jeden Tipp dankbar.

mfG. mhard666

Content-Key: 213768

Url: https://administrator.de/contentid/213768

Printed on: December 4, 2022 at 16:12 o'clock

Mitglied: 108012
108012 Aug 08, 2013 at 20:30:10 (UTC)
Goto Top
Hallo,

da solltest Du mal warten bis der @aqui hier vorbeischaut der löst das ganze rucki zucki auf und ist auch echt bewandert mit
der pfSense.

Leider gibt die Doku nichts Konkretes für die v2.0.x her, alles für die v1.xx und da hat sich offenbar einiges geändert.
Wenn die Karte oder besser der Chipsatz unterstützt wird sollte das kein Problem sein.

Ist die WLAN-Karte möglicherweise inkompatibel?
Das sollte man unbedingt vorher klären! Hinterher ist das Geschrei dann immer groß!

Ansich werden die Atheros Chips ja alle unterstützt. Oder hab ich etwas übersehen? Bin für jeden Tipp dankbar.
Schau Dir das hier mal an und dann kannst Du ja selber nachschauen. WLAN Karten für pfSense

Gruß
Dobby
Member: orcape
orcape Aug 09, 2013 at 03:36:56 (UTC)
Goto Top
Hi mhard666,
ein ähnliches Problem war vor einigen Tagen aktuell.
https://www.administrator.de/forum/pfsense-installation-212691.html
Ist zwar bei Dir kein WLAN-n Standart, vielleicht hilft Dir das weiter.

Gruß orcape
Member: aqui
aqui Aug 09, 2013 updated at 13:54:03 (UTC)
Goto Top
Vorab musst du wissen ob du das WLAN an ein bestehenden LAN Port (LAN oder OPT1) koppeln willst so das das WLAN Teil dieses IP Netzes wird so wie es klassisch bei allen DSL WLAN Routern der Fall ist.
Das erfordert dann ein Bridge Setup in der pfSense.

Wenn du so das Interface einrichtest behandelt es die pfSense wie ein dediziertes weiteres Interface. Um das erstmal zum Senden zu bringen ist das aber auch erstmal OK
Generell ist das Setup wie oben beschrieben richtig. Diese Einstellungen sollten korrekt sein wenn es ein Single Radio (2,4 Ghz only) Modul ist:
1.) Im Interface assign Menü auf "+" klicken und das Interface als OPT2 hinzufügen. Du kannst dann auch sehen das es eine ath0 Bezeichnung trägt, dann ist es korrekt vom OS erkannt worden.
2.) Im Interface Setup zu OPT2 das Interface aktivieren, auf static setzen und IP und Maske konfigurieren. Dabei drauf achten (ohne Bridge) das das ein eigenständiges IP Netz ist und sich nicht mit den anderen IP Netzen an den Interfaces überschneiden darf ! Andere Bezeichnung ist optional.
3.) WLAN Interface in den Mode hostap also "Accesspoint" setzen.
4.) Mode fest auf 802.11g ONLY setzen.
5.) Regulatory Domain ETSI und Country "Germany/ETSI" setzen und die gewünschte SSID setzen. (Keine Sonderzeichen)
Du kannst das Interface erstmal auf "open" lassen ohne Verschlüsselung. Es geht ja erstmal darum das zum Senden zu bekommen.
Mit den o.a. Einstellungen sollte es auf UP gehen und auch so im Dashboard zu sehen sein !

Wenn du nun auf deinem Laptop den inSSIDer startest um dir die WLANs in deinem Bereich anzusehen solltest du da jetzt schon dein pfSense WLAN sehen:
http://www.metageek.net/products/inssider/
Dann kannst du auch die Verschlüsselung WPA-2 mit AES-CCMP aktivieren. Key wieder ohne Sonderzeichen !

Wie gesagt wenn du ein Dual Mode Modul hast für 2,4 Ghz und 5 Ghz, musst du ein Subinterface konfigurieren, damit du auf beiden Bändern zugleich aktiv sein kannst.
Das dazugehörige Tutorial hat ein Update für die erforderlichen Einstellungen dafür:
https://www.administrator.de/wissen/wlan-oder-lan-gastnetz-einrichten-mi ...
Member: mhard666
mhard666 Aug 12, 2013 at 19:12:08 (UTC)
Goto Top
Hallo aqui,

danke für die - wie immer - sehr ausführliche Beschreibung. Ich habe aber dennoch Probleme das Ganze wie beschrieben zum Laufen zu bekommen.
Problem 1: einfach nur das 2.4 GHz IF einrichten funktioniert soweit - es ist im Dashboard aktiv, allerdings wird es mit inSSIDer nicht gefunden. Kann das an der Antenne liegen?
Problem 2: ich hab ein Dual Modul. Die beschriebene Vorgehensweise hat allerdings einen Haken: wenn ich das Sub-IF hinzufüge und den Mode auf 802.11a ändere, wird automatisch auch für das Hauptinterface der Mode auf 802.11a geändert. Es sind also immer alle WLAN-IF entweder 802.11a oder 802.11g - egal wo ich die Einstellung ändere (im Haupt-IF oder im Sub-IF).

Gruß mhard666.
Member: aqui
aqui Aug 13, 2013 updated at 06:47:33 (UTC)
Goto Top
.. ."allerdings wird es mit inSSIDer nicht gefunden" Mmmhhh...da gibt es dann 3 Optionen:
1.) Du hast bei inSSIDer vergessen auf "2,4 Ghz" zu klicken um die Ansicht umzuschalten ! Check: Werden in der Anzeige denn andere 2,4 Ghz Netze angezeigt ?
2.) Wenn ja kann es sein das du Kanal 1 oder 13 eingestellt hast ? Billige China Treiber in Laptops "ignorieren" diese Kanäle oft gerne bei einem WLAN Scan. Testweise also mal einen Kanal "in der Mitte" nehmen !
3.) Du hast schlicht und einfach im pfSense Setup das SSID Beaconing abgeschaltet (SSID Broadcast)
Bei allen 3 Möglichkeiten kann das dann so passieren.
Wenn es allerdings nur der deaktivierte SSID Broadcast ist zeigt die inSSIDer immer trotzdem das Signal an, dann eben nur mit der BSSID (Mac Adresse) und ohne SSID Namen. Sehen tust du es in jedem Falle.
Wenn nicht, dann sendet die pfSense de facto nicht oder du bist Opfer der ignorierten "Randkanäle" im Treiber.

Was du schreibst mit der automatischen Mode Änderung stimmt de facto nicht ! Jedenfalls nicht mit der aktuellen Release Version 2.0.3 auf einem ALIX Board !
Das rennt hier so wie im Tutorial und oben beschrieben mit der 2.0.3 fehlerfrei mit einem Wistron und TP-Link Modul. Beide mit Atheros Chipsatz an einer Dual Band Antenne.
Beide Modi sind per Bridge gekoppelt, damit sie im gleichen IP Segment arbeiten. Testweise ein LAN Port der Bridge zugefügt funktioniert auch wunderbar. Alles wasserdicht ausgetestet im Live Betrieb mit einem Dual Radio WLAN Client sowohl mit OS-X als auch Winblows.
Poste gerne Screenshots wenn du willst...
Member: hotrest
hotrest Aug 25, 2014 updated at 20:12:50 (UTC)
Goto Top
Hallo aqui,

könntest du bitte screenshots von deinem config machen.
Ich möchte meine dualband-wifi auch so einrichten. Nur habe ich das gleiche Problem, wie mhard666. Wenn ich ein Interface ändere, ändert sich das andere auch. So springen beide wlans von 2,4 auf 5 und umgekehrt.

Irgendwie fehlt mir eine Möglichkeit Bilder anzuhänden. Der Reiter fehlt komplett...
Mitglied: 108012
108012 Aug 25, 2014 at 20:19:33 (UTC)
Goto Top
Irgendwie fehlt mir eine Möglichkeit Bilder anzuhänden. Der Reiter fehlt komplett...
Auf den "Bearbeiten" Knopf drücken und dann unter Bilder oben (Frage bearbeiten - Vorschau - Bilder - Formatierung) über der Überschrift benutzen.

Gruß
Dobby

Member: hotrest
hotrest Aug 26, 2014, updated at Jan 08, 2015 at 17:13:59 (UTC)
Goto Top
Ich habe keinen Tab "Bilder" wie es in der Formatierungshilfe beschrieben ist.
cadb96accd9b971f147138d4f9c6b623
Ich habe nur Kommentar bearbeiten - Vorschau - Formatierungshilfe.
Member: aqui
aqui Aug 26, 2014 updated at 07:51:58 (UTC)
Goto Top
Bitte unterlasse diesen überflüssigen Blödsinn mit externen Bilderlinks und damit verbundenen Zwangswerbung im Forum. Das Forum selber hat eine sehr komfortable Bilder Upload Funktion !
Es ist zigmal in den FAQs beschrieben wie das zu handhaben ist !

Bitte editiere deinen Originalthread (Ursprungsthread) ! mit Klick auf "Bearbeiten" !
Dann siehst du oben auch "Bilder hochladen"....
Den Button dann klicken, Bild hochladen und den dir dann präsentierten Bilder URL dann markieren und mit einem Rechtsklick und Cut and Paste sichern.
Diesen Bilder URL kannst du dann hier in jeglichen Text bringen ob Antwort, Mail usw. Statt des URL wird dir dann bei Aufruf immer... Tadaaaa... dein Bild embedded angezeigt.
So schwer kann das doch nun wahrlich nicht sein !!

Die gesamte Konfiguration eines Dual Band WLAN Adapters ist im Gäste Hotspot Tutorial:
https://www.administrator.de/wissen/wlan-oder-lan-gastnetz-einrichten-mi ...
im Kapitel "Optional: WLAN Erweiterung" doch explizit beschrieben !

Falls was nicht klappen sollte bitte dann hier detailierte Infos und embeddete Bilder, bitte...
Member: hotrest
hotrest Aug 26, 2014 updated at 08:20:17 (UTC)
Goto Top
Bitte unterlasse diesen überflüssigen Blödsinn mit externen Bilderlinks und damit verbundenen Zwangswerbung im Forum. Das Forum selber hat eine sehr >komfortable Bilder Upload Funktion !
wow, geht auch in einem anderen Ton?

Bitte editiere deinen Originalthread (Ursprungsthread) ! mit Klick auf "Bearbeiten" !
Originalthread (Ursprungsthread) ist nicht von mir, sondern von mhard666.

Dann siehst du oben auch "Bilder hochladen"....
Sehe ich eben nicht! Lesese bitte genau, was ich geschrieben habe - diese Funktion ist NICHT da! Ich habe ein Screenshot von einem externen Hoster nurdeswegen eingefügt, damit ihr das sehen könnt.
und dieser Beitrag ist mir bekannt. Funktioniert aber nicht.

So schwer kann das doch nun wahrlich nicht sein !!
Kann sein, siehst du doch.
Member: aqui
aqui Aug 26, 2014 updated at 09:10:40 (UTC)
Goto Top
wow, geht auch in einem anderen Ton?
wow, schwer wenn man es schon zum x-ten Mal wiederholt hat hier...aber wir bemühen uns redlich den richtigen Ton zu treffen. face-wink
Originalthread (Ursprungsthread) ist nicht von mir, sondern von mhard666.
OK, dann richte dir hier unter einem nicht so wichtigen Bereich wie Humor oder Off Topic einen Thread ein und klicke den auf nicht freigeben. Damit hast du einen unsichtbaren Dummy Thread für deine Bilder in Antworten.
Kommt man mit ein bischen Nachdenken auch von selbst drauf....
Sehe ich eben nicht! Lesese bitte genau, was ich geschrieben habe - diese Funktion ist NICHT da!
Klar, in Antworten direkt geht das auch nicht. Deshalb auch die Betonung mit Originalthread ohne den gehts logischerweise nicht. Also beim Lesen mal an die eigene Nase fassen...
Der eigene Dummythread ist deine Lösung !

So und nun mal wieder zu de Fakten und eigentlichen Fragestellung. WAS genau funktioniert denn da nicht ?? Hier im Testsetup funktioniert es wunderbar !!
Member: hotrest
hotrest Aug 27, 2014 updated at 08:38:27 (UTC)
Goto Top
na, is ja gut jetzt... ich sehe wirklich zum ersten mal ein Forum wo in Beiträgen keine Pictures hochgeladen werden können und das so umständlich gemacht werden mus...

Zum Problem:
- ich erstelle unter Interface assign ein Interface WLANG (ath0(xx:xx:xx:xx:xx:xx)) und verpasse ihm: AP-Mode + Standard 11g + Channel12 + SSID
- dann gehe ich zum Tab Wireless und füge ein neues Interface (ath0_wlan1(AP-5Ghz)) ein: Parent-if ath0(xx:xx:xx:xx:xx:xx) + Mode Access Point
- ich erstelle unter Interface assign ein Interface WLANA (ath0_wlan1(AP-5Ghz)) und verpasse ihm: AP-Mode + Standard 11a + Channel100 + SSID wie in g-mode
= Als Ergebnis übernimmt pfsense eingestellte Werte auf dem Interface WLANA und überschreibt die Werte auf dem WLANG

wenn ich dann WLANG wieder anpasse werden WLANA settings mit überschrieben.
Unter wifi settings steht ja auch, dass diese an alle ath0 weitergegeben werden: Common wireless configuration - Settings apply to all wireless networks on ath0.

Die Frage ist: habe ich was falsch gemacht, oder ist die Karte (Wistron CM9) garnicht dual-wifi-fähig?
Hier sind entsprechende step-by-step Sreenshots:
17759c395772f48df8bfee5d85c6512d
Member: aqui
aqui Aug 27, 2014 updated at 11:49:20 (UTC)
Goto Top
Sorry, aber du hast das Gast WLAN Tutorial nicht gelesen, denn hättest du es hättest du es richtig gemacht.
https://www.administrator.de/wissen/wlan-oder-lan-gastnetz-einrichten-mi ...
Der Punkt beschreibt die Schritte genau und den hier letzten hast du nicht gelesen oder ignoriert... face-sad

Für dich also nochmal genau die Schritte bei einem nackten ALIX Board mit bestückter WLAN Dual Radio Karte:
  • Interface assign und + klicken
  • Es fügt sich das Interface OPT1 zu (Systeminterface vr0) und ist der 3te Port
  • Nochmal Interface assign und + klicken
  • Es fügt sich das Interface OPT2 zu (Systeminterface ath0 (Hier Beispiel)) und ist der WLAN Port
  • Save
  • OPT 2 Interface enablen und ggf. umbennen in "WLAN2.4Ghz", AP Mode, 11g only, ETSI, Channel usw. klicken
  • Jetzt im Menü Interface -> assign auf den Reiter Wireless gehen und + klicken
  • Parent Interface auf ath0 einrichten und es "WLAN5Ghz" nennen
  • Nun wieder in Interface assign Global gehen und unten auf + klicken
  • Jetzt wird dieses neue Wireless Interface der gesamten Interface Liste hinzugefügt so das du insgesamt 5 Interfaces hast.
  • Dies nun auch enablen und alle Parameter entsprechend konfigurieren !
  • Zum Schluss dann beide WLAN Interfaces in einer Bridge zusammenfassen und fertig ist der Lack !
Funktioniert hier wunderbar auf einem ALIX mit 2.1.4 Version.
Wo ist also dein Problem ?!
Member: hotrest
hotrest Aug 27, 2014 at 13:49:34 (UTC)
Goto Top
Sorry, aber du hast das Gast WLAN Tutorial nicht gelesen, denn hättest du es hättest du es richtig gemacht.
https://www.administrator.de/wissen/wlan-oder-lan-gastnetz-einrichten-mi ...
Der Punkt beschreibt die Schritte genau und den hier letzten hast du nicht gelesen oder ignoriert... face-sad
Doch habe ich gelesen. Meinst du den Punkt mit der Bridge?

Für dich also nochmal genau die Schritte bei einem nackten ALIX Board mit bestückter WLAN Dual Radio Karte:
...
Wo ist also dein Problem ?!

Danke für die Anleitung noch mal.
Ich habe vorhin alles bis zum Bridge-Punkt 1 zu 1 gemacht. Und getestet, ob der AP in beiden Bändern sendet. Ergebins - Beide Interfaces senden auf dem Band, das zuletzt konfiguriert wurde.
Jetzt bin ich durch das setup noch ein mal durchgegangen und alles komplett so eingestellt. Ergebnis - das gleiche wie vorhin. Sendet mit beiden Interfaces auf einem Band.

Du hast hier vorgeschlagen Screenshots zu posten:
Zitat von @aqui:
...
Poste gerne Screenshots wenn du willst...

Kanns du bitte screens machen? Ich denke - das Problem löst sich dann von selbst.
Gruß.
Member: aqui
aqui Aug 27, 2014 at 15:42:49 (UTC)
Goto Top
Meinst du den Punkt mit der Bridge?
Nein, den wo man das Subinterfcae in die globale Interface Liste übernimmt mit +. Genau die fehlt bei dir vollständig !
Ich habe das hier mit einem Atheros Chipsatz basiertem Modul getestet und da rennt es fehlerlos. Sauber getrennt in 2,4 und 5 Ghz.
Achte darauf das du bei 5 Ghz die unteren 12 Kanäle nimmst, denn das Gros der Module supportet nur die.
Probier es also im .11a band mal mit Kanal 48 oder drunter.
Ggf. löst das das Problem schon.
Prüfe ebenfalls das der verwendete WLAN Chipsatz auch in der BSD Kompatibilitätsliste ist, sonst wirds eh schwierig.
Member: hotrest
hotrest Aug 27, 2014 updated at 21:14:16 (UTC)
Goto Top
Nein, den wo man das Subinterfcae in die globale Interface Liste übernimmt mit +. Genau die fehlt bei dir vollständig !
Das ist doch der dritte Schritt auf meinem Screenshot. Genau da habe ich in die globale Liste das Unterinterface aufgenommen.
Oder sieht es falsch aus auf dem 3-tten Screenshot?

Ich habe das hier mit einem Atheros Chipsatz basiertem Modul getestet und da rennt es fehlerlos. Sauber getrennt in 2,4 und 5
Ghz.
Achte darauf das du bei 5 Ghz die unteren 12 Kanäle nimmst, denn das Gros der Module supportet nur die.
Probier es also im .11a band mal mit Kanal 48 oder drunter.
Das werde ich machen - ich hatte 100-er channel.


Prüfe ebenfalls das der verwendete WLAN Chipsatz auch in der BSD Kompatibilitätsliste ist, sonst wirds eh schwierig.
Das ist schwer... steht nur dass von atheros die meisten unterstützt werden... ich hatte aber schon mal mit einem ar9220 meine Probleme und habe ihn ersetezen müssen.
Dad checke ich aber noch mal. Danke.
Member: hotrest
hotrest Aug 28, 2014 updated at 15:06:42 (UTC)
Goto Top
Zitat von @aqui:
Achte darauf das du bei 5 Ghz die unteren 12 Kanäle nimmst, denn das Gros der Module supportet nur die.
Probier es also im .11a band mal mit Kanal 48 oder drunter.
Ggf. löst das das Problem schon.

Das ist der Tipp! Mit Umstellung auf Channel 48 sehe ich das Ding auf beiden Bändern senden. Danke.
Member: aqui
aqui Aug 28, 2014 updated at 15:11:20 (UTC)
Goto Top
Sag ich doch... ! face-smile
Sonst hätte ich das Tutorial ja nicht geschrieben. Aber danke für das Feedback, denn das ist ein wichtiger Punkt den man im Tutorial noch aufnehmen sollte.
Klasse wenns nun mit dem Dual Mode klappt wie es soll !
P.S.: Denk dran das du am Modul dann auch eine Dual Band Antenne anschliesst die beide Bänder bedienen kann !
Member: hotrest
hotrest Aug 28, 2014 at 15:36:39 (UTC)
Goto Top
Zitat von @aqui:

Sag ich doch... ! face-smile
Sonst hätte ich das Tutorial ja nicht geschrieben. Aber danke für das Feedback, denn das ist ein wichtiger Punkt den man
im Tutorial noch aufnehmen sollte.

Du soltest auch bitte afnehmen, dass die Anzeige im Dashboard ignoriert werden soll. Die zeigt, dass bede Interfaces im A-Band senden.
d08d66c10b0a0f96658785fd1e2f7a10

P.S.: Denk dran das du am Modul dann auch eine Dual Band Antenne anschliesst die beide Bänder bedienen kann !
Ja, die Antenne ist dran.
Member: aqui
aqui Aug 28, 2014 updated at 15:48:17 (UTC)
Goto Top
Mmmhh komisch das kommt sicher durchs Autoselect. Hast du denn dediziert 11g only und 11a only in beiden Interfaces konfiguriert ?
Aber auch wenn dann ist das eher nur ein kosmetischer Anzeige Bug im GUI. Aber guter Punkt nehme ich mit auf... Verweise auch in der Linksammlung auf diesen Thread.
Member: peterhart
peterhart Sep 02, 2014 at 20:59:55 (UTC)
Goto Top
Hallo,
mein Name ist Peter und ich kämpfe seit 2 Tagen genau mit dem o. g. Problem, dass die eingestellten Werte auf dem Interface WLAN24GHZ
und die Werte auf dem WLAN5GHZ sich gegenseitig überschreiben.

Ich bin mehrfach die Anleitung Schritt für Schritt durchgegangen.
Es ist immer das gleiche Ergebnis.
Stelle ich im IF WLAN24GHZ 802.11g und Kanal 1 ein, werden leider auch die Werte im IF WLAN5GHZ überschrieben.
Stelle ich dann im IF WLAN5GHZ 802.11a und Kanal 48 ein, werden die vorher eingestellten Werte im IF WLAN24GHZ überschrieben.
D. h., beide Schnittstellen senden entweder auf 802.11g und Kanal 1 oder auf 802.11a und Kanal 48, aber nicht gleichzeitig auf 2,4 GHz und 5 GHz.

Ich verwende ein APU.1D4 Board mit einer Compex WLE200NX (Atheros XSPAN family chipset).
Installiert ist pfSende 2.1.5 auf einer mSATA SSD 32GB

Unter Interfaces (assign) habe ich:
WAN: re2
LAN: re1
DMZ: re0
WLAN24GHZ: ath0
WLAN5GHZ: ath0_wlan1

Ich habe natürlich unter Wireless das Parent Interface für WLAN5GHZ hinzugefügt und dieses dann unter Interfaces (assign) in die Liste
aufgenommen (s.o.).

Ist ggf. die Compex WLE200NX nicht in der Lage unter pfSense gleichzeitig beide Frequenzbänder zu bedienen?

Danke.
Gruß
Peter
Member: orcape
orcape Sep 03, 2014 updated at 03:46:04 (UTC)
Goto Top
Hi,
Ich habe in eine pfSense (v2.0.3 Release)
...abgesehen davon, das mittlerweise v.2.0.5 aktuell ist und Du mal ein Upgrade machen solltest..face-wink
Ich habe gleiche, bzw. ähnliche Probleme mit einem Linksys DD-WRT Router. Auch dort wird nicht sauber zwischen 2,4 und 5 GHz getrennt.
Also vermute ich mal, das auch bei Dir das Zusammenspiel zwischen Hard-, und Software die Ursache ist.
mein Name ist Peter und ich kämpfe seit 2 Tagen genau mit dem o. g. Problem,
..das kann ich locker toppen...face-wink
Gruß orcape
Member: peterhart
peterhart Sep 03, 2014 updated at 04:48:21 (UTC)
Goto Top
Hallo,
was ich nicht verstehe ist, das es bei einigen Usern ja zu funktionieren scheint.
Ich bin schon drauf und dran einfach eine 2. WLAN Karte einzubauen.
Gestern bin ich die Anleitung zum x-ten mal Schritt für Schritt durchgegengen.
Da kann man eigentlich nichts falsch machen.
Das Ergebnis war aber immer das Gleiche.
Die vorher eingestellten Werte auf der WLAN-Schnittstelle wurden sofort wieder überschrieben, sobald man
die jeweils andere WLAN-Schnittstelle konfigurierte.
Dabei war es völlig egal, ob ich für die Kanäle feste Werte einstelle oder auf Auto umstelle.
Ich habe natürlich auch beachtet, dass ich für die 5GHz Schnittstelle die unteren Kanäle (<48) verwende.

Vielleicht hat ja jemand noch eine Idee?

Gruß
Peter
Member: aqui
aqui Sep 03, 2014 at 17:42:06 (UTC)
Goto Top
das mittlerweise v.2.0.5 aktuell ist
Ahem 2.1.5 ist das aktuelle Release !!!
mein Name ist Peter und ich kämpfe seit 2 Tagen genau mit dem o. g. Problem, dass die eingestellten Werte auf dem Interface WLAN24GHZ
und die Werte auf dem WLAN5GHZ sich gegenseitig überschreiben.
Peter, das ist ein bekanntes Problem bei einigen Dual Band miniPCI Karten.

Du kannst als Workaround derzeit nur das Secondary Interface komplett löschen und auch die Definitiopn unter "Wireless"" entfernen und dann das ganze wieder neu aufsetzen.
Dann kommt beides auch sauber wieder hoch in getrennten Bändern und alles funktioniert wie es soll.
Das problem tritt dann auch wenn Änderungen an der bestehenden Konfig gemacht werden dann passieren diese Überschreibungen. So wie es derzeit aussieht ist das ein Bug der Konfig Schnittstelle.
Setze also deien Konfigs fest und konfiguriere sie so und zwar einmalsig ohne Änderung. Dann funktioniert das Konstrukt stabil.
Member: orcape
orcape Sep 03, 2014 at 17:57:54 (UTC)
Goto Top
Ahem 2.1.5 ist das aktuelle Release !!!
...vorgestern aktualisiert.face-wink
Member: hotrest
hotrest Sep 07, 2014 updated at 20:17:30 (UTC)
Goto Top
Nach einem Update oder Reboot werden die Einstellungen überschrieben.

Ich habe für mich folgende Vorgehensweise entwickelt, wenn das Konstrukt zerfällt:
- auf dem 2,4ghz Interface setze 11g und Channel auf bspw. 12 ein. Dann Apply settings.
- auf dem 5ghz Interface lasse 11g stehen und setze nur Channel auf 48. Dann apply settings.
- fertig.

Löschung der Interfaces ist NICHT erforderlich.
Gerade nach dem Update auf 2.1.5 getestet. In 30 sek. steht das Konstrukt wieder.
Member: peterhart
peterhart Sep 08, 2014 at 05:03:29 (UTC)
Goto Top
Hallo,
danke für die Hinweise.
Das werde ich diese Woche gleich mal Testen und berichten.

Gruß
Peter
Member: aqui
aqui Sep 08, 2014 at 08:57:12 (UTC)
Goto Top
@hotrest
Danke für den guten Tip !
Ist auch so im WLAN_Tutorial vermerkt und es verweist auch auf diesen Thread.
Member: peterhart
peterhart Sep 20, 2014 updated at 14:24:37 (UTC)
Goto Top
Hallo hotrest,
ich habe Deinen Tipp getestet.
Allerdings ohne Erfolg.
Alles Einstellungen unter "Common wireless configuration - Settings apply to all wireless networks on ath0" werden
immer auf das jeweilige andere WLAN Interface übernommen.
Egal ob man nur die Frequenz oder den WLAN Standard oder ... einstellt.

Komisch.

Gruß
Peter
Member: aqui
aqui Sep 21, 2014 at 09:20:16 (UTC)
Goto Top
Hier auf einem Referenzsystem mit ALIX 2D13 und Cistron Adapter funktioniert es wunderbar !
Ggf. musst du die pfSense einmal rebooten !
Member: peterhart
peterhart Sep 21, 2014 at 10:13:23 (UTC)
Goto Top
Hallo,
werde ich mal testen.

Benutzt man für beide Einstellungen die gleiche WLAN SSID?

Gruß
Peter
Member: aqui
aqui Sep 21, 2014 updated at 15:42:07 (UTC)
Goto Top
Nein !
Das 5 Ghz Band sollte man immer speziell kennzeichnen in der SSID mit z.B. "Bitschleuder-5Ghz" wenn z.B. Bitschleuder die normale 2,4 Ghz SSID ist.
So können 5 Ghz fähige Clients dediziert ihr Band auswählen und auf das störungsärmere 5 Ghz Band ausweichen und auch 2,4 Ghz entlasten.
Mit gleicher SSID wäre daslogischerweise nicht möglich !
Member: hotrest
hotrest Sep 21, 2014 at 18:37:03 (UTC)
Goto Top
Hallo Peterhart,
es wird nur angezeit, dass Settings übernommen wurden - tatsächlich läuft das aber richtig. Lass dich nich von der Anzeige nicht verwirren - klicke dich einfach stumpf nach Anleitung durch.

Gruß
Member: peterhart
peterhart Sep 22, 2014 updated at 04:30:47 (UTC)
Goto Top
Hallo,
von der Anzeige verwirren?
Wie habe ich das zu verstehen?
Wenn ich z. B. auf dem Adapter (WLAN24GHZ) Kanal 3 einstelle und anschließend auf dem Adapter (WLAN5GHZ) Kanal < 48 einstelle, werden
die Werte des Adapters (WLAN24GHZ) unter "Common wireless configuration - Settings apply to all wireless networks on ath0" überschrieben.

Soll das heißen, dass hier nur ein Anzeigefehler vorliegt?
Ich werde das mal mit einem WLAN Scanner nachprüfen.

Gruß
Peter
Member: aqui
aqui Sep 22, 2014 at 06:38:36 (UTC)
Goto Top
Wie habe ich das zu verstehen?
Von der Anzeige in der Konfig GUI.
Was nachher wirklich rennt siehst du mit einem WLAN Sniffer wie inSSIDer oder WiFiNetview usw. wie du ja auch schon selber erkannt hast.
Member: hotrest
hotrest Sep 22, 2014 at 07:58:52 (UTC)
Goto Top
Zitat von @peterhart:
Wenn ich z. B. auf dem Adapter (WLAN24GHZ) Kanal 3 einstelle und anschließend auf dem Adapter (WLAN5GHZ) Kanal < 48
einstelle, werden
die Werte des Adapters (WLAN24GHZ) unter "Common wireless configuration - Settings apply to all wireless networks on
ath0" überschrieben.


wenn du so machst, hast in der GUI beide Adapter auf 48 Channel. Aber wenn du deine WLAN-Umgebung scannst siehst du beide Adapter auf verschiedenen Bändern senden. Ich mache es mit meinem Tablet und WIFI Analyser vom google Play.
Member: peterhart
peterhart Sep 22, 2014 at 08:05:43 (UTC)
Goto Top
Danke.
Das werde ich heute Abend mal testen.

Gruß
Peter
Member: peterhart
peterhart Sep 23, 2014 at 05:17:23 (UTC)
Goto Top
Hallo,
nach unzähligen Tests und diversen Neustarts muss ich wohl das Ergebnis akzeptieren, dass es bei meinem APU.1D4 Board und der
Compex WLE200NX (Atheros XSPAN family chipset) nicht funktioniert.

1. Die eingestellten Werte überschreiben sich wechselseitig auf beiden WLAN IF.

2. Mit einem WLAN-Scanner konnte ich feststellen, dass beide WLAN IF immer den gleichen Kanal verwenden (entweder 2,4GHz oder 5 GHz).
Nur einmal schien es so, als ob wirklich beide Bänder funktionierten. Nach dem Neustart war aber alles wieder wie vorher. Ich konnte
das Verhalten leider nicht wiederholen.

3. Wenn ich auf dem 5GHz IF den Standard auf 11g stehen lasse und nur den Kanal auf < 48 setze, dann bestätige, wird auf beiden
WLAN IF irgendein Kanal aus dem 2,4GHz Band verwendet. I. d. R. ist das der letzte Kanal aus dem 2,4GHz Band.

4. Verwende ich die Option "Persist common settings" kommt es in 2 von 3 Fällen zum totalen Verlust aller IF Zuordnungen.
D. h., nach dem Neustart muss ich alle IF (WAN, LAN, DMZ etc.) neu zuordnen.
Was macht eigentlich diese Funktion "Persist common settings"?

5. Eine Neuinstallation änderte am oben beschriebenem Verhalten auch nichts.

Vielleicht kann mir jemand mal ein Backup File seiner pfSense zu Testzwecken zur Verfügung stellen?

Obwohl ich denke keinen Fehler gemacht zu haben, werde ich heute abend nochmals genau die Schritte aufschreiben und hier posten.

Gruß
Peter
Member: aqui
aqui Sep 23, 2014 at 08:31:19 (UTC)
Goto Top
Hier ist ne Wistron im Einsatz aber mit anderen Atheros Chips mit der der Trick funktioniert:
http://varia-store.com/Hardware/MiniPCI-Karten/Wistron-DNMA92-802-11a-b ...
Möglich das die Karten Unterschiede in den Treibern haben die das Verhalten bedingen.
Member: peterhart
peterhart Sep 23, 2014 at 11:48:14 (UTC)
Goto Top
Danke für die Info.
Der Gedanke eine andere oder einfach 2 WLAN Karten einzusetzen kam mir auch schon.
Vielleicht sollte ich aber auch auf die neue Version der pfSense mit dem neuen FreeBSD warten.

Gruß
Peter
Member: karle77
karle77 Jan 24, 2015 at 13:08:22 (UTC)
Goto Top
Hallo,
erst mal danke für die vielen tollen Anleitungen hier im Board.
Ich habe die letzten Tage ein APU Board mit Pfsense 2.2 in Betrieb genommen. Beim Einrichten der internen Wlan Karte "Ubiquiti SR71E" habe ich genau oben genannte Probleme mit den sich überschreibenden Werten bei den "Common Wireless Einstellungen". Ich bin strikt an die Anweisung von aqui gehalten und hab 1x Wlan Interface + 1 Parent Infterface --> dieses dann zum 2. Wlan Interface gemacht und dann über eine Brigde in den LAN Adressraum verbunden.
Nach langem hin und her sendet die Karte im 2.4/5Ghz Band --> soweit i.O.

Das 2.4Ghz läuft problemlos - beim 5Ghz bekomme ich Authenthifizierungsfehler.
Wenn ich nun nochmal im 2.4Ghz Interface "nur" den Kanal zuweise und Apply drücke bleiben beide Frequenzbereiche aktiv - die Sendeleistung beider Bänder wird redziert (Anzeige lt. WLan Analyzer sinkt um 20dB) und nach diesem Schritt kann man sich ins 5Ghz Wlan einloggen.
Irgendwie bin ich momentan ein bisschen ratlos an welchem Punkt es hier scheitert. Liegt es am WLAN Modul / vielleicht irgendwas mit DHCP Kollision oder evtl. noch ein Bug in 2.2 RC?

Ich würde mich sehr über Antworten freuen.
Kann auch jederzeit noch ein paar Screenshots von der Konfiguration liefern.
Member: aqui
aqui Jan 24, 2015 at 14:57:10 (UTC)
Goto Top
die Sendeleistung beider Bänder wird redziert
Benutzt du auch eine Dual Band Antenne die beide Frequenzbereich abdeckt ??
Member: karle77
karle77 Jan 24, 2015 at 15:26:08 (UTC)
Goto Top
Ja, an dem Modul sind 2 Dualband-Antennen 2.4 + 5Ghz
Member: orcape
orcape Mar 23, 2018 at 16:57:25 (UTC)
Goto Top
Hi Leute,
auch wenn der letzte Post mehr als 3 Jahre zurück liegt, hier noch einmal etwas zum Thema WLAN-Dualband.
Ich habe heute, nachdem ich einige Zeit nur das 5 GHz Band genutzt habe, das Thema mit einem APU2 und einer Compex WLE200NX Dualband-Karte noch einmal von Grund auf "durchgespielt".
Und ja, @aqui, ich habe mehrmals gelesen und hoffe verstanden zu haben. Im übrigen, sehr Hilfreich Deine Tutorials und eigentlich, mit ein wenig Geduld, auch für weniger versierte Leute hin zu bekommen, aber zum Thema.
Das Problem mit dem überschreiben der Kanaleinstellungen ist natürlich nach wie vor ein "solches" und ich vermute den Grund zu kennen.
Das Interface dieser WLAN-Karte wird von der pfSense nicht automatisch erkannt, so das man unter "Interfaces / InterfaceAssignments" nicht die Möglichkeit hat, ein WLAN-Interface im 2,4 GHz Bereich hinzu zu fügen.
Erst mit einem, unter "Interfaces / InterfaceAssignments / Wireless" hinzugefügtes "Parent Interface", ist man in der Lage, überhaupt ein WLAN-Interface unter "Available network ports" zu finden und hinzu zu fügen.
Ein weiteres WLAN-Interface als "Parent Interface" welches man nun hinzufügen muss, wird wohl hier die Probleme mit den Überschreibungen der Daten verursachen und macht wohl das ganze instabil.
@aqui, wie Du in Deinem Tutorial schreibst, wird das Interface Deiner verwendete WLAN-Karte auf Anhieb erkannt, was bei meiner pfSense (Version 2.4.2-RELEASE-p1 (amd64)) und der Compex nicht der Fall ist.
Gruss orcape
Member: aqui
aqui Mar 23, 2018 at 17:24:31 (UTC)
Goto Top
Vermutlich ist es besser immer auf Nummer sicher zu gehen und Karten aus der Liste der supporteten WLAN Adapter zu wählen:
https://doc.pfsense.org/index.php/Wireless_Interfaces
Member: orcape
orcape Mar 24, 2018 at 10:03:04 (UTC)
Goto Top
Also auch eindeutig, das seit pfSense 2.4 erst unter "Interfaces / InterfaceAssignments / Wireless" das WLAN-Interface aktiviert werden muss, bevor es in den Interface-Einstellungen verfügbar ist. Das WLAN wird auch mit "minicom" am Com-Port nicht mehr automatisch erkannt und kann auf diese Weise so nicht mehr zugeordnet und aktiviert werden.