Mikrotik - Telekom Magenta TV - IPTV - Tutorial

Mitglied: Firstfreak

Firstfreak (Level 1) - Jetzt verbinden

06.06.2021, aktualisiert 07.06.2021, 1166 Aufrufe, 7 Kommentare


Einleitung


Um Mikrotik in Verbindung mit IPTV / Magenta TV verwenden zu können, benötigt Ihr neben ein paar Einstellungen, auch die richtige Firmware ist zu beachten
Ich habe es nun längere Zeit mit allen Firmware - Versionen ausprobiert, derzeit bleibt nur eine Firmware Version mit der die IGMP Proxy Funktion in Verbindung mit IP-TV stabil funktioniert, siehe Topic: Die richtige Firmware.
Denkt auch daran, das Ihr euren Switch (falls eine Switching Funktion vorhanden ist) entsprechend mit IGMP Snooping richtig konfiguriert.

Die richtige Firmware ist wichtig


Nach längeren Test stellt sich die Firmware : 6.48.1 als stabil heraus (Stand: Juni 2021)

Bei der Vorversion (<6.48.0) gibt es häufige Aussetzer, ebenso wie in der 6.48.2.
Diese sind zwar geringer aber vorhanden.

Package List


Das MultiCast Packet findet Ihr passend zu eurem Router auf der Download-Seite von Mikrotik LINK
all_packages-XYZ-6.48.1.zip !!! (XYZ = Hier das Packet für euren Router verwenden z.B. all_packages-arm-6.48.1.zip)

package-list - Klicke auf das Bild, um es zu vergrößern

IGMP-Proxy - WinBox


Nach der Installation vom MultiCast Package muss man zum IGMP Proxy (ev. Router - Neustarten)

igmp-proxy - Klicke auf das Bild, um es zu vergrößern


Settings


Hier folgen die Einstellungen, welche über z.B. die Winbox getätigt werden müssen.

IGMP-Proxy Menü


Öffne den IGMP-Proxy um die nächsten Einstellungen zu erstellen. Klicke in dieser Übersicht auf "+"

uebersicht_ipgm-proxy - Klicke auf das Bild, um es zu vergrößern

Interface der Internet-Verbindung


Erstelle die Einstellung zum MultiCast Netzwerk.
Diese Anleitung umfasst ausschließlich eine Mikrotik geroutete Verbindung.
Hier ist es der Router, der die Einwahl direkt über PPPOE macht,
Alternativ kann der Weg über das Eth gehen, welches euch das Internet für den Mikrotik Router bereitstellt. (Das habe ich aber nicht getestet.)

WICHTIG !!! Auf das Upstream-Häkchen achten !!!

upstream_igmp-proxy - Klicke auf das Bild, um es zu vergrößern

Interface - VLAN für IPTV im Netzwerk


Erstelle die im Anschluss die Einstellungen für das Empfangs-Netzwerk (Hier VLAN 70)

igmp-empfaenger - Klicke auf das Bild, um es zu vergrößern

Firewall


Einstellungen in der Firewall

Adresses List


Wechsel zu IP / Firewall und dann weiter zu "Adresses Lists" und erstellt dort die Einträge mit "+".

adresses-lists - Klicke auf das Bild, um es zu vergrößern

Filter Rules


Nun brauchen wir noch die Filter-Rules für den Empfang des MultiCast Streams. Erstelle die folgenden Einträge:

firewall-filter-rules - Klicke auf das Bild, um es zu vergrößern
firewall-multicast-input-forward - Klicke auf das Bild, um es zu vergrößern

Bridge-Settings


Als letztes noch die Bridge - Settings:

bridge-settings - Klicke auf das Bild, um es zu vergrößern

Bandbreitenanpassung


Wenn die Bandbreite Probleme macht, dann kann man auch noch über Queues die Prioritäten anpassen.
Dafür habe ich auch schon die Verbindungen markiert.

mark-packets - Klicke auf das Bild, um es zu vergrößern
mark-connections - Klicke auf das Bild, um es zu vergrößern

Schaue die Queues Einstellungen unter den weiterführende Links an.

Weiterführende Links


Mikrotik - Queues
https://administrator.de/forum/mikrotik-begrenzung-bandbreite-queue-mac- ...

VLAN Tutorial Mikrotik
https://administrator.de/tutorial/mikrotik-vlan-konfiguration-ab-routero ...

Mitglied: Cyberurmel
07.06.2021, aktualisiert um 16:26 Uhr
Hi und danke erstmal für deine Anleitung.

Leider geht das bei mir nicht wirklich. Habe alles so eingestellt wie bei dir allerdings die 6.48.2

Kannst du mir sagen wie man Fehler sucht? Nach meinem Verständnis sollte alles so passen.

ich habe erstmal kein eigenes VLAN erstellt für TV. Sollte aber nicht das Problem sein oder doch?

Danke
Bitte warten ..
Mitglied: Firstfreak
07.06.2021 um 16:30 Uhr
Moin,
ich habe auch mit der 6.48.2 Probleme gehabt.
Du musst es einem VLAN zuordnen im IGMP Proxy.
Und wenn du einen Switch hast, dann bitte den auch auf IPTV konfigurieren.

Wie sieht denn deine Übersicht im IGMP Proxy aus?
Und wie die Optionen darin?

MFG Freak
Bitte warten ..
Mitglied: Cyberurmel
07.06.2021 um 17:12 Uhr
Moin,

ich habe es dem native Vlan zugewiesen. Sieht genauso aus wie bei dir aber wenig traffic .. input Firewall 864 B , Forward 0

Im IGMP Proxy 0 Rx 0 Tx

Hm.. ich dokter schon ne Weile rum ..vielleicht auch was verstellt .. ich schau nochmal i nder config

greets
Bitte warten ..
Mitglied: aqui
07.06.2021, aktualisiert um 19:31 Uhr
Und wenn du einen Switch hast, dann bitte den auch auf IPTV konfigurieren.
Nennt sich IGMP Snooping. ;-) face-wink
Hier sollte man darauf achten das der Switch in dem Downstream Segment (VLAN) des Mikrotik Proxys bei aktivem IGMP Snooping kein Querrier ist, denn das sollte immer der Mikrotik Proxy sein. (Siehe oben beim Haken "Querrier" im Downstraem Interface.
Es schadet zwar nicht wenn beide Querrier sind aber es kommt dann zu einer Race Condition weil der IGMP Standard nur einen Querrier in der L2 Domain vorsieht. Das führt dann dazu das das Gerät mit der niedrigsten Mac Adresse den Querrier Tie Break gewinnt, was dann der Switch statt Mikrotik sein kann. Der Verlierer bleibt dann so lange stumm bis der Gewinner ausfällt oder vom Netz genommen wird.
Bitte warten ..
Mitglied: Cyberurmel
08.06.2021, aktualisiert um 11:57 Uhr
Hi ,

ich habe es mit Switch

als auch schon direkt mit dem Mikrotik verbunden ..nix..
Entweder es liegt wohl tatsächlich an der version oder aber ggfs habe ich noch den Fritzbox als Client in dem Vlan .. die trällert da auch munter drauf los..
Ich mach mal eigenes Vlan nur für den TV und häng den direkt an den MT.. dann sehe ich vielleicht was

Update -- so eigenes VLAN gemacht . Bekommt IP und TV geht auch für die ca 10-15 sek bis es auf MC umschaltet.
bei der FW bleibt forward auf 0 stehen. Input zählt Packetweise 1 hoch.

update2 -- im log steht igmp-proxy, debug immer was mit ignoring request from unknown adress -" alternative-subnets" configuration may be required :



greets
Bitte warten ..
Mitglied: Firstfreak
08.06.2021 um 15:03 Uhr
Versuch mal ein downgrade auf die 6.48.1

Ist auch das richtige In Interface ausgewählt? Also pppoe, es darf nicht die eth sein wenn du eine direkte Verbindung über Modem machst.

Wie ist denn dein Hardware Setup?

Gruß Freak
Bitte warten ..
Mitglied: Cyberurmel
08.06.2021 um 16:49 Uhr
Hi,

ja werd ich mal machen müssen dann.
Ja das ppoE ist ausgewält.. er zählt ja auch hoch beim IGMP Proxy ..
pppoe-out mit upstream und AS 87.141.215.251 Empängt RX

vlan x transmitted denselben Wert dazu.

Im Moment ist das Setup ganz simple - der MT hinter einem Vigor Modem und an dem MT hängt direkt dann der Media Receiver mit eigenem VLAN- Bild kommt ja auch von daher scheint mir das zu stimmen.


greets
Cyb
Bitte warten ..
Heiß diskutierte Inhalte
Backup
Backupstrategie
Xaero1982Vor 1 TagFrageBackup37 Kommentare

Nabend Zusammen, wir bekommen es ja leider alle immer wieder mal mit, dass es auch große Firmen gibt, die von irgendwelchen Verschlüsselungstrojanern verseucht werden. ...

LAN, WAN, Wireless
MikroTik: kaskadisches Core-Netzwerk CCR-CRS-CRS mit Satelliten-Swichtes+APs - ein Versuch einer Anleitung von A-Z
gelöst PackElendVor 1 TagFrageLAN, WAN, Wireless12 Kommentare

Hallo zusammen, da ich mit der gelieferten Konfiguration meiner MikroTiks nicht so zufrieden bin, fange ich von vorne an. Das liegt daran, dass ich ...

Internet
ARD und ZDF Live Stream
gelöst ben1300Vor 1 TagFrageInternet14 Kommentare

Guten Morgen ! wir haben zwei Samsung Monitore im Einsatz (Modell DM48E), welche via Netzwerk mit unserem MagicInfo Server verbunden sind. Hierdrüber möchte ich ...

Windows 10
Windows 10 Clients werden mit TMP-Ordnern geflutet
kgbornVor 1 TagTippWindows 107 Kommentare

Vielleicht mal nachschauen, ob die Windows 10 Clients oder die Server auch mit leeren TMP-Verzeichnissen im angegebenen Pfad vollgemüllt werden. Hab da unterschiedliche Rückmeldungen ...

LAN, WAN, Wireless
SFP mit SFP+ verbinden
maximum3012Vor 1 TagFrageLAN, WAN, Wireless10 Kommentare

Hallo zusammen, mich würde folgendes interessieren, ist es eigentlich möglich, ein SFP Switch mit einem SFP+ Switch zu verbinden? Es gibt ja die Möglichkeit ...

SAN, NAS, DAS
Hardware oder Software RAID
CrunkFXVor 1 TagFrageSAN, NAS, DAS12 Kommentare

Mahlzeit, Kurz vorab eine Einigung darauf dass es kein Hardware RAID gibt, ich aber trotzdem differenziere zwischen: Software RAID ( reine Software auf einem ...

Router & Routing
Ortsveränderliches Netzwerk einrichten
Daniel82619Vor 1 TagFrageRouter & Routing10 Kommentare

Hallo, ich habe eine Frage zum Thema Netzwerk(e) und Routing. Im angehängten Bild habe ich versucht die Situation etwas darzustellen. Ich habe mehrere Geräte ...

Netzwerke
USB an FritzBox neu starten
mirmichVor 1 TagFrageNetzwerke16 Kommentare

Hallo, ich habe an einer Fritzbox 7360 ein entferntes Netzwerk laufen. Dieses ist per LTE am USB-Port mit dem Internet verbunden. Mein Problem: Ab ...