Adaptec RAID 6805 verhält sich merkwürdig

bloodstix
Goto Top
Hallo zusammen,

ich habe einen Server mit einem X10DRL-C Supermicro Mainboard und einem im Titel genannten Raid-Controller.
Auf diesem soll ESX installiert werden aber es will nicht so recht. Ich habe dutzende Kombinationen von ESX 6 bis 6.7U3 mit den von
VMware und Adaptec vorgegebenen "zertifizierten" Treibern/Utilitys ausprobiert aber ich bekomme es einfach nicht hin
per arcconf oder MSM den Controller zu monitoren. Mit der letzten Kombi ESXI6+1.8er treiber von Adaptec hab ich nun zumindest mal
den Status "OPTIMAL" im vSphere Web Client in der Storage-Überwachung zu gesicht bekommen. Bei allen anderen Kombis kann der Raid zwar angesprochen
werden aber keine der Lösungen für arcconf oder MSM funktionieren. Obwohl angeblich von VMware supportet.
Nun ist heute plötzlich der Raid6 im Status "degraded". Das ESX bootet normal, aber im RAID-Bios (Raid Config Utility) beim booten meldet er zunächst das
degraded Array, findet dann aber im eigentlichen utility kein Array mehr. Das scannen nach Festplatten dauert sehr lang und dann rebootet sich der Server plötzlich automatisch.
Firmware habe ich auch schon verschiedene ausprobiert, außer die neuste die habe ich erst heute spät entdeckt.

Ich will morgen noch die neuste Firmware ausprobieren und den Controller einmal komplett resetten (das geht wohl per Jumper).

Kann mir von euch jemand etwas hilfreiches dazu mitteilen?
Der Server ist von 2015 und sollte nun überholt werden. Da lief vorher schon ESX 6 drauf jedoch gab es von Anfang an Probleme den Raid mit den Adaptec-Tools zu monitoren und
es gab einige PSOD's woraufhin ein neuer Server angeschafft wurde. Dort ist ein LSI-Controller drin und der lässt sich zumindest per storcli abfragen und per Skripts monitoren!

Für die Zukunft: Kann mir jemand eine stabile und ohne diverse Komplikationen einzurichtende Hardware-KOmbi für einen ESX-Server nennen? Geht speziell um den RAID-Controller.

Grüße bloody

Content-Key: 562378

Url: https://administrator.de/contentid/562378

Ausgedruckt am: 16.08.2022 um 14:08 Uhr

Mitglied: StefanKittel
StefanKittel 02.04.2020 um 01:33:15 Uhr
Goto Top
Zitat von @bloodstix:
Für die Zukunft: Kann mir jemand eine stabile und ohne diverse Komplikationen einzurichtende Hardware-KOmbi für einen ESX-Server nennen? Geht speziell um den RAID-Controller.

Moin,
bei Servern von HP, Dell und Fujitsu gibt es ein Custom-ESXi-Image vom Hersteller.
Da sind Monitoring für Lüfter, CPU, RAM und Storage bereits enthalten.

Die meisten Monitoren das allerdings über das IPMI und/oder SNMP.

Viele Grüße

Stefan
Mitglied: cykes
cykes 02.04.2020 um 06:15:44 Uhr
Goto Top
Moin,

wir hatten hier im letzten Jahr schon eine Diskussion zum Thema Adaptec/Microsemi 6805 und VMWare 6.x -> hier. Ergebnis war da: Geht nicht (in vollem Umfang).
Daran hat sich seit Mitte letzten Jahres wohl auch nichts geändert. Meiner Erfahrung nach machen insbesondere die CIM-Provider für die Adaptec Controller Probleme.
Ein paar allgemeine Informationen bis ESXi 6.0 finden sich auch hier und hier.
Besonders stabil war diese Lösung nmoch nie, unter ESXi 5.5 ging's noch halbwegs, aber seit 6.x wurde das immer instabiler.

Das Schiksal teilen aber auch andere Controller, außer man hat - wie von Stefan bereits erwähnt - einem Server von einem der großen Hersteller inkl. einem Customized Image laufen. Selbst dann ist es aber nicht 100% gesichert, dass alles stabil läuft.

Gruß

cykes
Mitglied: bloodstix
bloodstix 02.04.2020 um 10:39:52 Uhr
Goto Top
Huhu,

ja diese Aussagen sind mir nicht neu. Aber wie kann das sein wenn der Controller angeblich laut Adaptec und VMWare Kompatibel ist und die Treiber/Tools zertifiziert?! Das grenzt ja schon an Betrug...

Ich probier jetzt gleich noch die neuste Firmware... bin aber nicht sehr zuversichtlich.

Grüße
bloody
Mitglied: StefanKittel
StefanKittel 02.04.2020 um 10:55:45 Uhr
Goto Top
Zitat von @bloodstix:
Aber wie kann das sein wenn der Controller angeblich laut Adaptec und VMWare Kompatibel ist und die Treiber/Tools zertifiziert?!
Das heisst ja nur dass der Controller als Storage funktioniert. Nicht dass man den Status auslesen kann.
Ein Schelm....
Mitglied: bloodstix
bloodstix 02.04.2020 aktualisiert um 12:38:02 Uhr
Goto Top
Hallo zusammen,

ich habe ein freudiges Update: Es läuft.
Das "degraded" ist wohl weil ein Stripe am Rebuilden ist.

Das System zeigt nun in der WebUI den Status des RAIDS. RemoteArcconf von einer beliebigen Linux-Maschine funktioniert
ebenfalls und das lokale arcconf auf dem ESX funktioniert auch. Abfrage per gOS-MSM von einem Windows-Host funktioniert
ebenfalls.

Das ist ein ESX6u3 mit
- aacraid-Treiber von Adaptec Version 52040
- arc-cim-provider 2.05-22932
- arcconf 2.05-22932
- Guest-OS MSM aus "maxView Storage Manager v2.05.22932 for VMware" von Adaptec

Den Guest-OS MSM für Linux hab ich leider nicht zum laufen bekommen da das Installationsskript für rpm-basierte Distributionen ist und bei der Umwandlung mit alien wichtige Details fehlen die noch um die RPM herum vom Skript konfiguriert werden. Klar könnte man sich das alles aus den Skripts fummeln was in welche Dateien zu schreiben ist aber das mag ich mir grad nicht antun.

Jetzt überlege ich mir gerade wie ich ein Image von der Installation ziehe, da alles auf dem 8TB-Datastore installiert ist. Wollte dann ein Update auf 6.5 testen und schauen obs damit dann auch noch läuft.

Grüße
bloody

edit: Und die Firmware aufm Adapter hab ich auch noch aktualisiert: Ver. 5.3.0 Build 19204
Mitglied: bloodstix
bloodstix 02.04.2020 um 21:22:10 Uhr
Goto Top
Ich dachte mir ich erwähne mal die Leute aus den anderen Threads. Die sind zwar schon was älter aber vielleicht besteht ja trotzdem noch Interesse.
@123290 @Vision2015 @sivsert @cola