ADPREP bei Istallatione einen 2003 R2 DCs

meinereiner
Goto Top
Hallochen,

nur mal kurz zur allgemeinen Info.
Wenn man versuchte einen 2003 R2 Server zum Domänencontroller zu machen und dies der Erste R2 Server ist. So muss man zuerst ADPREP ausführen. Das ist ja nicht so neu. Wichtig dabei ist allerdings das man die adprep.exe von der CD2 nimmt.

Man muß adprep auch ausführen wenn es schon einmal mit einem "normalen" (also nicht R2) 2003 Server ausgeführt wurde.

Viele Grüße
meinereiner

Content-Key: 37594

Url: https://administrator.de/contentid/37594

Ausgedruckt am: 17.08.2022 um 19:08 Uhr

Mitglied: cbbob
cbbob 06.09.2006 um 11:33:59 Uhr
Goto Top
Hi meinereiner,

bist Du dabei schon auf irgendwelche Probleme gestoßen? Ich versuche schon den ganzen tag beträge zu diesem Thema zu finden, aber scheinbar haben nocht nicht viele Leute dieses Problem gehabt.

FYI: Ich administriere eine W2k3 Domäne mit 6 Standorten (7DCs), die alle noch ohne SP1 laufen.

Ich konnte bisher auch nicht herausfinden, ob es eine bessere Idee ist alle DCs auf SP1 anzuheben und ob das das Schema wieder kompatibel macht. Da war ich mir wiederum nicht sicher welche Nebenwirkungen das SP1 upgrade haben könnte...

Fragen über Fragen.. Vielen Dank für Antworten im Voraus.

Gruss cbbob
Mitglied: meinereiner
meinereiner 06.09.2006 um 18:40:19 Uhr
Goto Top
Ich hatte den Beitrag geschrieben, weil wir hier zweimal die Probleme hatten.

Auch mit SP1 ist das Schema nicht zu R2 kompatibel.
Das habe ich gerade bei miener Domäne zu Hause ausprobiert. Auch in dem Fall musst du adprep von der CD2 nehmen.
Ob es jetzt mit oder ohne SP1 besser läuft kann ich dir nicht sagen. Ich schätze aber das wird keinen so großen Unterschied machen. Hier sind auch nie Probleme dazu aufgetaucht. DAs Problem war immer nur, dass das falsche adprep benutzt wurde. Das von CD1 und nicht das von CD2.

HTH
meinereiner
Mitglied: DanG
DanG 11.10.2006 um 08:54:49 Uhr
Goto Top
Ich habe leider fats kein Wartungsfenster, darum: Kann man ADPREP während dem laufenden Betrieb durchführen? Ist das überhaupt sinnvoll? Ist ein Neustart nötig?

Gruss Dani
Mitglied: meinereiner
meinereiner 11.10.2006 um 18:21:52 Uhr
Goto Top
Ich habs in meinem kleinen Heimnetzwerk im laufenden Betrieb ohne Reboot gemacht.
Wenn das ganze aber bei mir in der Firma ansteht, werde ich dem ursprünglichen RAT von MS folgen und den DC auf dem ich adprep /forestprep ausführe komplett vom Netz trennen und erst wieder rein nehmen, wenn alles gut gelaufen ist.

Wenn du so kleine Wartungsfenster hast solltest du aber mindestens zwei DCs haben, so dass einer mal weg sein kann?!
Mitglied: DanG
DanG 12.10.2006 um 07:18:18 Uhr
Goto Top
OK, ich habe ADPREP nun durchgeführt.

Ich habe es am Abend gemacht und das ganze dauerte etwa 5min.
Alles lief ohne Fehler durch.

Auf DC war Windows 2003SP1 mit AD Schema 30. Nun habe ich AD Schema 31 und konnte einen neuen Windows 2033R2 DC in die Domäne reinnehmen.


Gruss Danger
Mitglied: Egbert
Egbert 22.12.2006 um 17:19:07 Uhr
Goto Top
Hallo ich habe gerade diesen Thread mal gelesen.

Bei mir ist folgendes passiert als ich mal einen R2 ins Netz genommen habe.

R2 installiert --> alles ok
in Domäne genommen --> alles ok
adprep gemacht --> alles ok
DCPROMO gemacht auf R2 --> alles ok
R2 Rechner zum GC gemacht --> alles ok
Rollen auf R2 Rechner umgezogen --> Domain Controller Policy im Sysvol verschwunden
DCGPOFIX --> keine Chance
Rollen zurück auf Sp1 Rechner
DCPROMO zum herunterstufen des R2 Rechners
Policy aus Sicherung wieder hergeholt
Alles war wieder ok.
In den logs konnte ich nichts finden das irgendetwas schiefgelaufen ist.
Hat von Euch jemand ähnliche erfahrungen gemacht?

Gruß
Egbert
Mitglied: meinereiner
meinereiner 22.12.2006 um 23:35:33 Uhr
Goto Top
Hallo Egbert,

sowas kenne ich nicht, bei mir hat das auch alles gut geklappt.
Mit ADPrep wird das auch nicht zuammen hängen, denn die neue AD Version hast du ja auch jetzt noch auf deinem DC.

Hast du vor dem runterstufen des DCs mal ein Restore der Policie versucht?


Grüße
meinereiner
Mitglied: Egbert
Egbert 23.12.2006 um 10:19:52 Uhr
Goto Top
Hallo meinereiner,

ich glaube auch nicht das dass an dem ADPRPEP liegt.

Den Restore habe ich mehrmals in verschiedenen Konstellationen versucht.
Hätte mich nur interessiert ob jemand schon solche Erfahrungen hatte.

Schöne Feiertage und Gesundheit und Erfolg im neuen Jahr

Egbert
Mitglied: 53114
53114 31.10.2007 um 09:57:11 Uhr
Goto Top
Hängt vielleicht mit der Replikation zusammen?
Gruß
Mitglied: NetGhostHH
NetGhostHH 28.03.2008 um 14:05:25 Uhr
Goto Top
Danke für den Tip mit der CD-2 - jetzt fuktioniert der Assi für das aufsetzten des AD problemlos.

Grüße aus dem Norden
Stefan
face-smile
Mitglied: NetGhostHH
NetGhostHH 28.03.2008 um 14:06:18 Uhr
Goto Top
Sorry, war zu hektisch und habe 2x gesendet