benjo83
Goto Top

BackupExec Snapshot Sicherung abschalten

Hallo zusammen,

Ich habe vor kurzem unseren Backup Exec 11d Server auf 12.5 upgegraded. Ich hatte zwe bestehende Sicherung von jeweils einem Windows 2008 Server. Die Sicherung sollte nur Dateien auf Band sichern. Seid dem Upgrade hat sich zum einen Das Symbol des Backupsatzes geändert (Wenn man einen neuen Wiederherstellungsauftrag einrichtet sieht man das ja in der Liste) und auch die Beschreibung von "(Vollständig)" auf "(Snapshot Vollständig)". Und seit dem das so ist, sichert er keine Daten mehr und gibt eine Meldung raus, das der Auftrag möglicherweise keine Daten enthält. Auf einem Server konnte ich jetzt verfizieren, dass der VSS Dienst des Servers zum Zeitpunkt des Backups abstürzt. Ich denke mal, weil die Dateien mit 17/21 GB zu groß für ne Shattenkopie sind.

Meine Frage wäre jetzt, wie bekomm ich ihn jetzt dazu wieder ganz normal zu sichern?


MfG

BenJo83

Content-Key: 130754

Url: https://administrator.de/contentid/130754

Printed on: July 21, 2024 at 07:07 o'clock

Member: mgoelike
mgoelike Dec 02, 2009 at 19:08:38 (UTC)
Goto Top
Hallo BenJo83,

zunächst mal einige Fragen zur BackupExec-Installation.

Ist SP3 installiert?
Wird der Sicherungsauftrag mit aktivierter AdvancedOpenFile Option durchgeführt?
Ist AdvancedDiskBackup Option lizenziert?

Die Backupsätze werden bei mir auch als SnapshotSätze gelistet. Dies gilt für die Sicherungssätze von Systemstatus und Shadow Copy Komponenten.
Die Bezeichnung sollte Dich also nicht verunsichern. Das ist normal. BackupExec 12.5 sichert generelle diese beide Dinge mit Snapshots (VSS) und bezeichnet sie auch so.

Die Größe des Snapshots ist eigentlich nur begrenzt durch die Menge an freiem Speicherplatz auf der Festplatte/Partition die gerade gesichert wird. 21 GB sollte aber überhaupt kein Problem sein.

Welchen ServicePack Stand haben die Windows Server?

Mit freundlichen Grüßen
Marcel
Member: BenJo83
BenJo83 Dec 03, 2009 at 09:55:41 (UTC)
Goto Top
Hi Marcel,

danke erst mal für die Antwort.

Aaaalso: SP3 ist installiert, der Sicherungsauftrag wird nicht mit AdvancedOpenFile durchgeführt (denke mal das brauch auch nicht, die Dateien sind nicht in Benutzung während des Backups), Advanced Disk-based Backup Option ist nicht lizensiert. Der Backup Server läuft auf Windows Server 2003, Sp Stand ist aktuell, ebenso bei den Windows 2008 Servern.


MfG
BenJo
Member: mgoelike
mgoelike Dec 03, 2009 at 15:18:59 (UTC)
Goto Top
Hi,

da Deine Installationen aktuell sind wird es jetzt interessant. Eine Frage noch vorweg, nach dem Update von BackupExec und der Installation von SP3, hast Du da die Agents auf den Windows Servern auch aktualisiert?
Hatte das beim letzten Mal vergessen zu fragen.

Poste mal bitte die Fehlermeldung (der Nummerncode reicht) des BackupBerichts.

Um jetzt herauszufinden ob der VSS-Dienst ne Macke hat, könntest Du mal mit der integrierten Sicherung von Windows Server ein Backup machen. Auf externe Festplatte oder Ordner im Netzwerk. Treten dabei keine Fehler auf, liegt das Problem wahrscheinlich in der Kommunikation zwischen VSS-Writer und BackupExec-Dienst.

Noch ein Hinweis zu AdvancedOpenFile: Ein laufendes System hat immer Dateien in Benutzung. Aus diesem Grund wird bei der Systemstate Sicherung immer mit dem VSS-Dienst oder aber mit einem gleichwertigen Provider von Symantec gearbeitet. Ist AdvancedOpen File nicht konfiguriert, wird dabei der Windows VSS-Dienst verwendet.

Wenn Du erstmal nicht weiterkommst konfiguriere doch mal AdvancedOpenFile mit Symantec Snapshot Provider und schau was passiert.


Mit freundlichen Grüßen
Marcel
Member: BenJo83
BenJo83 Dec 03, 2009 at 15:32:34 (UTC)
Goto Top
Hi,

so vorweg, ich probier mal beides. Ich lass mit Advanced OpenFile sichern und eine Windows Sicherung.

Die Agents habe ich nach der Installation vom SP3 aktualisiert.

Das Auftragsprotokoll meldet dass die Sicherung erfolgreich war, alles was ich bekomme ist eine E-Mail Benachrichtigung mit folgender Warnung: "Dieser Sicherungssatz enthält eventuell keine Daten."

Ich melde mich morgen nochmal mit dem Ergebnis des Tests.


MfG
BenJo
Member: BenJo83
BenJo83 Dec 04, 2009 at 09:00:38 (UTC)
Goto Top
Guten morgen,

leider konnte ich das Windows eigene Backup nicht testen, ich habe keine Netzfreigabe gehabt die genügend Platz bietet. Der Advanced OpenFile Test ist auch fehlgeschlagen, ich hatte ihn auf automatisch auswählen gestellt.


mfG
BenJo83
Member: mgoelike
mgoelike Dec 06, 2009 at 11:29:26 (UTC)
Goto Top
Hallo,

bei Automatischer Auswahl verwendet er den VSS-Writer von Windows. Ist also kein Unterschied zu den vorhergehenden Sicherungsoptionen.
Bitte unbedingt mal den Symantec Provider auswählen und erneut testen.

Mit freundlichen Grüßen
Marcel
Member: BenJo83
BenJo83 Dec 07, 2009 at 09:06:27 (UTC)
Goto Top
Guten morgen,

habe es mit dem Symantec-Provider ausgewählt. Ändern tut sich nichts allerdings bekomme ich folgende Warnmeldung im Auftragsprotokoll:


Sichern- "Servername"V-79-57344-34086 - AOFO: Initialisierung fehlgeschlagen: "C:". Advanced Open File Option verwendet: Microsoft Volume Shadow Copy Service (VSS).
Fehler im Snapshot-Provider (0xE0008526): Backup Exec konnte zu diesem Auftrag keinen Software- oder Hardware-Snapshot-Provider für den Microsoft Volumeschattenkopie-Dienst (VSS) finden. Wählen Sie einen gültigen VSS-Snapshot-Provider für den Zielcomputer aus.
Ausführliche Angaben finden Sie in der Windows-Ereignisanzeige.

Im Eventlog seh ich jetzt aber nix besonderes


MfG
BenJo83
Member: mgoelike
mgoelike Dec 07, 2009 at 20:43:27 (UTC)
Goto Top
Guten Abend,

eventuell hilft es die VSS Dateien neu zu registrieren.

Hier sind mal zwei Links die Dir vielleicht weiter helfen:

http://support.microsoft.com/default.aspx?scid=kb;en-us;940032
http://support.microsoft.com/default.aspx?scid=kb;en-us;941956

War auf den Servern zwischendurch vielleicht auch mal eine andere BackupSoftware installiert? Zum Beispiel Acronis TrueImage oder ähnliches?

Mit freundlichen Grüßen
Marcel
Member: BenJo83
BenJo83 Dec 08, 2009 at 10:13:50 (UTC)
Goto Top
Hi,

die Artikel bezihen sich jetzt ja auf Windows Server 2003 und nicht auf 2008. Weiß jetzt nicht in wieweit das zutreffend ist.

Auf den Servern war nur der Backup Exec Remote Agent 11d installiert.


MfG
BenJo83
Member: BenJo83
BenJo83 Dec 08, 2009 at 10:27:02 (UTC)
Goto Top
Also ich habe jetzt ncohmal auf anderen Servern geschaut, dort werden auch größere Datein gesichert als auf den Servern die nicht gehen.

Was ich sichere sind vhd-Dateien von Hyper-V Maschinen und deren Config xmls. Vor dem Backup werden die Maschinen die gesichert werden per PowerShell Script gesaved. Köbnnte das was damit zutun haben?
Member: mgoelike
mgoelike Dec 08, 2009 at 19:58:08 (UTC)
Goto Top
Hallo,

ahh jetzt kommt langsam Licht in die Sache.

Möglicherweise will BackupExec die vhd-Dateien nicht ohne die entsprechende Lizenz sichern bzw. ignoriert diese Art von Daten. Deshalb auch der Hinweis (Sicherung enthält eventuell keine Daten, er kann nämlich nicht in die vhd-Dateien reinschauen). Normalerweise werden die Virtuellen Maschinen mit dem Agenten für Hyper-V gesichert. Dabei werden dann die vhd-Dateien und die entsprechenden Configs durch BackupExec gesichert.

http://blog.buerstinghaus.net/anleitungen/hyper-v-sicherung-mit-backup- ...

Installier doch mal die Lizenzoption für Hyper-V. Ohne gültige Lizenz läuft der 30 Tage als Demo unabhängig von den anderen Optionen.
Versuch dann mal zu sichern.

Mit freundlichen Grüßen
Marcel
Member: BenJo83
BenJo83 Dec 09, 2009 at 09:01:34 (UTC)
Goto Top
Hi,

ja das werd ich mal probieren. Allerdings wird nur auf einem Server gar nichts gesichert. Auf dem anderen wird wenigstens ein Teil gesichert. Naja, wir haben ja Support bei Symantec. Sonst ruf ich da auch nochmal an, mal schauen was die dann sagen.


MfG
BenJo83
Member: BenJo83
BenJo83 Dec 09, 2009 at 10:25:09 (UTC)
Goto Top
Mmh wenn ich die Option Microsoft Virtual Server installieren will bekomm ich folgende Fehlermeldung:

12-09-2009,10:55:34 : BIGSAFEGUARD\BKUPEXEC is a SQL Server Express Edition
12-09-2009,10:55:34 : "SQLExpress\SQLEXPR.exe" /wait /qn /norestart /lv "C:\Programme\Microsoft SQL Server\90\Setup Bootstrap\LOG\Summary.txt" INSTANCENAME=BKUPEXEC SQLACCOUNT="NT-AUTORITÄT\SYSTEM" SQLPASSWORD="" UPGRADE=SQL_Engine,SQL_Data_Files,SQL_Replication,Client_Components,Connectivity SAPWD= DISABLENETWORKPROTOCOLS=0
12-09-2009,10:55:34 : V-225-53: ERROR: Failed to install SQL Express BKUPEXEC instance with error 1603. ***To search for information about this error, click here
12-09-2009,10:55:34 : Please review C:\Programme\Microsoft SQL Server\90\Setup Bootstrap\LOG\Summary.txt for more details.
12-09-2009,10:55:34 : Failed to install third party products.


Ich hab schon mit BEUtility dem user der die BackupExec Dienste ausführt und dem System Account Zugriff auf die Datenbank gewährt, ohne Erfolg.