CmdLet-Probleme

judgelg
Goto Top
Hallo,

wenn ich enable-mailbox in die EMS eingebe kommt folgender Fehler:

Hat eventuell jemand nen tipp für mich?

Ich Tippe mal auf irgendwelche Berechtigungsprobleme. Aber welche?

Grüße
unbenannt1

Content-Key: 347455

Url: https://administrator.de/contentid/347455

Ausgedruckt am: 16.05.2022 um 10:05 Uhr

Mitglied: SeaStorm
SeaStorm 28.08.2017 um 07:46:17 Uhr
Goto Top
Hi

Entweder du hast die Exchange shell nicht eingebunden oder, falls doch, hast du die Berechtigung für das command nicht. Letzteres muss dir dann dein Admin geben
Mitglied: Judgelg
Judgelg 28.08.2017 aktualisiert um 07:58:48 Uhr
Goto Top
Ich bin selbst Admin. Das ist ja das kuriose... Das Problem tauchte auf einmal auf.
Exchange Shell nicht eigebunden?
Mitglied: SeaStorm
SeaStorm 28.08.2017 um 08:13:53 Uhr
Goto Top
hab überlesen das du "EMS" geschrieben hast. Dachte irgendwie du hast Powershell geschrieben. Und ohne, das du die Exchange CMDlets einbindest, wird das halt nix.


Berechtigungen:
https://technet.microsoft.com/en-us/library/dd876911.aspx :

The Mail Recipients management role enables administrators to manage existing mailboxes, mail users, and mail contacts in an organization. This role can't create these recipients. Use the Mail Recipient Creation role to create them.
Mitglied: Judgelg
Judgelg 28.08.2017 aktualisiert um 10:29:24 Uhr
Goto Top
Habe jetzt festgestellt, wenn ich in der EMS den Befehl: Get-PSSnapin -Registered eingebe werden mir die fehlenden Snapins angezeigt. Wenn ich die Snapins dann importiere ist enable-Mailbox auch wieder vorhanden. Wenn ich die EMS aber schließe und erneut aufrufe ist alles wieder verschwunden. Erst wenn ich die Snapins wieder hinzufüge ist alles wieder gut.

Auf den Tipp brachte mich folgende Seite: http://www.techguy.at/powershell-import-module-oder-add-pssnapin/
Mitglied: Judgelg
Judgelg 25.09.2017 um 14:18:08 Uhr
Goto Top
Habe jetzt folgendes gemacht. Habe den Befehl einfach hinten unter Eigenschaften der Shell mit angehangen. So funktioniert es wieder.


C:\Windows\System32\WindowsPowerShell\v1.0\powershell.exe -noexit -command ". 'C:\Program Files\Microsoft\Exchange Server\V15\bin\RemoteExchange.ps1'; Connect-ExchangeServer -auto; Get-PSSnapin -Registered | Add-PSSnapin"