Debian bootet nicht in HyperV

sireistee
Goto Top
Hallo zusammen,

ich bin am Verzweifeln. Wahrscheinlich etwas banales, aber ich hänge gerade einfach fest.

Ich habe hier eine 240GB SSD worauf ein Debian + Software läuft. Die SSD steckte original in einer Intel NUC drin. Nun möchte ich diese Festplatte virtualisieren und unter HyperV nutzen.

screenshot_423


Wie stelle ich das am Besten an?

Bisher probiert:
- Mittels Disk2Vhdx eine virtuelle Festplatte erstellt und eingebunden
- Mit Lazesoft die komplette Festplatte (inkl. freien Speicher) kopiert und als VHDX erstellt
- Im HyperV-Manager eine virtuelle Festplatte auf Basis der per SATA angebundenen SSD erstellt

Was immer passiert und wo ich nicht weiter komme:
-> in Gen2 kein x64 Bootloader gefunden (auch bei ausgeschaltetem SecureBoot)
-> in Gen1 kommt nach dem HyperV-Logo nur ein blinkender Cursor der eine zweite Zeile verrutscht

Muss ich irgendwas mit Diskpart bearbeiten? Ich nehme da HBCD als Tool dazu.

Gruß
Eistee

Content-Key: 2912421559

Url: https://administrator.de/contentid/2912421559

Ausgedruckt am: 07.07.2022 um 09:07 Uhr

Mitglied: Vision2015
Vision2015 27.05.2022 um 16:51:19 Uhr
Goto Top
Moin...

ich denke du sollst mal grub reparieren!
das sollte Helfen....
Super Grub2 Disk

Frank
Mitglied: fdk007
fdk007 29.05.2022 um 18:30:03 Uhr
Goto Top
Hallo Icetee,

also, ich würde die VM Löschen und nochmals von vorne anfangen. Ich denke Du hast Irgendwo einen Fehler gemacht(?). Falls Du zum gl. Ergebnis kommst, versuche mal den NUC ohne VM direkt mit einem Ubuntu-USB-Stick zu starten, ob das überhaupt geht?

BG
FDK