stefankittel
Goto Top

ESXi vertut sich nach einem Neustart leicht bei der Anzahl der virtuellen CPUs einer VM

Hallo,

ich führe gerade eine Wartung bei einem Kunden durch.
Dabei haben wir auch den Backup-ESXi runtergefahren, örtlich umgestellt und neu gestartet.
Bis auf eine VM lief alles auf anhieb.

Eine VM lief nicht.
Ich dachte, wir hätte den Autostart vergessen. Aber das war es nicht.

Beim starten kam der Hinweis, dass unsere Lizenz erschöpft wäre.
Es ist eine normale gekauft Basis-Lizenz. Alle anderen VMs liefen fein.

Da sah ich, dass die VM auf einmal 20 vCPUs mit 20 Sockeln statt 2 vCPU mit 1 Sockel hatte. Das passt zur Meldung, da nur 8 Sockets erlaubt sind. Wieder auf 2 gestellt und alles OK.

Aber wo kamen die 20 vCPUs her?

Stefan

PS: Dies ist keine Frage.

Content-Key: 6509108489

Url: https://administrator.de/contentid/6509108489

Printed on: February 24, 2024 at 15:02 o'clock

Mitglied: 2423392070
Solution 2423392070 Mar 26, 2023 at 05:22:02 (UTC)
Goto Top
Sende die Support-Files ein. Das hort sich nach einem Bug an.

Ich leider immer noch einen Bug, dass Windows VMs nach dem der Hosts aus war, also nicht Neustart, die NIC zwar auf verbunden stehen aber das virtuelle Netzwerkkabel dennoch nicht gepatcht ist.
Heißt im Hypervisor online und gepatcht und im Windows Adapter grau und offline.
Das bezieht sich auf alle Intel NICs der Hardware. Broadcom usw nicht betroffen.
Member: Dani
Solution Dani Mar 26, 2023 at 19:41:53 (UTC)
Goto Top
Moin Stefan,
es wäre durchaus hilfreich, wenn du noch die Version von ESXi postet.

Dabei haben wir auch den Backup-ESXi runtergefahren, örtlich umgestellt und neu gestartet.
Geschieht das Problem nochmals, wenn du den ESXi herunterfährst und wieder startest?

Aber wo kamen die 20 vCPUs her?
Evtl. wurde die Anzahl in der Vergangenheit angepasst (z.B. Tippfehler), aber die VM nicht neu gestartet?!


Gruß,
Dani
Member: StefanKittel
StefanKittel Mar 27, 2023 at 16:48:17 (UTC)
Goto Top
Zitat von @Dani:

Moin Stefan,
es wäre durchaus hilfreich, wenn du noch die Version von ESXi postet.
Muss ich schauen. Irgenwas 7.xxx

Dabei haben wir auch den Backup-ESXi runtergefahren, örtlich umgestellt und neu gestartet.
Geschieht das Problem nochmals, wenn du den ESXi herunterfährst und wieder startest?
Nein.

Aber wo kamen die 20 vCPUs her?
Evtl. wurde die Anzahl in der Vergangenheit angepasst (z.B. Tippfehler), aber die VM nicht neu gestartet?!
Nein

Ich wollte mal hören ob einige Sagen "Ja, ist bekannt".
Da es nicht mehr auftritt und auch einfach zu beheben war suche ich da nicht weiter.

Stefan