nicole-1305
Goto Top

Excel 2003, wie setzte ich zwei Formeln zusammen?

Hallo zusammen,

ich habe ein Problem mit einer wahrscheinlich zu langen Formel:
=WENN(M80<>0;GANZZAHL((M80-DATUM(JAHR(M80-REST(M80-2;7)+3);1;REST(M80-2;7)-9))/7);GANZZAHL((L80-DATUM(JAHR(L80-REST(L80-2;7)+3);1;REST(L80-2;7)-9))/7))*ODER(L80=0;GANZZAHL((L8-DATUM(JAHR(L8-REST(L8-2;7)+3);1;REST(L8-2;7)-9))/7))+3
Der erste Teil funktioniert einwandfrei:
=WENN(
M80<>0;
GANZZAHL((M80-DATUM(JAHR(M80-REST(M80-2;7)+3);1;REST(M80-2;7)-9))/7);
GANZZAHL((L80-DATUM(JAHR(L80-REST(L80-2;7)+3);1;REST(L80-2;7)-9))/7))
Dazu brauche ich aber noch diesen Teil der alleine für sich auch gut funktioniert:
WENN(L80=0;GANZZAHL((L8-DATUM(JAHR(L8-REST(L8-2;7)+3);1;REST(L8-2;7)-9))/7))+3
Habe ich eine Chance alles unter einem Hut zu bekommen?

Vielen Dank im Voraus und liebe Grüße

Nicole

Content-Key: 203665

Url: https://administrator.de/contentid/203665

Printed on: June 20, 2024 at 21:06 o'clock

Member: Alchimedes
Alchimedes Mar 20, 2013 at 14:48:00 (UTC)
Goto Top
Hallo ,

benutze bitte codetags.


Danke und Gruss
Member: bankaifan
bankaifan Mar 20, 2013 at 14:49:09 (UTC)
Goto Top
Hallo Nicole,

Habs noch ned gebraucht aber kurzes googeln ergab zwei Möglichkeiten:

=CONCATENATE('BLATT1'!A1,", ",'BLATT1'!A2)

und

='BLATT1'!A2&" "&'BLATT1'!A2

Grüße
Member: Nicole-1305
Nicole-1305 Mar 20, 2013 at 15:03:34 (UTC)
Goto Top
klasse wie schnell ihr eine Antwort habt!
Leider habe ich beide nicht verstanden - bin kein Fachmann

wie genau sieht eine solche Verknüpfung zwischen den Formeln aus?

LG!!
Member: bankaifan
bankaifan Mar 20, 2013 updated at 15:14:59 (UTC)
Goto Top
Alchimedes meinte du sollst vor deine Beiträge:

``
 und danach 
schreiben


EDIT: Getested... liefert vermutlich nicht dein gewünschtes ergebnis
Member: LianenSchwinger
LianenSchwinger Mar 20, 2013 at 15:11:09 (UTC)
Goto Top
Hallo Nicole,

vielleicht beschreibst Du kurz Dein Problem, also was steht in M80 und L80 und was erwartest Du als Ergebnis.
Was soll die Formel ausrechnen?

G Jörg
Member: Alchimedes
Alchimedes Mar 20, 2013 at 15:12:55 (UTC)
Goto Top
Hallo,

hier findest Du nuetzliches

Formatting instructions in the posts


Viel Erfolg.

Gruss
Member: bankaifan
bankaifan Mar 20, 2013 at 15:26:38 (UTC)
Goto Top
Probier mal

=WENN(M80<>0;GANZZAHL((M80-DATUM(JAHR(M80-REST(M80-2;7)+3);1;REST(M80-2;7)-9))/7);GANZZAHL((L80-DATUM(JAHR(L80-REST(L80-2;7)+3);1;REST(L80-2;7)-9))/7))&WENN(L80=0;GANZZAHL((L8-DATUM(JAHR(L8-REST(L8-2;7)+3);1;REST(L8-2;7)-9))/7))+3
Member: Nicole-1305
Nicole-1305 Mar 20, 2013 at 17:56:32 (UTC)
Goto Top
Hab ich versucht - kommt leider nur wieder #ZAHL!

Was ich möchte ist, dass in meiner Liquidationsliste automatisch der zu zahlende Betrag für eine bestimmte Kalenderwoche anzeigt.
Dazu fragt die Formel erst:
1.
=WENN(M79<>0;
-> gibt es ein Zahlungsdatum mit Skonto
2.
GANZZAHL((M79-DATUM(JAHR(M79-REST(M79-2;7)+3);1;REST(M79-2;7)-9))/7);
-> wenn ja dann rechnet er mir die KW von dem Datum aus
3.
GANZZAHL((L79-DATUM(JAHR(L79-REST(L79-2;7)+3);1;REST(L79-2;7)-9))/7))
-> sonst rechnet er mir die Kalenderwoche von dem letztmöglichem Zahlungsdatum aus

soweit so gut - funktioniert der erste Teil ja auch
Das Anhängsel:
ODER(L80=0;GANZZAHL((L8-DATUM(JAHR(L8-REST(L8-2;7)+3);1;REST(L8-2;7)-9))/7))+3
-> ist für die Berechnung einer Kalenderwoche die immer 3 Wochen nach der aktuellen KW liegt
also im Feld L8 ist das aktuelle Datum

Der Teil ließe sich auch abkürzen in dem ich die aktuelle KW schon fertig stehen habe und diese +3 nehme
also: *ODER(L80=0;L7+3;0) anhänge - funktioniert aber genauso wenig :o(

@Alchimedes: tut mir Leid - ich weiß nicht was du meinst oder was ich falsch mache.
Ich habe kurz in deinen Link geschaut - habe aber gerade nicht die Zeit mich dort schlau zu machen.
Ich muss zwar nicht gerade die Welt retten aber meine Firma mit 25 Mitarbeitern - dazu ist die Liste so wichtig - bitte nicht böse sein wenn ich gerade vielleicht gegen eine Norm verstoße
Member: LianenSchwinger
LianenSchwinger Mar 20, 2013, updated at Mar 21, 2013 at 06:06:44 (UTC)
Goto Top
Hallo Nicole,

nicht verzweifeln. face-smile

Du weißt schon, dass es in Excel eine Funktion zur Berechnung der Kalenderwoche gibt?

Wenn ich Dich richtig verstehe steht in der Spalte M das Zahlungsdatum mit Skonto und in der Spalte L das letzt mögliche Zahlungsdatum jeweils als Datum. Weiterhin steht im Feld L8 das aktuelle Datum (was wir aber nicht brauchen).

In Deinem Feld wo die Formel steht möchtest Du also sofern in M ein Datum steht diese Kalenderwoche haben, ist M leer so soll die Kalenderwoche von L genommen werden, ist diese ebenfalls leer so nimm die aktuelle Kalenderwoche + 3.

Das müsste dann so gehen.

=WENN(ISTLEER(M79);WENN(ISTLEER(L79);KALENDERWOCHE(HEUTE())+3;KALENDERWOCHE(L79));KALENDERWOCHE(M79))

G Jörg
Member: Alchimedes
Alchimedes Mar 20, 2013 at 21:24:45 (UTC)
Goto Top
Hallo ,

wenn Du Dein Excelproblem geloest hast , hast Du ja vielleicht Zeit mal in die FAQ zu schauen.
Bin hier auch nicht der Richtlinienpapa... face-smile

Gruss
Member: LianenSchwinger
LianenSchwinger Mar 20, 2013, updated at Mar 21, 2013 at 06:07:18 (UTC)
Goto Top
Hallo Nicole,

sehe gerade erst, dass DU Excel 2003 einsetzt. Da gibt es die Funktion Kalenderwoche standardmäßig wohl nicht. Daher auch Dein Konstrukt. ;)

Bei Microsoft gibt aber eine Anleitung um die Funktion KALENDERWOCHE frei zu schalten.

Wenn diese Funktion nicht verfügbar ist und der Fehlerwert #NAME? zurückgegeben wird, installieren und laden Sie das Add-In Analyse-Funktionen.

Wie wird's gemacht?

1.Klicken Sie im Menü Extras auf Add-Ins.
2.Aktivieren Sie in der Liste Verfügbare Add-Ins das Kontrollkästchen Analyse-Funktionen, und klicken Sie dann auf OK.
3.Folgen Sie, falls notwendig, den Anweisungen im Setup-Programm.


Wenn Du aber bei Deiner Berechnung bleiben möchtest dann geht folgendes:

=WENN(ISTLEER(M79);WENN(ISTLEER(L79);GANZZAHL(($L$8-DATUM(JAHR($L$8-REST($L$8-2;7)+3);1;REST($L$8-2;7)-9))/7)+3;GANZZAHL((L79-DATUM(JAHR(L79-REST(L79-2;7)+3);1;REST(L79-2;7)-9))/7));GANZZAHL((M79-DATUM(JAHR(M79-REST(M79-2;7)+3);1;REST(M79-2;7)-9))/7))

G Jörg
Member: Nicole-1305
Nicole-1305 Mar 21, 2013 at 08:33:35 (UTC)
Goto Top
Du bist mein Held!! Dankeschön! So funktioniert das!!

@Alchimedes: mach ich :o) ist versprochen!

Viele liebe Grüße!!
Member: LianenSchwinger
LianenSchwinger Mar 21, 2013 updated at 08:44:21 (UTC)
Goto Top
Hallo Nicole,

dann verate mir bitte was Du jetzt gemacht hast.

a) KALENDERWOCHE freigeschaltet und benutzt (wäre ja die kürzere und übersichtlichere Variante)
b) Deine eigene Berechnung der Kalenderwoche benutzt

G Jörg
Member: Nicole-1305
Nicole-1305 Mar 21, 2013 at 15:35:43 (UTC)
Goto Top
huhu jörg,
b)
zumindest fürs erste weil es (außer der richtigen Formel) nix weiter bedurfte :o)

lg!!!