Geräte hinter PC nicht zu erreichen

ntb857
Goto Top
Moin

Bin am verzweifeln.... ;)

Gerät 1 \
Gerät 2 - Switch über LAN --> PC --> über WLAN zu Access Point --> Netzwerk (ipfire etc.)
Gerät 3 /

IPs:
Gerät 1 192.168.1.141 (Thermodesinfektor)
Gerät 2 192.168.1.142 (Barcodedrucker)
Gerät 3 192.168.1.40 (Dampfsterilisator)

Lan Anschluss PC:
IP: 192.168.1.140
Gateway: 192.168.1.18
DNS: 192.168.1.1


WLAN PC :
IP: 192.168.1.18
Gateway: 192.168.1.1
DNS: 192.168.1.1

Netzwerk: 192.168.1.0/24

Ping zu PC funktioniert.
PC kann alle Geräte im Netzwerk erreichen.
Netzwerk kann PC erreichen.

Problem: Geräte 1-3 tauchen nicht im Netzwerk beim DHCP-Server (Ipfire) auf und ein Ping ist auch nicht möglich.

Das glaube ich noch zu verstehen...
Die Pakete werden nicht vom PC (192.168.1.18) an den LAN Adapter (192.168.1.140) weitergeleitet.

Aber wie stelle ich es an, dass es funktioniert?

Danke im Vorraus!

Content-Key: 2841883228

Url: https://administrator.de/contentid/2841883228

Ausgedruckt am: 02.07.2022 um 16:07 Uhr

Mitglied: altmetaller
altmetaller 19.05.2022 um 17:32:15 Uhr
Goto Top
Hallo,

…indem Du das Routing auf dem PC aktivierst?!?

Abgesehen davon: Der steht mit zwei Beinen im gleichen IP-Adressbereich; aber offenbar in unterschiedlichen Netzen. Wie soll das funktionieren?!? Und vor allem - warum ist der überhaupt via W-LAN verbunden?

Gruß,
Jörg
Mitglied: ntb857
ntb857 19.05.2022 aktualisiert um 17:39:46 Uhr
Goto Top
Routing ist aktiviert.
Wieso unterschiedliche Netze?
Das Netzwerk besteht doch nur aus 192.168.1.0/24
Oder meinst du einmal LAN und einmal WLAN?

Warum Wlan?
Weil LAN (ertmal) nicht ohne Weiteres möglich ist und Powerlan durch die tolle Phasenschaltung eine Kathastrophe ist. ;)

Der PC soll doch "nur" die Anfragen, die auf 192.168.1.18 ankommen, auf 192.168.1.140 weiterleiten und umgekehrt.
Mitglied: PC-Helfer
PC-Helfer 19.05.2022 um 17:58:08 Uhr
Goto Top
Hallo,

du könntest in den Netzwerkverbindungen eine Netzwerkbrücke einrichten, „Verbindung überbrücken“ heißt die Funktion.

SG
Mitglied: ntb857
ntb857 19.05.2022 um 18:05:11 Uhr
Goto Top
Hab ich auch gedacht.
Aber dann verliere ich den Zugriff per WLAN auf den Access Point, bzw. die Verbindung wird dermaßen langsam, weil sich die Pakete vermutlich irgendwo zwischen Wlan und LAN Adapter verirren. Änderung der Metrik bringt auch nix.
Mitglied: erikro
erikro 19.05.2022 um 18:27:53 Uhr
Goto Top
Moin,

wie Kollege @altmetaller schon sagte: Du musst routen. Sonst wird das nichts. Der Aufbau muss in etwa so aussehen:


Auf dem PC musst Du dann das Routing von Netz 192.168.1.0/24 in das Netz 192.168.10.0/24 und umgekehrt einrichten. Dann bekommen noch die Geräte die 192.168.10.1 als Gateway eingetragen und schon läuft das.

Wie? Dazu wäre es hilfreich zu wissen, um welches Betriebssystem es sich handelt und um welche Geräte.

hth

Erik
Mitglied: aqui
aqui 19.05.2022 aktualisiert um 18:35:05 Uhr
Goto Top
Das kann so nicht funktionieren!
Du hast sicher im Eifer des Gefechts sicher übersehen das du 2mal das gleiche IP Netz am PC verwendest und fälschlicherweise 2 Default Gateways konfiguriert hast. Ein fundamentaler Verstoß gegen grundlegende IP Routing Regeln, denn damit ist eine eindeutige Wegefindung unmöglich. Klar also das du mati scheitern musst.

Luft holen, Tasse Kaffee trinken und dabei einmal in aller Ruhe das hiesige Routing Tutorial durchlesen und verstehen.
Das erklärt dir dein Szenario einfach, verständlich und von Grund auf und weist auf alle Fallen hin auf die du achten musst.
Mitglied: ntb857
ntb857 19.05.2022 aktualisiert um 19:00:52 Uhr
Goto Top
Danke für die Antworten!
Dann hole ich mir mal einen Kaffee und lese noch einmal nach. ;)
Melde mich morgen wieder, wenn ich alles in der Praxis ausprobiert habe.

Also nochmal für mich:

Die Geräte 1-3 bekommen eine statische IP im Subnetz 192.168.10.0/24.
Als Gateway die 192.168.10.1 (die IP des LAN Adapters am PC)

Routen im PC anlegen:

route -p add 192.168.1.18 MASK 255.255.255.0 192.168.10.1

route -p add 192.168.10.1 MASK 255.255.255.0 192.168.1.18

Aber dann hab ich ja wieder zwei Gateways...grübel...denn ich muss ja Richtung WLAN kommen.

Zum weiteren Verständnis:
Der PC ist eine Windows Kiste.
Die Geräte 1-3 speichern ihre Daten auf den PC über LAN.
Gerät 1 Miele Thermodesinfektor
Gerät 2 Melag Sterilisator
Gerät 3 Barcodedrucker
Der PC hängt via WLAN im übrigen Netzwerk.

Hab ich schon wieder einen Denkfehler?
Mitglied: aqui
aqui 19.05.2022 aktualisiert um 19:06:09 Uhr
Goto Top
Die Geräte 1-3 bekommen eine statische IP im Subnetz
Das kann man machen, ist aber nicht zwingend wenn du dir einen kleinen DHCP Server auf dem PC Installierst der das 10er Subnetz bedient.
https://www.dhcpserver.de/cms/
Das macht das Leben ggf. etwas einfacher. face-wink
Routen im PC anlegen:
Routen am PC sind Blödsinn!
Die IP Netze sind da ja direkt angeschlossen und folglich kennt der PC diese Netze und benötigt deshalb keine statischen Routen!!
Bitte lies das Tutorial!! Da ist alles zu dem Thema haarklein erklärt, inklusive bunter Bilder zum besseren Verständnis.
...grübel...denn ich muss ja Richtung WLAN kommen.
Wie bereits mehrfach gesagt: Tutorial lesen, dann wird das alles schnell klar.
Übrigens:
Mit einem kleinen 23 Euro WLAN Router könntest du dieses sehr einfache Szenario auch völlig unabhängig vom PC lösen:
https://www.varia-store.com/de/produkt/97209-rb941-2nd-routerboard-hap-l ...
Es gibt, wie immer, viele Wege nach Rom.
Mitglied: ntb857
ntb857 19.05.2022 um 19:08:47 Uhr
Goto Top
Bilder sind immer gut. ;)

Danke nochmal! Ich gelobe zu lesen und komme dann bestimmt trotzdem nochmal mit Fragen an... face-smile
Mitglied: aqui
aqui 19.05.2022, aktualisiert am 20.05.2022 um 09:53:46 Uhr
Goto Top
Nach dem Lesen (und verstehen) immer gerne! 😉
Bilder sind immer gut.
Wenn dir Bilder helfen, dann sähe so deine fertige Lösung aus:

roupc
(Das IPv4 Forwarding musst du nur dann aktivieren wenn die Endgeräte im LAN Netz auch ins Internet müssen (Software Update, Wartung etc.). Wenn das nicht erforderlich ist kannst du das weglassen.)
Mitglied: ntb857
ntb857 20.05.2022 um 14:30:36 Uhr
Goto Top
Moin

Soooo....

Die versprochene Rückmeldung:

Hab den Geräten und dem LAN Anschluss am PC, eine IP im 10er Subnetz gegeben (192.168.10.0/24)
Die IP am WLAN Anschluss bleibt bei 192.168.1.18.

Keine Routen oder Ähnliches am PC.

Uuuuuund...

Es funktioniert. Ohne Netzwerkbrücke etc.

Grübel...

Denn....

Vorher hatten die Geräte ne IP im 140er Subnetz und es hat nicht funktioniert.

Naja, egal.

Nebenbei: Ping zu den Geräten geht immer noch nicht. ;) Tracert und der eigentlich gebrauchte Zugriff aus dem restlichen Netz funktioniert aber.
Muss ich aber jetzt auch nicht verstehen. Übersteigt vermutlich eh meinen Horizont.

Nochmal tausend Dank für die Antworten, den vorgeschlagenen Lesestoff und die Bilder!
Mitglied: aqui
aqui 20.05.2022 aktualisiert um 15:03:50 Uhr
Goto Top
Nebenbei: Ping zu den Geräten geht immer noch nicht.
Ist normal und solltest du als Netzwerk Profi eigentlich wissen, denn ICMP (Ping) ist in der Windows Firewall per Default deaktiviert! Übersteigert also nichtmal den Horizont eines Laien. face-wink
https://www.windowspro.de/wolfgang-sommergut/ping-windows-10-erlauben-gu ...

Nochmal tausend Dank für die Antworten
Bitte deinen Thread dann auch als erledigt markieren!
https://administrator.de/faq/32
Mitglied: ntb857
ntb857 20.05.2022 um 15:10:07 Uhr
Goto Top
Windows Firewall läuft "nur zum Teil".
Eine Endpoint Security übernimmt den Part und ICMP hab ich dort zugelassen. Egal. Läuft.

Grüße
Mitglied: altmetaller
altmetaller 21.05.2022 um 00:56:35 Uhr
Goto Top
Hallo,

Zitat von @aqui:
Ist normal und solltest du als Netzwerk Profi eigentlich wissen, denn ICMP (Ping) ist in der Windows Firewall per Default deaktiviert!

Nö. Das ist eher ein Indiz, dass das Netzwerk der falschen Kategorie zugeordnet ist.

In dem Fall ist im NetConnectionProfile Public statt Private eingetragen. Windows macht das z.B. in Netzen, in denen es ursprünglich kein Gateway hat.

Oder, um es mit deinem Worten zu sagen: Das lernt man in der ersten Stunde Informatikunterricht… face-smile

Gruß,
Jörg
Mitglied: aqui
aqui 21.05.2022 um 12:32:45 Uhr
Goto Top
So oder so ist es dann, wie immer, die lokale Windows Firewall die der TO nicht richtig customized hat! face-wink
Case closed...
Mitglied: altmetaller
altmetaller 21.05.2022 um 12:56:38 Uhr
Goto Top
Hallo,

ich wollte es nur noch mal erwähnt haben, weil Viele auf Irrsinnsideen kommen, wenn sie so etwas lesen.

Z.B. Firewall abschalten, ICMP für öffentliche Netze freigeben usw. - alles schon „gesehen"!

Gruß,
Jörg
Mitglied: Lochkartenstanzer
Lochkartenstanzer 21.05.2022 um 12:59:56 Uhr
Goto Top
Zitat von @altmetaller:

... ICMP für öffentliche Netze freigeben ...

Das sehe ich als unproblematisch an, solange man kein redirect akzeptiert.

lks
Mitglied: ntb857
ntb857 21.05.2022 um 15:09:14 Uhr
Goto Top
Da zumindest bei mir noch ne "richtige Firewall" davor hängt, darf ich dann ja durchatmen. ;)
Mitglied: altmetaller
altmetaller 21.05.2022 um 17:30:02 Uhr
Goto Top
Hallo,

Zitat von @Lochkartenstanzer:

Das sehe ich als unproblematisch an, solange man kein redirect akzeptiert.

Jein, bei Fremdrechnern sehe ich da schon ein Problem.

So eine Konfiguration ist ja letztendlich ein Indiz dafür, dass der Rechner mal von einer Person administriert wurde, die nicht einmal rudimentäre Grundkenntnisse hat.

Der Aufwand, den Rechner in die richtige Zone zu setzen ist ja letztendlich deutlich geringer, als an den eigentlichen Profilen zu spielen. Wer weiß, was da noch alles gefrickelt wurde face-wink

Gruß,
Jörg