GPO - Alle freigegebenen Druckerverbindungen auf TS löschen

Mitglied: Balgor

Balgor (Level 1) - Jetzt verbinden

27.01.2021 um 16:35 Uhr, 541 Aufrufe, 2 Kommentare

Hallo,

ich habe seit kurzem das Problem, dass eine von mir gebaute GPO welche sämtliche freigegebenen Druckerverbindungen auf dem TS löschen soll, nicht mehr funktioniert.
So langsam sehe ich nicht weiter und deswegen hoffe ich hier auf einen anstubser in die richtige Richtung.

Ich habe ~40 Richtlinien mit denen ich freigegebene Drucker verbinden lasse.
Es gibt ~40 Standorte mit ortsspeziefischen Anmeldungen am TS, über diese Anmeldungen lasse ich die Drucker per Sicherheitsfilterung verknüpfen bzw. "aktualisieren".
Ich habe mich gegen das "ersetzen" entschieden aus Gründen die ich weiter unten versuche zu erklären.
Pro Standort habe ich zwischen 2 und 4 Drucker die GPO läuft noch annehmbar zügig ab.

Bsp.:

Standort A -> Benutzer A -> Drucker A, B und C
Standort B -> Benutzer B -> Drucker D,E und F
etc...

Da ich in der Anfangsphase viel umher tauschen musste hatte ich nach einer weile viele Konstellationen bei denen sehr viel Wildwuchs entstanden ist. Und auch für die Zukunft wollte ich mir das Aufräumen leichter machen.

Wildwuchs Bsp.:

Standort A -> Benutzer A -> Drucker A, B, C, F, G, H
Standort B -> Benutzer B -> Drucker D, E, F, G, H, I
etc...

Deswegen habe ich mir eine Richtlinie gebaut welche ganz pauschal erst einmal alle freigegebenen Druckerverbindungen löschen soll und diese so priorisiert, dass sie auch als erstes ausgeführt wird und erst im Anschluss die Drucker wieder neu verbunden werden.

Somit wurden also bei der Anmeldung am TS erst mal alle Drucker gelöscht und anschließend wieder verbunden. Dies hat eine ganze Zeit sehr gut funktioniert. Vor ein paar Tagen ist mir aber aufgefallen, dass ein Drucker den ich kurz zum testen mir selbst ebenfalls per Sicherheitsfilterung verbunden hatte nicht wieder weg ging, obwohl ich mich aus nach den Tests wieder aus der Sicherheitsfilterung rausgenommen habe.

Wenn ich mit "gpresult /r" schaue wird mir die Richtlinie zum Löschen auch unter "Angewendete Gruppenrichtlinienobjekte" angezeigt, aber es wird nichts mehr gelöscht.
Die GPO welche die Drucker aktualisieren soll macht weiterhin ihre Arbeit. Das kann ich zum einen sehen, wenn nach dem einloggen schnell in die Geräte schaue, dort sehe ich wie z.B. Treiber aktualisiert werden oder ähnliches. Oder wenn ich alle Drucker per Hand lösche bauen sie sich bei der nächsten Anmeldung wieder neu.
Ich habe auch geguckt was passiert, wenn ich quasi nur noch die GPO habe zum löschen der Drucker und keine mehr aktualisieren. Es passiert einfach gar nichts.

Das Problem betrifft übrigens alle Benutzer auf dem TS.

Mir ist zumindest nicht bewusst irgendwas grundlegendes geändert zu haben deswegen meine Frage kann irgendwo rausbekommen, was genau jetzt hakt? Warum sagt er "wird angewendet" macht es aber doch nicht?

Hoffe hier Hilfe zu bekommen, ich verzweifle langsam.

Achja betrieben wird alles auf diversen Windows Server 2016 - Hyper-V. :) face-smile

Wenn weitere Infos benötigt werden sollten, immer raus damit.

Mfg
Mitglied: Doskias
27.01.2021 um 18:41 Uhr
N'abend

Also offenbar scheint ja irgendwas bei der löschen-GPO nichjt zu stimmen, da du ja selbst schreibt, dass einfach gar nichts passiert. Ohne die Konfiguration der GPO zu kennen, artet das ganze in Glaskugelraterei aus. Wieso postest du nicht einfach mal Screenshots deiner GPO, die offenbar nicht funktioniert (inkl. Sicherheitsfilter und Delegation).

Ich persönlich würde die GPO allerdings umbauen. 1 GPO für Drucker, geltend für alle Benutzer und dann in der GPO einstellen, dass bei den gemeinsamen Optionen (a) den Haken setzen, dass Elemente entfernt werden sollen, wenn Sie nicht mehr genutzt werden und (b) die Zuweisung über die Zielgruppenadressierung laufen lassen. Dann hast du nur 1 GPO die für alle user einheitlich die Drucker steuert und musst nicht in den Sicherheitseinstellungen und Delegierungen herumfummeln :) face-smile

Gruß
Doskias
Bitte warten ..
Mitglied: Balgor
30.01.2021 um 13:20 Uhr
Hallo,

danke für die Rückmeldung.

Als Lösung des Problems hatte sich ein Neustart des Terminalservers herausgestellt. Diesen musste ich aus anderen Gründen in der Nacht machen und direkt danach ging es wieder.
Ich hatte nur soviel um die Ohren dass ich noch nicht zum Feedback geben kam. Mea Culpa ...

Dennoch würde ich die Gelegenheit gern ergreifen deinen Vorschlag zu besprechen.
Anfangs hatte ich vor die Verteilung über die Zielgruppenadressierung laufen zu lassen. Ich fand das nur unheimlich unübersichtlich und dabei hatte ich gerade mal 4-5 Standorte eingegeben. Eine Elends lange Liste mit Druckern und ich müsste überall in die Untermenüs gucken wenn ich sehen will wie diese Verteilt werden.
Deswegen bin ich später auf die Variante gewechselt die es jetzt gibt. Dort habe ich jetzt zwar mehrere GPO's, diese sind aber thematisch und gut benannt dass ich auf einen Blick sofort sehe um welchen Standort es sich handelt, Wenn ich ihn anklicke sehe ich ebenfalls auf einen Blick wer diese Drucker bekommt und ich kann in wenigen Sekunden Benutzer hinzufügen bzw. rausnehmen.
Um zu sehen um welche Drucker es sich denn genau handelt muss ich sie bearbeiten, das ist der einzige "Nachteil" der mir hier auffällt. Aber den Weg müsste ich bei deiner vorgeschlagenen Variante ja auch gehen. So ein richtiger Nachteil ist es auch gar nicht.

Was ich mich bei den Optionen gefragt habe wie genau sich der Haken bei "Element entfernen wenn es nicht mehr genutzt wird" auswirkt. Ab wann ist ein Drucker "nicht mehr genutzt"?

Mfg Balgor
Bitte warten ..
Heiß diskutierte Inhalte
LAN, WAN, Wireless
Switch läuft, ist aber nicht erreichbar
gelöst AndiPeeVor 1 TagFrageLAN, WAN, Wireless19 Kommentare

Hallo zusammen, mein Problemfall einleitend kurz umrissen: Privates Netzwerk Es funktioniert grundsätzlich, allerdings habe ich immer mal ein paar Ausfälle im WLAN-Netzwerk und bin ...

MikroTik RouterOS
Simples VLAN bringt mich zur Verzweiflung
gelöst Daniel26Vor 14 StundenFrageMikroTik RouterOS27 Kommentare

Moin, ich bin sehr neu im Mikrotik-Bereich, aber schon dabei, aufzuegeben. Wir verbauen in unserer Hardware Switche von Mikrotik. Bisher waren da Netgear-Teile drin, ...

Windows Netzwerk
Sporadisch kein Netz auf mehreren Win10-Maschinen
SolarflareVor 1 TagFrageWindows Netzwerk6 Kommentare

Hallo, ich habe seit Monaten einen eigenartigen Effekt in unserem Windows-Netz. Windows-Domäne mit ca. 100 Maschinen, alle Clients aktuelles Windows 10. Die Maschinen hängen ...

VB for Applications
Auf SQL Datenbank schreiben welche Sich im Firmennetzwerk befindet
RSST-SORVor 1 TagFrageVB for Applications12 Kommentare

Hallo Ich habe ein funktionierendes VBA Makro im EXCEL welches mit: conn.Open "driver={SQL Server};" & _ "server=RSST-OFFICEIII\RSSTSQLSERVER;database=RSSTZeiterfassung;" Daten in die Tabelle schreibt Nun würde ...

Microsoft
STRG + ALT + ENTF
TezzlaVor 8 StundenAllgemeinMicrosoft9 Kommentare

Mahlzeit zusammen, wir haben gerade im Kollegenkreis über Sinn und Unsinn der Sperrbildschirmentriegelung STRG + ALT + ENTF unter Win10 diskutiert. Mich würde hierzu ...

E-Mail
Alternative zu horde webmail
fisch56Vor 1 TagFrageE-Mail6 Kommentare

Hallo, ich habe das horde webmail auf meinem Server, macht allerdings Probleme. Suche daher eine Alternative. Das Postfach hat viele Unterordner, die z.B. bei ...

Windows 10
SMB Performance VPN
Guhl22Vor 1 TagFrageWindows 103 Kommentare

Hallo zusammen, wir stellen bei uns in der Firma ein sehr merkwürdiges Phänomen fest. Zugriffe über VPN auf gemappte Netzlaufwerke (über vbs Logon Skript ...

Outlook & Mail
Outlook Ansicht
gelöst Kisters.SolutionsVor 1 TagFrageOutlook & Mail9 Kommentare

Hallo zusammen, seit kurzem sieht der Posteingang im Outlook 2019 eines Kollegen plötzlich anders aus. Standard ist das die ungelesenen Mails mit einem blauen ...