IPhone und Fritzbox 7170 WLan Problem

Michael-24
Hallo,

ich habe eine Frage zum Wlan Roaming.

Ich habe eine Fritzbox 7390 im Büro. Diese dient als DSL-Router.

Eine weitere Fritzbox 7390 steht im Wohnzimmer. Beide sind mittels WDS miteinander verbunden.

Die Fritzbox im Büro ist also als Basistation und die Fritzbox im Wohnzimmer ist als Repeater konfiguriert.

Um WDS zu verwenden muss auf beiden Fritzboxen der gleiche Wlan-Kanal eingestellt sein. Desweiteren habe ich auch beiden Fritzboxen die gleiche SSID und den gleichen Netzwerkschlüssel eingestellt. Somit müsste auch Roaming funktionieren, d. h. ein Client verbindet sich automatisch mit der besseren Wlan-Station. Soweit funktioniert die Konfiguration auch schon seit längerem.

Seit einiger Zeit hab ich nun ein iPhone und dieses bereits über WLAN an die Fritzbox gekoppelt.

Aber das Roaming funktioniert irgendwie nicht richtig. Bin ich mit dem iPhone im Wohnzimmer verbindet sich das iPhone logischerweise mit der Fritzbox 7170 im Wohnzimmer. Gehe ich nun ins Schlafzimmer, verbindet sich das iPhone mit der Fritzbox 7390. Das ist auch ok, da diese Box räumlich gesehen, die nähere ist. Aber was nun komisch ist, das das iPhone sich auf der Fritzbox 7170 nicht abmeldet. Es ist also auf beiden Wlan-Station angemeldet.

Ich nun einige Tage rumgespielt und habe folgendes festgestellt.

Wenn es der Fall ist, das das iPhone auf beiden Fritzboxen angemeldet ist, habe ich das Wifi-Modul im iPhone abgeschaltet. Nach ca. 2 Sekunden steht in der Ereignisanzeige der Fritzbox 7390 (Büro). Gerät abgemeldet. In der Ereignisanzeige der Fritzbox 7170 im Wohnzimmer steht dieser Eintrag erst nach 10 Minuten drin. Während der 10 Minuten sieht man das iPhone in der Liste mit den verbundenen Clients (in der Fritzbox unter Menü Funknetz). Schaltet man nach den 10 Minuten das Wifi-Modul im iPhone wieder ein und man befindet sich im Schlafzimmer verbindet sich das iPhone nur mit der Fritzbox 7390, so wie es sein soll! Geht man nun ins Wohnzimmer verbindet sich das iPhone wiederum mit der Fritzbox 7170 und wird von der Fritzbox 7390 abgemeldet. Und hier beginnt das Problem wieder von vorne.

Mein Sat-Receiver ist ebenfalls über eine integrierte WLAN-Karte mit der Fritzbox 7170 im Wohnzimmer verbunden. Auf dem iPhone habe ich eine App, die es erlaubt sich einen Stream eines TV-Programms des Sat-Receivers anzusehen. Das funktioniert aber nur, wenn das iPhone nicht an beiden Fritzboxen angemeldet ist. Ich hab mir eine App (PING) installiert. Ein Ping zum Sat-Receiver ist in dieser Konstelation nicht möglich. Nur wenn das iPhone an einer Basisstation angemeldet ist, funktioniert der Ping und natürlich auch das APP Live Stream.

Was ist an meiner Konfiguration falsch bzw. warum dauert es so lange, das iPhone abzumelden? Ist die Fritzbox 7170 defekt?

Gruß
Michael

Content-Key: 168993

Url: https://administrator.de/contentid/168993

Ausgedruckt am: 21.01.2022 um 09:01 Uhr

Mitglied: aqui
aqui 02.07.2011, aktualisiert am 18.10.2012 um 18:47:26 Uhr
Goto Top
Das ist so wie es aussieht ein Bug in der Repeating Funktion der FritzBox. Das sieht man schon am höheren Timeout ! Hier die Frage ob du auf beiden FBs die aktuellste Firmware geflasht hast ??
Generell ist es keine gute Idee im Medien und Streaming Umfeld auf WDS Repeating zu setzen. Ein Repeater ist sowas wie ein dummer Papagei und sendet zeitversetzt quasi als Relais die Daten an den Ursprungs AP.
Das halbiert schon einmal per se die WLAN Bandbreite durch den dadurch zwangsläufigen Half-Duplex Betrieb. Wenn du noch Störungen und Überlappungen durch Nachbar WLANs hast (von den du mindestens 5 Funkkanäle entfernt sein musst !! Scan macht z.B. der freie inSSIDer ) und mit sog. "Hidden Station" Problemen beim Repeater Betrieb kämpfen musst ist die WLAN Performance meist sehr mickrig.
Besser ist es also immer den 2ten AP (oder ein zum dummen AP kastrierten WLAN Router) nie als WDS Repeater laufen zu lassen sondern immer als eigenständigen AP.
Mit flachem_Ethernet_Kabel kann man auch problemlos Kabel hinter der Fussleiste verlegen.
Falls das auch nicht gehen sollte ist immer noch einen Power LAN (D-LAN) Kopplung der APs erheblich besser als WDS Repeating:
https://www.administrator.de/wissen/kopplung-von-2-routern-am-dsl-port-4 ...
Bedenke auch das du mit billigen Consumer APs / WLAN Routern nie ein WLAN basiertes Roaming machst, sondern immer ein Client basiertes Roaming. Das basiert meist ausschliesslich auf dem RSSI Wert den der AP an den Client zurückliefert, also nur der Feldstärke und dem Polling Wert wie oft der Client diesne abfragt. Meist ist das Treiber immanent so das du keinerlei Einfluss auf dieses Verhalten hast.
Besser also du baust dein Szenario um in ein distribuiertes WLAN statt Repeating.
Mitglied: Michael-24
Michael-24 05.07.2011 um 00:18:02 Uhr
Goto Top
Ich habe die zweite Fritzbox im Wohnzimmer nun über dLan verbunden. Das Netzwerkkabel habe ich dann direkt an LAN1 Fritzbox 7170 im Wohnzimmer angeschlossen. WDS bei beiden Fritzboxen ausgeschaltet. SSID und Netzwerkschlüssel bei beiden Fritzboxen gleich eingestellt. Funkkanal habe ich automatisch vergeben lassen. Somit sind die Kanäle auf jeden Fall nicht gleich. Somit müsste doch jetzt das Roaming einwandfrei funktionieren. Tuts aber nicht.

Eigentlich das selbe Problem. Befinde ich mich mit meinem Iphone im Wohnzimmer verbindet sich das Telefon mit der Fritzbox im Wohnzimmer. Wandere ich nun ins Büro, verbindet sich das iPhone mit der Fritzbox im Büro. In der Weboberfläche der Fritzbox Wohnzimmer sieht man aber immer das iPhone als verbunden. Auch der Eintrag in der Ereignisdiagnose "Gerät abgemeldet" fehlt.

Irgendwas stimmt doch mit der Box nicht, oder? Das kann ja jetzt garnicht sein, da ja unterschiedliche Kanäle verwendet werden. Auch wenn die Funkkanäle manuell einstelle, z. B. Funkkanal auf 1 Fritzbox Büro, und Funkkanal auf 6 Fritzbox Wohnzimmer habe ich das gleiche Problem.

Schalte ich wiederum das Wifi-Modul in der Fritzbox ab, erscheint nach ca. 2 Sekunden in der Fritzbox 7390 Büro, Gerät abgemeldet. In der Fritzbox 7170 im Wohnzimmer kommt die Meldung tatsächlich erst 10 Minuten später. Während dieser Zeit, sieht man das iPhone in der Übersicht der Fritzbox 7170 als verbunden.

In den letzten Tagen ist ja eine neue Firmware für die Fritzbox 7170 erschienen. Diese habe ich bereits aufgespielt, brachte auch keine Besserung. Kann das sein, das das integrierte WLan Modul defekt ist. Leider habe ich kein weiteres WLan Gerät, mit dem ich diese Konstellation nachprüfen kann, obs nicht am iPhone liegt, aber ich denke eher an die Fritzbox 7170.

Was kann ich tun? Kennt das Problem jemand von euch?

Gruß
Michael
Mitglied: aqui
aqui 05.07.2011 um 10:13:24 Uhr
Goto Top
Die Funkkanäle solltest du in KEINEM Fall automatisch vergeben lassen, denn das funktioniert bei keinem AP richtig...nichtmal bei den hochpreisigen Premium APs.
Ausserdem ist es auch Blödsinn, denn der AP wählt den Funkkanal dann nur mit der Situation an seinem AP Standort, nicht aber am Standort der Clients wo es eigentlich nur Sinn macht. Vergiss das also und mache das unbedingt immer manuell !!
Du solltest dafür immer einen inSSIDer laufen lassen:
http://www.metageek.net/products/inssider
und zwar dort wo sich auch deinen Clients bewegen.
Hier musst du zwingend darauf achten das dein jeweiliger AP Funkkanal mindestens 5 Kanäle vom anderen AP bzw. AUCH von den benutzen Kanälen ggf. vorhandener Nachbar WLANs im Bereich der Clients entfernt ist !!
Ferner sollte deine SSID einzigartig sein, also niemals die SSID des Herstellers verwenden sondern sowas wie "Bitschleuder" oder "Wurstsemmel" usw. Ohne Sonderzeichen.
Wenn es dann immer noch ein solches Roaming Verhalten gibt kannst du nix machen, denn dann ist das Roaming Client basierend, d.h. wird immer vom Client gesteuert. Bei einem iPhone hast du auf das Roaming Verhalten keinerlei Einfluss dann, da es ein geschlossenes System ist.
Bei vielen Intel Karten kann man im Treiber Setup z.B. "Aggressive Roaming" aktivieren was das Roaming verhalten oft verbessert.
Wirklich sinnvoll und perfekt wird es aber nur mit einem Controller basierten WLAN weil es dann nicht mehr Client bezogen ist !
Heiß diskutierte Beiträge
question
Windows XP: IE 8 zeigt keine Seiten mehr an :-) gelöst altmetallerVor 1 TagFrageWindows XP21 Kommentare

Huhu, ich habe hier tatsächlich noch einen Dell Dimension 9100 (Pentium IV, 3Ghz) stehen, den ich mit einer NVIDIA Quadro FX 540 und 4GB RAM ...

question
Datensicherung nach Geschäftsaufgabefboy33Vor 1 TagFrageBackup8 Kommentare

Guten Tag liebe (ex) Kollegen, nun nach 50 Jahren EDV, habe ich meine Firma abgemeldet und bin in den Ruhestand gegangen. Mein Problem, was mache ...

question
Ethernet über Telefonleitung gelöst Net-ZwerKVor 1 TagFrageLAN, WAN, Wireless8 Kommentare

Moin! Ich suche einen Konverter, mit dem ich auf eine Telefonleitung (2 Draht) ein Netzwerksignal legen kann. Geht darum, dass ich beim einem Kunden einen ...

question
PLEX bricht im HEIMNETZ nach 1 Minute Film abStrahlemann-69Vor 1 TagFrageUbuntu9 Kommentare

Hallo an alle, ich hab mir den Plexserver auf Proxmox installiert und mein NAS eingebunden. Er ließt auch alles ein und funktioniert. Nun laß ich, ...

question
O365 Outlook + Teams sperren gelöst sraL91Vor 20 StundenFrageMicrosoft Office16 Kommentare

Hallo Zusammen, wir haben in unserer Firma Office 365 ausgerollt und ich stehe nun vor folgendem Problem. Unsere Firma sind in 50 Standorte unterteilt und ...

question
MFA mit Microsoft?cseVor 16 StundenFrageWindows Userverwaltung5 Kommentare

Hi Leute, ich hoffe ihr könnt mir ein wenig helfen. Von unserer Gruppe (central IT im Ausland) verlange ich (im Zuge TISAX Audit) auf unseren ...

question
Image auf zweiten Laptop kopierenmario28Vor 1 TagFrageWindows Installation5 Kommentare

Hallo zusammen, ich habe mir für daheim zwei Mal den gleichen Laptop bestellt (Schenker Via 15 Pro M20) und nach Erhalten mit dem ersten begonnen, ...

question
PC - Komplettsicherunggreenhorn1Vor 21 StundenFrageBackup10 Kommentare

Hallo, welche Möglichkeit gibt es an Sicherungen, wo man das gesamte System Win10 sichern kann? Sodass ich mit einer Sicherung einen neuen PC 1 zu ...