Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Kein Zugriff auf Cisco Switch SG300 über OpenVPN

Mitglied: miuliu

miuliu (Level 1) - Jetzt verbinden

07.05.2016 um 08:23 Uhr, 775 Aufrufe, 4 Kommentare

Hey,

ich benutze pfsense als Firewall und OpenVPN Server zum Zugriff auf das Heimnetzwerk.

Folgende Netzwerke und Regeln sind in pfsense hinterlegt:
INTRANET: 10.0.10.0/24
OpenVPN-NET: 10.0.50.0/24
Regeln: Allow OpenVPN-NET zu INTRANET

Der Zugriff über OpenVPN auf das INTRANET funktioniert prinzipiell. Ich kann dort Geräte pingen und mich zum Beispiel auch mit einer Synology NAS verbinden.
Im INTRANET ist ein Cisco Switch SG300 vorhanden (dieser ist im Layer 2-Betrieb). Auf diesen kann ich mich nicht verbinden und ein Ping auf dieses Gerät funktioniert auch nicht.

Ich vermute der Cisco Switch lässt die Verbindung nicht zu, weil die Quell-Adresse nicht im INTRANET liegt. In den Einstellungen und der Dokumentation habe ich dazu nichts gefunden. Kennt jemand den Schalter, den ich hier konfigurieren muss, damit ich Remote auf den Switch zugreifen kann? Oder gibt es hier noch Konfigurationsmöglichkeiten im OpenVPN-Server? Ein Zugriff auf den Switch aus dem INTRANET heraus funktioniert natürlich einwandfrei.

OpenVPN Konfiguration Client:
dev tun
persist-tun
persist-key
cipher AES-256-CBC
auth SHA256
tls-client
client
resolv-retry infinite
remote X.X.X.X 1194 udp
lport 0
verify-x509-name "fw" name
auth-user-pass
pkcs12 fw-udp-1194.p12
tls-auth fw-udp-1194-tls.key 1
ns-cert-type server

Mitglied: aqui
LÖSUNG 07.05.2016, aktualisiert um 08:56 Uhr
Auf diesen kann ich mich nicht verbinden und ein Ping auf dieses Gerät funktioniert auch nicht.
Da hast du dann mit an Sicherheit grenzender Wahrscheinlichkeit vergessen das Default Gateway oder die Default Route auf diesem Switch im Management Interface (VLAN 1, Default) einzustellen !!

ciscosg - Klicke auf das Bild, um es zu vergrößern

Denk dran das das auch auf ein Gateway zeigen muss was die Routen in das VPN Netz kennt ! Üblicherweise ist das ja dann das gleiche auf das auch die Endgeräte zeigen die sich problemlos pingen lassen ?!
Traceroute ist da wieder dein Freund...
Bitte warten ..
Mitglied: miuliu
07.05.2016 um 10:56 Uhr
Danke. Das hat das Problem gelöst.

Traceroute hatte ich über VPN probiert, aber bin daraus nicht schlauer geworden. Der einzige Eintrag im Traceroute war die Firewall und das hat mir keine Mehrinformation gebracht. Was hätte ich daraus ableiten können?
Bitte warten ..
Mitglied: aqui
07.05.2016, aktualisiert um 11:01 Uhr
Da wo Traceroute aufhört ist meist auch der Fehler...
Gut wenns nun klappt wie es soll. Ein täglicher Dauerbrenner hier im Forum wenns ums Routing geht.

Bitte dann auch
https://www.administrator.de/faq/32
nicht vergessen.
Bitte warten ..
Mitglied: miuliu
07.05.2016 um 11:09 Uhr
Ich hatte leider nicht an den Rückkanal gedacht. Anfängerfehler! Sorry und nochmal danke!
Bitte warten ..
Ähnliche Inhalte
Router & Routing
DHCP-Relay mit Cisco SG300-28 Switch
gelöst Frage von ITplusRouter & Routing3 Kommentare

Hallo geschätzte Mit-Admins, ich habe momentan das erste Mal mit einer Umgebung mit VLANs zu tun. Dabei stellt sich ...

Netzwerkgrundlagen
ACL auf Cisco SG300 L3 Switch einrichten
gelöst Frage von JejeSwissNetzwerkgrundlagen10 Kommentare

Hallo Zusammen Ich habe das mit den ACL noch nicht ganz drauf. Die Konfiguration funktioniert noch nicht wie ich ...

Router & Routing
Cisco Switch SG300-20 als DHCP Server
Frage von carbo1Router & Routing7 Kommentare

Hallo liebe Gemeinde, ich habe mich hier angemeldet um meine Kenntnisse zu verbessern. Ich habe auch gleich ein Problem, ...

LAN, WAN, Wireless
Cisco SG300 Startschleife
gelöst Frage von DieOmerLAN, WAN, Wireless13 Kommentare

Hallo, Ich habe mich vorkurzem beim Neukauf für die SG300 Serie entschieden. Grundsätzlich zu mir, ich arbeite das erste ...

Neue Wissensbeiträge
Sicherheits-Tools

TrendMicro Worry-Free Business Security 10.0 SP1 - Jetzt in Deutsch verfügbar! (Windows 10 1903 Support)

Tipp von TrinXx vor 1 TagSicherheits-Tools1 Kommentar

Moin! Nach wochenlangem Warten wird Trend Micro das SP1 für WFBS 10 voraussichtlich am 26.08.19 veröffentlichen. Ich habe das ...

Hyper-V
Setup VM W2016 startet nicht in Hyper-V 2016
Erfahrungsbericht von keine-ahnung vor 2 TagenHyper-V4 Kommentare

Moin, sitze gerade über meinem neuen Server und versuche, die VM auf den Host zu prügeln. Jetzt wollte ich ...

Server-Hardware

HPE Proliant ML350P Gen8 Probleme mit Zugriff auf Raid-Volumes

Erfahrungsbericht von goscho vor 2 TagenServer-Hardware1 Kommentar

Hallo Leute, das Problemgerät: HPE ML350P G8 Windows Server 2012R2 HyperV-Host 8 x 300 GB 10K SAS HDD (1 ...

Humor (lol)

"Linux und 5 Gründe Warum man kein Windows verwenden sollte sondern Ubuntu Linux"

Information von Snowbird vor 4 TagenHumor (lol)9 Kommentare

Gerade gefunden. Ja, ist etwas älter, aber irgendwie lustig?

Heiß diskutierte Inhalte
Backup
Veeam Backup Endpoint Free sichert nicht alle Dateien in AppData
gelöst Frage von speedy26gonzalesBackup12 Kommentare

Hallo, ich sollte ein paar Dateien in C:\Users\xyc\AppData\Local\Microsoft\Outlook wieder herstellen. Auf dem Benutzerkonto ist in Outlook ein IMAP Konto ...

Server
Ein Server ins Haus stellen. Was brauche ich dafür?
Frage von JoschiTomServer11 Kommentare

Hallo Community, ich spiele mit dem Gedanken eine Server mir zu holen. Was brauche ich dafür? Und wie sind ...

Windows Server
Ist es möglich, eine deutsche W2016 Installation mit einer UK-Lizenz zu aktivieren?
gelöst Frage von keine-ahnungWindows Server10 Kommentare

Moin at all, ist ja noch Freitag. Ich habe hier noch zwei UK OEM W2016 Standard Pakete rumfliegen Muss ...

Windows 10
Windows 10 Backup auf Netzwerk Storage
Frage von Futschel2608Windows 1010 Kommentare

Hallo geehrte Mitstreiter Innen, Wir wollen in unserer Windows 10 Domäne den Einzelnen Usern ermöglichen ihre Desktop PC's zusichern. ...