Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Kein Zugriff auf externe IP aus dem Intranet

Mitglied: GIS-olli

GIS-olli (Level 1) - Jetzt verbinden

08.08.2007, aktualisiert 11:51 Uhr, 4826 Aufrufe, 4 Kommentare

Ich habe folgendes Problem. Wir haben ein Firmennetzwerk mit einem Win2003 SBS laufen. An diesem Server sind mehrere Clients in einer Domäne zusammgefasst. Der Internetzugang erfolgt bei uns über einen Innominate MGuard Router. Wir haben eine vom ISP feste IP, 213.23.xx.xx. Ich habe den Router für den Routerbetrieb konfiguriert, d.h. er hat extern die IP vom ISP und intern die IP 192.168.1.250, Subnet 255.255.255.0. Soweit funktioniert der Internetzugang für alle Rechner einwandfrei. Nun habe ich auf unserem Server (192.168.1.201, gleiches Subnet) einen Apache Webserver auf dem Port 8080 laufen. Wenn ich im Intranet nun die Seite 192.168.1.201:8080 eingebe (oder alternativ auch den Servernamen:8080) sehe ich den Webinhalt einwandfrei. Jetzt wollte ich den Webinhalt aus dem Internet erreichbar machen, also über 213.23.xx.xx . Dazu habe ich im Router eine Portweiterleitung eingerichtet. Wenn eine Anfrage an den http Port von aussen an die IP 213.23.xx.xx kommt, soll er die Anfrage an 192.168.1.201:8080 weiterleiten. Das funktioniert auch, allerdings nur aus dem Internet. Wenn ich nun die IP 213.23.xx.xx aus unserem Firmennetzwerk aufrufe kommt eine Zeitüberschreitung im Browser. Allerding, und das ist das komische, sehe ich im Log des Routers, dass die Firewallregel gegriffen hat, mit den richtigen Quell IPs usw... Aber es kommt am Client nichts an. Ich habe auch schon versucht, die Firewall komplett auszuschalten, also den ganzen eingehenden Verkehr mal zugelassen, mit dem gleichen Ergebnis. Aber wie gesagt, von aussen gehts. Kann mir jemand weiterhelfen?
Mitglied: aqui
08.08.2007 um 11:05 Uhr
Sehr wahrscheinlich hat der NAT Prozess im Router ein Problem damit eine aus seinem internen lokalen Netz kommete Quelladresse auch wieder als Forwarding IP einzusetzen. Ein recht häufig sichtbares Phänomen bei NAT Routern.

Auf der anderen Seite musst du dich aber auch mal ernsthaft fragen lassen was der Unsinn soll aus dem lokalen Intranet als Zieladresse für einen lokalen Webserver eine externe IP Adresse und dann auch noch die des Routers auf dem Internet Port anzugeben. Normal ist das ja eigentlich nicht und der Sinn erschliesst sich erstmal auch nicht !
Bitte warten ..
Mitglied: GIS-olli
08.08.2007 um 11:15 Uhr
Danke erstmal für die rasche Antwort.
Also das mit der IP lässt sich einfach erklären: Ich erstelle Webanwendungen, welche auf einen Mapserver zugreifen. Dieser arbeitet OGC-konform, d.h. er greift über einen konformen Request auf einen Server zu. In diesem Request ist natürlich die IP mit drin. Das hätte zur Folge, dass ich bei der Entwicklung der Anwendung alle IPs lokal halten müsste, und dann alles auf "öffentlich" umstellen müsste. Also muss es mit der öffentlichen IP gehen, da ich sonst eine sehr umständliche Arbeit habe.

Nun zum NAT:
Ich habe bei unserem Router unter NAT folgendes probiert: Unter dem Punkt "Network Address Translation/IP Masquerading" stand ursprünglich 192.168.1.0/24. Damit ging es nicht. Dann habe ich es in 0.0.0.0/0 umgewandelt, da in der Router Anleitung stand, dass damit alles verarbeitet wird. Es gibt dann aber noch die Möglichkeit eines 1:1-NAT. Dabei muss ich das lokale Netzwerk, das externe Netzwerk und die Netzmaske angeben. Das habe ich auch schon ausprobiert, hat aber auch keine Änderung gebracht.
Bitte warten ..
Mitglied: aqui
08.08.2007 um 11:44 Uhr
Ein Lösung kann sein eine IP aus dem öffentlichen Kontingent eurer IP Adresse zu nehmen. Das funktioniert aber nur wenn ihr statt einer einzigen IP eine Subnetz oder Teile davon bekommen habt.
Dann könntest du dir eine statische NAT Regel konfigurieren nur für den Webserver sofern der Router sowas kann. Allerdinsg würde das dann letztendlich keinen Sinnmachen, denn dann könnte man sich eine DMZ einrichten und den Server auch mit einer öffentlichen IP betreiben und hätte das Problem erst gar nicht....

Das ist vermutlich ein Bug oder Feature des NAT Prozesses in der Firmware deines Routers. Ggf. fixt ein Firmware Image das auf das neueste Release. Wie gesagt nicht alle Router zeigen so ein Verhalten bei vielen klappt das problemlos. Eine feste Regel wer es kann und wer nicht gibt es aber nicht, da hilft leider nur der versuch
Evtl. solltest du mal die Hotline des Herstellers kontaktieren. Innominate nutzt m.W. ein embeddetes Linux auf ihren Systemen und da sollte eine Lösung allemal möglich sein !
Bitte warten ..
Mitglied: GIS-olli
08.08.2007 um 11:51 Uhr
Danke erstmal. Ich hab noch einen DLink Router rumliegen, ich probiers erstmal mit dem ob es wirklich daran liegt.
Bitte warten ..
Ähnliche Inhalte
Windows Server
RDWeb Zugriff von Extern
Frage von GrueneSosseMitSpeckWindows Server6 Kommentare

Hi, ich hab gerade ein RD Web Deployment ausprobiert. Ziel des ganzen ist daß ein Webinterface zum Anmelden an ...

Router & Routing
PC Zugriff von Extern
Frage von flocky84Router & Routing17 Kommentare

Hallo zusammen, ich hab eine Frage und hoffe, dass ich hier richtig bin. Was ich vllt. noch erwähnen sollte ...

Router & Routing

Dual WAN konfiguration mit Extern-Zugriff

Frage von ScratcherRouter & Routing1 Kommentar

Hallo zusammen! Folgende Herausforderung habe ich: - Firmennetzwerk mit 2 Internetanschlüssen (1x Unitymedia mit fester IP/ 1x DSL mit ...

Windows Netzwerk

RDP kein Zugriff (intern und extern)

gelöst Frage von andi74151Windows Netzwerk6 Kommentare

Seit kurzen kann ich mich nicht mehr auf eine virtuelle Maschine windows 7 per RDP zugreifen. Es kommt immer ...

Neue Wissensbeiträge
Internet

CDU Propaganda: Urheberschutz im Internet - Ende des digitalen Wild-West

Information von Frank vor 18 StundenInternet3 Kommentare

Hallo Administratoren, aus einem Kommentar heraus habe ich folgenden Beiträge von Herr Sven Schulze und Axel Voss (beide CDU ...

Router & Routing

Zyxel VMG 1312 B30A - Firmwareupdate nur im "privaten" Firefox Modus möglich

Tipp von the-buccaneer vor 1 TagRouter & Routing2 Kommentare

Hatte hier ein Zyxel 1312 das ums verrecken kein Firmwareupdate durchführen wollte. Datei ist auswählbar, dann kommt der Fortschrittskreisel ...

Windows 7

Windows 7 u. Server 2008 (R2) SHA-2-Update kommt am 12. März 2019

Information von kgborn vor 2 TagenWindows 75 Kommentare

Kleine Info für die Admins der oben genannten Maschinen. Ab Juli 2019 werden Updates von Microsoft nur noch mit ...

Firewall
PfSense 2.5.0 benötigt doch kein AES-NI
Information von ChriBo vor 4 TagenFirewall2 Kommentare

Hallo, Wie sich einige hier erinnern werden hat Jim Thompson in diesem Aritkel beschrieben, daß ab Version 2.5.0 ein ...

Heiß diskutierte Inhalte
Netzwerke
Verteilung von Programmdaten außerhalb des internen Netzwerkes
Frage von mertaufmbergNetzwerke27 Kommentare

Guten Morgen liebe Administratoren, ich versuche zurzeit eine möglichst sichere und einfache Lösung zu suchen, um ein Programmverzeichnis über ...

Datenbanken
PHP Fatal error: Uncaught Error: Call to undefined function oci connect
Frage von PlanitecXDatenbanken19 Kommentare

Hallo Zusammen, ich sitze seit Tagen am Problem das ich keine PHP Anwendung mit Anbindung zu Oracle zum laufen ...

Hardware
PC im Selbstbau, Workstation, mittelklasse Gaming
gelöst Frage von MrRobot1997Hardware19 Kommentare

Hallöchen Leute, ich bin seit einigen Jahren leider nicht mehr wirklich im Bild, wenn es um die Hardware und ...

Hardware
Welchen Shop Großhandel für EDV?
Frage von opc123Hardware17 Kommentare

Hallo, ich finde kein passendes Thema. Ich suche einen Großhändler für alltägliche EDV Ausstattung: Ethernet Kabel, Switche, Stromverteiler, Handy´s, ...