Konfigurationsproblem DMZ

Mitglied: cantor

cantor (Level 1) - Jetzt verbinden

25.07.2011 um 22:54 Uhr, 5091 Aufrufe, 5 Kommentare

Mit kleinen Schritten und etwas Hilfe komme ich mit meinem Netzwerk immer weiter voran.
Nächste - und letzte - Hürde ist die Einrichtung eines WebDAV Servers in der DMZ meiner m0n0wall.

Als ersten Schritt habe ich das DMZ-Interface nach dem m0n0wall Handbuch eingerichtet.
Die DMZ hat den IP-Bereich 192.168.1.1/24, der Webserver besitzt die statische IP 192.168.1.1

Dem LAN ist der IP-Bereich 192.168.2.1/24 zugewiesen.
Die m0n0wall besitzt die IP 192.168.2.100

Inbound NAT ist wie folgt eingerichtet:
Was mich jetzt verblüfft und total irritiert ist die Tatsache, daß ich bei Aufruf von 192.168.1.1 aus dem LAN (das eigentlich ohne entsprechende Konfiguration gar nicht auf das andere Subnetz zugreifen können sollte), die Konfigurationsseite der m0n0wall erreiche.

Sofern ich die Firewall-Regel
aktiviere, bin ich natürlich auch aus dem WAN bei Aufruf meiner ext. IP-Adresse auf der m0n0wall-Konfigurationsseite.

Da liegt offensichtlich ein fundamentaler Denkfehler bei mir vor. Für einen Schubs in die Richtige Richtung (in Form eines entsprechenden Hinweises) würde ich mich sehr freuen.

Ganz herzlichen Dank im voraus.

Gruß Jürgen
Mitglied: Lochkartenstanzer
26.07.2011 um 08:02 Uhr
Überprüf mal die IP-Adressen auf den verschiedenene Schnittstellen der Monowall.
Bitte warten ..
Mitglied: kopie0123
26.07.2011 um 09:32 Uhr
Hey,

dein Webserver hat die falsche IP... Die M0n0wall benötigt auch eine IP im Subnetz, irgendwie muss sie auch mit den Servern in der DMZ sprechen können :) face-smile

aktuell haben die wall UND dein Webserver die IP 192.168.1.1 zugewiesen, dann kann nicht klappen :) face-smile

besser:

wall: 192.168.1.1
Webserver: 192.168.1.2

Freigaben anpassen, dann läuft es

Gruß
Bitte warten ..
Mitglied: kopie0123
26.07.2011 um 09:34 Uhr
Wenn es läuft, solltest Du auf deinem Webserver SSL aktivieren. Damit kannst Du deine Verbindungen verschlüsselt aufbauen. Der Port ändert sich dann für HTTPS auf 443.
Bitte warten ..
Mitglied: aqui
26.07.2011 um 13:44 Uhr
Irgendwo ist da ja der Wurm in der IP Adressierung:
Oben steht
der Webserver besitzt die statische IP 192.168.1.1
und
wall: 192.168.1.1
Was ja schon mal per se nicht geht , denn so hätte man die IP mit der .1 ja doppelt vergeben !
Auch "...LAN ist der IP-Bereich 192.168.2.1/24 " ist irgendwie Unsinn, denn einer Host Adresse wie der .1 kann man kein LAN zuweisen. Wenn schon technisch korrekt müsste es 192.168.2.0 /24 heissen, denn das IP Netz selber bezeichnet immer die IP, wo alle Host Bits auf 0 sind !!
Du solltest also erstmal deine korrekte IP Adressierung überprüfen, denn dann passieren solche Dinge auch nicht.
Sinnvoll ist es der Monowall auf allen Interfaces z.B. die .254 am obersten Ende zu geben um solche Überschneidungsprobleme sicher zu vermeiden !
Wenn das sauber gemacht ist hast du solche Probleme auch nicht !!
Bitte warten ..
Mitglied: cantor
26.07.2011 um 19:43 Uhr
Hallo,

erst einmal ganz herzlichen Dank für die Rückmeldungen, auch in den anderen Beiträgen von mir - es läuft jetzt!

Darüber hinaus auch Entschuldigung, falls meine Fragen allzu laienhaft sind. Ich tue mich mit Netzwerkfragen wirklich schwer. Das liegt einfach daran, daß ich leider nur sehr wenig Zeit für die Beschäftigung mit dem Computer/Netzwerk aufbringen kann. Es muß halt laufen ...

Zitat von @kopie0123:
dein Webserver hat die falsche IP... Die M0n0wall benötigt auch eine IP im
Subnetz, irgendwie muss sie auch mit den Servern in der DMZ sprechen können :) face-smile

aktuell haben die wall UND dein Webserver die IP 192.168.1.1 zugewiesen,
dann kann nicht klappen :) face-smile

besser:

wall: 192.168.1.1
Webserver: 192.168.1.2

So habe ich es auch schlußendlich gemacht. Ich hatte (Netzwerklaie!) einfach total verpeilt, daß die m0n0wall natürlich auch noch eine IP in der DMZ hat. Bei dem WebDAV-"Server" handelt es sich lediglich um einen kleinen Netzwerkadapter, an dem eine USB-Platte hängt (NAS 3.0 von Addonics). Und die IP 192.168.1.1 war schon voreingestellt. :) face-smile

Zitat von @aqui:
Irgendwo ist da ja der Wurm in der IP Adressierung:
Oben steht
der Webserver besitzt die statische IP 192.168.1.1
und
wall: 192.168.1.1

Siehe oben.

Auch "...LAN ist der IP-Bereich 192.168.2.1/24 " ist irgendwie Unsinn,
denn einer Host Adresse wie der .1 kann man kein LAN zuweisen. Wenn schon
technisch korrekt müsste es 192.168.2.0 /24 heissen, denn das IP Netz
selber bezeichnet immer die IP, wo alle Host Bits auf 0 sind !!
Du solltest also erstmal deien korrekte IP Adressierung überprüfen, denn
dann passieren solche Dinge auch nicht.

Du hast natürlich recht. Aber bei der Angabe des IP-Bereiches für das LAN hatte ich mich lediglich falsch ausgedruckt. "Die DMZ hat den IP-Bereich 192.168.1.1/24" und "Dem LAN ist der IP-Bereich 192.168.2.1/24 zugewiesen" meint lediglich, daß ich diese Angaben bei der IP-Konfiguration in der m0n0wall für LAN und DMZ angegeben habe. Ich hoffe, daß ich mich mit wachsendem know-how auch präziser ausdrücken kann.

Nochmals herzlichen Dank für die Geduld/Hilfsbereitschaft.

Gruß Jürgen
Bitte warten ..
Heiß diskutierte Inhalte
MikroTik RouterOS
Simples VLAN bringt mich zur Verzweiflung
gelöst Daniel26Vor 23 StundenFrageMikroTik RouterOS28 Kommentare

Moin, ich bin sehr neu im Mikrotik-Bereich, aber schon dabei, aufzuegeben. Wir verbauen in unserer Hardware Switche von Mikrotik. Bisher waren da Netgear-Teile drin, ...

LAN, WAN, Wireless
Switch läuft, ist aber nicht erreichbar
gelöst AndiPeeVor 1 TagFrageLAN, WAN, Wireless19 Kommentare

Hallo zusammen, mein Problemfall einleitend kurz umrissen: Privates Netzwerk Es funktioniert grundsätzlich, allerdings habe ich immer mal ein paar Ausfälle im WLAN-Netzwerk und bin ...

Microsoft
STRG + ALT + ENTF
TezzlaVor 16 StundenAllgemeinMicrosoft11 Kommentare

Mahlzeit zusammen, wir haben gerade im Kollegenkreis über Sinn und Unsinn der Sperrbildschirmentriegelung STRG + ALT + ENTF unter Win10 diskutiert. Mich würde hierzu ...

VB for Applications
Auf SQL Datenbank schreiben welche Sich im Firmennetzwerk befindet
RSST-SORVor 1 TagFrageVB for Applications12 Kommentare

Hallo Ich habe ein funktionierendes VBA Makro im EXCEL welches mit: conn.Open "driver={SQL Server};" & _ "server=RSST-OFFICEIII\RSSTSQLSERVER;database=RSSTZeiterfassung;" Daten in die Tabelle schreibt Nun würde ...

Windows 10
SMB Performance VPN
Guhl22Vor 1 TagFrageWindows 104 Kommentare

Hallo zusammen, wir stellen bei uns in der Firma ein sehr merkwürdiges Phänomen fest. Zugriffe über VPN auf gemappte Netzlaufwerke (über vbs Logon Skript ...

E-Mail
Alternative zu horde webmail
fisch56Vor 1 TagFrageE-Mail6 Kommentare

Hallo, ich habe das horde webmail auf meinem Server, macht allerdings Probleme. Suche daher eine Alternative. Das Postfach hat viele Unterordner, die z.B. bei ...

Video & Streaming
Streamingplattform mit eigenen Servern
gelöst icegetVor 18 StundenFrageVideo & Streaming5 Kommentare

Hallo liebe Community, ich würde gerne via Amazaon AWS (oder andere Cloudanbietern) mehrere Serverinstanzen (Streaming) starten, um z.B. 2000 Personen den selben Stream den ...

Microsoft Office
PST Verschwunden
shnu125Vor 1 TagFrageMicrosoft Office8 Kommentare

Guten Tag, ich habe aufgrund diverser Outlook Probleme , das Office neu installiert und unter AppData Local und AppData Roaming die dazugehörigen Ordner unter ...