Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst MAC ändert sich nach 30s - Mikrotik WLan Bridge (P2P)

Mitglied: Spirit-of-Eli

Spirit-of-Eli (Level 3) - Jetzt verbinden

25.03.2020, aktualisiert 08:02 Uhr, 348 Aufrufe, 13 Kommentare

Moin zusammen,

ich habe hier zwei Mikrotiks als Wlan Bridge laufen. Diese haben jeweils eine IP in den entsprechenden Netzen.
Die Strecken über Wlan laufen Einwand frei. Möchte ich allerdings den Mikrotik selbst über die Wlan Strecke (es geht um die Station auf der anderen Seite.) erreichen (Winbox) kommt dieser andauernd mit einer anderen MAC Adresse seiner Interfaces raus. Somit bricht die Verbindung über Winbox dann verständlich ab. In der PfSense sehe ich auch ARP changes aller "moved to ...".

Ich komme nicht mehr auf den Kniff was gemacht werden muss.
Ich habe bereits versucht die MAC Adressen auf den Interfaces zurück zu setzen, allerdings löst es das Problem nicht.
Ebenfalls habe ich dem Wlan Interface schon die selbe MAC wie der Bridge gegeben, jedoch ohne erfolg.

Irgend so einen Trick gab es dabei, nur ich suche mir gerade einen Wolf. Wird Zeit das ich wieder häufiger mit der HW zu tun habe.
Bin gespannt ob ihr den Fehler seht und ich bloß blind bin.

Edit: Eine Sache habe ich vergessen. Der AP läuft als "bridge" und die Station als "Station - WDS". WDS ist auch aktiv und im AP ist die bridge Funktion aktiv.

Gruß
Spirit
Mitglied: vibrations
LÖSUNG 25.03.2020, aktualisiert um 09:07 Uhr
Die Verwaltung über die MAC Adresse in Winbox ist nur für die absolute Ersteinrichtung oder Fallback wenn man per Kabel am Gerät steckt und das Gerät noch keine IP hat. Danach sollte man die Verbindung über IP herstellen, nicht mehr über die MAC. Über WLAN kannst du die Verwaltung per MAC Adresse über Winbox knicken das läuft nicht sehr zuverlässig (zumindest nicht sehr lang) und wenn dann nur kurzzeitig so lange bis man dem Teil eine IP verpasst hat.
Die Änderung der MAC kommt vom Setting der Bridge auto-mac (Lösung admin-mac)
https://wiki.mikrotik.com/wiki/Manual:Interface/Bridge#Bridge_Interface_ ...
Bitte warten ..
Mitglied: aqui
LÖSUNG 25.03.2020, aktualisiert um 09:08 Uhr
Auto Mac oder Admin Mac falsch oder vergessen zu setzen ?
https://wiki.mikrotik.com/wiki/Manual:Interface/Bridge#Bridge_Interface_ ...
Admin Mac setzen sollte das Problem sofort fixen
Schalte das Auto Mac Feature ab und setze die Bridge fest mit Admin Mac auf die Adresse die sie sich zuvor per Auto Mac gegeben hat.
https://vswitchzero.com/2019/08/23/preventing-mikrotik-routeros-bridge-m ...

Nebenbei: Die gravierenden Nachteile einer Bridge in puncto Performance sind dir sicher bewusst, oder ? Wenn das eine LAN zu LAN Kopplung ist über WLAN solltest du wenn möglich immer routen und nicht bridgen !
Bitte warten ..
Mitglied: Spirit-of-Eli
25.03.2020 um 09:08 Uhr
Zitat von aqui:

Auto Mac oder Admin Mac falsch oder vergessen zu setzen ?
https://wiki.mikrotik.com/wiki/Manual:Interface/Bridge#Bridge_Interface_ ...
Admin Mac setzen sollte das Problem fixen
https://vswitchzero.com/2019/08/23/preventing-mikrotik-routeros-bridge-m ...

Nebenbei: Die gravierenden Nachteile einer Bridge in puncto Performance sind dir sicher bewusst, oder ? Wenn das eine LAN zu LAN Kopplung ist über WLAN solltest du wenn möglich immer routen und nicht bridgen !

Moin aqui,

den Punkt habe ich auch gerade gefunden. Ist es richtig das ich "auto-mac" dann deaktivieren muss, sobald ich die "admin-mac" setzte?
Bitte warten ..
Mitglied: aqui
LÖSUNG 25.03.2020 um 09:09 Uhr
Ist es richtig das ich "auto-mac" dann deaktivieren muss, sobald ich die "admin-mac" setzte?
Ja !
Bitte warten ..
Mitglied: Spirit-of-Eli
25.03.2020 um 09:17 Uhr
Ich habe mir die Interface Konfig angeschaut. Bei allen Bridges steht "auto-mac=no".
Ich schätze dafür ist ein Reboot nötig.
Bitte warten ..
Mitglied: aqui
LÖSUNG 25.03.2020 um 09:18 Uhr
Nur "auto-mac=no" ist nur die halbe Miete ! Du musst auch noch die Admin Mac setzen ! Das hast du auf dem Radar ?!
Bitte warten ..
Mitglied: Spirit-of-Eli
25.03.2020, aktualisiert um 09:27 Uhr
Zitat von aqui:

Nur "auto-mac=no" ist nur die halbe Miete ! Du musst auch noch die Admin Mac setzen ! Das hast du auf dem Radar ?!
Die "admin-mac" ist gesetzt. Die Konfiguration ist i.o. Derzeit verursacht nur noch der AP die ARP moves in der Sense.

Kann ich irgendwie überprüfen ob der AP sowie die Station den MAC adress table für die WDS Konfig korrekt anlegen?
Bitte warten ..
Mitglied: aqui
LÖSUNG 25.03.2020 um 09:28 Uhr
show arp, show mac-address oder arp -a
Bitte warten ..
Mitglied: Spirit-of-Eli
25.03.2020, aktualisiert um 09:55 Uhr
Zitat von aqui:

show arp, show mac-address oder arp -a

Auf dem Mikrotik sehe ich dort keine localen Einträge. Auf der Sense jedoch ist zu erkennen, das die Clients hinter der Station nun mit der jeweiligen Interface MAC ankommen. Ich habe mit der WDS Konfig jedoch erwartet, das deren eigene MAC genutzt wird.
Bitte warten ..
Mitglied: Spirit-of-Eli
25.03.2020, aktualisiert um 10:59 Uhr
Zitat von aqui:
Nebenbei: Die gravierenden Nachteile einer Bridge in puncto Performance sind dir sicher bewusst, oder ? Wenn das eine LAN zu LAN Kopplung ist über WLAN solltest du wenn möglich immer routen und nicht bridgen !

Das ganze ist mehr eine Übergangslösung um zwei Rechner anzubinden. Wenn ich jetzt anfange zu routen, müsste ich dahinter weitere Netze anlegen und auf dem Main GW die Rückrouten pflegen. Die Performance ist ansonsten okay. Nur die MAC adress Thematik bereitet Probleme.
Dargestellt hat sich das ganze auch nur bei der Verbindung mit Winbox zur Station. Die Clients dahinter hatte nie Probleme. Diese kommen allerdings mit der Mikrotik MAC an der Firewall an.

Mittlerweile habe ich keine Ping drops mehr. Einzig die ARP changes auf der Sense sind noch vorhanden. Einen Reboot kann ich derzeit aber nicht durchführen.
Wie erwähnt hätte ich mir gewünscht, dass Clients hinter der Station nun auch mit ihrer eigenen MAC ins Netz kommen. Das funktioniert noch nicht.
Bei meinem Verständnis hätte sich das durch die Konfig AP=bridge mode und Station=Station-wds lösen lassen sollen da hier von den Wlan Teilnehmern ein eigener MAC table gepflegt werden sollte. Das passiert aber anscheint noch nicht.

Edit: Das Problem mit den MAC Adressen hinter der Station konnte ich lösen. Hätte ich am Anfang richtig gelesen, wäre ich drauf gekommen direkt den "station-bridge" mode zu nutzen. Dann ist meine geforderte Funktionalität gegeben.
Bitte warten ..
Mitglied: Spirit-of-Eli
25.03.2020 um 09:55 Uhr
Zitat von vibrations:

Die Verwaltung über die MAC Adresse in Winbox ist nur für die absolute Ersteinrichtung oder Fallback wenn man per Kabel am Gerät steckt und das Gerät noch keine IP hat. Danach sollte man die Verbindung über IP herstellen, nicht mehr über die MAC. Über WLAN kannst du die Verwaltung per MAC Adresse über Winbox knicken das läuft nicht sehr zuverlässig (zumindest nicht sehr lang) und wenn dann nur kurzzeitig so lange bis man dem Teil eine IP verpasst hat.
Die Änderung der MAC kommt vom Setting der Bridge auto-mac (Lösung admin-mac)
https://wiki.mikrotik.com/wiki/Manual:Interface/Bridge#Bridge_Interface_ ...

Moin,

das ist mir bewusst. Mein Problem bezieht sich aber darauf, das sich die MAC zu der IP ändert und darauf hin die Verbindung weg fliegt. Ich versuche mich ja über die IP zu verbinden.
Bitte warten ..
Mitglied: Spirit-of-Eli
25.03.2020, aktualisiert um 11:45 Uhr
Ich habe nun alle Probleme gelöst. Auf dem AP war nur noch ein Neustart nötig damit die admin-mac ebenfalls griff.
Auf der Station hat tatsächlich die Konfig als station-bridge alle weiteren Themen beseitig.

Euch vielen Dank für die Hilfe!
Nebenbei scheint auto-mac mittlerweile default auf einer Bridge deaktiviert zu sein oder es wird zumindest beim setzen der admin-mac deaktiviert. (Konfig über Winbox)

Edit: Die MAC vom Uplink Port muss bei der Bridge eingetragen sein. Möglicherweise ein Bug. Ansonsten kommen nach wie vor ARP moves.
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
Mikrotik Antennen P2P-Verbindung
gelöst Frage von dragonfire8LAN, WAN, Wireless8 Kommentare

Hallo, ich habe zwei MikroTik RB SXTsq5 - Antennen. Aufbau ist ganz einfach gestrickt. Antenne 1 hängt in der ...

LAN, WAN, Wireless
Mikrotik CAPsMAN MAC-Filter nutzen
gelöst Frage von McLionLAN, WAN, Wireless9 Kommentare

Hallo, ich habe bei mir CAPsMAN eingerichtet, was auch wunderbar funktioniert. Habe darauf zwei WLAN-Netze laufen, "Normal-WLAN" und "GAST-WLAN". ...

LAN, WAN, Wireless
Mikrotik WLAN - Best practice?
Frage von AndroxinLAN, WAN, Wireless10 Kommentare

Hallo zusammen, ich habe diverse Mikrotik Geräte (RB951G-2HnD (6.38.1), RB951G-2HnD (6.38.5), 4x RBwAPG-5HacT2Hnd (6.38.1), CRS109-8G-1S-2HnD (6.35.4)) im Einsatz und ...

LAN, WAN, Wireless

WLAN-Funkreichweite Access Point MikroTik

Frage von teret4242LAN, WAN, Wireless4 Kommentare

Hallo, welcher Access Point von MikroTik kann die WLAN-Funkreichweite eines MikroTik RB2011UiAS-2HnD-IN abdecken? Gruß

Neue Wissensbeiträge
Internet

Aktuelle Netzauslastung in Deutschland durch die Covid-19-Pandemie

Information von Frank vor 7 StundenInternet4 Kommentare

Viele Bürger fragen sich, ob die Telekommunikationsnetze während der Covid-19-Pandemie der verstärkten Internetnutzung durch Home Office, eLearning, Videostreaming und ...

iOS

iOS-Bug unterbindet vollständiges VPN-Tunneling

Information von transocean vor 2 TageniOS

Moin, seit dem letzten Update hat iOS für iPhone und iPad ein Problem mit der Verschlüsselung. Lest selbst. Grüße ...

Sicherheit
Corona Malware über manipulierte Router
Information von sabines vor 2 TagenSicherheit

Heise berichtet über Malware, die in Zusammenhang zum Suchethema Corona steht und über DNS Einstellungen bei D-Link und Linksys ...

Windows 10
Windows 10 Update KB4535996 fehlerhaft
Information von Frank vor 2 TagenWindows 101 Kommentar

Laut Microsoft ist das Update KB4535996 die Ursache für aktuelle Verbindungsprobleme bei Virtual Private Networks (VPNs). Microsoft arbeitet bereits ...

Heiß diskutierte Inhalte
KVM
Best Practice für Fileserver auf Proxmox Cluster
gelöst Frage von maichelmannKVM17 Kommentare

Hallo, derzeit laufen in einer Firma, dessen Netzwerk ich betreue, zwei Windows Server Hyper-V Hosts, jeweils mit einem recht ...

Windows Server
DNS Problem Server 2019 unter Win10 Host
Frage von Ketme10Windows Server13 Kommentare

Guten Tag zusammen. Ich bräuchte mal Hilfe. Ich habe Win 10 und Hyper V laufen. Hier habe ich 4 ...

TK-Netze & Geräte
Netphone APP nimmt kein Kontakt auf
Frage von Finchen961988TK-Netze & Geräte12 Kommentare

Hallo, ich kämfpe mit einem Problem im Bereich Netphone und der Mobil APP. Bei einem Kunden habe ich eine ...

SEO
Was ist die neueste SEO-Technik, um eine Webseite zu bewerten?
gelöst Frage von clscomputerSEO11 Kommentare

Hallo Leute , Ich habe ein ernstes Problem mit der SEO für meine Website. Ich habe viele Leute ausprobiert ...