wusa88
Goto Top

Mikrotik AccessPoint IP Adresse

Hallo zusammen,

ich stehe gerade etwas auf dem Schlauch.
Ich habe einen cAP AC in meinem Netzwerk dieser ist wie folgt konfiguriert:
interface-list_1
bridge_vlan_1
bridge1
vlan1
vlan3

Leider habe ich jetzt das Problem, dass ich den AP nur erreiche, wenn ich am Netzwerkport 2 anschließe und per MAC darauf zugreife.
Ich hätte gerne, dass der AP eine IP Adresse hat und ich diesen auch erreichen kann, ohne dass ich immer ein Kabel anstecken muss.
Ich komme allerdings nicht weiter.
Ich habe schon versucht über einen DHCP Client eine IP zu bekommen.
Dann versucht über Adresses eine IP zu vergeben.
Ich schaffe es leider nicht, dem AP eine IP zu geben.
Kann mir hier bitte jemand auf die Sprünge helfen?

Danke

Content-Key: 6126937565

Url: https://administrator.de/contentid/6126937565

Printed on: March 1, 2024 at 18:03 o'clock

Member: Spirit-of-Eli
Spirit-of-Eli Feb 25, 2023 at 14:24:10 (UTC)
Goto Top
Moin,

wie schauen denn deine Versuche über Adresses aus? Hast du die IP an das VLan 1 gebunden, oder an welches Interface soll diese gebunden sein. Denk daran, dass bei einen VLan erst ein entsprechendes virtuelles Interface angelegt werden muss um daran IP Adressen binden zu können.

Gruß
Spirit
Member: wusa88
wusa88 Feb 25, 2023 at 14:35:08 (UTC)
Goto Top
Da ich gar nicht weiß, wie ich die IP rein bekommen sollte, habe ich über alles möglich probiert.
Von bridge1 bis vlan1 und auch über ether1 bin ich gegangen.

Kannst du mir sagen, welches virtuell Interface ich erstellen muss? Dann werde ich das gleich mal probieren.

Danke
Member: Spirit-of-Eli
Spirit-of-Eli Feb 25, 2023 at 14:42:58 (UTC)
Goto Top
Schau mal unter Interfaces - VLAN nach.
Dort muss ein Interface mit der entsprechenden VLan ID erstellt werden.

Dann kannst du unter IP - Adresses einen IP erstellen und an dieses neue Interface binden.

In der Bridge muss das neu Interface ebenfalls aufgeführt werden und dort am besten als PVID das entsprechende VLan eingetragen sein.
Member: wusa88
wusa88 Feb 25, 2023 at 15:02:29 (UTC)
Goto Top
Muss das nochmal ein weiteres VLAN sein?
Ich habe das VLAN1 in dem mein Netzwerk ist, über das erreicht werden soll.


dhcp_vlan1
address_vlan1
bridge_vlan1

Es funktioniert weder DHCP Client auf VLAN1 noch Address auf VLAN1.
Member: Spirit-of-Eli
Spirit-of-Eli Feb 25, 2023 at 17:44:09 (UTC)
Goto Top
Nein, das VLan ist ja da. Nur hast du darin kein Interface. Das erstellt du wie gesagt unter Interfaces - VLAN. Nenen kannst du das dann z.B. vMgmt.
An dieses Virtuelle Interface bindest du die IP.

Dann muss das Interface vMgmt nur noch, wie andere Ports usw, in der Bridge eingetragen werden. PVID kann dort dann 1 bleiben.
Member: aqui
aqui Feb 25, 2023 updated at 18:34:06 (UTC)
Goto Top
Das Bridge Interface darf in einem VLAN Setup keinesfalls eine IP Adresse haben!! Diese MUSS immer auf einem VLAN IP Interface liegen, je nachdem in welchem VLAN du dein AP Management haben möchtest!! Kollege @Spirit-of-Eli hat es oben richtig gesagt.
Das hiesige Mikrotik VLAN Tutorial weist mehrfach und in rot auf diesen wichtigen Punkt hin!
Lesen und verstehen...!
Dann muss das Interface vMgmt nur noch, wie andere Ports usw, in der Bridge eingetragen werden
Nein, das ist nicht nötig! Lediglich nur die VLANs und nur die Tagged Ports müssen in der VLAN-Bridge definiert werden, mehr nicht! Siehe dazu auch HIER!
Member: Spirit-of-Eli
Spirit-of-Eli Feb 25, 2023 at 18:50:42 (UTC)
Goto Top
Also, wenn ich das vMgmt Interface hier aus der Bridge nehme, ist das Gerät nicht mehr per IP erreichbar. Auch nicht nach einem Reboot.
Mitglied: 6017814589
6017814589 Feb 26, 2023 updated at 10:15:29 (UTC)
Goto Top
Is ja auch klar warum es nicht geht, das vlan1 ist nicht auf der Bridge als tagged markiert, also kann es die CPU des CAP niemals erreichen und somit auch keine IP beziehen ... Btw. das vlan1 selbst als tagged einzutragen ist überflussig vlan-interfaces sind im Router selbst immer automatisch getagged.

So muss das aussehen wenn der untagged Traffic auf ether1 auf das vlan1 Interface gelegt werden soll

74b748bbfa6543a66bbf04ebb65f9979~2
Und dann die static IP oder den dhcp client auf das vlan Interface legen, feddisch.
Member: Spirit-of-Eli
Spirit-of-Eli Feb 26, 2023 at 10:25:30 (UTC)
Goto Top
Okay komisch. Bei einem anderen Gerät kann ich das Interface Unter Bridge - Ports tatsächlich raus nehmen und das Gerät ist noch erreichbar.
Ich sehe den Unterschied nur gerade noch nicht.
Mitglied: 6017814589
6017814589 Feb 26, 2023 updated at 10:30:26 (UTC)
Goto Top
Klar man kann auch ohne VLAN Filtering oder extra vlan Interface dem Device an der Bridge ne IP geben, da braucht man nur dem Bridge-Interface selbst ne IP geben oder beziehen lassen, denn sie hat als PVID per Default die 1, also alles an untagged Traffic was in der Bridge aufläuft landed dort. Wenn man das System dahinter einmal verstanden hat ist das eingehend und logisch 😉.
Member: wusa88
wusa88 Feb 26, 2023 updated at 11:31:56 (UTC)
Goto Top
@6017814589

Ich habe es jetzt genauso versucht, wie du geschrieben hast.
Siehe anbei die Screenshots.
Die IP Adresse sehe ich, wenn ich über Winbox direkt per Kabel am CAP hänge.
Hänge ich aber den CAP an den Switch, bzw. an meinen "Haupt" hAP Lite, dann funktioniert das ganze nicht mehr.
Also ich komme über die IP Adresse nicht auf den CAP. VLAN wird richtig verteilt, das sehe ich, wenn ich mich per WLAN an das Gerät verbinde und die IP kontrolliere.

Hier die Screenshots direkt per Kabel angeschlossen.
winbox_ip
bridge_vlans

Hier noch die Einstellungen von meinem hAP Lite, vielleicht liegt auch hier der Fehler?
haplite_vlans

Ich werde jetzt noch den Vorschlag von @Spirit-of-Eli und @aqui testen.
Member: aqui
aqui Feb 26, 2023 updated at 11:48:28 (UTC)
Goto Top
Es ist sinnfrei eine zentrale VLAN Bridge die nichts mit den einzelnen Ports zu tun hat (oder nur indirekt) dann "eth4-bridge" zu nennen. Die Bridge hat doch rein gar nix mit eth4 zu tun.
Das ist sehr verwirrend und du selber wirst da auch nach 2 Wochen nicht mehr durchsteigen! Das gilt ebenso für deine VLANs deren Benennung hat ebenso nichts mit irgendwelchen physischen Ports zu tun. Diese Benennung ist logisch völlig falsch. Auch ein Grund warum man deine Konfig nur mit großer Mühe versteht. face-sad
Einfach nochmal in Ruhe das Mikrotik VLAN Tutorial lesen und verstehen:
  • VLAN Bridge ist eine zentrale Bridge und sollte auch so heissen ("vlan-bridge")
  • VLAN Interfaces richtet man unter Interfaces --> VLAN an und mappt sie mit ihrem Tag unten auf die VLAN Bridge. Idealerweise heissen sie vlan1, vlan10, vlan20 etc.
  • IP Adresse(n) werden auf diese VLAN Interfaces gebunden. Wenn man, wie du, nur einen AP managen will braucht man natürlich nur ein einziges Interface, nämlich das im Management VLAN!
  • In der Bridge legt man im VLAN Reiter für alle VLAN IDs (auch 1) einen Eintrag ein und trägt als Tagged Interface die Bridge ein. Zusätzlich ggf. noch tagged Uplinks wenn vorhanden. Es müssen NUR Tagged Interfaces eingetragen werden nichts mehr!! UNtagged Interfaces werden durch die PVID in Port Reiter der Bridge definiert!
Das ist doch nun wirklich alles kein Hexenwerk und man sollte tunlichst sich die Zeit nehmen und einmal in Ruhe lesen und verstehen was im Tutorial steht und das auch entsprechend umsetzen! Dann klappt es auch alles sofort auf Anhieb. face-wink
Member: wusa88
wusa88 Feb 26, 2023 at 12:00:09 (UTC)
Goto Top
Ok dann sollte ich vielleicht meine Grundkonfig nochmal in Angriff nehmen.
Es ist jetzt wirklich lange so gelaufen. Aber jetzt wo ich einen zusätzlichen AP rein nehmen will, stehe ich vor genanntem Problem.
Ich werde die Tage die Grundkonfig nochmal angreifen und sehen, ob es dann sauber funktioniert.
Member: Visucius
Visucius Feb 26, 2023 updated at 14:50:07 (UTC)
Goto Top
@wusa88

a) Das Mgmnt-vLAN MUSS auf der Bridge getagged sein! Wenn das bei Dir vLAN 1 ist, dann muss das aktuelle tagging von vLAN3 weg und dafür vLAN1 rein! Bei mir sieht das z.B. so aus (auch ein WAP). In meinem Fall vLAN-ID 99
bildschirm­foto 2023-02-26 um 15.40.46

b) Die IP-Vergabe machst Du unter: IP > Addresses > add new
Als Interface wählst Du NICHT die Bridge SONDERN Dein Mgmnt-vLAN (in meinem Fall 99, deshalb auch der entsprechende IP-Bereich). Ich habe als Interface-Name aber nicht mehr vLAN99, sondern Mgmt. genommen.
bildschirm­foto 2023-02-26 um 15.43.37

Viel Erfolg!
Member: Spirit-of-Eli
Spirit-of-Eli Feb 26, 2023 at 15:05:47 (UTC)
Goto Top
Muss das virtuelle Interface im Vlan nun explizit auf der Bridge getagged sein, oder nicht??
Bei mir taucht es in der VLan Übersicht in beiden Fällen nicht auf!!
Mitglied: 6017814589
6017814589 Feb 26, 2023 updated at 15:36:59 (UTC)
Goto Top
Zitat von @Spirit-of-Eli:

Muss das virtuelle Interface im Vlan nun explizit auf der Bridge getagged sein, oder nicht??
Das Interface selbst nicht (das ist intern immer getagged) aber die vlanID, wenn du es auf dem Device selbst auch nutzt, also dem Gerät eine IP zuweisen willst! Siehe mein Bild dazu oben!
Wird das vlan nur zwischen den Ports durchgeleitet muss es nicht auf den BridgePort getagged sein.
Die Bridge muss man also nur im jeweiligen vlan taggen wenn das vlan auf dem Gerät terminiert(genutzt) wird, weil dadurch die CPU das Tag dann erst sehen und den Traffic zuordnen kann.

Ist das echt so schwer zu verstehen😬? Einfach mal etwas in sich gehen und sich das Traffic Flow Diagramm ansehen wie der Router mit einer Bridge intern arbeitet, damit kann man sich das dann auch logisch selbst herleiten 😉.
Member: aqui
aqui Feb 26, 2023 updated at 16:14:19 (UTC)
Goto Top
Muss das virtuelle Interface im Vlan nun explizit auf der Bridge getagged sein, oder nicht??
Vielleicht sollte ich den Tutorial Font nochmal auf Größe 30 in Rot setzen damit es wirklich einmal gelesen wird: 😉
Mikrotik VLAN Konfiguration ab RouterOS Version 6.41
Die Antwort lautet: Nein, müssen sie nicht!
In Ruhe in sich gehen, lesen, verstehen ist der richtige Weg!
Das Mgmnt-vLAN MUSS auf der Bridge getagged sein!
Alle aktiven MSSID VLANs müssen auf der Bridge unterm VLAN Reiter Tagged auf der Bridge eingetragen sein! Das fehlt bei @Visucius' VLANs 11 und 22 insofern ist sein Screenshot oben auch nicht ganz korrekt. Einzige Ausnahme: Man will diese VLANs in der Bridge nicht weitergeben an andere Interfaces, dann muss man aber auch die VLANs gar nicht erst eintragen.
Ok dann sollte ich vielleicht meine Grundkonfig nochmal in Angriff nehmen.
Besser ist das! Ganz besonders wenn man mit einer MSSID Konfig auf den APs arbeitet.

Nebenbei:
Wenn du dir Konfig Arbeit ersparen willst mit der AP Konfig und hast noch einen Mikrotik Router oder Switch am werkeln aktivierst du dort den CapsMan Manager. Dann machst du nur eine zentrale Konfig für alle APs und kannst die dann nackig, out of the Box ins netz hängen und der CapsMan konfiguriert sie automatisch. Erspart ne Menge Arbeit und die WLAN Konfig wird zentral verwaltet. Ab 3 oder 4 APs macht das Sinn.
Member: wusa88
wusa88 Feb 26, 2023 at 19:38:51 (UTC)
Goto Top
Danke für den Hinweis. Aktuell hängen aber "nur" 2 AP im Netzwerk.

Ich habe jetzt die komplette Konfig neu gemacht wie in deinem Tutorial.
Aktuell sieht es so aus:

einstellungen
einstellungen_2

Wenn ich noch Screenshots nachliefern muss, gerne!

Momentan läuft alles wie zuvor. Sieht also denke ich soweit gut aus.

Jetzt werde ich mich nochmal an die ganzen Beiträge machen und versuchen den cAP zu konfigurieren.
Member: Visucius
Visucius Feb 26, 2023 at 20:02:32 (UTC)
Goto Top
Alle aktiven MSSID VLANs müssen auf der Bridge unterm VLAN Reiter Tagged auf der Bridge eingetragen sein!
Hm, laut MT – so wie das verstehe nicht?! Für den WAP dürfte ja das unterste Setup relevant sein.
https://help.mikrotik.com/docs/display/ROS/Basic+VLAN+switching

Das fehlt bei @Visucius' VLANs 11 und 22 insofern ist sein Screenshot oben auch nicht ganz korrekt. Einzige Ausnahme: Man will diese VLANs in der Bridge nicht weitergeben an andere Interfaces, …
Bei mir werden sie durchgereicht. Konkret, der WAP hängt mit dem Trunk an dem RB (vergl. Setup), der wiederum am CRS/SwitchOS und dieser an der OPNsense. Am anderen Ende bekommt der Wifi-Client ne IP von der OPNsense durch die komplette Kette aus vLAN 11.
Member: Spirit-of-Eli
Spirit-of-Eli Feb 26, 2023 at 21:08:38 (UTC)
Goto Top
Das ist echt noch ein Problem von Mikrotik. Die Konfig hat sich mit der Bridge über die Jahre geändert und es gibt immer noch nicht den Weg wie es zu Konfigurieren ist.

Ich habe ein ähnliches Setup wie @Visucius hier aber auch anders konfiguriert. Funktionieren tut es dennoch wie es soll.
Member: wusa88
wusa88 Feb 26, 2023 updated at 21:56:17 (UTC)
Goto Top
Jetzt funktioniert es bei mir auch.
Und schuld war ich wieder mal selber... Ich habe mir über den Switch selber ein Bein gelegt.
Ich hatte nur Tagged Traffic zum AP eingestellt.
Ich musst aber Tagged und Untagged einstellen.

Ich hatte aber trotzdem noch einen Fehler in der Konfiguration.
Die IP kommt jetzt nicht über den Untagged VLAN1 sondern über ether1.

Anbei ein Screenshot:
address-list

Das ist soweit ich bisher gelesen habe, falsch. Funktioniert aber?
Hänge ich die IP auf VLAN1 um, dann ist der AC nicht mehr über die IP erreichbar.
Und es wird die IP auch nicht mehr im Winbox Anmeldefenster angezeigt.
Member: aqui
aqui Feb 27, 2023 updated at 07:47:58 (UTC)
Goto Top
Ich habe jetzt die komplette Konfig neu gemacht wie in deinem Tutorial.
Soweit alles richtig bis auf einen gravierenden Fehler!!!

Das Tutorial beschreibt primär einen zentralen VLAN Router aber keinen einfachen Accesspoint.
Dein Kardinalsfehler ist das du fälschlicherweise allen VLAN Interfaces eine IP Adresse vergeben hast und auch fälschlicherweise in allen VLANs ein Interface gesetzt hast.
Das ist ein Fehler, denn so hast du aus dem AP einen VLAN Router gemacht was ja sicher NICHT dein Ziel ist, oder?!
Du musst auch einmal genau lesen was dir oben mehrfach geschrieben wurde:
  • VLAN Interface NUR für das Management VLAN anlegen!
  • Nur das Management Interface bekommt eine IP Adresse und ein Default Gateway. Idealerweise gibt man keine statische IP sondern mappt einen DHCP Client auf diese Management VLAN Interface, denn so zieht sich der AP immer selber per DHCP eine IP im Management VLAN
  • Die am AP genutzen MSSID VLANs werden NUR im VLAN Reiter der Bridge definiert mit Tagged Interface auf der Bridge
  • Mehr nicht...!!
Momentan läuft alles wie zuvor.
Ja aber mit der latenten Gefahr eines Backdoor Routers. Entferne also dringenst die IP Adresssen auf ALLEN Interfaces mit Ausnahme des Managements und entferne auch diese VLAN Interfaces mit Ausnahme des Managements. Dann hast du auch eine wasserdichte und saubere Konfig!
Hilfreich für dich wäre sicher noch wenn du die Interfaces tec. einmal sinnvoll unter "Comment" beschriftest und nicht ein nichtssagendes "defconf" dort überall hast! face-wink
Wie sagte noch der Kollege oben??? Einfach mal in sich gehen und nur etwas logisch nachdenken... face-wink

Die Konfig hat sich mit der Bridge über die Jahre geändert und es gibt immer noch nicht den Weg wie es zu Konfigurieren ist.
Was die Bridge Historie angeht ist das sicher richtig. Der Rest nicht. Mit der neuen Konfig Logik hat sich MT schlicht und einfach an exakt die Logik angepasst wie es weltweit alle Switch Hersteller auch machen. Das macht die Sache dann sehr einfach und verständlich.
  • zentrale VLAN Bridge Konfig mit Tagging
  • VLAN Interfaces sind die Layer 3 IP Interfaces in den VLANs was z.B. bei Cisco dem interface vlan und bei HP, Ruckus und anderen dem interface ve entspricht.
  • PVID und Tag Forwading wird am Port definiert. Auch das macht Cisco und der Rest der Hersteller nicht anders.
Einfache Standard Logik! face-wink
Ich musst aber Tagged und Untagged einstellen.
Das ist in der Regel auch völlig normal, denn auf Tagged Uplinks wir IMMER das native VLAN bzw. PVID VLAN untagged übertragen. Der Switch muss ja an so einem Port wissen was er dort mit untagged Traffic machen muss. So gut wie alle Switches verhalten sich so. Auch das ist eine allseits bekannte Standard Logik! face-wink (Siehe hier)
Die IP kommt jetzt nicht über den Untagged VLAN1 sondern über ether1.
Weil du vermutlich schlicht und einfach vergessen hast den DHCP Client der unter IP --> DHCP Client auf das ether1 Interface gemappt ist zu entfernen! Den DHCP Client mappst du jetzt logischerweise auf dein Management VLAN IP Interface!! Und nur da... Ist ether1 auch Memberinterface der VLAN Bridge? In sich gehen und nachdenken!!! face-wink
Member: wusa88
wusa88 Feb 27, 2023 at 08:43:53 (UTC)
Goto Top
@aqui
Ich hoffe wir sprechen nicht aneinander vorbei.
Ich rolle das ganze jetzt nochmal von hinten auf, damit wir einen definierten Zustand haben.

Mein "Hauptrouter" ist ein hAP Lite.
Der soll alles übernehmen und dient auch als wirklicher Router.
Hier die Screenshots vom Router:

vlan-bridge
bridge-vlans-hap
interfaces
address-list-hap
interface-list
dhcp-client
dhcp-server
interface-vlan
pool


Wenn du noch Screenshots brauchst, dann liefere ich die natürlich!
Kannst du hier grundsätzlich mal drüber schauen, ob ich soweit alles richtig gemacht habe, damit ich einen sauberen Ausgangspunkt habe. Erst dann würde ich nochmal den AP angreifen.

Ein Problem habe ich aber jetzt schon, ich habe über WLAN kein Internet. Hier passt irgend eine Einstellung noch nicht.
Ich bin leider nicht so Fit in der Mikrotik bzw. Netzwerkthematik. Daher bin ich über jede Hilfe froh und versuchte natürlich so gut es geht dazu zu lernen.

Danke
Member: aqui
aqui Feb 27, 2023 updated at 12:15:14 (UTC)
Goto Top
Ich hoffe wir sprechen nicht aneinander vorbei.
Das hoffen wir hier alle auch! 😉
Kardinalsfrage die du weiterhin nicht beantortet hast ist: Ist der Mikrotik zugleich auch noch VLAN Router???
Wenn ja = Dann ist alles richtig außer das du einen toten DHCP auf dem Bridge Interface hast (rot) Solche "Konfig Leichen" solltest du besser immer weglöschen!
Wenn nein und der MT NUR als reiner WLAN Accesspoint arbeitet = Dann ist das Anlegen der VLAN Interfaces für alle VLANs falsch!!
Ist letzteres der Fall darf nur ein einziges VLAN Interface eingerichtet sein nämlich das Management Interface an das auch die IP gebunden ist. KEINE weiteren Interfaces! Logisch, denn in dem Fall willst du mit dem AP ja keinen VLAN Router kreieren.

Damit wir jetzt nicht wirklich aneinander vorbeireden solltest du zumindestens diese grundlegende Frage wasserdicht klären!

ich habe über WLAN kein Internet.
Wie leider sehr oft hast du vermutlich die Default Route im MT vergessen, kann das sein?? (0.0.0.0/0 via IP Internet Router) Hier ist das onboard Ping Tool im Mikrotik wie immer dein bester Freund! face-wink
Das gilt aber einzig und allein nur wenn 2 Punkte zutreffen:
  • Der MT ist zentraler VLAN Router und Punkt 1 von oben gilt
  • Der MT wird in einer Router Kaskade mit einem Internet Router zusammen betrieben!
Wenn der MT als reiner AP rennt oder direkt mit einem NUR Modem am Internet gilt das obige NICHT.
IM AP Fall arbeitet der AP nur als Bridge, sprich die Clients bekommen ihr Gateway und DNS von einem DHCP Server. Im Internet direkt Fall bekommt der MT Gateway und DNS immer direkt vom Provider
Ohne die obige Kardinalsfrage zu klären kann man nicht zielführend darauf antworten.
Member: Visucius
Visucius Feb 27, 2023 updated at 12:11:12 (UTC)
Goto Top
Ist letzteres der Fall darf nur ein einziges VLAN Interface eingerichtet sein
Was aqui sagen möchte: Die hier müsstest Du in dem Fall löschen

1e4c71b54152527b178c72af0a8920e8
Member: aqui
aqui Feb 27, 2023 updated at 12:19:53 (UTC)
Goto Top
Die hier müsstest Du in dem Fall löschen
Nicht wenn der Mikrotik sein zentraler VLAN Router ist!
Das Löschen gilt nur wenn der MT als reiner AP arbeitet oder arbeiten soll. Zumindestens hat er das System ja auch vollständig mit DHCP Server usw. für alle VLANs ausgestattet so das sich vermuten lässt das das sein VLAN Router ist. Normal macht man solchen Unsinn auf einem reinen AP ja nicht. Wie gesagt...alles geraten. face-sad
Die Frage sollte der TO erstmal grundsätzlich beantworten damit hier allgemeine Klarheit herrscht über dessen Konfig!
Member: Visucius
Visucius Feb 27, 2023 at 12:26:07 (UTC)
Goto Top
Nicht wenn der Mikrotik sein zentraler VLAN Router ist!
Klar - deshalb ja Dein
Ist letzteres der Fall

und mein
in dem Fall
Member: wusa88
wusa88 Feb 27, 2023 at 12:53:40 (UTC)
Goto Top
Es ist mein zentraler Router, mit DHCP, VLAN und alles was dazu gehört.
Der Router hängt auch im Internet.

routes

Erst wenn dieser Router sauber ist, dann will ich mich an das WLAN wagen und dort auch alles sauber Konfigurieren.

Die Route ist gesetzt. Es funktioniert nur das WLAN nicht, sobald ich am Kabel hänge, habe ich zumindest im VLAN 1 keine Probleme.
Member: Visucius
Visucius Feb 27, 2023 updated at 13:12:03 (UTC)
Goto Top
Nur um das sicherzustellen:

Es funktioniert jetzt, bis auf das Wifi, weil Du das noch nicht konfiguriert hast?!

Dann würde ich an Deiner Stelle hier ein Backup des CAPs ziehen face-wink

Und für die - mit Sicherheit - aufkeimenden Wifi-Fragen würde ich Dir auch einen neuen Thread dringend(!) ans Herz legen face-wink

PS: Nur der Interesse halber – Was hängt denn vor (Firewall/Modem?!) und hinter (Switch?) dem CAP AC?
Member: wusa88
wusa88 Feb 27, 2023 at 13:57:48 (UTC)
Goto Top
Zitat von @Visucius:

Nur um das sicherzustellen:

Es funktioniert jetzt, bis auf das Wifi, weil Du das noch nicht konfiguriert hast?!
Nein bitte nicht verwechseln. Es handelt sich um einen hAP Lite. Der hat auch WLAN an Board.
Es geht um das WLAN von dem hAP Lite.

Dann würde ich an Deiner Stelle hier ein Backup des CAPs ziehen face-wink
Bei dem cAP bin ich noch gar nicht. Bisher immer noch bei meinem Hauptrouter.

PS: Nur der Interesse halber – Was hängt denn vor (Firewall/Modem?!) und hinter (Switch?) dem CAP AC?
Ich bin bei Vodafone Kabel. Heißt das Kabelmodem ist an erster Stelle. Das ist aber im Bridge Modus. Heißt mein Zugangspunkt ist der hAP Lite.
Es soll zum Schluss so aussehen:
hAP Lite <-> Switch <-> cAP AC

Bei dem cAP bin ich aber bisher noch gar nicht, da es am Hauptrouter noch nicht sauber läuft, zumindest auf das WLAN bezogen.
Mitglied: 6017814589
6017814589 Feb 27, 2023 updated at 14:19:33 (UTC)
Goto Top
Silbertablett, ist ja nicht so als wärst du der Erste face-smile:
TP-Link und Mikrotik CapsMan

Btw. ein hAP Lite mit aktiviertem VLAN-Filtering?? Autsch, das wird eine extrem lahme Ente ohne Hardware Offload und dem mikrigen Prozessor, erwarte damit nicht viel Performance, eine Fritte hat da sogar noch mehr Power.
Member: wusa88
wusa88 Feb 27, 2023 updated at 14:26:52 (UTC)
Goto Top
Wieso?
Es lief jetzt Monatelang wirklich Reibungslos. Das ganze Thema kam jetzt eigentlich auf, da @aqui gesagt hat, dass ich vieles falsch konfiguriert habe.
Bisher nie Schwierigkeiten gehabt und auch wirklich sauber gelaufen.

Jetzt habe ich alles neu Konfiguriert, soweit soll es ja gut aussehen, nur WLAN auf dem hAP Lite läuft nun nicht.
wlan-komolett
bridge-vlan-wlan
Mitglied: 6017814589
6017814589 Feb 27, 2023 updated at 16:33:08 (UTC)
Goto Top
Zitat von @wusa88:
nur WLAN auf dem hAP Lite läuft nun nicht.
Auch kein Problem, ich gehe erst mal davon aus das du es erst mal ohne Capsman versuchst. In dem Fall lege deine WIFI-Interfaces an, packe sie als Ports mit der entsprechenden PVID des vlan in die Bridge, feddisch. den vlan Tab brauchst du hierfür nicht anfassen!!! Das gehört nur in die Portliste
/interface bridge port add interface=wlan-intern bridge=vlan-bridge pvid=70
/interface bridge port add interface=wlan-gast bridge=vlan-bridge pvid=90 
Wifi ist hier ja ein reiner Access-Port da muss nüscht getagged werden denn die pvid bestimmt wohin das WLAN gehört.
Member: wusa88
wusa88 Feb 27, 2023 at 14:56:33 (UTC)
Goto Top
So sieht es aktuell aus:
bridge-vlan-wlan
wlan-komolett
bridge-bridge
bridge-ports

Muss ich die WLANs mit VLAN jetzt noch zur Bridge hinzufügen?
Mitglied: 6017814589
6017814589 Feb 27, 2023 updated at 15:01:22 (UTC)
Goto Top
Steht doch oben unmissverständlich in meinem Kommentar, sie müssen mit der richtigen PVID in die Port Liste der Bridge, das ist alles was du für die brauchst.

Btw. mit einem Terminal-Export lässt sich effektiver arbeiten, dann braucht man nicht immer tausend Bildchen, Text-Config sagt mehr als tausend Bilder und man hat alles auf einen Blick.
Member: wusa88
wusa88 Feb 27, 2023 at 15:01:40 (UTC)
Goto Top
Habe jetzt erst gesehen, dass du deinen Beitrag nochmal angepasst hast.
Ich dachte, dass man die VLANs nicht extra in die Bridge mit aufnehmen muss? Da es im VLAN Tab hinterlegt ist.
Das ist aber vermutlich nur, wenn die VLANs über eth raus gehen, WLAN intern muss das dann denke ich doch an die Bridge?
Mitglied: 6017814589
6017814589 Feb 27, 2023 updated at 15:06:50 (UTC)
Goto Top
Zitat von @wusa88:
Ich dachte, dass man die VLANs nicht extra in die Bridge mit aufnehmen muss? Da es im VLAN Tab hinterlegt ist.
Doch. Die WIFIs sind Access-Ports, es muss nichts getagged werden hier reicht es sie als Ports hinzuzufügen dann sind sie automatisch mit der PVID im richtigen VLAN.

Das ist aber vermutlich nur, wenn die VLANs über eth raus gehen, WLAN intern muss das dann denke ich doch an die Bridge?
Jepp vlan Tab brauchst du in der Regel nur wenn Dinge getagged aus dem Router fließen oder angenommen werden sollen. Für Access-Ports also Ports an denen Clients hängen reicht es immer diese nur unter den Ports mit der passenden PVID hinzuzufügen. Die PVID erscheint dann automatisch mit einem d auf dem vlan tab.
Member: Visucius
Visucius Feb 27, 2023 at 15:08:45 (UTC)
Goto Top
... und ich sach Euch, das wird episch face-wink
Member: aqui
aqui Feb 27, 2023 updated at 16:14:46 (UTC)
Goto Top
Es ist mein zentraler Router, mit DHCP, VLAN und alles was dazu gehört.
OK, dann hast du alles richtig gemacht und musst NICHTS ändern! 😉
Einzig nur der tote DHCP Server auf dem nicht mehr existierenden Bridge Interface löschen!
Sorry für die Verwirrung oben aber bei "cAP" denkt man erstmal imemr an einen reinen Accesspoint und nicht an einen kompletten Router wie du ihn betreibst. Das hat leider die ganze Diskussion oben in die falsche Richtung gelenkt... Per se ist also bis auf die kleinen kosmetischen Kinken alles OK so. Sorry nochmal.

Erst wenn dieser Router sauber ist, dann will ich mich an das WLAN wagen
Das ist auch goldrichtig so mit dem Vorgehen.
Heißt das Kabelmodem ist an erster Stelle. Das ist aber im Bridge Modus. Heißt mein Zugangspunkt ist der hAP Lite.
OK, hier musst du dann sehr aufpassen:
  • ether1 wenn da dein Vodafone Kabelmodem dran ist (also Internet Zugang) darf NIEMALS Memberport der Bridge sein!
  • ether1 muss dann im IP DHCP Client Mode konfiguriert sein damit es sich eine IP aus dem Vodkafön Netz zieht. Gleichzeitig kommt die Default Route und auch der DNS Server. Das kannst du immer unter den IP Adresses sehen (IP Adresse), bzw. unter IP Route (Default Route) und IP DNS (DNS Server)
  • Ein Ping mit dem internen MT Ping Tool auf 9.9.9.9 und www.heise.de (dann mit DNS Auflösung) sollte immer klappen.
  • In der DHCP Netzwerk Einstellung für die lokalen VLANs wird KEIN DNS Server angegeben. Dann arbeitet der MT als DNS Proxy. Unter IP DNS muss der Haken "Answer remote requests" gesetzt sein!
  • Check mit einem VLAN Client indem du dir dort mal mit ipconfig die IP Adressierung ansiehst. Die muss zum jeweiligen VLAN passen. DNS und Gateway ist der MT. Dann wieder die beiden Pings wie oben ausführen und Connectivity checken.
  • Und denk dran: Das blöde, nichtssagende "defconf" im Comment einfach mal mit etwas Sinnvollem versehen. Das vereinfacht das Verständnis deiner Konfig und das nicht nur für dich!
  • Fertisch
Ich dachte, dass man die VLANs nicht extra in die Bridge mit aufnehmen muss?
Doch, musst du wenn du mit HIER. Die virtuellen APs werden dann mit entsprechenden VLAN Tags versehen in dem sie arbeiten sollen.
und ich sach Euch, das wird episch
Jepp...wo lag nochmal der Thread Rekord bei 97, oder? 🤣
Member: wusa88
wusa88 Feb 27, 2023 updated at 16:12:05 (UTC)
Goto Top
Zitat von @aqui:
  • ether1 wenn da dein Vodafone Kabelmodem dran ist (also Internet Zugang) darf NIEMALS Memberport der Bridge sein!
ether1 ist in meinem Fall kein Memberport der Bridge.
* ether1 muss dann im IP DHCP Client Mode konfiguriert sein damit es sich eine IP aus dem Vodkafön Netz zieht. Gleichzeitig kommt die Default Route und auch der DNS Server. Das kannst du immer unter den IP Adresses sehen (IP Adresse), bzw. unter IP Route (Default Route) und IP DNS (DNS Server)
  • Ein Ping mit dem internen MT Ping Tool auf 9.9.9.9 und www.heise.de (dann mit DNS Auflösung) sollte immer klappen.
Das klappt auch wunderbar. IP kommt von Vodafone und soweit funktioniert auch alles.

* Check mit einem VLAN Client indem du dir dort mal mit ipconfig die IP Adressierung ansiehst. Die muss zum jeweiligen VLAN passen. DNS und Gateway ist der MT. Dann wieder die beiden Pings wie oben ausführen und Connectivity checken.
  • Fertisch

Das klappt leider nicht. Ich wollte mit meinem Notebook in irgendein Wlan gehen, aber ich bekommen keine Verbindung.
Auch mit dem Handy kommt die Meldung "IP Adresse konnte nicht abgerufen werden".
Irgendwo habe ich noch ein gravierendes Problem. Aber wie gesagt, nur im WLAN.

und ich sach Euch, das wird episch
Jepp...wo lag der Thread Rekord bei 97, oder? 🤣

Wenn das mit mir so weiter geht, dann kommen wir da nah dran....
Member: aqui
aqui Feb 27, 2023 updated at 16:19:05 (UTC)
Goto Top
in irgendein Wlan gehen, aber ich bekommen keine Verbindung.
Am LAN Port klappt aber alles wie es soll?? Dann ist es in der Tat NUR noch das WLAN. face-wink
Wenn ja bedeutet das das du das WLAN Interface gar nicht oder in ein falsches VLAN gemappt hast.
Wie gesagt, das virtuelle MSSID WLAN Interface muss dann auf die VLAN ID gemappt werden wie hier im VLAN 20:
wlanmssid.
Member: aqui
aqui Feb 27, 2023 updated at 16:22:42 (UTC)
Goto Top
Das muss er aber wenn er mit MSSID WLANs arbeitet. Die SSID sprich virtuelles WLAN Interface muss ja wissen in welches VLAN es ihren WLAN Traffic forwarden soll. Der Screenshot stammt aus dem Tutorial. 😉
Oder ich hab dich jetzt missverstanden?!
Mitglied: 6017814589
6017814589 Feb 27, 2023 updated at 16:23:29 (UTC)
Goto Top
Zitat von @aqui:
Oder ich hab dich jetzt missverstanden?!
Ja, er arbeitet noch nicht mit CAPSman. Er hat ganz normale Wifi interfaces auf dem Router erzeugt die er jetzt nutzen will, also total simpel.
Member: aqui
aqui Feb 27, 2023 updated at 16:26:59 (UTC)
Goto Top
Das ist auch nicht aus dem CapsMan Setup sondern vom ganz normalen standalone Setup. Da ist das identisch. Ohne Tag kann die SSID ja das VLAN nicht zuordnen... Sonst endet das alles im PVID VLAN 1. Dein Screenshot für 90 und 111 oben zeigt es ja auch.
Member: wusa88
wusa88 Feb 27, 2023 updated at 17:12:38 (UTC)
Goto Top
Zitat von @6017814589:

Zitat von @aqui:
Oder ich hab dich jetzt missverstanden?!
Ja, er arbeitet noch nicht mit CAPSman. Er hat ganz normale Wifi interfaces auf dem Router erzeugt die er jetzt nutzen will, also total simpel.

Total simpel sollte es eigentlich sein. Irgendwas mache ich aber falsch.

Mikrotik AccessPoint IP Adresse

Hier ist meine Einstellung genau wie von dir vorgeschlagen. Es funktioniert aber nicht.

Dort ist die ap bridge eingestellt und darunter die VLAN Tags.
70, 90 und 111 zu sehen auf den Screenshots.
Member: aqui
Solution aqui Feb 27, 2023 updated at 18:57:31 (UTC)
Goto Top
Da fehlen aber deine WLAN Interfaces komplett in der Bridge!!! Die musst du als Memberports in der VLAN Bridge definieren und dann dem VLAN Tag zuweisen in dem der AP arbeiten soll.
Hier als Beispiel für das Master WLAN Interface was in VLAN 10 arbeitet:
wlan1.
Dann in der VLAN Bridge diese Interfaces tagged dem VLAN zuweisen:
wlan2.

Weitere WLANs die andere VLANs bedienen sollen definierst du dann mit virtuellen WLAN Interfaces.
Dazu unter WiFi Interfaces auf das "+" klicken "Virtual" auswählen und diesem virtuellen AP dann ein Master Interface zuweisen je nach Radio Band. Für beide WLAN Bänder musst du das 2mal machen.
wlan3.
Diesen virtuellen APs weist du dann wieder die VLAN ID des entsprechenden VLANs zu in dem der AP arbeiten soll. Das musst du für beide Bänder machen. Beispiel hier für das VLAN 20:
wlan4.
Einfache Logik und kein Hexenwerk!! 😉
Member: wusa88
wusa88 Feb 27, 2023 at 20:22:28 (UTC)
Goto Top
Zitat von @6017814589:

Das ist aber vermutlich nur, wenn die VLANs über eth raus gehen, WLAN intern muss das dann denke ich doch an die Bridge?
Jepp vlan Tab brauchst du in der Regel nur wenn Dinge getagged aus dem Router fließen oder angenommen werden sollen. Für Access-Ports also Ports an denen Clients hängen reicht es immer diese nur unter den Ports mit der passenden PVID hinzuzufügen. Die PVID erscheint dann automatisch mit einem d auf dem vlan tab.

@aqui
Danke für die Hilfe. Hier noch der Beitrag, der mich glauben lies, dass ich unter Bridge - VLANs keinen Eintrag machen müsste.
Das hast du aber mit deinem Beitrag widerlegt und jetzt funktioniert es.
Ich hatte das vermutlich falsch verstanden.

Ich bin jetzt aber wieder Online und es funktioniert!

Danke an alle die hier beteiligt waren. Das war eine schwere Geburt mit mir....

Ich mache mich morgen mal an die Konfig des cAP AC. Da kommen dann vermutlich die nächsten Fragen.
Dann werde ich auch sehen, ob ich hier nochmal frage, was eigentlich auch das ursprüngliche Problem war, oder ob ich einen neuen Thread wie Empfohlen machen.
Mitglied: 6017814589
6017814589 Feb 27, 2023 updated at 21:57:22 (UTC)
Goto Top
Zitat von @wusa88:

@aqui
Danke für die Hilfe. Hier noch der Beitrag, der mich glauben lies, dass ich unter Bridge - VLANs keinen Eintrag machen müsste.
Das hast du aber mit deinem Beitrag widerlegt und jetzt funktioniert es.
Ich hatte das vermutlich falsch verstanden.

Es gibt hier zwei Varianten die beide funktionieren. In beiden Varianten muss das WLAN Interface immer als MemberPort der Bridge hinzugefügt werden und die PVID passend zum WLAN eingestellt werden.
Bei Aquis Variante stellt man dann im WLAN-Interface zusätzlich auf "use-tag" und trägt die VLAN-ID ein und zusätzlich unter den Bridge->VLANs die ID getagged auf die Bridge und das WLAN Interface.

Was aber bei der zweiten Variante auch einwandfrei funktioniert ist das man im WLAN Interface auf "No tag" stellt und die vlan-id weg lässt, und dann unter bridge->vlan auf die vlanID nur das Bridge-Interface tagged einfügt.
Der Grund warum das ebenfalls funktioniert ist, dass ja das WLAN-Interface als MemberPort eine PVID definiert hat, also alles was vom Wifi-Interface untagged ankommt diesem Vlan welches in der PVID definiert ist zugewiesen wird.

Aufpassen muss man aber das man den Frame-Type im Member-Port richtig wählt, bei Variante Aqui muss hier ausgewählt sein das nur getaggte Frames erlaubt sind, bei der zweiten muss man auch ungetaggte zulassen, denn von Wifi-Interface das bei Variante 2 keine Tag Definition hat kommen die Frames untagged am Interface an.
In beiden Fällen kann man natürlich auch "admit-all" benutzen, aber einschränken wie man es benötigt ist sinnvoller.
Member: aqui
aqui Feb 28, 2023 updated at 07:54:05 (UTC)
Goto Top
Ich bin jetzt aber wieder Online und es funktioniert!
👍👏
Das war eine schwere Geburt mit mir....
Dafür ist ein Forum ja da und die Erfahrung mit der Konfig kann dir keiner mehr nehmen! Sieh es also immer positv!

Jetzt nach der Erklärung macht die Variante des Kollegen @6017814589 natürlich auch Sinn. Ist sogar ganz sexy weil man das Tagging dann ausschliesslich nur beim Bridge Setup macht. 😉

Bleibt ja dann nur noch das du deinen Thread hier dann als erledigt markierst.
Member: wusa88
wusa88 Mar 01, 2023 updated at 21:08:41 (UTC)
Goto Top
Jetzt muss ich mich leider nochmal melden.
Irgendetwas passt leider noch nicht ganz.

Nach den ganzen Einstellungen läuft zwar jetzt alles wie gewünscht, aber mir ist ein Problem aufgefallen.

Auch der cAP AC läuft jetzt mit der IP wie oben beschrieben.

Jetzt kommt das große aber. Wenn ich per Kabel angeschlossen bin direkt auf dem hAP Lite, dann habe ich kaum richtigen Durchsatz.
Ich habe eine 50/50Mbits Leitung.
Mit dem Kabel erreiche ich 25 im Download und gerade so 1 Mbit im Upload.
Da stimmt irgendetwas nicht mit den Einstellungen wie ich vermute.

Hänge ich mit dem Handy cAP zb. im VLAN70, dann habe ich die vollen 50/50 anliegen. Also an der Leitung an sich liegt es nicht.
Es gibt auch keine Queues die mich hier ausbremsen würden.

Wo kann ich hier ansetzen um dem Problem auf die Schliche zu kommen?

Edit: Nach einem Reboot habe ich jetzt die volle Leistung im Download, aber im Upload erreiche ich nur 5Mbits statt der 50Mbits (das ganze Kabelgebunden am hAP Lite)

Über den cAP AC erreiche ich nach wie vor die vollen 50/50Mbits.
Mitglied: 6017814589
6017814589 Mar 02, 2023 updated at 04:28:38 (UTC)
Goto Top
Bitte für neue Fragen auch einen neuen Thread benutzen! Das hat rein gar nichts mehr mit der ursprünglichen Frage gemein.
Und bitte gewöhne dir an statt immer 1000 und 1 Bildchen zu posten, bei Mikrotik Routern immer zu aller erst einen export der Config im Terminal als Text einzustellen, dann entfallen die üblichen Nachfragen von selbst und man kann Fehlkonfigurationen i.d.R. schon daran erkennen. Danke.
Member: aqui
aqui Mar 02, 2023 at 07:27:36 (UTC)
Goto Top
Auch der cAP AC läuft jetzt mit der IP wie oben beschrieben.
Mit dergleichen?? Würde ja bedeuten das der DHCP Server doppelte IPs vergibt. Das kann hier sicher niemand wirklich glauben und dann stimmt in der Tat irgendetwas ganz sicher nicht in deinem Setup.
Wenn der cAP jetzt der reine AP ist hat der
  • nur ein einziges VLAN Interface im Management VLAN
  • einen DHCP Client auf das VLAN Interface gebunden
  • Fertisch
Damit zieht er sich vom zentralen Layer 3 Switch eine IP im Management Netz die niemals doppelt sein kann.
Zum Rest hat Kollege @6017814589 schon alles gesagt.
Member: Visucius
Visucius Mar 02, 2023 at 07:37:31 (UTC)
Goto Top
Zum Rest hat Kollege @6017814589 schon alles gesagt.
Noch nicht vollumfänglich:
Terminal/CLI > export hide sensitive

Und das Ergebnis hier posten. Wie oben gesagt.

Zudem ist der Case hier schon länger closed. D.h. damkommen keine neuen Inputgeber als die, die sich hier bisher schon geäußert haben. Deshalb möglichst neuen Thread!
Mitglied: 6017814589
6017814589 Mar 02, 2023 updated at 10:17:35 (UTC)
Goto Top
Zitat von @Visucius:

Zum Rest hat Kollege @6017814589 schon alles gesagt.
Noch nicht vollumfänglich:
Terminal/CLI > export hide sensitive
Dann aber bitte auch richtig mit Bindestrich!
export hide-sensitive
Btw. in ROS v7 zeigt ein einfaches "export" ohne die Option "show-sensitive" eh keine sensitiven Informationen mehr an ein angehängtes "hide-sensitive" ist da gar nicht mehr nötig, die Option ist nur noch der Abwärtskompatibilität halber noch vorhanden.

screenshot
Member: Visucius
Visucius Mar 02, 2023 at 08:23:40 (UTC)
Goto Top
Good 2 know face-wink

Ich mache immer export > TAB
Kann mir so Kleinigkeiten wie Bindestriche eh nicht merken