Mikrotik CAP AC als Wlan Bridge

Mitglied: theoberlin

theoberlin (Level 2) - Jetzt verbinden

22.02.2021 um 22:22 Uhr, 845 Aufrufe, 30 Kommentare

Hallo zusammen,

ich habe mal wieder ein kleines Problem.
Folge Idee:

5Ghz Modul des CAP AC wird als Client in ein WLAN eingebunden(Station).

2.4 GHz Modul gibt als AP ein neues WLAN aus.

Modus soll eine reine Bridge sein.

Leider klappt das ganze nicht. Ich habe das 5 GHz Modul bereits als Client angebunden. Auch das 2.4 GHz läuft als AP.

Ich bekomme aber keine transparente Bridge ans laufen. DHCP kommt nicht durch was es durch die Bridge ja eigentlich müsste.
Ich muss irgendwo noch einen Denkfehler haben.

Ach manuelle IPs im 2.4 GHz Netz erreichen den Router im 5Ghz Bereich nicht.

Hat hier jemand einen Anstoß?

LG
Theo
30 Antworten
Mitglied: Spirit-of-Eli
22.02.2021 um 22:30 Uhr
Moin,

hast du denn auch eine bridge zwischen den Interfaces laufen? Deine Ausführung zur Konfig selbst ist sehr dürftig.

Was ist denn die Gegenseite wo sich das 5GHZ interface einloggt? Auch ein Mikrotik mit aktivierter Bridge Funktion?
Wie sieht die König des Clients aus?

Gruß
Spirit
Bitte warten ..
Mitglied: theoberlin
22.02.2021, aktualisiert um 23:24 Uhr
Hi,

es ist eine Bridge zwischen den beiden WLAN Ports und eth.0.

Auf dem CAP direkt kann ich externe IPs anpingen und DNS auflösen. Das läuft.

Die Gegenseite vom 5Ghz wird ein Speedport sein. Ist aktuell noch eine Fritzbox.

Sämtliche Firewall Regeln im CAP sind gelöscht.

Das einbuchen in das 2.4 GHz wlan läuft ebenfalls. Client zum Testen ist ein Win10 Laptop oder IPhone.

Aus dem Client Wlan ist aber kein Pingen möglich als auch kein DHCP etc. Es kommt quasi nichts über die Bridge.

LG
Theo
Bitte warten ..
Mitglied: SchmitzKatz
22.02.2021, aktualisiert 23.02.2021
Aus dem Client Wlan ist aber kein Pingen möglich als auch kein DHCP etc. Es kommt quasi nichts über die Bridge.
Lies dir das mal in Ruhe durch dann weißt du anschließend wieso ;-) face-wink
https://wiki.mikrotik.com/wiki/Manual:Wireless_Station_Modes
Statt bridgen route hier zwischen den Netzen das ist eh effizienter als den ganzen Broadcast-Müll über beide Wifis raus zu pusten.
Bitte warten ..
Mitglied: theoberlin
23.02.2021 um 08:37 Uhr
Danke, hatte ich vorher schonmal durchgeackert, aber ich habe vorhin gesehen, dass er beim Connect nach der Netzsuche den Typ wieder auf Station abändert.

Routen ginge natürlich auch, aber ich will eigentlich im gleichen Netz bleiben.

Ich teste das heute Abend nochmal mit dem nachträglichen umstellen auf die Station-Bridge-clone.
Bitte warten ..
Mitglied: aqui
23.02.2021, aktualisiert um 09:48 Uhr
Routen ginge natürlich auch, aber ich will eigentlich im gleichen Netz bleiben.
Ist das zwingend ?
Wenn du 2 Netze verbindest bedenke das der gesamte Broad- und Multicast Traffic aus den zu bridgenden Segmenten den schmalbandigeren Funklink belastet und in der Wirkbandbreite schmälert was je nach Last auf die Performance bzw. Durchsatz des Links geht.
Gut, wenn das nur 2-3 Stationen sind sicher vernachlässigbar. Bei 20-30 sieht das aber schon ganz anders aus. Das solltest du beachten.
Es gilt da wie immer die goldene Netzwerker Regel: "Route where you can, bridge where you must." Die Aussage ist da eindeutig !

Ansonsten hilft dieser Link ggf. beim Bridging:
https://wiki.mikrotik.com/wiki/Manual:Wireless_VLAN_Trunk
Kann sogar VLAN Tags mit übertragen ! ;-) face-wink
Bitte warten ..
Mitglied: theoberlin
23.02.2021 um 10:02 Uhr
Hi Aqui,

das ganze ist für einen Home Arbeitsplatz der im Keller sehr schlechtes WLAN hat.
Ich bin überhaupt kein Freund von Repeatern und ein Kabel kriege ich dort nicht hin.

Daher die Idee den Mikrotik direkt im Keller „unter“ den Speedport zu packen und dort ein neues WLAN aufzumachen.
Da das ganze nur bei der Kollegin zuhause stattfindet ist da nicht viel los. Dann lieber mit Broadcast damit irgendwelche Home Lösungen aka Sonos etc. noch laufen.

Theo
Bitte warten ..
Mitglied: aqui
23.02.2021 um 10:07 Uhr
OK, unter den Vorausetzungen kannst du dann natürlich auch bridgen... 😉
Bitte warten ..
Mitglied: Spirit-of-Eli
23.02.2021 um 10:14 Uhr
Der TO sollte darauf achten auf der "Station" dieses MAC Adresse bridging zu aktivieren. Sonst melden sich alle Clients mit der MAC des Mikrotiks.
Bitte warten ..
Mitglied: theoberlin
23.02.2021 um 10:18 Uhr
Ja, dass müsste der Modus Station-Pseudobridge-Clone sein.

Teste ich heute Abend.
Bitte warten ..
Mitglied: Spirit-of-Eli
23.02.2021 um 10:49 Uhr
Zitat von @theoberlin:

Ja, dass müsste der Modus Station-Pseudobridge-Clone sein.

Teste ich heute Abend.

Ne, der Mode "Station-Bridge" ist korrekt. Es bedarf unter Reiter Wireless unten noch einem Haken "bridge". Ein Beispiel habe ich gerade nicht zur Hand.
Bitte warten ..
Mitglied: theoberlin
23.02.2021 um 10:54 Uhr
aber station-bridge ist ja propritär mit dem Austausch der MAC Tabellen.

Der Mikrotik hängt ja später an einem Speedport und nicht an einem weiteren Mikrotik.

Aber ich probiere es trotzdem und suche den Haken.

LG
Theo
Bitte warten ..
Mitglied: Spirit-of-Eli
23.02.2021 um 12:07 Uhr
Zitat von @theoberlin:

aber station-bridge ist ja propritär mit dem Austausch der MAC Tabellen.

Der Mikrotik hängt ja später an einem Speedport und nicht an einem weiteren Mikrotik.

Aber ich probiere es trotzdem und suche den Haken.

LG
Theo

Ich will nicht abstreiten, dass ich mich vertuhen könnte. Ich habe gerade keine Beispiel Installation greifbar.
Bitte warten ..
Mitglied: SchmitzKatz
23.02.2021, aktualisiert um 13:44 Uhr
Zitat von @Spirit-of-Eli:


Del "h" = vertun

Vert und Hun geht immer, am besten mit viel Soße 😁
Bitte warten ..
Mitglied: theoberlin
23.02.2021 um 20:48 Uhr
Hallo zusammen,

also im Modus Station Pseudobridge klappt DHCP im gebrückten WLAN etc.

Allerdings ist der Durchsatz absolut miserabel. Download ist mit 20mbit noch tolerabel aber der Upload ist quasi Null.

Gibts hier noch ne Idee?

Lg
Theo
Bitte warten ..
Mitglied: SchmitzKatz
23.02.2021, aktualisiert um 22:04 Uhr
Das einzig wahre bei sowas: ROUTING, oder wenn kein Kabel möglich dann Powerline ! Da hier ein RouterOS fremder AP zum Einsatz kommt hast du hier keine andere Möglichkeit bei den Modes.
Bitte warten ..
Mitglied: 147448
147448 (Level 1)
23.02.2021, aktualisiert um 23:17 Uhr
Und wo ist das Problem ?

Du hast nur das eine WLAN Interface ! Und nun ? Nicht verzagen Andy fragen !

Du stellst das Master Interface WLAN1 auf Station !
Dazu musst du die Client Daten des WLAN eingeben, das geschieht in einem Security Profile unter WLAN !
Also mal weg von dem ganzen Quick schitte.
Jetzt hast du zwar den Master als Client auf deine Basis angemeldet, und nun geht es weiter !

Du klicks auf der Interface Liste auf das Hinzufügen Zeichen, und erzeugst einen Virtuellen AP !

Der muss natürlich auch mit einem eigenen Security Profil ausgestattet werden, aber es geht.

Und nun musst du dir nur den Kopp machen, ob du von dem einen Eingang alles rein Durchbridges oder ein neues eigenes WLAN aufmachst, mit einem eigenen Addresss Bereich, und NAT und Firewall ...

eigentlich ganz Primitiv

Edit: nur im reinen Bridge Modus würde ich mir jetzt hier kein all zu hoch Nutzbare Bandbreite erwarten, oder zur Verfügung zu stellen !

Jetzt kommt es noch auf dein ROS an, weil dann kan man auch im VAP Modus eine andere Frequenz oder Kanal nutzen ;)
Bitte warten ..
Mitglied: theoberlin
24.02.2021 um 06:19 Uhr
@Schmitz
Powerline kann man probieren. Habe ich bis jetzt nicht, da es ein altes Haus mit relativ unordentlicher Verkabelung ist und da kommt bei Powerline ja meist nicht viel bei rum.

Routing werd ich dann wohl mal testen.

Nur mal für mich:

- Bridge löschen
- 5Ghz als Station
- 2,4 GHz als AP Bridge
Dort:
Neue Adresse mit DHCP Server

Gibts noch was was man beachten Muss und irgendwo versteckt ist?

@ Andy
Der CaP AC hat Zwei WLAN interfaces. Und die sind vom Connect her auch nicht mein Problem. Und ich hätte echt nicht gedacht das eine blöde Bridge zwischen zwei wlan interfaces so ein Problem ist.
Bitte warten ..
Mitglied: SchmitzKatz
24.02.2021, aktualisiert um 07:53 Uhr
Zitat von @theoberlin:
Routing werd ich dann wohl mal testen.

Nur mal für mich:

- Bridge löschen
- 5Ghz als Station
- 2,4 GHz als AP Bridge
Dort:
Neue Adresse mit DHCP Server

Gibts noch was was man beachten Muss und irgendwo versteckt ist?
Wenn du am 5GHz Interface keinen DHCP Client einsetzt um die Default Route zu setzen musst du diese noch als statische Route unter IP > routes setzen 0.0.0.0/0 -->IP des Speedport, und natürlich die IP statische IP des Mikrotik unter IP>Addresses setzen.
Zusätzlich wird es nötig sein am Mikrotik ausgehenden Traffic am 5GHz Interface zu NATen (Masquerading) da sich auf den Speedport-Gurken bekannterweise keine statischen Routen anlegen lassen, diese aber für transparentes Routing nötig sind damit der Speedport weiß woher die Pakete des fremden Netzes stammen. Ohne diese würde er die Pakete aus dem fremden Netz fälschlicherweise ins Internet routen.
Bitte warten ..
Mitglied: theoberlin
24.02.2021 um 08:05 Uhr
Am 5Ghz Interface ist ein DHCP Client.
Das NAT masquerading ist nochmal ein guter Hinweis.
Und ja Speedports....unfassbar wie man Geräte so stark auf den reinen Home Anwender auslegen kann.

Mal gucken was heute Abend rauskommt.

Theo
Bitte warten ..
Mitglied: SchmitzKatz
24.02.2021, aktualisiert um 11:20 Uhr
Und ja Speedports....unfassbar wie man Geräte so stark auf den reinen Home Anwender auslegen kann.
Naja, man bekommt was man bestellt und einen Home-Anschluss bestellt ein Business Kunde wohl kaum ;-) face-wink. Dank Routerfreiheit kann das jeder Kunde selbst entscheiden. Es hindert dich also keiner daran dort einen vernünftigen Router zu setzen dann hast du die ganzen Beschränkungen allesamt nicht.
Bitte warten ..
Mitglied: theoberlin
24.02.2021, aktualisiert um 11:29 Uhr
Da bin ich absolut bei dir. Aber ich kann jetzt keine Firmenrouter an die Privatanschlüsse der Homeofficler klemmen.

Und was business und Home angeht gibts ja bspw. die FRITZ!Box als schönes Beispiel wie man Home Anschlüsse versorgen kann, ohne sie technisch völlig zu kastrieren. Zumindest die Basics wie Routen / Portfreigaben sollten machbar sein.

Aber ja...
Bitte warten ..
Mitglied: 147448
147448 (Level 1)
24.02.2021 um 20:23 Uhr
Komme mal auf den Punkt !

Du laberst hier einen solchen Unsinn ! Mal so, mal so !

Einmal geht das nicht, einmal so das nicht möglich sein !

Frei nach dem Motto einer Kindersendung "Nimm den Bleistift und mal etwas ! " Damit wir das auch mal erfassen können !

Meine Glaskugel hatte Urlaub beantragt, und ist jetzt auch noch "TANTEN" positiv
Bitte warten ..
Mitglied: theoberlin
24.02.2021, aktualisiert um 20:57 Uhr
Sag mal Andy gehts noch? Nur weil dein Post am Problem vorbei geht und du anscheinend nicht mitliest musst du noch lange nicht unfreundlich werden.

Ich glaube die Situation ist ziemlich klar, ich kann aber auch gern nen Diagramm machen.

https://administrator.de/images/c/1/7/5e5139336b934e24b44596ed6adeebcd.j ...

Zurück zur Frage:

Im Routing habe ich den selben Effekt mit dem quasi nicht vorhandenen Upload.

- Mikrotik ist als Station ins 5Ghz Netzwerk (192.168.174.0) eingebunden.
- Mikrotik ist als DHCP Client registriert.
- 2,4 Ghz im AP Bridge Modus hat statische Adresse und DHCP Server
- Client hat Internet Zugriff im neuen Netz (192.168.175.0)
- Der Download ist halbwegs in Orndung. Der Upload zeigt genau das selbe Verhalten mit o.o1 MBps. Bridge und Routing Methode zeigen also das selbe Verhalten.
- Um die NAT Problematik erstmal auszuklammern, habe ich in meiner Fritzbox hier zuhause eine Route ins 175er Netz angelegt.

Noch jemand eine Idee warum der Upload über den Mikrotik quasi nicht vorhanden ist?

Theo
diagramm1 - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: 147448
147448 (Level 1)
24.02.2021 um 21:36 Uhr
Ich werde definitiv nicht unfreundlich !

Speedport mit 5 GHz WLAN

Der Cap AP findet die SSID des Speedports und bekommt eine Adresse ! IPv4 oder IPv6 ?

Das WLAN Interface 2,4 Ghz ist nun ?


Aber eine andere Frage die ich mir gestatte ! Nutzt du die Quick Lösung ? Odermachst du das alles händisch ?

Wenn Quick , dann könnten "Altlasten" noch im System sein, die dir jetzt Probleme bereiten !


Wenn die IP Verwaltung auf der Speedbox bleiben soll, dann ist es nur eine Bridge !

Beide Interface einzeln und unabhängig voneinander Konfigurieren. Dann eine Bridge aufmachen und die beiden Interface miteinander Verbinden ! Über Bridge Ports !
Bitte warten ..
Mitglied: theoberlin
24.02.2021 um 21:47 Uhr
Ich starte immer ohne default config clean.

Der CAP AC hat ein 5Ghz und ein 2.4 GHz Interface.

5Ghz Interface wird mit dem Speedport 5 GHz WLAN verbunden. Und bekommt per DHCP Client eine V4 IP.

Das 2.4 GHz Interface vom Mikrotik läuft als AP Bridge und stellt ein eigenes WLAN zur Verfügung.

Hier war der erste Versuch das ganze über eine Bridge im gleichen Netz zu versuchen und der zweite mit Routing und separatem DHCP Server auf dem 2.4 GHz Interface.

Beides führt am Client in dem 2.4 GHz WLAN zur Verbindung mit moderater Download und quasi nicht vorhandener Upload Rate.
Egal ob per Netz/DHCP vom Mikrotek oder mit der Bridge auf den WLAN Interfacen und DHCP vom Speedport.

Theo
Bitte warten ..
Mitglied: 147448
147448 (Level 1)
24.02.2021, aktualisiert um 22:01 Uhr
Clean Config !

Ok
WLAN 5 GHZ von Speedport als DHCP Client, wenn das Interface in Running geht !
Damit siehst du ob alles klappt. Das geht auch über MAC Telnet ,oder MAC WINBOX !

Jetzt konfigurierst du dir dein 2.4 GHZ WLAN mit einem eigen neuen Sicherheitsprofil

Nun machst du im Menü Bridge ein neue auf, udn im Reiter PORT das Ausgangsinterface ! Also die 2,4 Sache !

Dann machst noch einen neuen Port auf, der sich nicht mit der IP , sodern nur mit dem 5 GHZ Station Client verbindet.

Da wird nichts geroutet nur gebridgest !
Aber wenn mehr als 1 /einer über die Bridge eine IP von dem Speedport haben wird das nichts !

Dann musst du mehr machen
Bitte warten ..
Mitglied: theoberlin
24.02.2021 um 22:11 Uhr
Das ist ja alles schon durch.

5Ghz connect läuft. 2.4 GHz AP ebenfalls.

Im MOMENT bin ich beim Routing Thema. Auch wenn ich lieber bridgen würde. Aber am Ende hängen da mindestens zwei Clients dran.

Auch der Zugriff im 2.4 GHz Netz klappt. NUR eben mit quasi nicht vorhandenem Upload. Das ist gerade mein Problem.
Selbiges hatte ich auch als eine Bridge über den beiden WLAN Interfaces hing und das 5 GHz Interface als pseudobridge läuft.

Client Connect, aber quasi kein Upload.

Theo
Bitte warten ..
Mitglied: 147448
147448 (Level 1)
24.02.2021 um 22:27 Uhr
Ohne das was im Hintergrund steht, kann ich keine Aussage machen !

Aber wenn du oder dir ein NAT egal ist, dann mach es anders !
Gib dem WLAN 2,4 AP Bridge eine IP ! Weise diesem eine einen DHCP Server zu, mache ein NAT auf das 5 GHZ Interface.

Und lass die Pfoten von irgendwelchen Routing regeln.
Bitte warten ..
Heiß diskutierte Inhalte
Windows 10
Windows 7 pro Lizenz nutzen für Windows 10
lukas0209Vor 1 TagFrageWindows 1016 Kommentare

Hallo Community, ich versuche seit einigen Wochen unser Netzwerk von Windows Server 2008 R2 Standard auf Windows Server 2016 Essentials um, welches eine städtische ...

Microsoft
Staatsanwaltschaften verschicken Vorladungen in Sachen Windows 10 Lizenzkeys
kgbornVor 1 TagInformationMicrosoft5 Kommentare

Nur zu Info für die Käufer der eBay-Schnäppchen - neuer Fall Staatsanwaltschaften verschicken Vorladungen in Sachen Windows 10 Lizenzkeys

Router & Routing
Vodafone Kabel: Eigenen Router an den Kabelanschluss oder einen WLAN-Router ohne Modem hinter die Vodafone Station?
gelöst DyingWordsVor 1 TagFrageRouter & Routing8 Kommentare

Hallo zusammen, da wir demnächst in eine Wohnung mit Kabelanschluss von Vodafone einziehen werden, frage ich mich, ob es sinnvoller ist einen eigenen Router ...

Netzwerke
Netzwerklaufwerk - Nur Lesen (Streamen)
CryexXVor 1 TagFrageNetzwerke8 Kommentare

Hallo, ich hab mal ne Frage und hoffe auf Lösung. Mir schießt aktuell keine in den Kopf :( Ich möchte ein Netzlaufwerk freigeben. Auf ...

Linux
Knoppix 9.1 verfügbar
sabinesVor 1 TagInformationLinux6 Kommentare

Klaus Knopper hat eine neue Version zum Download bereitgestellt. Achtung in der Übersicht ist noch die Version 8.6.1 aus 2019 genannt, im Downloadverzeichnis ist ...

Netzwerke
Multi WAN Router
JoergDittVor 1 TagFrageNetzwerke9 Kommentare

Hallo zusammen, folgende Situation wir versorgen ca 150 Refugess in einer Gemeinschaftsunterkunft mit freiem WLAN Aktuell haben wir einen Fritzrouter mit Richtantenne an einer ...

Netzwerke
Wieviel parallel TCP Verbindung zum Datenserver erlauben
gelöst decehakanVor 1 TagFrageNetzwerke4 Kommentare

Hallo Zusammen, ich spiele gerade mit meinem Ubuntu Server mit der Firewall iptables rum und würde gern wissen wieviel man parallele Verbindung zum Datenserver ...

Windows Systemdateien
Windows CE 6.0 Problem
gelöst PepsiDoseVor 1 TagFrageWindows Systemdateien10 Kommentare

Servus, Ich habe letztens ein alten mini. Netbook mobile Computer gefunden (Oder wie die heißen) welches Windows CE 6.0 betreibt. Mein Problem ist, es ...