samvanratt
Goto Top

Mikrotik Repeater Bridge Probleme

Hallo zusammen
aufgrund eines von mir empfohlenen WLAN Netzwerkes auf MT Basis darf ich nun an einigen Stellen nachbessern. Aqui sei dank habe ich da einige merkwürdige MT Hürden genommen, bzw. nicht aufgegeben.

Hintergrund ist die Unfähigkeit EAP bei einigen (mobil) Geräten einzustellen und Funkschatten auszugleichen. Beides führt immer zu vernichtenden Kritiken, was sehr negativ rüberkommt (egal wer daran schuld ist). Deshalb möchte ich eine Repeater Bridge (eigentlich gut bei MT beschrieben) einsetzen, welche auf der einen 2,4GHz hört (WPA2-EAP) und per PEAP sich anbindet und auf WPA2-PSK im 5GHz sendet (eigene SSID). Hardware sind die MT hAP ac (FW: 6.48.2 und .4) welche "gerade mal so rumliegen".
Dazu habe ich mir daheim ein nahezu gleiches (CAPSMAN2 basierendes) Testsystem (gleiche SSID, gleiche Passwörter, gleiche Frequenzen) aufgesetzt, eingerichtet, geht und hingeschickt=> geht nicht. OK, draufgeschalten und die gleiche SSID (Empfängerseitig) erneut angeklickt, neu gestartet und geht, super. Umgesteckt (soll ja wireless laufen) geht nicht mehr. Zurücksenden lassen, scheint zu gehen wie soll, resetet und einen Besuch VorOrt eingelegt. Die üblichen Verdächtigen wie falsche/fehlende Länderkennung, indoor/outdoor, Auto Frequenzen oder Sonstige sind sicher ausgeschlossen!

Dort konfiguriert, dann fast verzweifelt, denn mal geht's nach Start mal nicht:
-startet
-bindet sich erfolgreich (EAP auf wlan1) ins Hausnetz ein und meldet erfolg; ich kann mich so auch aufschalten, aber die Sendefunktion ist aktiviert (wlan2) tut aber nichts im Sinne von SSID broadcasten. Ich deaktiviere das wlan2 in der Winbox und aktiviere sie wieder:geht; ich starte neu geht nicht bis ganz selten ab boot.
-reboot und selten geht es, mal aber schon.

Meine Erklärung dafür wäre, dass der Station mode (wlan1) länger braucht (DHCP), als der AP bridge mode um sein wlan2 hochzukriegen, dann hat er keine IP und schmollt (bis zum disablen und enablen). Nahezu alle APs die ich kenne wollen explizit eine IP bevor sie loslegen. Ich habe die Konfig jedesmal neu erstellt (winbox) anstatt auf meinen alten Fehler (konfig importieren und "sollte dann gehen") aufzubauen.

Der DHCPd (pfsense) dort braucht eigentlich nicht länger als bei mir oder hat eine nenneswerte Last.

Kann sich die Ursache jemand vorstellen; meine Erklärung ist schon weit hergeholt (bei meinem nahezu identisch aufgebauten Repeater daheim (nur mit einem WLAN NIC (virt wlan)) geht die Funktion wie soll.

Kennt jemand eine Möglichkeit wie ich das gestaggert geordnet hochkommen lasse um die "Fehlfunktion" zu fixen und bestätigen?

Gruß
Sam

Content-Key: 1301444687

Url: https://administrator.de/contentid/1301444687

Printed on: June 13, 2024 at 16:06 o'clock

Mitglied: 149569
149569 Sep 24, 2021 updated at 16:36:10 (UTC)
Goto Top
Hi.
Viel Text aber leider etwas wenig handfeste Fakten zur Config.

Fragen:
  • Gegenstelle für das WIFI Interface das sich per EAP authentifiziert ist auch Mikrotik Hardware?
  • Wenn vorherige Frage mit "ja" beantwortet wurde, verwendest du ein Bridge-Interface in das du beide Wifi Interfaces rein wirfst und den AP im "ap-bridge" mode und die station im "station bridge" mode betreibst, oder routest du stattdessen, mit den Clients am AP in einem separaten Subnetz?
  • Wenn erste Frage mit "nein" beantwortet wurde, routest du oder verwendest du eine Bridge? Bei letzterem müsste der AP dann nämlich im "pseudo bridge mode" laufen und dann wäre auch nur ein einziger Client am AP möglich wegen der MAC Geschichte bei Wifi Bridges mit fremder Hardware.

Alles in allem wäre es zu aller erst mal sinnvoll hier die Config im klartext zu posten damit man hier nicht raten muss wie die Config nun tatsächlich aussieht.

/ht
Member: SamvanRatt
SamvanRatt Sep 24, 2021 at 16:46:03 (UTC)
Goto Top
Hallo hacktor
die Anleitung "verpflichtet" zum bridge Modus (ich will ja den DHCP Traffic und co 1:1 durchreichen) und ja da ist rein MT im Einsatz (CAPSMAN2 geht afaik nur mit MT pur).

Das Anbinden klappt auch immer (sehe ich an der IP Vergabe und der vorherigen RADIUS Abfrage); der AP Mode will nicht so.

Die Config habe ich aus gutem Grunde nur via GUI gemacht, da ich im ersten Go (so Mai 2021) NUR schlechte Erfahrung mit export/import hatte und zum Schluß auf aquis Tipp mit backup/Restore im Files umgestiegen bin.

Ich kann es aber gerne (blind) beschreiben, nach gut 10 Durchläufen hat man es recht schnell wieder zusammen:

-reset config
-CPE Mode mit "Bridge all ports" +Auto Address +
-Firmware "stable" neueste
-WLAN Security Profile WPA-ENT erstellen; Mode dynamic Keys + Auth WPA2 EAP (aes/ccm) + Supplicant ID = GastWLANx + PEAP +mschapv2 + GastWLANx + Passwort
-WLAN Security Profile WPA-PSK erstellen; Mode dynamic Keys + Auth WPA2 PSK (aes/ccm)=> GastWLANx + PW
-WLAN1 Interface (=Empfänger)=>advanced; Mode: station pseudobridge + 2GHZ auf n-only setzen; Channel=20MHz + country:germany + Frequency=Auto + Installation=indoor; Skip DFS:disabled; Wireless Protokoll: 802.11; SSID=Hotel; Security Prof=WPA-ENT
-WLAN2 Interface (=Sender)=>advanced; Mode: ap bridge + 5GHZ auf N/AC-only setzen; Channel=20MHz + country:germany + Frequency=Auto + Installation=indoor; Skip DFS:disabled; Wireless Protokoll: 802.11; Security Prof=WPA-ENT; SSID=GastWLANx; skipDFS ch.=disabled; Wireless Proto=802.11; Security Pro=WPA-PSK; WPS-Mode=disabled; Installation=indoor; BridgeMode=enabled
-Check Bridge Settings
-IP_Services=>api+api-ssl+telnet+www+www-ssl deaktivieren
-System_Clock=> EU/Berlin
-System_Identity=>GastWLANx
-System_Password: X
-System_SNTP: Enabled + X

Ich denke das ist es komplett. Die Basis dazu kommt vom "www.MikroTik-Training-Center.de"

Gruß
Sam
Member: Visucius
Visucius Sep 25, 2021 at 07:32:27 (UTC)
Goto Top
HW durchwechseln/tauschen?
Mitglied: 149569
149569 Sep 25, 2021 updated at 09:58:53 (UTC)
Goto Top
Mode: station pseudobridge
Das ist eine schlechte Wahl! "station-bridge" wäre hier das Mittel der Wahl bei Mikrotik Hardware.
Das erklärt das du solche Probleme hast!

Der Mode pseudobridge ist nicht umsonst von Miktotik als
should be avoided when possible
markiert
https://wiki.mikrotik.com/wiki/Manual:Wireless_Station_Modes
und hat entsprechende Beschränkungen:
This mode is limited to complete L2 bridging of data to single device connected to station (by means of single MAC address translation) and some support for IPv4 frame bridging - bridging of non-IP protocols to more than one device will not work. 
Also MAC address translation limits access to station device from AP side to IPv4 based access - the rest of protocols will be translated by single MAC address translation and will not be received by station itself.

This mode is available for all protocols except nv2 and should be avoided when possible. 
The usage of this mode can only be justified if AP does not support better mode for L2 bridging (e.g. when non-RouterOS AP is used) or if only one end-user device must be connected to network by means of station device.

Da du ja überall Mikrotik Hardware hast ist das auch nicht nötig auf den pseudobridge Mode auszuweichen, hat da eigentlich nur Nachteile.
Member: SamvanRatt
SamvanRatt Sep 27, 2021 at 20:43:03 (UTC)
Goto Top
Hallo Visucius
wie geshrieben habe ich da mehrere (gleiche hAP ac) zur Hand gehabt mit ähnlichen Verläufen. Nachdem immer nur 5GHz nicht ging dachte ich beim ersten auch an einen evtl. HW Fehler.
Gruß
Sam
Member: SamvanRatt
SamvanRatt Sep 27, 2021 at 20:50:07 (UTC)
Goto Top
Hallo hacktor
Danke deines Hinweises. Ich kann mich akut nicht erinnern wieso es bei mir daheim notwendig war (L2 Fähigkeit oder sonstwas) aber die kleine Box (caplite) die ich nutze kann es eben genau so.
Ich war am WE mal "kurz" dort und habe die bei mir laufende Konfig (ohne 5GHZ Problem) dort probiert=>genau der Effekt, mal geht mal geht nicht. Dann habe ich den Hinweis "bitte keine Station pseudobridge" nutzen (sehe da keinen Grund) eingetragen=> geht mal, mal nicht. Dann anderen Scanner probiert, dann komplett neu aufgesetzt, anstatt meine Konfig zu verändern=> keine Veränderung.

Als es mal ging habe ich mir was zu trinken geholt und als ich wiederkam ging es nicht mehr; ich wollte gerade mein macbook holen, als es dann wieder ging. O.K......

Nachdem ich schon die Wände hochgehen wollte, habe ich einen Bekannten aus München angerufen, welcher mir riet nur mal zu scannen. Ich habe einen hAP dazu geleert und dann halt als dummen Scanner im 5GHz genutzt.
Tat ich über knapp zwei Stunden und siehe da: alle 15 Minuten in etwa sind die mittleren+oberen Bändern voll belegt für einige Minuten. Die oberen nutze ich aber als fixe Frequenz (schlechte Idee....).
=> Wetterradar. Ist eine dokumentierte Stelle hier in den Allgäuer Alpen und wir sitzen rund 2km entfernt und die scheinen da nicht mit 200mW zu arbeiten. Da ich DFS Einfluss erlaubt habe dürfte der hier dicht gemacht haben und eine Operation mit Null (volle Bänder nicht nutzen) ist immer Null egal ob ich dann woanders sage fix nutzen. Klingt logisch.

Ich habe jetzt die vier unteren empfohlenen Bänder mal fix eingestellt=>geht in jedem Versuch; auf Auto gestellt, ebenso. Auto kenne ich aus sehr schlechter Erfahrung mit open/dd-wrt=>fix einstellen geht. Mag bei MT anders sein.

Ich denke das war der ganze Fehler?! Ich habe jetzt einen AP dort gelassen zum Test und hoffe das bleibt so und ein wenig Erfahrung damit gesammelt wird. Ich habe die Einstellung mal auf "station bridge" gelassen; ist sicher sauberer (bei mir läufts aber auch so).

Gruß
Sam