easyma
Goto Top

Möchten Sie zulassen, dass durch die App Änderungen vorgenommen werden?

Hallo,
ich stehe auf dem Schlauch und der bezahlte Support kann hier auch nicht weiterhelfen.

Ich habe ein Windows Server 2016 Betriebssystem, auf dem SAP Business One läuft. Letzte Woche wurde auf dem Server eine neue Installation vom SAP Business durchgeführt, oder es wurden nur Ordner kopiert (zumindest wenn ich in die Installationen gucke, da sehe ich keine Veränderung).

Wenn sich nun ein User anmeldet, dann erscheint, die Meldung "möchten Sie zulassen, dass durch diese App Änderungen vorgenommen werden?"

Die Benutzerkontensteuerung ist bereits auf niedrieg.
Wenn ich mich als Admin anmelde, bekomme ich auch keine benachrichtigung.

Ich habe zu diesem Thema leider nicht viel gefunden.

Nun ist das jetzt kein großes Problem, wenn die Leute dort auf "Nein" klicken geht es weiter, es gibt aber leider Mitarbeiter die jetzt dort ihr PW eingeben und dann beim Helpdesk anruffen.

Daher meine Frage, ob einer eine Idee hat, wie man das Thema gut lösen könnte, oder zumindest die Ursache ermitteln könnte?

Im Eventlog finde ich nichts zu.
61159a34fa7ba71416508d54081d9f49__01

Content-Key: 3611666515

Url: https://administrator.de/contentid/3611666515

Ausgedruckt am: 25.09.2022 um 10:09 Uhr

Mitglied: radiogugu
radiogugu 10.08.2022 aktualisiert um 21:04:37 Uhr
Goto Top
Hallo.

Die Benutzer melden sich an PC oder einem Remote Desktop Server an?

Es erscheint die UAC auf den PC, korrekt?

Wenn dort einmal mit Admin Zugangsdaten das Fenster ausgefüllt wurde, erscheint es dann erneut?

Wenn das Phänomen auftrat nachdem ein Dienstleister aktiv war, dann diesem hier die Nachbesserung abverlangen.

Gruß
Marc

PS: Bitte die Domäne anonymisieren.
Mitglied: Avoton
Avoton 10.08.2022 um 21:08:20 Uhr
Goto Top
Hi,

Melden sich die User auf dem Server an, wo auch der SQL Server für SAP und die Serverdienste laufen?

Die Meldung Kot vom Service Manager der Server Dienste und ist normal, wenn man sich an einem B1 Server anmeldet. Da haben die Nutzer aber nichts drauf verloren, die gehören wenn auf einen RDS Server, wo nur der B1 Client drauf ist.
Mitglied: Easyma
Easyma 10.08.2022 um 21:27:41 Uhr
Goto Top
Zitat von @radiogugu:

Hallo.

Die Benutzer melden sich an PC oder einem Remote Desktop Server an?

Es erscheint die UAC auf den PC, korrekt?

Wenn dort einmal mit Admin Zugangsdaten das Fenster ausgefüllt wurde, erscheint es dann erneut?

Wenn das Phänomen auftrat nachdem ein Dienstleister aktiv war, dann diesem hier die Nachbesserung abverlangen.

Gruß
Marc

PS: Bitte die Domäne anonymisieren.

Hallo @radiogugu,

die Infos meinerseits waren ein wenig lückenhaft.
Die Leute melden sich per RDP an einem Terminalsever an. Dann erscheint diese Meldung, jedes mal wenn Sie sich anmelden.
Auch wenn ich einmal das Adminpasswort eingebe, ist bei der nächsten Anmeldung, das gleiche Spiel.
Nur bei Personen mit Adminrechten, erscheint die Meldung nicht.
Mitglied: Easyma
Easyma 10.08.2022 um 21:29:27 Uhr
Goto Top
Zitat von @Avoton:

Hi,

Melden sich die User auf dem Server an, wo auch der SQL Server für SAP und die Serverdienste laufen?

Die Meldung Kot vom Service Manager der Server Dienste und ist normal, wenn man sich an einem B1 Server anmeldet. Da haben die Nutzer aber nichts drauf verloren, die gehören wenn auf einen RDS Server, wo nur der B1 Client drauf ist.

Genau so ist es auch, die Leuet melden Sich auf dem B1 Server an, über RDP. Der SQL ist noch mal eine andere Maschine.
Mitglied: Avoton
Avoton 10.08.2022 um 21:35:22 Uhr
Goto Top
Aber die Serverinstallation vom B1 liegt auf dem Terminalserver?

Sonst gibt es das Programm nämlich nicht auf einer Maschine...
Mitglied: Easyma
Easyma 10.08.2022 um 21:41:53 Uhr
Goto Top
Zitat von @Avoton:

Aber die Serverinstallation vom B1 liegt auf dem Terminalserver?

Sonst gibt es das Programm nämlich nicht auf einer Maschine...

Ja, genau so ist es. Auf dem Terminalserver ist auch die SAP Business One Installation.

Die Meldung muss auch was mit dem SAP Business One Server Manager zu tun haben, so meine Vermutung.
Mitglied: radiogugu
radiogugu 10.08.2022 um 22:34:01 Uhr
Goto Top
Zitat von @Easyma:
Ja, genau so ist es. Auf dem Terminalserver ist auch die SAP Business One Installation.

Nochmal zum Mitschreiben:

Die Datenbank läuft auf dem Terminalserver?

Wer macht denn sowas?

Die Meldung muss auch was mit dem SAP Business One Server Manager zu tun haben, so meine Vermutung.

Kein Wunder, wenn jedes Mal im Autostart dieser Dienst anklopft.

Üblich ist dieses Konstrukt auf keinen Fall.

Hier sollte dringend an dem Ort der Datenbank etwas geändert werden, wenn dem wirklich so ist.

Gruß
Marc
Mitglied: Easyma
Easyma 10.08.2022 aktualisiert um 22:52:03 Uhr
Goto Top
Nein, der SQL Server läuft auf einer anderen Maschine.
Die SAP Business One Applikation auf dem Terminalserver.
Im Autostart ist die Applikation auch nicht drin.
Mitglied: Avoton
Avoton 11.08.2022 um 04:17:18 Uhr
Goto Top
Das würde ich aber trotzdem schnell ändern...

Die Serverinstallation von Business One hat nichts auf dem RDS Host zu suchen, auch wenn die SQL Datenbank woanders liegt (immerhin).

Die Serverinstallation gehört entweder mit auf den Server wo die Datenbank läuft oder auf einen eigenen Anwendungsserver.

LG,
Avoton
Mitglied: Easyma
Easyma 11.08.2022 um 06:39:45 Uhr
Goto Top
Hallo, Ich weiß jetzt nicht genau, was du meinst, und ich bin mir nicht sicher, ob das mein Problem lösen würde.
Oder anders gesagt:
Es ging mir nicht um die Installation der SAP Applikation, sondern ob jemand eine Ahnung hat, wie ich diese Meldung vermeiden kann.
Mitglied: Thomas2
Thomas2 11.08.2022 um 07:06:57 Uhr
Goto Top
Moin,

was Avoton wissen möchte ist, ob du den SAP Server auf dem Terminalserver hast laufen. Es gibt den Client, den Server und die Datenbank. Client installierst du auf den Arbeitsstationen / Terminalserver und Server+Datenbank auf ein eigenes oder zwei getrennte Systeme. Von der Beschreibung des Dienstes sieht es so aus, als hättet ihr ein Server Tool auf dem Clientzugang am laufen.

In unserer SAP B1 Installation gibt es diesen Dienst nicht. Ich nehme an, da wurde beim Update was mit installiert, dass es vorher nicht gab oder einfach deaktiviert wurde. Hast du schon geschaut, ob das Ding in den Diensten zu finden ist und es deaktiviert?

Gruß,
Thomas
Mitglied: MysticFoxDE
Lösung MysticFoxDE 11.08.2022 um 07:17:57 Uhr
Goto Top
Moin Easyma,

Es ging mir nicht um die Installation der SAP Applikation, sondern ob jemand eine Ahnung hat, wie ich diese Meldung vermeiden kann.

der Client versucht bei Start vom SAP auf irgend etwas schreibend zuzugreifen, auf das der normale User keine Rechte hat. Könnte eine Datei aber auch ein Registry-Eintrag sein.

Du kannst dem SAP bei Dateizugriffen mit dem Process Explorer eigentlich ganz einfach auf die Finger schauen. 😉
https://docs.microsoft.com/en-us/sysinternals/downloads/process-explorer

Alternativ würde ich mal testweise den SAP-Usern einen Vollzugriff auf den SAP Ordner unter "C:\Program Files (x86)\" gewähren.

Beste Grüsse aus BaWü
Alex
Mitglied: Avoton
Lösung Avoton 11.08.2022 um 08:53:19 Uhr
Goto Top
Das Tool was da startet kontrolliert die SAP Serverdienste, dass da kein normaler User dran darf ist wohl klar.

Schau in der Registry Mal im Run Zweig, ob sich da was versteckt.

Sonst muss ich nachher Mal bei einem Kundensystem schauen, von wo der Start davon kommt.
Mitglied: Easyma
Easyma 11.08.2022 um 09:03:07 Uhr
Goto Top
Hallo @avaton,

ich werde mal heute Abend den Tip von @MysticFoxDE umsetzten.
Da brauchst du dir keine Große Mühe machen.

Es ist auf jeden Fall etwas in der Rergistry, ich hatte nur kein Weg herauszufinden, welcher Registryeintrag betroffen ist.

Das gute ist ja, wir haben einen zweiten Server, da kann ich die Werte vergleichen.

Gibt es da ein Trick, wie man herausfindet, welches Programm, welche RegEinträge hat?
Mitglied: MysticFoxDE
Lösung MysticFoxDE 11.08.2022 um 11:32:13 Uhr
Goto Top
Moin Easyma,

Gibt es da ein Trick, wie man herausfindet, welches Programm, welche RegEinträge hat?

auch hier hilft der Process Explorer, der zeigt dir auch an auf welche Registry-Einträge der entsprechende Prozess/Applikation zugreift.

Und was den den Punkt mit dem ungewollten automatischen Start bei den Usern angeht,
hier hilft bestimmt das folgende Tool etwas weiter.

https://docs.microsoft.com/en-us/sysinternals/downloads/autoruns

Beste Grüsse aus BaWü
Alex
Mitglied: Easyma
Easyma 11.08.2022 um 18:47:50 Uhr
Goto Top
Hallo @MysticFoxDE,
Hallo @avaton,

das war die Lösung:
Das Prgramm war in den HKLM\Software\Wow6432Node\Microsoft\Windows\Currentversion\Run eingetragen.
In den anderen Server, wo die Applikation läuft, ist der Eintrag nicht vorhanden.
Mitglied: Avoton
Avoton 11.08.2022 um 18:54:40 Uhr
Goto Top
Super, dass es geklappt hat face-smile

Langfristig würde ich den Serverteil von Business One trotzdem umziehen (lassen).

Viele Grüße,
Avoton