yan2021
Goto Top

Netzlaufwerk fest verbinden und öffnen per Batchdatei

Hallo,

ich brauche einen Zugriff auf einer Freigabe im Netzwerk.
Diese will ich per Batchdatei mit einem Klick öffnen können.
Die Freigabe ist über "Sicherheit" nur für den Admin und mich editierbar.

Ich habe nun eine Batchdatei geschrieben mit folgendem Inhalt:

@ echo off

REM Zugriff auf NW-Freigabe

net use Z: \\dasbackup2\backups wichtige pcs\IT 
explorer Z:

REM ALTERNATIV: net use Z: \\dasbackup2\backups wichtige pcs\IT  /persistent:yes /user:dasbackup2\Administrator passwort123

pause

Leider funktioniert es so nicht (auch nicht die Alternative Lösung, wie sie oben im Code steht).
Es könnte daran liegen, dass der Teil "backups wichtige pcs" Leerzeichen enthält.
Ich habe auch schon verschiedene Möglichkeiten mit Anführungsstrichen ausprobiert... bisher ohne Erfolg face-sad

Könnt Ihr helfen?

Grüße von
Yan face-wink

Content-Key: 72146225926

Url: https://administrator.de/contentid/72146225926

Printed on: June 12, 2024 at 19:06 o'clock

Member: radiogugu
radiogugu May 22, 2024 updated at 11:54:48 (UTC)
Goto Top
Mahlzeit.

Ist der angegebene Pfad die Freigabe oder ist "IT" schon ein Ordner?

Das net use Kommando kann, meine ich, keine Ordner direkt verarbeiten, sondern benötigt immer eine Freigabe als Ziel.

Leerzeichen waren noch nie eine gute Idee. Besser mit Binde- oder Unterstrichen arbeiten.

Gruß
Marc
Member: ThePinky777
Solution ThePinky777 May 22, 2024 at 12:31:23 (UTC)
Goto Top
Zitat von @Yan2021:

Hallo,

ich brauche einen Zugriff auf einer Freigabe im Netzwerk.
Diese will ich per Batchdatei mit einem Klick öffnen können.
Die Freigabe ist über "Sicherheit" nur für den Admin und mich editierbar.

Ich habe nun eine Batchdatei geschrieben mit folgendem Inhalt:

@ echo off

REM Zugriff auf NW-Freigabe

net use Z: \\dasbackup2\backups wichtige pcs\IT 
explorer Z:

REM ALTERNATIV: net use Z: \\dasbackup2\backups wichtige pcs\IT  /persistent:yes /user:dasbackup2\Administrator passwort123

pause

Leider funktioniert es so nicht (auch nicht die Alternative Lösung, wie sie oben im Code steht).
Es könnte daran liegen, dass der Teil "backups wichtige pcs" Leerzeichen enthält.
Ich habe auch schon verschiedene Möglichkeiten mit Anführungsstrichen ausprobiert... bisher ohne Erfolg face-sad

Könnt Ihr helfen?

Grüße von
Yan face-wink


ja sind leerzeichen dann musst du die Zeile so machen:

net use Z: "\\dasbackup2\backups wichtige pcs\IT"  
Member: itisnapanto
itisnapanto May 22, 2024 at 12:34:21 (UTC)
Goto Top
Moin,

und Backuplaufwerke Mappen ist schon 2 mal schlecht.
Oh Gott und auch noch Administrator Passwort in einer Batchdatei ....
Wie der Kollege radiogugu schon schrieb mag Batch keine Leerzeichen.

Was soll das Konstrukt denn bewirken ?

Gruss
Member: emeriks
emeriks May 22, 2024 at 12:36:03 (UTC)
Goto Top
Zitat von @radiogugu:
Das net use Kommando kann, meine ich, keine Ordner direkt verarbeiten, sondern benötigt immer eine Freigabe als Ziel.
Doch, das geht.
Das Problem werden hier die fehlenden "" sein.
Member: Yan2021
Yan2021 May 22, 2024 updated at 12:37:58 (UTC)
Goto Top
OK, hat jetzt geklappt.
Vielleicht hatte ich die "" auch falsch gesetzt... glaube hinter dem Doppel-Backslash face-wink

Wie mache ich das jetzt richtig mit dem "/persistent:yes"?
Soweit ich das verstanden habe, bewirkt das ja, dass das Laufwerk "Z" nun dauerhaft bei mir verbunden wird.

Grüße von
Yan face-wink

EDIT:

das mit dem Admin-KW wird überhaupt nicht benötigt.
Und es funktioniert jetzt... auch mit dem Verzeichnis "IT".
Member: ThePinky777
ThePinky777 May 22, 2024 updated at 15:16:52 (UTC)
Goto Top
net use Z: "\\dasbackup2\backups wichtige pcs\IT"  /persistent:yes /user:dasbackup2\Administrator passwort123  

einfach so face-smile aber das hast du wohl schon rausgefunden, die parameter hinten natürlich ohne Anführungszeichen, es geht ja nur um den Pfad...

User und PW musst du garnicht setzen, solltest du automatisiert daten hin verschieben wollen, den du startest die BAT im Aufgabenplaner, da kann man ja ne windows kennung eintragen, dort eine eintragen wo rechte auf den pfad hat und dort das Passwort entsprechend speichern (im Aufgabenplaner).

Also dann nur noch so:

net use Z: "\\dasbackup2\backups wichtige pcs\IT"  /persistent:yes  

sollte dann gehen...