ibastl
Goto Top

PFSENSE 2.7.2 - Unable to retrieve package information. DNS funktioniert

Hallo zusammen, Ich habe einen Router (Fujitsu mini PC) mit PFSENSE 2.7.2 laufen. Läuft soweit alles gut.
Ich komme allerdings nicht per SSH über LAN auf die PFSENSE (Time Out) und wie im Titel: Unable to retrieve package information.

Update funktioniert aber und DNS Auflösung auch. Ping auch.

Wenn ich einen Monitor anschließe sehe ich nur Statusmeldungen und die Tastatur kann nichts eingeben. Wie komme ich da auf das Menü?

Jemand eine Idee? Was soll ich an Infos liefern?

Content-Key: 4463465529

Url: https://administrator.de/contentid/4463465529

Printed on: May 26, 2024 at 06:05 o'clock

Member: aqui
aqui Apr 18, 2024 updated at 11:38:15 (UTC)
Goto Top
Ich komme allerdings nicht per SSH über LAN auf die PFSENSE (Time Out)
Das ist auch völlig normal, denn im Default ist bekanntlich der SSH Zugang firewallüblich immer deaktiviert!!
Das musst du erst unter System - Advanced erlauben das es funktioniert!
ssh
Handbuch lesen soll gemeinhin helfen um solche peinlichen Fauxpas zu vermeiden! ­čžÉ
https://docs.netgate.com/pfsense/en/latest/recipes/ssh-access.html
Member: ibastl
ibastl Apr 18, 2024 at 11:31:48 (UTC)
Goto Top
ah ja, sorry - das hab ich total übersehen. Danke!
Das Problem mit der Ansicht der verfügbaren Pakete bleibt leider. Dazu eine Idee?

Gruß

Bastian
Member: ibastl
ibastl Apr 18, 2024 at 11:35:08 (UTC)
Goto Top
Bin dran ... folgendes hab ich jetzt:

Enter an option: 13

ERROR: It was not possible to determine pkg remote version
Updating repositories metadata...
Updating pfSense-core repository catalogue...
pkg-static: An error occured while fetching package
pkg-static: An error occured while fetching package
repository pfSense-core has no meta file, using default settings
pkg-static: An error occured while fetching package
pkg-static: An error occured while fetching package
Unable to update repository pfSense-core
Updating pfSense repository catalogue...
pkg-static: An error occured while fetching package
pkg-static: An error occured while fetching package
repository pfSense has no meta file, using default settings
pkg-static: An error occured while fetching package
pkg-static: An error occured while fetching package
Unable to update repository pfSense
Error updating repositories!
ERROR: It was not possible to determine pfSense-upgrade remote version
ERROR: It was not possible to determine pfSense-upgrade remote version
Upgrading pfSense-upgrade... failed.

pfsense-core has no meta file?
Member: aqui
aqui Apr 18, 2024 updated at 11:47:12 (UTC)
Goto Top
Benutzt du den DNS Resolver oder Forwarder??
Kann auch bei Nutzung von Dual Stack am falschen oder fehlerhaften IPv6 Setup liegen.
v6
Haken je nachdem ob v6 generell aktiv sein soll oder nicht!
Member: ibastl
ibastl Apr 18, 2024 at 11:59:55 (UTC)
Goto Top
Hi, danke für deine Antwort. Ich benutze den Forwarder. IP6 ist deaktiviert.
Member: Spirit-of-Eli
Spirit-of-Eli Apr 18, 2024 at 12:12:46 (UTC)
Goto Top
Steht unter General ein DNS Server für die Box zur Verfügung?
Member: ibastl
ibastl Apr 18, 2024 at 12:23:41 (UTC)
Goto Top
Ja, es stehen drei alternative DNS Server drin
Member: Pjordorf
Pjordorf Apr 18, 2024 at 13:20:22 (UTC)
Goto Top
Hallo,

Zitat von @ibastl:
Ja, es stehen drei alternative DNS Server drin
Sind es vielleicht/evtl. 3 falsche DNS?

Gruss,
Peter
Member: ibastl
ibastl Apr 18, 2024 at 13:31:44 (UTC)
Goto Top
Ist es dann nicht komisch, dass alles andere zu funktionieren scheint Updates! DNS Auflösung
Member: aqui
Solution aqui Apr 18, 2024 updated at 14:09:01 (UTC)
Goto Top
Ja, es stehen drei alternative DNS Server drin
Die aber nur zur Anwendung kommen wenn der WAN Port nicht DHCP Client oder PPPoE ist und der "Override" Haken entsprechend gesetzt ist. face-wink

Ansonsten über die Shell mal versuchen:
  • certctl rehash
  • Dann pkg-static -d update
Member: ibastl
ibastl Apr 18, 2024 at 14:12:59 (UTC)
Goto Top
Hallo, Danke für die Antwort. Der WAN Port ist static IP. den certctl rehash hab ich auch gerade gefunden.
Die pfsense stand offenbar doch auf 2.7.0. Jetzt läuft ein Update durch. Mal sehen was danach läuft.

Vielen Dank schon mal an alle. Ich berichte

Gruß

Bastian
Member: aqui
aqui Apr 18, 2024 at 14:16:57 (UTC)
Goto Top
2.7.2 ist das latest und greatest! face-wink
Member: ibastl
Solution ibastl Apr 18, 2024 at 14:20:54 (UTC)
Goto Top
Problem resolved!!!

Nach dem Update von 2.7.0 auf 2.7.2 (welches erst durch "certctl rehash" angezeigt wurde) werden auch wieder die verfügbaren Pakete angezeigt. Juchu!!!

Ich danke für die allgemeine Hilfe ­čĹŹ­čĆ╗

Gruß

Bastian