Proxykonfiguration für 2 Standorte

stelli
Goto Top
Hallo,

ich habe folgendes Problem. Wir besitzen in unserer Firma 2 Standorte. Die beiden Standorte sind miteinander verbunden und die Domaincontroller auf beiden Standorten gleichen sich ab (sind in der gleichen Domain). Dennoch hat jeder Standort seinen eigenen Proxy Server, der an jedem Standort eine unterschiedliche Adresse hat. Ich habe mir jetzt überlegt, das ganze mit einem konfigurationsscript zu lösen. Das Script liegt auf der netlogon Freigabe und ist somit erreichbar.
Wenn ich das Script in Firefox eintrage funktioniert es ohne Probleme und er speichert es mir im Firefox so ab: file://///domain-name.de/netlogon/proxy.pac
Wie muss ich das Script in den Internet Explorer eintragen, damit es auch hier Funktioniert?? Ich habe es schon mit folgenden Schreibweisen probiert: file://///domain-name.de/netlogon/proxy.pac und \\domain-name.de\netlogon\proxy.pac und mit keinem lässt sich mit dem IE surfen.

Hier noch das Script:

function FindProxyForURL(url, host)
{
return "PROXY 192.168.17.254:8080; DIRECT";
}

So das nächste Problem ist, dass ich die Proxy Einstellungen ja für 2 Standorte machen muss. Hierzu habe ich mir jetzt folgendes Script überlegt. Allerdings funktioniert das weder im IE noch im Firefox. Kann mir jemand sagen wo hier mein Fehler liegt??


function FindProxyForURL(url, host)
{
if (isInNet(myIpAddress(), "192.168.17.0", "255.255.255.0"))
return "PROXY 192.168.17.254:8080; DIRECT";

if (isInNet(myIpAddress(), "192.168.18.0", "255.255.255.0"))
return "PROXY 192.168.18.11:8080; DIRECT";;
}

Danke

Gruß Stelli

Content-Key: 162653

Url: https://administrator.de/contentid/162653

Ausgedruckt am: 23.05.2022 um 00:05 Uhr

Mitglied: Mike.ekiM
Mike.ekiM 15.03.2011 um 11:39:21 Uhr
Goto Top
Hi,

Wenn du Active Directory hast ist das ganz easy. Du bildest enstprechende OU´s nach den Standorten und legst Policies mit den entsprechenden Proxyeinstellungen fest.
Die verlinkst du dann auf die gewünschte OU.

Gruß
Mitglied: Stelli
Stelli 15.03.2011 um 11:56:21 Uhr
Goto Top
Das habe ich auch schon probiert... Nur übernimmt er mir die Einstellungen nicht... Wenn ich in der Default Domain Policy aber was eintrage dann übernimmt er das.. Das problem hier ist das das domänenweit gilt und ich es so nicht auf 2 Standorte aufteilen kann... Sobald ich aber eine Gruppenrichtlinie bilde. Übernimmt er mir aus der Default Domain Policy den nicht gesetzten Haken und nicht den aus dem Gruppenrichtlinienobjekt indem der Proxy konfiguriert ist...

Aus diesem Grund habe ich ja erst versucht das ganze über ein Skript zu machen...

Bei den Gruppenrichtlinienobjekt habe ich es einmal mit der Einstellung: Benutzerkonfiguration --> Richtlinien--> Windows-einstellungen-->Internet Explorer Wartung--> Verbindung--> Proxyeinstellungen. Probiert aber ohne Erfolg

Dann habe ich es noch mti der Einstellung unter Benutzerkonfiguration --> Einstellungen --> Systemsteuerungseinstellungen --> Interneteinstellungen mit der Einstellung für Internet explorer 7 probiert (müsste auchb ei IE 9 funktionieren oder?) auch wiederum ohne Erfolg (Die Sache mit den grünen und roten linien ist mir bekannt)

er hat mir einfach nicht die einstellungen übernommen. Ich habe dann im GPResult nachgeschaut welche gruppenrichtlinien verarbeitet werden.. Da stand diese Gruppenrichtlinie für den Proxy drin.. Ich habe die Richtlinie dann noch um ein Netzlaufwerkzuordnung erweitert um zu schauen ob sie durchläuft. Das Netzlaufwerk aus diesem Objekt wurde verbunden.. die Proxyeinstellungen aber nicht angewendet

Hast du vielleicht hierfür einen Lösungsansatz?

Gruß
Stelli
Mitglied: Mike.ekiM
Mike.ekiM 15.03.2011 um 13:08:27 Uhr
Goto Top
Vielleicht hilft dir das hier weiter: http://support.microsoft.com/kb/316702/en-us
Mitglied: Stelli
Stelli 16.03.2011 um 10:18:15 Uhr
Goto Top
Die beschriebenen Einstellungen gibt es bei mir nicht in der Gruppenrichtlinienverwaltung....

Des Weiteren tritt das Problem ja nicht nur bei einem PC auf.. die Proxy Einstellungen werden überall nicht übernommen. Habe auch eine frisch installiert Windows 7 Workstation hier an der noch keine Einstellungen vorgenommen wurden. Auch hier werde keine Proxy Einstellungen eingetragen...
Mitglied: Mike.ekiM
Mike.ekiM 16.03.2011 um 12:13:26 Uhr
Goto Top
Hi,

Hast du schonmal die Rangfolge der Gruppenrichtlinien überprüft. Hast du irgendeine Richtlinie mit höheren Rang welche die Einstellungen des IE wieder auf 0 setzt?
Mitglied: Stelli
Stelli 16.03.2011 um 12:17:58 Uhr
Goto Top
naja wie gesagt, in der Default domain Policy steht kein Proxy drin... und diese "kein Proxy" Einstellung bekomme ich auch immer wieder zugewiesen (auch wenn ich am pc vorher was eingestellt habe bekomme ich das wieder gelöscht und es steht kein Proxy mehr drin)... Wie kann ich denn eine Gruppenrichtlinie einen höheren Rang als der Default Domain Policy geben???
Mitglied: FourHead
FourHead 02.12.2011 um 15:31:09 Uhr
Goto Top
Hi,
ich weiß, dass dieser Beitrag schon ein paar Tage alt ist, aber ich bin gerade dabei quasi das Gleiche zu machen. Ich hab zwei PAC Files, IE8 und FF6. Am sinnvollsten für alle ist es, die PAC Files ins NETLOGON Verzeichnis zu legen, denke ich, da ich keinen Webserver zur Verfügung habe.

Der Aufruf mit IE klappt mit file://\\domänenname\netlogon\pacfile.pac problemlos, allerdings klappt bei mir der Aufruf für FF mit file://////domänenname/netlogon/pacfile.pac nicht. Hat sich da bei FF inzwischen was geändert und ich muss die URL anders schreiben?

Vielen Dank und viele Grüße
Manuel