gelöst RIPv1 VS RIPv2 (Routingtabelle)

Mitglied: MrLabel

MrLabel (Level 1) - Jetzt verbinden

29.09.2020 um 12:43 Uhr, 367 Aufrufe, 11 Kommentare

Hallo zusammen,

ich hänge seit geraumer Zeit an einer Aufgabe bzgl. RIPv1 und RIPv2.
Ich habe mit Cisco Paket Tracer RIPv1 und RIPv2 bei 2 verschiedenen Netzwerken jeweils eingerichtet und soll anhand der Routingtabellen
einen Unterschied feststellen. Jedoch weiß ich nicht, was genau damit gemeint ist.

Siehe Aufgabenblatt

Siehe Routingtabellen

Ich sehe keinen unterschied von RIPv1 und RIPv2 bei den Routingtabellen - sie sind exakt gleich.
Außer bei dem 10-er Netz - dort wird eine /8 SM angezeigt - das hat aber meines wissens nach was mit dem Netz zu tun und nicht mit RIPv1 und RIPv2....

Schaut euch mal die Bilder an - die Beschriftung passt zu den Aufgaben auf dem Aufgabenblatt.

Danke im Vorraus !
ripaufgabenstellung - Klicke auf das Bild, um es zu vergrößern
3cboston_rt_ripv1 - Klicke auf das Bild, um es zu vergrößern
3chouston_rt_ripv1 - Klicke auf das Bild, um es zu vergrößern
3cnewyork_rt_ripv1 - Klicke auf das Bild, um es zu vergrößern
3g-c_boston_rt_ripv1 - Klicke auf das Bild, um es zu vergrößern
3g-c_houston_rt_ripv1 - Klicke auf das Bild, um es zu vergrößern
3g-c_newyork_rt_ripv1 - Klicke auf das Bild, um es zu vergrößern
4a-c_boston_rt_ripv2 - Klicke auf das Bild, um es zu vergrößern
4a-c_houston_rt_ripv2 - Klicke auf das Bild, um es zu vergrößern
4a-c_newyork_rt_ripv2 - Klicke auf das Bild, um es zu vergrößern
Mitglied: brammer
29.09.2020 um 13:11 Uhr
Hallo,

kannst du bitte die einzelnen Screenshots noch beschriften?
Dann wüsste man welches Routingtable welches ist.

und vor allem die Configuration des Routers

brammer
Bitte warten ..
Mitglied: MrLabel
29.09.2020 um 13:29 Uhr
die Beschriftung ging verloren ...
3cboston_rt_ripv1 - Klicke auf das Bild, um es zu vergrößern
3chouston_rt_ripv1 - Klicke auf das Bild, um es zu vergrößern
3cnewyork_rt_ripv1 - Klicke auf das Bild, um es zu vergrößern
3g-c_boston_rt_ripv1 - Klicke auf das Bild, um es zu vergrößern
3g-c_houston_rt_ripv1 - Klicke auf das Bild, um es zu vergrößern
3g-c_newyork_rt_ripv1 - Klicke auf das Bild, um es zu vergrößern
4a-c_boston_rt_ripv2 - Klicke auf das Bild, um es zu vergrößern
4a-c_houston_rt_ripv2 - Klicke auf das Bild, um es zu vergrößern
4a-c_newyork_rt_ripv2 - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: aqui
29.09.2020, aktualisiert um 14:34 Uhr
Ich sehe keinen unterschied von RIPv1 und RIPv2 bei den Routingtabellen
Das liegt daran das du keine CIDR Maske verwendest bei deinen Netzen ! RIPv1 ist megatot und heute im Zeitalter von CIDR Masken unbrauchbar, da es diese nicht supportet. Das kann nur RIPv2.
Vermutlich hast du im RIPv1 Test vergessen v1 zu aktivieren, denn das kann nicht mit CIDR Masken umgehen wie es im 10er Netz vorkommt. Version 1 kann das 10er Netz nur immer als /8 behandeln niemals aber als /24. Das kannst du nur mit v2.
https://de.wikipedia.org/wiki/Routing_Information_Protocol#RIPv1
Vermutlich hast du vergessen auf v1 umzuschalten oder die Routing Tabelle zu löschen. Kann man aber nur raten da du die Router Konfig hier leider nicht gepostet hast.
Bitte warten ..
Mitglied: MrLabel
29.09.2020 um 14:36 Uhr
ripv1 habe ich folgender maßen eingestellt

router rip
network xxx



normaler weise sollte dann v1 eingestellt sein oder nicht
Bitte warten ..
Mitglied: brammer
29.09.2020 um 15:31 Uhr
Hallo,


Zitat von MrLabel:

ripv1 habe ich folgender maßen eingestellt

router rip
network xxx



normaler weise sollte dann v1 eingestellt sein oder nicht

nicht ganz
https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/iproute_rip/configurat ...
Ich gehe mal davon aus das der Router wegen der angegebenen Netzwerkmasken das ganze als RIPv2 handhabt und du deswegen keinen Unterschied im Routing Table siehst

brammer
Bitte warten ..
Mitglied: aqui
29.09.2020, aktualisiert um 16:03 Uhr
wegen der angegebenen Netzwerkmasken das ganze als RIPv2 handhabt
Das ist richtig wenn man nicht explizit v1 auch konfiguriert. (Was keiner wegen der o.a. Gründe heute mehr macht)
Ein klassisches Praxisbeispiel dazu findest du z.B. hier:
https://administrator.de/tutorial/cisco-mikrotik-pfsense-vpn-standort-ve ...
Natürlich mit v2.
Bitte warten ..
Mitglied: BitBurg
30.09.2020, aktualisiert um 23:19 Uhr
Hi MrLabel,

du wirst in den Routingtabellen keinen Unterschied zwischen RIPv1 und RIPv2 feststellen. Bei der 192.168.X.0/ 255.255.255.0 Adressierung hat man 4 Class-C Netzwerke. RIPv1 ist ein Classful Routingprotokoll und kann damit umgehen.
Bei der 10.168.X.0/255.255.255.0 Addressierung hat man 4 Class-A Netzwerke, die identisch gesubnettet (FLSM) sind. Das entspricht den Regeln für das Subnetting von Classful Netwerken. Damit kann RIPv1 ebenfalls umgehen.

RIPv2 ist ein Classless Routingprotokoll und es wird, im Gegensatz zu RIPv1, die Subnetzmaske in den Routingupdates mit übertragen. Es muss sich nicht an diese Regeln halten und kann deshalb auch mit nicht identisch gesubnetteten Netzen (VLSM) umgehen. RIPv2 betrachtet die Routingupdates nicht als Classful-Netzwerke. Es wird die Netze so in den Routingtabellen eintragen, wie sie empfangen werden. Letzlich sieht man in den Routingtabellen keinen Unterschied.

Du könntest mal auf den Links zwischen den Routern die 192er-Adressierung lassen und nur an den beiden "Enden" die 10er Adressen nehmen oder du nimmst die 10er Adressen komplett, allerdings mit unterschiedlichen Subnetzmasken. Dann würdest du den Unterschied zwischen RIPv1 und RIPv2 sehen.

BB
Bitte warten ..
Mitglied: MrLabel
02.10.2020 um 12:04 Uhr
Hallo,
das was du da oben geschrieben hast ist exakt das selbe wie ich es oben beschrieben habe
Bitte warten ..
Mitglied: MrLabel
02.10.2020 um 12:10 Uhr
@BitBurg Danke ich werde mir das mal genauer durch den Kopf gehen lassen und etwas rumprobieren
Bitte warten ..
Mitglied: brammer
02.10.2020 um 12:24 Uhr
Hallo,

der gravierende Nachteil von FLSM ist aber das ein Großteil der IP Adressen nicht effektiv verwendet werden kann .

btw.: die Begriffe Class A (bis Class E) wurden übrigens 1993 mit der Einführung von CIDR abgeschafft

brammer
Bitte warten ..
Mitglied: aqui
LÖSUNG 04.10.2020, aktualisiert um 15:16 Uhr
Um das hier jetzt zu beenden...

rip - Klicke auf das Bild, um es zu vergrößern

Konfig Router 1 RIP Version 1:

interface FastEthernet0/0
description Lokales LAN
ip address 10.26.21.254 255.255.255.0
!
interface FastEthernet0/1
description Link zu Router 2
ip address 172.27.2.254 255.255.255.0
!
router rip
version 1
passive-interface default
no passive-interface FastEthernet0/1
network 10.0.0.0
network 172.27.0.0
no auto-summary
!

Konfig Router 2 RIP Version 1:

interface Ethernet0
description Lokales LAN
ip address 192.168.77.1 255.255.255.0
!
interface Ethernet2
description Link zu Router 1
ip address 172.27.2.1 255.255.255.0
!
router rip
version 1
passive-interface default
no passive-interface Ethernet2
network 172.27.0.0
network 172.31.0.0
network 192.168.77.0
no auto-summary

Relevant ist hier das Verhalten des Interfaces FastEthernet0/0 an Router 1 da es eine CIDR Adresse hat die RIPv1 nicht supportet. Folglich kann nur ein /8 Prefix (alte Class A) übertragen werden.
Der Output der Routing Tabelle an Router 2 verhält sich also entsprechend:
Ändert man jetzt beide Konfigs auf RIP Version 2:
router rip
version 2
passive-interface default
no passive-interface Ethernet2
network 172.27.0.0
network 172.31.0.0
network 192.168.77.0
no auto-summary

router rip
version 2
passive-interface default
no passive-interface FastEthernet0/1
network 10.0.0.0
network 172.27.0.0
no auto-summary

Dann ändert sich dementsprechend auch sofort der Routing Table Output an Router 2 in einen CIDR Notation:
Fazit: Works as designed !!!

Hoffentlich reicht es beim TO dann final auch noch für ein:
https://administrator.de/faq/32
Bitte warten ..
Heiß diskutierte Inhalte
Router & Routing
Wireguard VPN (oder andere alternative) - Kompletter Traffic routen
gelöst KodaCHFrageRouter & Routing15 Kommentare

Guten Morgen Ich habe bisher mit OpenVPN und mit Wireguard VPN einige Tests gemacht. OpenVPN (Kostenlose Version): Hier habe ...

Windows Server
Hyper-V Server vs Datacenter?
holliknolliFrageWindows Server14 Kommentare

Hallo, hat jemand Erfahrung mit dem - kostenlosen - Hyper-V-Server? Ich meine, warum teure Lizenzen für Datacenter zahlen, wenn ...

Server-Hardware
Konfiguration und Stromverbrauch ML350 Gen10
kosta88FrageServer-Hardware13 Kommentare

Hallo, ich versuche mal zu berechnen was ein ML350 verbrauchen würde. Ich weiß dass es von der Konfiguration und ...

Server
Kein Zugriff auf NAS bei DS Lite
martingerdesFrageServer11 Kommentare

Hallo liebe Gemeinde, dieses Thema kennen wahrscheinlich viele und ich selbst habe schon viele Forenbeiträge zu diesem Thema gelesen. ...

Grafikkarten & Monitore
Grafikkarte kaputt? Hier muss noch etwas hin, weil der andere Titel schon vergeben ist :)
Sir.classicFrageGrafikkarten & Monitore9 Kommentare

Hallo an alle, ich habe einen selbst gebauten PC und mein Problem ist, dass meine Monitore regelmäßig (alle 3h) ...

LAN, WAN, Wireless
Spanning Tree Probleme
predator66FrageLAN, WAN, Wireless9 Kommentare

Hallo, wir haben hier eigenartige Spanningtree Probleme, die wir zur Zeit nicht gelöst bekommen: New Root Port MAC ist ...

Ähnliche Inhalte
Netzwerke
Fortigate vs Sophos vs Stormshield
eglipeterFrageNetzwerke18 Kommentare

Hallo zusammen, Ich möchte unsere alte Firewall in der Firma durch eine UTM ersetzen. Dabei habe ich die Auswahl ...

Monitoring

Monitoring Software: RiverBird vs. PRTG vs. ServerEye

networker-kaFrageMonitoring12 Kommentare

Hallo zusammen wer von euch hat oder hatte die RiverBird Monitoring Software im Einsatz? Wenn ihr die RiverBird Software ...

Windows Server

SCCM vs. Zenworks

ROLS733FrageWindows Server6 Kommentare

Hallo zusammen, wir werden bald unsere komplette Infrastruktur mit neuen Servern und Clients (ca. 10 virtuelle Server und 25 ...

Visual Studio

Automatisches Update VS

LeeX01FrageVisual Studio2 Kommentare

Hallöchen, hoffe euch geht’s allen gut und hätte eine Frage zum Visual Studio. Regelmäßig veröffentlicht Microsoft Updates für seine ...

Microsoft Office

Checklisten incl Fehlerbehandlungsroutinen Excel vs. Word vs. OneNote

chef1568FrageMicrosoft Office3 Kommentare

Hallo zusammen, ich möchte eine Checkliste (im Bereich Maschineninbertiebnahme) erstellen, in der auch mögliche Fehlerbehandlungsroutinen hinterlegt sind. Diese sollen ...

Router & Routing

PfSense vs. opnSense

fnbaluFrageRouter & Routing45 Kommentare

Hallo zusammen, ich habe seit einigen Jahren pfSense im Einsatz und bin soweit auch zufrieden. Jetzt habe ich mir ...

Berechtigungs- und IdentitätsmanagementBerechtigungs- und IdentitätsmanagementWebdienste und -serverWebdienste und -serverDatenbankenDatenbankenMonitoring & SupportMonitoring & SupportHybrid CloudHybrid CloudSmall Business ITSmall Business IT