Cisco RIPv1 RIPv2

Mitglied: MrLabel

MrLabel (Level 1) - Jetzt verbinden

27.10.2020 um 11:56 Uhr, 824 Aufrufe, 32 Kommentare, 5 Danke

Hallo Zusammen,

ich muss nochmal auf eine schon behandelte Frage eingehen.
Bitte jemand, der auch den Cisco Paket Tracer besitzt.

GOOGLE DRIVE:

https://drive.google.com/file/d/1GQRCjO0nwuuLm-LO4Z7AULypkLXc8p3d/view?u ...

Hier findet ihr meine Projektdokumentation (dort findet ihr alles was in Paket Tracer gearbeitet und eingestellt wurde) sowie die Paket Tracer Dateien.

PROBLEM:
Vergleichen der Routingtabellen von RIPv1 zu RIPv2.
In Aufgabe 3g. soll der unterschied der Routingtabellen aufgezeigt werden - ich sehe jedoch keinen Unterschied!
Kann sich das bitte mal jemand ansehen und mir da eventuell weiterhelfen?

Vielen Vielen Danke im Vorraus!
32 Antworten
Mitglied: brammer
27.10.2020 um 12:03 Uhr
Hallo,

das haben wir doch gerade erst alle durchgekaut...

https://administrator.de/content/detail.php?id=608429

und vergiss den Link auf Google drive...

brammer
Bitte warten ..
Mitglied: MrLabel
27.10.2020 um 12:15 Uhr
Ja, aber es MUSS doch einen sichtbaren Unterschied geben sonnst würde es da nicht stehen.
Mein Lehrer meinte auch dort würde man normalerweise einen Unterschied sehen....
das kanns doch nicht sein :'D
Bitte warten ..
Mitglied: aqui
27.10.2020, aktualisiert um 12:48 Uhr
Wann lernst du es... Es ist auch schon zig mal im ursprünglichen Thread gesagt worden:
  • RIPv1 kann NICHT mit CIDR_Netzmasken umgehen !! Ein variables Subnetting außerhalb der alten Class A, B und C Masken ist nicht möglich. Genau das sieht man auch an der Routing Tabelle.
  • RIPv2 überwindet das und lässt auch CIDR Masken zu.

Versuche z.B. 10er Adressen mit einem 24er Prefix mit RIPv1 zu routen, das geht nicht !!
Du siehst es hier an einer Live Konfig anhand von alten Class B 172er Adressen:
!
interface Ethernet0
description Lokales LAN
ip address 172.31.77.1 255.255.255.0
!
interface Ethernet2
description Link zu Router 1
ip address 172.27.2.1 255.255.255.0
!
router rip
version 1
passive-interface default
no passive-interface Ethernet2
network 172.27.0.0
network 172.31.0.0 <== 24Bit Prefixe sind NICHT konfigurierbar mit v1 !!
no auto-summary
!

Diese 172er Netze (altes Class B) werden bei RIPv1 immer nur als /16er Netze propagiert an andere v1 Router und NICHT mit den am Interface konfigurierten 24 Bit Masken !
Das ist der Unterschied der deutlich in der Routing Tabelle zu sehen ist !!
Warum stellst du es nicht einfach nach mit der o.a. Banal Konfig ??!!

Der ursprüngliche Thread von dir hat dir das haarklein an einem Live System und Konfig ja auch gezeigt. Mehr Silbertablett zum Hausaufgaben lösen gibt es ja nun wahrlich nicht !
Bitte warten ..
Mitglied: MrLabel
27.10.2020 um 12:28 Uhr
Wenn du dir meine Doku ansiehst - siehst du, dass der Ping von 10.168.0.1 zu 10.168.3.1 mir RIPv1 funktioniert?!
Bitte warten ..
Mitglied: MrLabel
27.10.2020 um 12:31 Uhr
Wo bitte ist hier der Unterschied?
newyorkripv1 - Klicke auf das Bild, um es zu vergrößern
newyorkripv2 - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: MrLabel
27.10.2020 um 12:35 Uhr
schau dir mal meine Bilder an
Bitte warten ..
Mitglied: brammer
27.10.2020 um 12:35 Uhr
Hallo,

poste doch bitte mal die Konfigurationen der beiden Router.

Der obere Screenshot kann kein RIPv1 sein.

brammer
Bitte warten ..
Mitglied: aqui
27.10.2020, aktualisiert um 12:37 Uhr
Die erste Abbildung ist FALSCH !
Dort ist ein Druckfehler, denn das Bild ist identisch zum 2ten Bild. Sie zeigt auch einen v2 Output. Und Kollege @brammer hat hier absolut Recht. Das ist kein RIPv1 Output !
Das ist ein klarer Druckfehler in der Dokumentation.
Wenn du dir selber in einem Live Setup einmal die Routing Tabelle ansiehst, dann siehst du die per RIPv1 gelernten Netze dort nur mit den klassischen Class A, B oder C Masken aufgeführt sind.
Bitte warten ..
Mitglied: MrLabel
27.10.2020 um 12:38 Uhr
ich habe RIPv1 so konfiguriert:

router rip
version 1
netwrok ....


so wirds doch gemacht!?
Bitte warten ..
Mitglied: brammer
27.10.2020 um 12:42 Uhr
Hallo,

hast du evtl noch Reste von einer RIPv2 Konfiguration in dem Router?
bitte mal die Komplette Konfig posten

brammer
Bitte warten ..
Mitglied: aqui
27.10.2020, aktualisiert um 15:49 Uhr
so wirds doch gemacht!?
Warum liest du den Thread hier nicht ??
Oben steht eine Bilderbuch Konfig für 2 Router !!!

Router 1:
!
interface Ethernet0
description Lokales LAN
ip address 10.1.77.1 255.255.2550
!
interface Ethernet2
description Link zu Router 2
ip address 172.27.2.1 255.255.255.0
!
router rip
version 1
passive-interface default
no passive-interface Ethernet2
network 10.0.0.0
network 172.27.0.0
no auto-summary
!

Router 2:
!
interface Ethernet0
description Lokales LAN
ip address 172.31.77.1 255.255.255.0
!
interface Ethernet2
description Link zu Router 1
ip address 172.27.2.2 255.255.255.0
!
router rip
version 1
passive-interface default
no passive-interface Ethernet2
network 172.27.0.0
network 172.31.0.0
no auto-summary
!
Bitte warten ..
Mitglied: MrLabel
27.10.2020 um 12:48 Uhr
Router1:

Boston#show run
Building configuration...

Current configuration : 665 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Boston
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524NU9B-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address 10.168.0.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
router rip
network 10.0.0.0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end


ROUTER2:

Router#show run
Building configuration...

Current configuration : 668 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524IHZ9-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address 10.168.1.2 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.168.2.1 255.255.255.0
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
router rip
network 10.0.0.0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end


ROUTER3:

Houston>ena
Houston#show run
Building configuration...

Current configuration : 666 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Houston
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX15244ABY-
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address 10.168.2.2 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.168.3.1 255.255.255.0
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
router rip
network 10.0.0.0
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end
Bitte warten ..
Mitglied: MrLabel
27.10.2020 um 12:49 Uhr
sehe gerade dass das die falsche datei war.. hat wohl eben einfach gespeichert moment...
Bitte warten ..
Mitglied: aqui
27.10.2020, aktualisiert um 12:52 Uhr
Bitte kürze die Konfigs um die überflüssigen "!" im Text !!! (geht auch nachträglich !)
Es fehlt das version 1 in deiner RIP Konfig !! Oben siehst du doch eine RIP v1 Konfig !!
Bitte warten ..
Mitglied: MrLabel
27.10.2020, aktualisiert um 12:54 Uhr
So jetzt....

Router1
________________________________________________
Houston(config)#no router rip
Houston(config)#router rip
Houston(config-router)#version 1
Houston(config-router)#network 10.168.2.0
Houston(config-router)#network 10.168.3.0
Houston(config-router)#exit
Houston(config)#exit
Houston#
%SYS-5-CONFIG_I: Configured from console by console

Houston#
Houston#show run
Building configuration...

Current configuration : 677 bytes

version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption

hostname Houston


ip cef
no ipv6 cef

license udi pid CISCO1941/K9 sn FTX15244ABY-

spanning-tree mode pvst

interface GigabitEthernet0/0
ip address 10.168.2.2 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.168.3.1 255.255.255.0
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown

router rip
version 1
network 10.0.0.0

ip classless
ip flow-export version 9

line con 0

line aux 0

line vty 0 4
login



end


Router2
_________________________________________________-
Router(config)#no router rip
Router(config)#router rip
Router(config-router)#version 1
Router(config-router)#network 10.168.1.0
Router(config-router)#network 10.168.2.0
Router(config-router)#exit
Router(config)#
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#show run
Building configuration...

Current configuration : 679 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption

hostname Router

no ip cef
no ipv6 cef

license udi pid CISCO1941/K9 sn FTX1524IHZ9-

spanning-tree mode pvst

interface GigabitEthernet0/0
ip address 10.168.1.2 255.255.255.0
duplex auto
speed auto

interface GigabitEthernet0/1
ip address 10.168.2.1 255.255.255.0
duplex auto
speed auto

interface Vlan1
no ip address
shutdown

router rip
version 1
network 10.0.0.0

ip classless

ip flow-export version 9

line con 0

line aux 0

line vty 0 4
login

end


Router3
______________________________________________-
Boston(config)#router rip
Boston(config-router)#version 1
Boston(config-router)#network 10.168.0.0
Boston(config-router)#network 10.168.1.0
Boston(config-router)#exit
Boston(config)#exit
Boston#
%SYS-5-CONFIG_I: Configured from console by console

Boston#
Boston#show run
Building configuration...

Current configuration : 676 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Boston

ip cef
no ipv6 cef

license udi pid CISCO1941/K9 sn FTX1524NU9B-

spanning-tree mode pvst

interface GigabitEthernet0/0
ip address 10.168.0.1 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface Vlan1
no ip address
shutdown
!
router rip
version 1
network 10.0.0.0
!
ip classless
!
ip flow-export version 9

line con 0
!
line aux 0
!
line vty 0 4
login

end
Bitte warten ..
Mitglied: aqui
27.10.2020, aktualisiert um 13:03 Uhr
Es ist sehr frustrierend mit dir hier...
Bitte KÜRZE deine Konfigs um die überflüssgen Ausrufezeichen ! Es hilft hier ALLEN die hilfswillig sind mit der Übersichtlichkeit !!!

Du kannst das Elend bei v1 ja schon selber sehen. Eigentlich müsstest du deine 24er Netze ja auch so in der RIP Konfig angeben damit sie mit einen 24er Prefix propagiert werden:
network 10.168.0.0
network 10.168.1.0

Das ist aber bei v1 nicht möglich und es steht dort nur 10.0.0.0 da v1, wie oben schon mehrfach gesagt, mit modernen CIDR Masken nicht umgehen kann und auch keine CIDR Netze in der RIP Router Konfig konfigurierbar sind. Der Cisco Kommando Parser im CLI setzt sie immer automatisch auf ihre alten Class A, B oder C Netze zurück auch wenn du ein /24er Netz dort angibst.
Das 10er netz wird also nur als /8er Netz im RIPv1 übertragen an die remoten Router und damit ist eine Routing in deinem CIDR gesubnetteten 10er Netz mit RIPv1 technisch unmöglich !!
All das steht auch schon mehrfach im ursprünglichen Thread !
Bitte warten ..
Mitglied: brammer
27.10.2020 um 12:55 Uhr
Hallo,

Router 1 ist der mit RIPV1 ?
Da dort IP CEF aktiv kann es sein das dir das hier in die Suppe spuckt.

brammer
Bitte warten ..
Mitglied: MrLabel
27.10.2020 um 12:55 Uhr
ja schau jetzt nochmal
Bitte warten ..
Mitglied: MrLabel
27.10.2020 um 12:55 Uhr
alle Router RIPv1 sieht man doch in der Konfig
Bitte warten ..
Mitglied: MrLabel
27.10.2020 um 12:57 Uhr
Ich hab extra die commands für Rip "version 1" mit rein genommen damit ihr seht, dass es Version 1 ist
Bitte warten ..
Mitglied: aqui
27.10.2020, aktualisiert um 13:02 Uhr
Aber die aktuelle Routing Tabelle beider Router show ip route fehlt !
Bitte warten ..
Mitglied: MrLabel
27.10.2020 um 13:07 Uhr
10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C 10.168.0.0/24 is directly connected, GigabitEthernet0/0
L 10.168.0.1/32 is directly connected, GigabitEthernet0/0
C 10.168.1.0/24 is directly connected, GigabitEthernet0/1
L 10.168.1.1/32 is directly connected, GigabitEthernet0/1
R 10.168.2.0/24 [120/1] via 10.168.1.2, 00:00:20, GigabitEthernet0/1
R 10.168.3.0/24 [120/2] via 10.168.1.2, 00:00:20, GigabitEthernet0/1


10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
R 10.168.0.0/24 [120/1] via 10.168.1.1, 00:00:15, GigabitEthernet0/0
C 10.168.1.0/24 is directly connected, GigabitEthernet0/0
L 10.168.1.2/32 is directly connected, GigabitEthernet0/0
C 10.168.2.0/24 is directly connected, GigabitEthernet0/1
L 10.168.2.1/32 is directly connected, GigabitEthernet0/1
R 10.168.3.0/24 [120/1] via 10.168.2.2, 00:00:28, GigabitEthernet0/1


10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
R 10.168.0.0/24 [120/2] via 10.168.2.1, 00:00:02, GigabitEthernet0/0
R 10.168.1.0/24 [120/1] via 10.168.2.1, 00:00:02, GigabitEthernet0/0
C 10.168.2.0/24 is directly connected, GigabitEthernet0/0
L 10.168.2.2/32 is directly connected, GigabitEthernet0/0
C 10.168.3.0/24 is directly connected, GigabitEthernet0/1
L 10.168.3.1/32 is directly connected, GigabitEthernet0/1
Bitte warten ..
Mitglied: MrLabel
27.10.2020 um 13:16 Uhr
das selbe wie vorher... und habs neu gemacht. und oben sieht man "router rip" "version 1" "network.."...
Bitte warten ..
Mitglied: MrLabel
27.10.2020 um 13:39 Uhr
Was mir aufgefallen ist ist dass bei RIPv1 und RIPv2 bei RIP und dem 10.168.x.x Netz nur 10.0.0.0 als RIP angezeigt wird.
Bei den 192.168.X.X werden bei RIPv1 und RIPv2 bei RIP bspw. 192.168.1.0 und 192.168.2.0 angezeigt...wieso?!
Langsam bin ich total verwirrt -.-
Bitte warten ..
Mitglied: PeterGyger
27.10.2020 um 13:54 Uhr
Hallo

Folgendes ist Fakt:

Post von 12:48 Uhr
Post von 12:54 Uhr
Router1
Router2

Post von 12:48 Uhr
interface GigabitEthernet0/0
ip address 10.168.1.2 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 10.168.2.1 255.255.255.0
duplex auto
speed auto

Post von 12:54 Uhr
Router 3 dieselbe Abweichung. D.h. das nicht konsistent arbeitest und Deine Arbeitstechnik das Problem ist.
Oder nach KISS:
Starte Paket Tracer neu, füge jedes Gerät hinzu, gehe auf CLI, tippe die vorher (!) dokumentierte Konfiguration ein. Danach kontrolleiren mit den üblichen Show Befehlen.

Grüsse
Bitte warten ..
Mitglied: BitBurg
27.10.2020, aktualisiert um 23:00 Uhr
Hi Label,

wenn es die gleiche Frage wie in deinem anderen Thread ist, dann ist die Antwort die Gleiche: Du wirst keinen Unterschied in den Routingtabellen feststellen. Ich verstehe den Sinn der Frage auch nicht, oder ich verstehe etwas falsch. Es ist doch folgendes Szenario, oder?
label_rip (2) - Klicke auf das Bild, um es zu vergrößern
Hier die RIPv1-Konfiguration von Router Boston. Die anderen sind Router sind identisch konfiguriert.

Boston#sh run | s router rip

router rip
network 10.0.0.0

Das Kommando "network" aktiviert RIP auf allen Interfaces, deren IP-Addresse mit der 10. beginnt. Und hier die resultierende Routingtabelle:

Boston#show ip route rip

10.0.0.0/24 is subnetted, 4 subnets
R 10.168.2.0 [120/1] via 10.168.1.2, 00:00:19, FastEthernet0/0
R 10.168.3.0 [120/2] via 10.168.1.2, 00:00:19, FastEthernet0/0

Danach wird die Konfiguration so geändert (auf allen Routern), dass RIPv2 benutzt wird.

Boston#sh run | s router rip

router rip
version 2
network 10.0.0.0

Und das Ergebnis in der Routingtabelle ist das Gleiche:

Boston#show ip route rip

10.0.0.0/24 is subnetted, 4 subnets
R 10.168.2.0 [120/1] via 10.168.1.2, 00:00:13, FastEthernet0/0
R 10.168.3.0 [120/2] via 10.168.1.2, 00:00:13, FastEthernet0/0

Zitat von MrLabel:

Ja, aber es MUSS doch einen sichtbaren Unterschied geben sonnst würde es da nicht stehen.
Mein Lehrer meinte auch dort würde man normalerweise einen Unterschied sehen....
das kanns doch nicht sein :'D
Du kannst Kopfstände machen, wie du willst. Du wirst immer das gleiche Ergebnis haben. Falls es dieses Szenario ist und du befürchtest, du hättest etwas falsch gemacht, dann ist es nicht so.

Falls du dich fragst, warum das so ist, dann solltest du noch mal deinen Lehrer fragen oder du überwindest dich mal und stellst die Frage hier.

BB
Bitte warten ..
Mitglied: PeterGyger
29.10.2020 um 18:16 Uhr
Hallo BitBurg

Wenn Rip V1 nicht mit CIDR Masken umgehen.
D.h. aus meiner Sicht - wie in der ersten Antwort von Aqui anhand der 172... Adressen dargelegt - wird ein Router mit RipV1 kein Zielgerät mt einer CIDR Adresse "addressieren" können. Ergo auch keinen Eintrag in der Routingtabelle.

IMO:
Wenn ich im Netz 2 Router habe:
RIPV1
RIPV2

Dann in der Routingtabelle von RIPV2 ein Host mit der IP p address 172.27.2.1 255.255.255.0 angezeigt werden.
Jedoch nicht in der Tabelle von RIPV1. Da die 172 eine B Klassen Adresse mit 16 Netzbit ist und die /24 Netzbit nicht aufgelöst werden können.

Nur meine Meinung, da es mir hier an konkreter Erfahrung mangelt.

Beste Grüsse
Bitte warten ..
Mitglied: BitBurg
29.10.2020, aktualisiert um 23:24 Uhr
Hi Peter,

lass mich mal was Grundsätzliches sagen. @MrLabel hat nicht das Problem, dass etwas nicht funktioniert, das Gegenteil ist der Fall. Er hat eine Aufgabe bekommen und soll offenbar die unterschiedlichen Ergebnisse interpretieren. Allerdings sieht er keinen Unterschied. Klick mal auf den Link in Brammers ersten Beitrag, dort kannst du die Aufgabe nachlesen. Auf diese Thread bezieht sich meine Antwort hier.

Vergiss mal alles, was Aqui hier schreibt. @MrLabel sieht keinen Unterschied in den Routingtabellen, weil alles korrekt addressiert ist. RIPv1 kann damit umgehen und RIPv2 sowieso.

RIPv1 kann mit zwei Dingen nicht umgehen:

1. Die Netze dürfen nicht "discontiguous", also nicht "unterbrochen" sein. Das heißt, Classful-Netze dürfen nicht durch ein anderes Classful-Netz getrennt sein. Oben im Bild sieht man, dass das nicht der Fall ist, alles identische Class-A Netze (10.0.0.0).

2. RIPv1 kann nicht mit VLSM umgehen. Das heißt, alles Netze müssen die identische Subnetzmaske benutzen. Das ist der Fall, es sind Class-A Netze mit identischen Subnetzmasken (255.255.255.0)

Der Grund dafür ist, dass RIPv1 ein Classful-Routingprotokoll ist. Es werden keine Subnetzmasken in den Routingupdates gesendet. Der empfangende Router und auch der sendende Router setzen voraus, dass alles nach den Regeln des Classful-Addressing konfiguriert ist. RIPv2 kann sowohl mit discontiguous Netzen als auch VLSM umgehen, da es Subnetzmasken in den Routingupdates mitsendet

Nochmal zu deinem Beitrag: Ich habe den mehrmals gelesen und verstehe nicht, was du sagen willst. Was immer du meinst, beachte mal folgendes:

RIPv1 und RIPv2 können nicht miteinander arbeiten. RIPv1 arbeitet mit Broadcast- und RIPv2 mit Mulicastnachrichten. Selbst wenn RIPv2 Broadcasts sendet (was konfigurierbar ist), benutzen beide ein anderes Paketformat. Das Zweite ist, dass das "network" Kommando die Aufgabe hat, RIP auf Interfaces zu aktivieren, die in den Range fallen. Man könntest auch das Kommando "network 0.0.0.0" eingeben, dann würde RIP auf allen Interfaces Routingupdates senden. Damit legt man keine Subnetze fest.

Grüße
BB
Bitte warten ..
Mitglied: PeterGyger
01.11.2020 um 10:36 Uhr
Hallo BB

Danke für die detaillierte Erklärung zu RIP.

Schade das ich mich nicht verständlich ausgedrückt habe.

Das ganze ist ja ein reines Testszenario, da in der Praxis niemand RIPv1 und RIPv2 im gleichen Netz betreibt.

Die Frage ist ja, weshalb die Routingtablle sowohl bei RIPv1 wie auch bei RIPv2 gleich aussieht. OK?

Meine Überlegung ist folgende.
RIPv1 kennt nur die klassischen IP Klassen (A / B / C / etc.).
RIPv1 kann nicht mit CIDR umgehen

RIPv2 kann mit CIDR verstehen.

D.h. wenn ich in diesem Netz Hosts mit einer CIDR Adresse habe, dann wird die nur in der Routingtabelle des RIPv2 Hostes angezeigt werden. Weil RIPv1 diese CIDR IP Adressen nicht sieht bzw. nicht versteht.

Ich müsste das Ganze mal im Paket Tracer oder GNS3 nachbauen, um das Live zu erleben.

Beste Grüsse
Bitte warten ..
Mitglied: aqui
01.11.2020, aktualisiert um 16:10 Uhr
Der Knackpunkt ist wie Kollege @BitBurg schon richtig sagt die discontiguous Netzwerke also die nicht zusammenhängenden IP Netze bei Subnetting mit denen RIPv1 nicht umgehen kann. Bei einer zusammenhängenden Adressierung merkt man es an den Masken nicht (output oben) aber sowie man ein nicht zusammenhängendes Adresskonzept nutzt sieht man das Elend, weil v1 nur ein altes classfull Netz anounced und den Hopcount in Routing Update (Broadcast). Mehr nicht. Es fehlt die Subnetzmaske.
v2 nutzt Multicast für das Update und überträgt eben die Maske mit.
Hier wird es recht gut erklärt mit einem Filmchen:
https://www.youtube.com/watch?v=97YVOoWeEZs

Bleibt dann nur noch:
https://administrator.de/faq/32
Bitte warten ..
Mitglied: PeterGyger
01.11.2020 um 16:27 Uhr
Hallo

Selbst wenn ich könnte, würde ich nicht den Thread eines anderen Users auf "gelöst" setzen 😉

IMO
Mr. Label hat aus meiner Sicht eine einfache Lernaufgabe gepostet Wahrscheinlich ist er gerade in einer Ausbildung / Weiterbildung.

Gegeben sind 2 Router. 1x mit RIPv1 und RIPv2. Gegeben sind ferner mehrere Hosts. Einige mit Subnetzmasken nach CIDR Standard.
Wie sehen die Router Tables aus nach einiger Zeit aus? Bzw. was wird der Unterschied sein.

Meine Annahme ist, dass die Tabelle des RIPv2 Routers zusätzliche Routen - CIDR Hosts - beinhaltet, die ein RIPv1 Router nicht "sieht" / "verarbeiten" kann. Keine Ahnung was ein IOS RIPv1 beim parsern einer CIDR Adressen macht. Ich nehme an, dass er nicht abstürzt oder in Flammen aufgeht. Er ignoriert sie einfach.

Ich glaube ich sollte wirklich selber den Packet Tracer kurz starten, um das Ganze mal zusammen zu klicken 😀

Grüsse
Bitte warten ..
Mitglied: aqui
01.11.2020, aktualisiert um 16:40 Uhr
würde ich nicht den Thread eines anderen Users auf "gelöst" setzen
War auch auf den TO bezogen...
Keine Ahnung was ein IOS RIPv1 beim parsern einer CIDR Adressen macht.
Das kannst du doch hier sehen:
https://administrator.de/forum/ripv1-vs-ripv2-routingtabelle-608429.html
Der Parser macht automatisch immer nur das alte Classfull Netz daraus. Muss er ja auch weil v1 kein CIDR kann da es keine Maske im Update übertragt. Ein debug ip rip wäre dann der der Befehl der es schwarz auf weiss zeigt.
den Packet Tracer kurz starten
Oder GNS3
Bitte warten ..
Heiß diskutierte Inhalte
Router & Routing
Lancom Router Site to Site Problem mit Außenstellen
gelöst mossoxFrageRouter & Routing24 Kommentare

Guten Tag zusammen, in der Hauptgeschäftsstelle nutzen wir einen Lancom 1781VA Router und haben i.d.R. zwei gleichzeitige IPSec Site ...

Netzwerke
Sporadische Ausfälle im gesamten Heimnetz
gelöst bilbo-dvdFrageNetzwerke20 Kommentare

Guten Morgen, ich habe einen Kabelanschluss bei Vodafone und mein Tarif wurde im März auf CableMax 1000 umgestellt. Ich ...

Router & Routing
RDP nur im internen Netz möglich nicht aber per vpn?
einfach112FrageRouter & Routing18 Kommentare

Hallo zusammen. Beim Kunden habe ich einen Server mit VMWARE laufen. Darauf ein Windows Server 2016 Essentials als VM ...

Sicherheit
Sicherheit oder bessere Benutzbarkeit?
StefanKittelFrageSicherheit17 Kommentare

Hallo, ich habe eine Webanwendung programmiert und sehe mich nun mit einer Frage zur Benutzbarkeit konfrontiert. Bei der Anmeldung ...

Internet
Über meinen WAN ist lidl.de nicht ereichbar
gelöst NetGodFrageInternet16 Kommentare

Hallo zusammen, mit meinem DTAG-Anschluß ist derzeit kein Durchkommen zu www.lidl.de möglich. Zu den selben Zeitpunkten ist es aber ...

Internet Domänen
Azure AD deactivate Identity Protection
Jannik2018FrageInternet Domänen15 Kommentare

kann mir einer sagen wie ich beim meiner MS Azure AD Domäne die Identity Protection deactiviere siehe Screenshot sollte ...

Ähnliche Inhalte
Firewall
Cisco cisco small business rv215w
bunticFrageFirewall1 Kommentar

Hallo, ich habe mir vor kurzem ein cisco small business rv215w zugelegt, jetzt zur meine Frage: ich hab 3 ...

Switche und Hubs

Cisco Meraki oder klassische Cisco Switche?

TiTuxFrageSwitche und Hubs12 Kommentare

Guten Morgen, wir werden unsere Switch-Infrastruktur zeitnah austauschen und stehen jetzt vor der Entscheidung, ob wir Cisco Meraki oder ...

Netzwerkgrundlagen

VPN Verbindung zwischen Cisco RV180 und Cisco RV340

dodo-rFrageNetzwerkgrundlagen26 Kommentare

Hallo! Ich habe folgende Situation: Zwei Wohnungen - in der ersten Wohnung befindet sich ein NAS das an einem ...

LAN, WAN, Wireless

Cisco AP 1142 )) Cisco AP 1142 als Repeater

JackCimberlyFrageLAN, WAN, Wireless2 Kommentare

Hallo zusammen. Habe zwei Cisco AP 1142 (AIR-AP1142N-E-K9) erstanden (gebraucht). Ich weiß, der Support ist nicht mehr gegeben, aber ...

Router & Routing

Cisco SVTI - Tunnel

gelöst Serial90FrageRouter & Routing44 Kommentare

Moin, moin. ich habe folgendes Problem: Ich möchte ein SVTI Tunnel zwischen zwei Cisco-Router aufbauen. (Multicast notwendig geworden) Gibt ...

Netzwerkgrundlagen

Cisco Switch simulator

gelöst 131361FrageNetzwerkgrundlagen4 Kommentare

Hallo zusammen, gibt es ein Programm, womit man einen Cisco Switch simulieren kann und darauf mit der config etwas ...

Neue Fragen
Administrator Magazin
11 | 2020 Virtualisierung ist aus der IT nicht mehr wegzudenken. In der November-Ausgabe des IT-Administrator Magazins dreht sich der Schwerpunkt um das Thema "Server- und Storage-Virtualisierung". Darin erfahren Sie, wie sich die Virtualisierungstechnologie entwickelt hat, welche Varianten es im Bereich Server und Speicher gibt und wie ...
Neue Beiträge
Neue Jobangebote
Server- und Storage-VirtualisierungServer- und Storage-VirtualisierungBerechtigungs- und IdentitätsmanagementBerechtigungs- und IdentitätsmanagementWebdienste und -serverWebdienste und -serverDatenbankenDatenbankenMonitoring & SupportMonitoring & SupportHybrid CloudHybrid Cloud