mpmichael
Goto Top

Routing mit mehreren Gateways (Juniper SSG 5)

Hallo,

ich habe ein Netzwerk 192.168.30.x/24
In diesem Netz ist das Default GW die 192.168.30.240

Allerdings gibt es einen Router, der das 192.168.30.x Netz mit dem 192.168.1.x netz verbindet.
Dieser Router ist der 192.168.30.1

Da es sich bei den Geräten im 30.x Netz um Telefone handelt - kann ich dort keine Routingtabellen eingeben
Also habe ich im Defaultgateway (192.168.30.240) die Route eingegeben:
192.168.1.0/24 GW 192.168.30.1

Jetzt mein Problem. aus dem 192.168.1.0-Netz kann die die Geräte im 192.168.30.x-Netz pingen - aber wenn ich versuche z. B. über Port 80 darauf zuzugreifen, kommt nichts zurück.
Kann mir jemand einen Tipp geben, woran das liegen könnte?
Beste Grüße
MPM

Content-Key: 246855

Url: https://administrator.de/contentid/246855

Printed on: May 23, 2024 at 09:05 o'clock

Member: IT-Nerds
IT-Nerds Aug 19, 2014 at 12:51:31 (UTC)
Goto Top
Vernutung ist, dass du natürlich auch eine Route zurück brauchst. Du hast vom 30.x ins 1.x, aber du brauchst noch von 1.x ins 30.x. Was ich aber noch nicht verstehe. Der Router hat die IP 192.168.30.1, aber bei den Clients ist das GW 192.168.30.240? Hat der Router zwei IPs?
Member: mpmichael
mpmichael Aug 19, 2014 at 12:57:52 (UTC)
Goto Top
Hallo,

Ok das Gateway 192.168.30.240 ist der Breakout in das Internet und funktioniert soweit
Auf dem anderen Gateway 192.168.30.1 ist ebenfalls eine Route für das Netz 192.168.30.x eingetragen.

Hilft das? Mit welchen Tools kann ich den am besten die Routen testen?
LG
mpm
Member: SlainteMhath
Solution SlainteMhath Aug 19, 2014 updated at 14:15:28 (UTC)
Goto Top
Moin,

wenn Layer 3 (ICMP) funktioniert und Layer 4 (http) nicht, dann kanns eigentlich nur ein einer Firewalleinstellung oder einem nicht laufenden Webserver liegen.

lg,
Slainte
Member: IT-Nerds
IT-Nerds Aug 19, 2014 at 13:02:46 (UTC)
Goto Top
In dem Fall kann ich SlainteMhath nur zustimmen. Mit Tracert könnte man den Weg ggf. nachvollziehen. Bei den Telefonen ist auch die 192.168.30.1 als Gateway eingetragen?
Member: mpmichael
mpmichael Aug 19, 2014 at 13:09:06 (UTC)
Goto Top
Hallo,

nein auf den Telefonen ist die 192.168.30.240 als defGW eingetragen, da die ja die Hauptverbindung in das Internet benötigen.
Die PC's befinden sich im 192.168.1.0 Netz und müssen die Telefone ansteuern können (über prot 80).
LG
mpm
Member: SlainteMhath
Solution SlainteMhath Aug 19, 2014 updated at 14:15:05 (UTC)
Goto Top
Routing und Netzwerkeinstellungen müssen wie folgt aussehnen:
Netz 1: 192.168.30.x/24
Default GW 192.168.30.240

Netz 2: 192.168.1.x/24  
Default GW 192.168.1.y

Juniper 
IP1: 192.168.30.1/24
IP2: 192.168.1.y/24
Zusätzlich Routen:
*keine*

"Router"   
IP1: 192.168.30.240
Zusätzlich Routen:
Defailt => ISP
192.168.1.0/24 => 192.168.30.1

Und dann:
wenn Layer 3 (ICMP) funktioniert und Layer 4 (http) nicht, dann kanns eigentlich nur ein einer Firewalleinstellung oder einem nicht laufenden Webserver liegen.
Member: mpmichael
mpmichael Aug 19, 2014 at 13:25:02 (UTC)
Goto Top
Hallo,

danke für die gute und präzise Erklärung! Damoit weiß ich jetzt das meine Konfig und meine Einschätzung richt waren.
Also muss es an der Firewall (192.168.30.1) liegen - irgendwas lässt die nicht durch - ich denke ich werde mal einen Portscanner probieren... um zu sehen was da durch geht...
LG
mpm
Member: aqui
aqui Aug 19, 2014 at 13:52:09 (UTC)
Goto Top
Mit welchen Tools kann ich den am besten die Routen testen?
Traceroute oder Pathping sind hier wie immer deine besten Freunde ! Das deine Routing Konfig richtig ist siehst du schon daran das der Ping sauber rennt. Der würde scheitern hättest du hier einen Fehler !
Fazit: Zu 98% ein Problem der lokalen Firewall, denn die blocken gemeinhin IP Pakete die mit Absenderadressen ankommen die NICHT aus dem lokalen Netzwerk kommen.