Rsync - seltsame Probleme mit Umlauten

Mitglied: Highend01

Highend01 (Level 1) - Jetzt verbinden

31.07.2011, aktualisiert 00:43 Uhr, 8419 Aufrufe, 3 Kommentare

N'abend zusammen,

irgendwie bin ich gerade über ein seltsames Problem bei der Verwendung von rsync gestolpert.

1.te Vorgehensweise:

Eingabeaufforderung geöffnet (ohne Adminrechte).
Die gewählte Datei (öööüüä.vbs) wird bei dieser Variante einwandfrei übertragen:
2.te Vorgehensweise:

Eigentlich findet diese Übertragung über eine Batchdatei statt, nicht über die direkte Eingabe des rsync Kommandos.

Hier also kurz die zugehörige Batchdatei (Pfad: C:\Users\Highend\AppData\Local\Temp\~rsync.bat):

Prinzipiell also 0 Unterschiede zur manuellen Vorgehensweise.

Starte ich das Ganze jetzt also über die Batchdatei dann bekomme ich folgenden Output:

Manuell ausgeführt hat rsync keine Probleme, die Datei zu finden und zu übertragen, über eine Batchdatei hingegen wird die gleiche Datei nichteinmal mehr gefunden.

Das Ganze unter Windows 7 Ultimate, x64, Deutsch.
rsync (v3.0.8) stammt übrigens aus der aktuellsten Ausgabe vom cwrsync Paket (http://www.itefix.no/i2/node/10650)

Hat jemand eine Ahnung, warum die Variante über die Batchdatei nicht funktioniert?

Danke und Gruß.
Mitglied: Friemler
31.07.2011 um 10:15 Uhr
Hallo Highend01,

wahrscheinlich hast Du Dein Batchscript mit Notepad gespeichert. Notepad speichert in ANSI-Codierung, die Kommandozeile arbeitet aber mit ASCII-Codierung. Du musst Dein Batchscript mit einem Editor speichern, der ASCII-Codierung beherrscht, z.B. Notepad++ mit der Einstellung OEM850 für die Codierung.

Gruß
Friemler
Bitte warten ..
Mitglied: Highend01
31.07.2011 um 10:46 Uhr
Hallo Friemler,

ich hab mir versuchsweise Notepad++ geholt, die ~rsync.bat geöffnet, die Enkodierung per "Encoding - Character sets - Western European - OEM 850" gewechselt, abgespeichert und die .bat neu aufgerufen.

Gleiche Fehlermeldung wie zuvor.

Der Enkodierungswechsel war allerdings erfolgreich, die Statuszeile zeigt dies entsprechend an (Dos\Windows OEM 850).

So sieht der zu übertragende Dateiname in der Batchdatei nach der Konvertierung aus:
Gruß,
highend
Bitte warten ..
Mitglied: Friemler
31.07.2011 um 11:02 Uhr
Hallo Highend01,

dann schreibe den Dateinamen nochmal neu in die Batchdatei, und zwar wenn der Code in Notepad++ geladen und die Codierung auf OEM850 eingestellt ist....

Gruß
Friemler
Bitte warten ..
Heiß diskutierte Inhalte
Microsoft
Mitteilung an alle bei Störungen in der IT
gelöst David.B2D45Vor 1 TagFrageMicrosoft31 Kommentare

Hallo Forum, ich bin auf der Suche nach einem Programm / Tool mit dem ich Text (Laufschrift) auf allen (gewünschten) PC's / Benutzer im ...

Exchange Server
Exchange Zero Day Hack - Wie entfernen?
gelöst mtaiitVor 11 StundenFrageExchange Server17 Kommentare

Hallo, bei mir hat es einige Kundenserver getroffen Weiß einer wie ich diese WebShells wieder loswerde? Das löschen der betroffenen .aspx Dateien wird wohl ...

E-Mail
Kann man mit SPF Mails für eine Domäne vollständig verbieten?
gelöst StefanKittelVor 23 StundenFrageE-Mail17 Kommentare

Hallo, viele Firmen haben ja zusätzliche Domänen. Als Web- und oder Mail-weiterleitung. Es werden also niemals Emails damit gesendet werden. kann man mit einem ...

Server-Hardware
Firmware-Updates auf Servern
redhorseVor 1 TagFrageServer-Hardware7 Kommentare

Guten Morgen, die Server-Hersteller stellen bekanntlich regelmäßig Firmware- und Treiberupdates für deren Serverhardware bereit, diese können z.B. bei Dell als Dell EMC Server Update ...

Linux
Windows auf Dualbootrechner entfernen und Linux die komplette Platte zur Verfügung stellen
N8chtfalterVor 1 TagFrageLinux6 Kommentare

Hallo Linux Profis, ich habe einen Laptop auf dem ursprünglichen Windows 10 installiert war, und ist, ich habe vor einem Jahr Ubuntu testhalber als ...

Router & Routing
Routing öffentliche IP-Adresse-Traffic per BGP im internal-Network
gelöst jescheroVor 22 StundenFrageRouter & Routing2 Kommentare

Guten Abend alle zusammen, ich habe ein kleines Problem beim Routing in pfSense. Mein aktuelles Aufbau ist folgenden: Ich habe eine pfSense-VM und zwei ...

Windows Server
Domänenadmin kann kein Zertifikat anfordern
noodellsVor 1 TagFrageWindows Server6 Kommentare

Hallo Zusammen, ich habe ein Problem beim Finden einer Einstellung. Zuerst einmal der Stand: Es gibt eine Windows CA und Domaincontroller und alles funktionierte ...

Exchange Server
Windows Server 2019 + Exchange Server 2019 (Probleme mit Pop3)
gelöst aristonVor 1 TagFrageExchange Server4 Kommentare

Hallo zusammen, ich habe gerade angefangen, mit dem Exchange Server 2019 in der Demoversion zu arbeiten und folge Schritt für Schritt bei der notwendigen ...