Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

sicherheitsproblem unter win2003 server mit PHP

Mitglied: martin70
wenn ich den auf http://www.linux-magazin.de/Artikel/ausgabe/2004/10/php/php.html beschriebenen filebrowser auf meinem IIS6 ausführe, kann ich auf sämtliche verzeichnisse und dateien zugreifen. ist da irgendwas falsch eingestellt?

Content-Key: 3947

Url: https://administrator.de/contentid/3947

Ausgedruckt am: 25.10.2021 um 10:10 Uhr

Mitglied: timi007
timi007 14.11.2004 um 16:35:56 Uhr
Goto Top
ahso das php script selber hat bei mir nicht funktioniert ( win2003 php3, 4, 5 )
habe aber ein anderes script verwenden, ich habe die ganze festplate gesehn !!
es hat alle ordner angezeigt !! auch win ordner !!

in der php.ini open_basedir umschtellung.

zeigt das script einen fehler das es nicht mehr funktioniert.
Mitglied: martin70
martin70 14.11.2004 um 21:30:27 Uhr
Goto Top
das mit dem open_basedir habe ich ja gemacht, aber da muss man ja den ordner wo sich die ganzen webs drinnen befinden, freigeben. so konnte der eine beim anderen reinsehen.

ich habe jetzt in der php.ini mal folgendes geändert:

open_basedir =./

wie es jetzt aussieht kommt man mit dem script jetzt nicht mehr in ein anderes verzeichnis...
Mitglied: timi007
timi007 14.11.2004 um 21:50:24 Uhr
Goto Top
schreib mich ma an : mailto:nc-nuhanoju@netcologne.de
dan send ich dir das script zu, dan kanst du testen ob es weiter hin funktioniert...

gruß
Heiß diskutierte Beiträge
question
Realistische Zeiterfassung für undisziplinierten Mitarbeiter? gelöst istike2Vor 19 StundenFrageWindows 1014 Kommentare

Hallo, ab Januar bin ich fest angestellt und wurde mir u. A. mitgeteilt, dass wir die Arbeitszeiten in einem Android-App erfassen sollen. Soweit OK. Das ...

question
PC zeigt kein Bild mehrben1300Vor 1 TagFrageHardware14 Kommentare

Hallo zusammen, mein PC geht zwar noch an (LED leuchten und Lüfter laufen), aber ich erhalte kein Bild mehr. Mainboard: MSI B450M Mortar Max Mainboard ...

question
Browserverhalten bei nicht offizieller TLD im privaten NetzSiegfried36Vor 1 TagFrageDNS21 Kommentare

Moin, ich hoffe ihr könnt mir helfen Licht ins Dunkel zu bringen. So ganz verstehe ich diesen ganzen Zusammenhang nicht. Ich will in meinem internen ...

question
Netzwerkproblem Feuerwehr EinsatzleitfahrzeugTorstenWeVor 20 StundenFrageNetzwerke4 Kommentare

Hallo Zusammen, Ich bin Mitglied in einer Feuerwehr mit einem Einsatzleitwagen. In diesem LKW sind mehre Computer-Arbeitsplätze mit einem eigenen Netzwerk verbaut. Wir haben ein ...

question
JBOD - Platte kopieren möglich? gelöst DoKi468Vor 1 TagFrageFestplatten, SSD, Raid2 Kommentare

Hallo zusammen, eine Frage: Ich habe eine Synology NAS und habe dort ein JBOD eingerichtet mit 2 4TB Platten Allerdings springt bei einer Platte teilweise ...

question
Benötige Empfehlung für Komponenten - Umstieg von Ubiquiti auf welches System??Dominik187Vor 8 StundenFrageNetzwerke13 Kommentare

Guten Tag liebe Community, aktuell habe ich einige Produkte von Ubiquiti im Einsatz und überlege, das System zu wechseln, denn leider habe ich mich schon ...

question
Wordpress bereitstellenWolf6660Vor 16 StundenFrageHosting & Housing7 Kommentare

Hi, ich habe eine Domain ohne Webspace gekauft und diese auf meine IP umgeleitet. Nun würde ich gerne eine Wordpress Seite erstellen und diese Online ...

question
Mit SSH auf Android - Fehler mit "mount"PeterGygerVor 20 StundenFrageNetzwerke16 Kommentare

Hallo Ich bin über SSH auf einem Android Device (Nvidia Shield). Das Device funktioniert im LAN. D.h. der Zugriff auf Dateien auf dem NAS über ...