SMTP-Error 503

chiefteddy
Goto Top
Hallo,

ich habe ein Problem beim versenden einer e-Mail an eine bestimmte Mail-Adresse.

Empfänger: Max.Mustermann@firma.de

Ich erhalte eine Unzustellbarkeits-Nachricht:

Command: EHLO mail.meine-firma.de
Response: 503 mailgate.firma.de Duplicate HELO

Ein Test mit "telnet mailgate.firma.de 25" und händischen Versenden einer Mail an obigen Empfänger brachte keine Fehlermeldungen.

Ein Test auf mxtoolbox.com für "mailgate.firma.de" zeigte keine Probleme.

Irgendwie komme ich mit der Fehlermeldung nicht weiter.

Hat jemand einen Tip, in welche Richtung ich suchen muss?

Die Beschreibung des Fehlers 503 "Der Server hat eine falsche Befehlsfolge festgestellt", hilft mir nicht wirklich weiter.

Bei meinem Mail-/Groupware-System handelt es sich um GroupWise 18.2. Das System ist in dieser Version seit über einem Jahr im Einsatz und dieser Fehler ist das erste mal und nur bei dieser Adresse aufgetreten ( ca. im Mai diesen Jahres funktionierte der Empfänger noch - laut Aussage des Kollegen).

Jürgen

Content-Key: 1441488283

Url: https://administrator.de/contentid/1441488283

Ausgedruckt am: 17.08.2022 um 12:08 Uhr

Mitglied: Lochkartenstanzer
Lochkartenstanzer 28.10.2021 um 14:27:54 Uhr
Goto Top
Moin,

Welches System schickt Dir diese Nachricht. Der Empfängerserver oder eines Deiner Systeme. Das sollte in den Headern der Fehlernachricht stehen.

Sind irgendwelche proxies oder smarthosts dazwischen?

Passiert das nur bei diesem Empfänger oder auch bei anderen?

lks
Mitglied: chiefteddy
chiefteddy 28.10.2021 um 15:18:19 Uhr
Goto Top
Hallo,

Die Unzustellbarkeits-Nachricht wird von meinem Internet-Gateway (GATEWAY.GWIA.DO_Meine-Firma) gesendet.
Auslöser ist sicherlich der vom Empfänger-Mailserver gesendete Fehler-Code 530.

Keine Proxies oder Smarthosts auf meiner Seite (nur Firewall)

Wie ich bereits schrieb: Fehler nur bei diesem Empfänger (andere Empfänger der gleichen Domäne konnte ich nicht testen)

Jürgen
Mitglied: SlainteMhath
SlainteMhath 28.10.2021 um 15:47:33 Uhr
Goto Top
Moin,

wirf mal einen Blick in die Logs deines Mailservers, evtl. steht da mehr/ausführlicheres

Oder du wendest dich an den Admin des Empfangsservers...

lg,
Slainte
Mitglied: em-pie
em-pie 28.10.2021 um 16:43:53 Uhr
Goto Top
Moin,

so wie es sich hier liest, hättest du dann zwei RDNS auf deiner IP sitzen.
IP: 47.11.47.11 (fiktiv)
RDNS1: mail1.contoso.tld
RDNS1: www.contoso.tld

Prüfe das mal.

Oder dein HELO im Mail-Server weicht vom RDNS-Eintrag ab...
Mitglied: Lochkartenstanzer
Lochkartenstanzer 28.10.2021 um 16:52:08 Uhr
Goto Top
Zitat von @chiefteddy:

Keine Proxies oder Smarthosts auf meiner Seite (nur Firewall)

Wie ich bereits schrieb: Fehler nur bei diesem Empfänger (andere Empfänger der gleichen Domäne konnte ich nicht testen)

Lass einen Sniffer auf Deinem gateway mitlaufen und schau, was schiefgeht.

lks
Mitglied: chiefteddy
chiefteddy 28.10.2021 um 17:16:56 Uhr
Goto Top
Hallo,

hier ein Screenshot des Tests meines Mailsystem über mxtoolbox.com

mxtoolbox

Ich sehe hier keinen Konfigurationsfehler. Es liegen auch definitiv keine 2 DNS-Namen auf der gleichen externen IP.

Das System funktioniert ja auch seit über einem Jahr für ca. 20 aktive Nutzer und 100 bis 200 Mails pro Tag.

Jürgen
Mitglied: LordGurke
LordGurke 29.10.2021 um 00:37:15 Uhr
Goto Top
Das testet, wie dein Server reagiert, wenn an deinen Server eingeliefert wird - es sagt nichts darüber, wie dein Server mit anderen Servern oder zumindest diesem einen speziellen Server redet.

Hast du die Möglichkeit, ein Transkript der SMTP-Kommunikation zwischen dir und diesem problematischen Server zu erzeugen? Das ist deutlich aussagekräftiger und damit sollte sich der Fehler finden lassen - oder im Zweifel der Beweis, dass die Gegenstelle zu doof für E-Mail ist.
Mitglied: chiefteddy
chiefteddy 29.10.2021 um 08:03:54 Uhr
Goto Top
Hallo,

der Screenshot war als Antwort auf den Hinweis von @em-pie bezüglich eines Fehlers bei der RDNS-Antwort gedacht.

Einen Protokoll-Mitschnitt bekomme ich sicher hin, wird nur etwas dauern.

Was mich stutzig macht ist der Fehler-Code und der Hinweis auf doppelte EHLO-Pakete. Das ist doch etwas, was das Mail-System eigenständig generiert. Auf die unmittelbare SMTP-Kommunikation habe ich in der Konfiguration doch gar keinen Einfluß. Und wenn ich wider erwarten doch so einen gravierenden Fehler in meinem System habe, müssten doch andere Empfänger das auch bemängeln.

Jürgen
Mitglied: SlainteMhath
SlainteMhath 29.10.2021 um 09:40:24 Uhr
Goto Top
bezüglich eines Fehlers bei der RDNS-Antwort gedacht.
Hm, evtl. solltest du mal nachlesen was RDNS ist... nämlich REVERSE DNS, also Zuordnung einer IP Adresse zu einem Domainnamen. Hast du da 2 Zuordnungen, gibts evtl. Problem.

Und nochmal mein Hinweis von oben:
Nur der Empfänger/Empfangsserver weis warum er deine Mails ablehnt. Das ist nicht unbedingt der Grund, den er dir im SMTP-Austausch nennt! Deswegen: setzte dich mit den Admins beim Empfänger in Verbindung und frag dort nach warum sie deine Mails nicht mögen.
Mitglied: chiefteddy
chiefteddy 29.10.2021 um 11:03:38 Uhr
Goto Top
Hallo @SlainteMhath

Hm, evtl. solltest du mal nachlesen was RDNS ist... nämlich REVERSE DNS, also Zuordnung einer
IP Adresse zu einem Domainnamen. Hast du da 2 Zuordnungen, gibts evtl. Problem.

Ich weiß was RDNS ist!

Auf die von Dir genannte Fehlerursache hatte mich auch schon @em-pie hingewiesen. Desshalb habe ich ja noch einmal mit mxtoolbox.com mein Mailsystem getestet und das Ergebnis gepostet:

mxtoolbox prüft RDNS und mein System ist OK (erste 3 grüne Haken im Screenshot).

Das ist nicht unbedingt der Grund, den er dir im SMTP-Austausch nennt!

Dann frag ich mich, warum es ein standadisiertes SMTP-Protokoll mit definierten Fehler-Codes gibt.
Sinn und Zweck eines Standards ist doch, dass man sich über Grenzen hinweg verständigen kann. Und nicht, um anderen das Leben schwer zu machen.

Nur der Empfänger/Empfangsserver weis warum er deine Mails ablehnt.

Das ist absolut richtig. Und normalerweise tut er das dem Sender über den Fehler-Code mitteilen. Dazu ist der Fehler-Code ja da. Natürlich kann ich beim Empfänger-Admin nachfragen, ob er mir die entsprechende Sequenz aus seinen Log-Dateien zukommen lassen kann.

Ich hatte die anscheinend irrige Annahme, dass der Fehler-Code mich erstmal weiter bringt und ich gegebenenfalls mein System als Ursache ausschließen kann. Bis jetzt hatte ich mit diesem Weg bei anderen Mail-Problemen eigendlich immer Erfolg und konnte die Ursache klären und in der Regel beseitigen.

Obige Fehlermeldung lässt mich aber vollkommen im Dunkeln stehen.

Jürgen

PS. Ich werde bei Gelegenheit dieses Problem über eine Protokoll-Analyse weiter aufklären.
Mitglied: Lochkartenstanzer
Lochkartenstanzer 29.10.2021 um 11:25:44 Uhr
Goto Top
Zitat von @chiefteddy:

Dann frag ich mich, warum es ein standadisiertes SMTP-Protokoll mit definierten Fehler-Codes gibt.
Sinn und Zweck eines Standards ist doch, dass man sich über Grenzen hinweg verständigen kann. Und nicht, um anderen das Leben schwer zu machen.

Nur halten sich leider nicht alle an die Standards oder "lügen" beim Grund.

lks
Mitglied: em-pie
em-pie 29.10.2021 um 13:40:49 Uhr
Goto Top
Zitat von @chiefteddy:

Hallo @SlainteMhath

Hm, evtl. solltest du mal nachlesen was RDNS ist... nämlich REVERSE DNS, also Zuordnung einer
IP Adresse zu einem Domainnamen. Hast du da 2 Zuordnungen, gibts evtl. Problem.

Ich weiß was RDNS ist!

Auf die von Dir genannte Fehlerursache hatte mich auch schon @em-pie hingewiesen. Desshalb habe ich ja noch einmal mit mxtoolbox.com mein Mailsystem getestet und das Ergebnis gepostet:

mxtoolbox prüft RDNS und mein System ist OK (erste 3 grüne Haken im Screenshot).
Ich mag mich ja irren, aber ich sehe nur, dass es zu deiner IP den passenden DNS Eintrag gibt, sowie der DNS-Eintrag zur IP passt.

Beispiel:
Zur ID 4711 passt Max Mustermann als auch Sabine Musterfrau
Wenn jetzt geprüft wird, ob zur 4711 die Sabine Musterfrau passt, wird die Meldung OK lauten, weil es ja der Tatsache entspricht. Wenn aber NICHT geprüft wird, ob die ID auch mehrfach verwendet wird, wirst du auch keinen Fehler erhalten.

Starte also mal von mxtoolxbox die DNS-Tests und gehe einmal über die IP und einmal über dein mail.xxx.de
https://mxtoolbox.com/dnslookup.aspx
Mitglied: chiefteddy
chiefteddy 29.10.2021 um 18:13:30 Uhr
Goto Top
Hallo @em-pie,

mxtoolbox2

Es gibt keine Probleme mit der Namensauflösung.


Hallo @Lochkartenstanzer

Nur halten sich leider nicht alle an die Standards oder "lügen" beim Grund.

Ich bin mir wohl bewußt, dass es nicht nur "gute Menschen" auf der Welt gibt. face-wink

Nur sollte es für´s "Lügen" einen Grund geben. Und welchen Grund ein Lieferant haben sollte, dass keine Bestellungen per Mail bei ihm eingehen und er die Ursache dafür bewußt verschleiert, erschließt sich mir nicht.

Schönes WE.

Jürgen
Mitglied: SlainteMhath
SlainteMhath 02.11.2021 um 10:37:52 Uhr
Goto Top
Nur sollte es für´s "Lügen" einen Grund geben.
Ganz einfach: Weil man Spammern nicht verraten will, warum man sie abgewiesen hat.
Mitglied: Lochkartenstanzer
Lochkartenstanzer 02.11.2021 um 10:58:51 Uhr
Goto Top
Zitat von @SlainteMhath:

Nur sollte es für´s "Lügen" einen Grund geben.
Ganz einfach: Weil man Spammern nicht verraten will, warum man sie abgewiesen hat.

Genau. Man gibt ja auch Leuten keine Hinweise auf das Paßwort, wenn sie verschiedene Paßwörter versuchen, außer man ist MIcrosoft. face-smile

lks