Sverweis kombinieren

bve
Goto Top
Folgende Ausgangssituation:

Eine Tabelle mit zwei Tabellenblättern. Bei den Daten handelt es sich um Telefonnummern.

Blatt 1, Bei den Daten handelt es sich um Telefonnummern:
ABC
1123456
2456789
3741598


Blatt 2, Bei den Daten handelt es sich um Telefonnummern und deren Standort:
ABC
1123456456789Blubb
2741598854789Blibb
3325478154789Blaaa

Folgendes soll passieren:
Erstmal soll nach dem Wert aus Blatt 1 B1 in Blatt 2 Spalte A gesucht werden. Sollte das Ergbniss gefunden werden soll der zugehörige Wert in Spalte C ausgegeben werden (Soweit alles mit Sverweis bereits hinbekommen). Sollte der Wert nicht vorhanden sein, soll in Blatt 2 Spalte B gesucht werden und dann der Wert aus Spalte C zurückgegeben werden. Das Ergebnis soll in Blatt 1 unter A1 angezeigt werden.

Wie kann ich zwei Sverweise kombinieren? Oder ist das der falsche Ansatz?

Danke für eure Hilfe!

Content-Key: 91213

Url: https://administrator.de/contentid/91213

Ausgedruckt am: 29.06.2022 um 00:06 Uhr

Mitglied: Supaman
Supaman 03.07.2008 um 12:57:22 Uhr
Goto Top
du brauchst eigentlich nur 2 verschiedene SVERWEIS formlen in eine WENN formal reinpacken.
=WENN( (SVERWEIS1...ETC) <>"";(SVERWEIS1...ETC) ; (SVERWEIS2...ETC) )

sinngemäß: wenn SVERWEIS1 einen inhalt hat, schreibe SVERWEIS1, ansonsten schreibe SVERWEIS2.

oder du trennst es auf:
SVERWEIS1 -> neue spalteE
SVERWEIS2 -> neue spaltef
=WENN( E2 <>"";E2; F2)
Mitglied: bve
bve 03.07.2008 um 13:50:06 Uhr
Goto Top
Schonmal danke für die schnelle Hilfe. Funktioniert aber noch nicht.

Ich erhalte als Ergbnis immer #NV, wenn SVerweis2 angeigt werden soll.
Ich habe auch die Trennung vorgenommen, wie von dir beschrieben, leider mit dem selber Ergebnis.

Meine Formel:
=
WENN
(
(SVERWEIS(F2;Telefonliste!A:V;11;0))<>"";
(SVERWEIS(F2;Telefonliste!A:V;11;0));
(SVERWEIS(F2;Telefonliste!B:V;10;0))
)
Mitglied: bve
bve 03.07.2008 um 13:57:15 Uhr
Goto Top
Es muss an der Prüfungsbedingung liegen. Wenn die Rufnummer in der Spalte nicht gefunden wurde ist das Ergebnis des Sverweises #NV und kann daher nicht ungleich "" sein. Sehe ich das richtig?
Mitglied: bve
bve 03.07.2008 um 14:21:27 Uhr
Goto Top
Gelöst;-) face-wink

Formel muss lauten:
=WENN((ISTNV((SVERWEIS(C2;Telefonliste!A:V;11;0))))=FALSCH;(SVERWEIS(C2;Telefonliste!A:V;11;0));(SVERWEIS(C2;Telefonliste!B:V;10;0)))

Trotzdem viel Dank für die Hilfe. Ohne den Ansatz hätte ich es wohl nicht hinbekommen.