VIA SATA RAID Controller nutzen

expone
Goto Top

Ich möchte an einem Computer mit RAID Controller (VIA-Chipsatz) RAID 1 in Betrieb nehmen. Es sind allerdings schon Daten auf den Datenträgern vorhanden.

Der Computer verfügt über einen SATA RAID Controller mit VIA Chipsatz. An diesem hängen zwei SATA Festplatten:

Datenträger 1: 186,31 GB
Partition 1: 68,47GB; Windows XP Professional SP2;
Partition 2: 122,83GB; Daten;

Datenträger 2: 149,05 GB
Partition 1: 29,30GB; Daten;
Partition 2: 119,75GB; Daten;

Der RAID-Controller wird von Windows erkannt und scheint über die richtigen Treiber zu verfügen. Es befindet sich auch bereits die Software "VIA RAID TOOL" auf dem PC.

Dies ist meine erste RAID Einrichtung und ich kenne noch nicht die vollwertige Hardware des Systems.

Partition 1 und 2 auf Datenträger 1 müssen auf jeden Fall so bestehen bleiben! Die anderen Partition von Datenträger 2 kann ich bedenkenlos auf die Partitionen von Datenträger 1 kopieren. Ich möchte das eigentlich ohne Neuinstallation von Windows und vor allem ohne Datenverlust umsetzen können.

Nun meine Fragen an Euch:
Wie sollte ich am besten vorgehen, um RAID 1 in diesem System zu konfigurieren?
Kennt ihr ein gutes Tutorial für diesen RAID Controller und welche Risiken bzw. Probleme würden auf mich zukommen?

Vielen Dank schon Mal im Voraus.
expone!

Content-Key: 70901

Url: https://administrator.de/contentid/70901

Ausgedruckt am: 02.07.2022 um 03:07 Uhr

Mitglied: ditpro
ditpro 14.10.2007 um 16:27:27 Uhr
Goto Top
Ich würde dir empfehlen so vorzugehen:
1. kopiere die Daten der 2. Festplatte mit auf die 1. Festplatte
2. erstelle von der 1. Festplatte ein Image z.B. mit Acronis True Image (Wahlweise auf CD oder externe USB Festplatte)
3. jetzt kannst du den Rechner neu starten und musst in das BIOS des RAID Controllers gehen (evtl. muss die RAID Funktionalität im Hauptsystem BIOS vorher erst noch aktiviert werden)
im BIOS des Raid Controllers kannst du jetzt das RAID 1 (Mirror) mit den bestehenden Festplatten anlegen. Möglicherweise erkennt das BIOS, dass bereits Daten vorhanden sind, dann kannst du Festplatte1 als Quelle und Festplatte 2 als Ziel angeben. Die Platten werden automatisch synchronisiert. Danach sollte Windows wieder starten können.

Falls die Daten verloren gehen, richtest du das RAID1 komplett neu ein und stellst mit Acronis True Image die gesicherten Daten darauf wieder her.

Falls Windows auch danach nicht starten sollte (weil z.B. der RAID Treiber nicht vorhanden war) kannst du immer noch den alten Zustand wiederherstellen und das Acronis Image wieder zurückspielen.
Mitglied: expone
expone 14.10.2007 um 20:05:13 Uhr
Goto Top
Ich habe bisher noch keine Lizenz von Acronis True Image, habe allerdings davon schon viel gehört. Nutze bisher die Nero Festplatten Image-Funktion.

Kann ich denn mit der 11er Demo eine risikolose Sicherung fahren?
Mitglied: ditpro
ditpro 16.10.2007 um 13:46:27 Uhr
Goto Top
weiß ich nicht, die 49€ für die Acronis Lizenz sind aber gut angelegt und später auch noch als sehr gute Sicherungssoftware zu verwenden
Mitglied: expone
expone 16.10.2007 um 18:31:37 Uhr
Goto Top
Hallo Zusammen!

Also die Demo von TrueImage tut Ihren Dienst. Werde die Tage auch eine Lizenz erwerben. 50€ sind wirklich gut investiert...

Nun zurück zum eigentlichen Problem:
Ich habe nun versucht ein neues RAID 1 Array anzulegen. Das funktioniert soweit auch.

Leider tritt immer ein Fehler bei der Duplizierung / Synchronisierung der Daten von der Quellplatte zur Zielplatte auf (Siehe URL zu Screenshot): http://was.lothargeisinger.de/uploads/share/scr1.png

Der Fehler tritt stets am Ende der 19% auf. Egal ob ich das Array via Bios oder mit dem VIA RAID Tool erstelle. Wenn ich das Array über das Bios erstelle wird danach auch eine Duplizierung der Daten eingeleitet, die allerdings ohne einen Fehler vor Beendigung durch einen Systemneustart abgebrochen wird.

Windows startet dann ganz normal und erkennt auch nur eine physikalische HD. Das Array ist also in Betrieb. Das VIA RAID Tool erkennt dann aber, dass die Platten nicht synchronisiert sind und schlägt vor, dieses direkt nachzuholen.

Aber jedes Mal wird bei 19% abgebrochen.

Das seltsame an der Sache ist, dass die Platten eigentlich synchronisiert wurden. Konnte mich durch einen Plattentausch davon überzeugen.


Kann mir an der Stelle Jemand weiterhelfen?
Woran könnte es liegen? Etwa an den unterschiedlichen HDs?
Mitglied: expone
expone 18.10.2007 um 00:56:18 Uhr
Goto Top
So, ich habe es nun endlich geschaft!

Leider konnte ich über den RAID Controller die Daten nicht erhalten, sondern musste das Array über das VIA RAID TOOL erstellen und dort auch sagen, dass ich das aktuelle OS nicht behalten möchte.

Hab alle Daten dann via Image auf die "geRAIDede" HD zurückgespielt...

Warum der Fehler auftrat ist mir nach wie vor schleierhaft.

Ich bedanke mich an dieser Stelle trotzdem für all die Hilfe.

Bis dann.