kerbel3rd
Goto Top

VMWare ESXI, vServer kein Zugriff mehr, Server läuft aber

Moin,

vserver

der grau unterlegte Server läuft, Remotezugriff usw. funktioniert, es gibt aber keinen Zugriff mehr über Webclient bzw vSphere-Client.

Dort wird er als Ausgeschaltet angezeigt und switched zwischen den Hosts hin und her.

Idee für einen Lösungsansatz?

Thx im voraus

3rd

Content-Key: 505340

Url: https://administrator.de/contentid/505340

Printed on: May 20, 2024 at 16:05 o'clock

Member: falscher-sperrstatus
falscher-sperrstatus Oct 16, 2019 at 13:08:08 (UTC)
Goto Top
Backup vorhanden? ESXI updaten?
Member: Kerbel3rd
Kerbel3rd Oct 16, 2019 updated at 13:12:29 (UTC)
Goto Top
der Vorgang startete als ich ein Snapshot löschen wollte um Platz zu gewinnen für Veeam BU.

Nachdem sich der alte BU-Server verabschiedet hat (inkl BLW) und frisch auf Veeam umgestiegen bin, also... Nein.

SAN ist randvoll, Neuanschaffung der Produktivserver inkl SAN steht ebenfalls gerade an.
Member: emeriks
emeriks Oct 16, 2019 at 13:18:04 (UTC)
Goto Top
Hi,
Dein Text ist missverständlich.
Es geht darum, dass eine VM nicht mehr erreichbar ist, nicht der ESX selbst?

E.
Member: cykes
cykes Oct 16, 2019 at 17:51:57 (UTC)
Goto Top
Hi,
Zitat von @Kerbel3rd:
SAN ist randvoll
das dürfte das Problem wohl ausgelöst haben. Villeicht hilft Dir das schon: https://www.virten.net/2014/01/vm-grayed-out-as-disconnected-inaccessibl ...

Ggf. mal die .vmx Datei in einem Editor ansehen, die könnte beschädigt worden sein.
Member: Kerbel3rd
Kerbel3rd Oct 17, 2019 updated at 04:23:11 (UTC)
Goto Top
@emeriks: der ESX ist erreichbar, VM kann den vServer nicht ansprechen.

@cykes: Danke für den Link, werd ich checken.
Member: cykes
cykes Oct 17, 2019 updated at 05:46:50 (UTC)
Goto Top
Zitat von @Kerbel3rd:

@emeriks: der ESX ist erreichbar, VM kann den vServer nicht ansprechen.
Auch das ist etwas missverständlich, da der Begriff vServer hier nicht so ganz passt - Du meinst vermutlich den vCenter(-Server). Anhand des Screenshots dürfte aber ersichtlich sein, dass die VM srv-sta... zwar läuft, über RDP usw. erreichbar ist, aber im vCenter ausgegraut angezeigt wird und nicht mehr über den vCenter angesprochen werden kann. Das ist der Fall, seitdem Du versucht hast, einen Snapshot zu löschen, um Platz auf dem SAN zu schaffen.
@cykes: Danke für den Link, werd ich checken.
Die Lösung kann dennoch recht kompliziert und vor allem zeitaufwändig sein. Bei Platzmangel auf der Datastore kann es sich ggf. fatal auswirken, einen Snapshot im laufenden Betrieb löschen zu wollen.
Das Hin- und Herspringen zwischen den Hosts ist eine Folge davon, da der Löschvorgang noch nicht abgeschlossen ist.
Da ich weder weiß, wie gut Du Dich im VMWare-Troubleshooting auskennst, noch genaue Eckdaten der Konfiguration bekannt sind, kein aktuelles Backup vorhanden ist und ich auch nicht vor dem System sitze, möchte ich eigentlich keine Empfehlungen aussprechen. Die vDisk der VM ist ja einge TB groß, on Thin- oder Thick-Provisioned ist aktuell nicht ersichtlich.
Kannst Du nicht anderweitig Platz auf dem SAN schaffen?
Eine gewisse Downtime der VM wirst Du wohl einplanen müssen. Im schlimmsten Fall kann Dir die VM auch in der nächsten Zeit abschmieren. Auf keinen Fall solltest Du blindlinks irgendwas durchprobieren, was irgendwo im Netz steht. Mein Link beschreibt nur die Symptome recht gut. Wenn ihr noch Support bei VMWare habt, zieh diesen hinzu. Ggf. auch den Support des SAN-Herstellers.
Member: Kerbel3rd
Kerbel3rd Oct 17, 2019 at 06:49:30 (UTC)
Goto Top
so weit stecke ich nicht in VMWare. Ist ein Fall für deren Supp.

Danke Dir
Member: Kerbel3rd
Kerbel3rd Oct 17, 2019 at 09:18:50 (UTC)
Goto Top
also....

erstmal habe ich alle funktionierenden virtuellen Server vom ESXI mit dem "defekten" auf meine anderen ESXer migriert

anschliessend per ssh auf den ESXI, nachgesehen ob vmsd und vmx i.O. sind, waren sie.

Anschliessend folgendes in Console gehauen:

vim-cmd vmsvc/getallvms

Antwort: Skipping invalid VM "17"


vim-cmd vmsvc/reload 17

2-5 Sekunden gewartet

und... tadaa, Kiste wieder da...

lüppt....
Member: Pimpfling
Pimpfling Oct 17, 2019 at 09:28:27 (UTC)
Goto Top
Ole ole!
Member: cykes
cykes Oct 17, 2019 at 17:24:45 (UTC)
Goto Top
Zitat von @Kerbel3rd:
vim-cmd vmsvc/getallvms
Antwort: Skipping invalid VM "17"

vim-cmd vmsvc/reload 17

2-5 Sekunden gewartet

und... tadaa, Kiste wieder da...

lüppt....
Top, dann war es Hilfe zur Selbsthilfe face-wink Wenn ein reload gereicht hat, war es auch noch nicht so kritisch. Aber trotzdem beobachten und beim nächsten SAN auf genügend freien Speicher für Snapshots etc achten...
Member: Kerbel3rd
Kerbel3rd Oct 18, 2019 at 05:29:45 (UTC)
Goto Top
Moin cykes,

das jetzige SAN hat 14 TB,

das geplante neue liegt bei 50...