Webdavzugriff im Browser ok, aber nicht im Windows-Explorer

derwowusste
Goto Top
Servus!

Wir haben Kunden, die mit Windows 10 bei uns über Webdav auf eine Freigabe auf Server 2016 zugreifen (das war nicht unsere Idee, sondern Ihre und ist nicht verhandel- oder änderbar).
Bei einem dieser Kunden wurde der PC neu aufgesetzt und seitdem kann er nur noch im Browser darauf zugreifen, jedoch nicht mehr im Dateiexplorer.
Die verwendete Verknüpfung zeigt korrekterweise auf \\server.dom@SSL\share\ (ebenso getestet: file://server.dom@SSL/share) - bei Zugriff heißt es "Netzwerkpfad nicht gefunden".

  • Der Dienst Webclient läuft
  • Im Browser funktioniert es (leider geht im Browser aber kein Upload)
  • Die Zugangsdaten sind korrekt im Anmeldeinfospeicher hinterlegt (konnten wir prüfen)
  • Dem Zielserver wird vertraut (https-Zertifikat ist installiert, ebenso wie das der CA)

Hat noch jemand Ideen, was man dem noch raten kann? Wir können die weder fernsteuern, noch sonstwie weiter diagnostizieren und deren Admins sind kaum zur Hilfe zu bewegen (Behörde).

Content-Key: 3081658791

Url: https://administrator.de/contentid/3081658791

Ausgedruckt am: 08.08.2022 um 02:08 Uhr

Mitglied: Snowman25
Snowman25 15.06.2022 um 15:04:13 Uhr
Goto Top
Hallo DWW,

ohne in das Eventlog sehen zu können wird's schwierig.
WebDAV unter Windows hat bei mir bisher IMMER zicken gemacht. Egal welche Version und welcher WebDAV-Server. Mal funktioniert die Anmeldung laut Serverlog aber Windows kann sich doch nicht verbinden, dann wird ewig "falsche Anmeldedaten" geliefert, obwohl kein einziger Anmeldeversuch beim Server ankommt, etc...

Habe das Gefühl, das bei deinem konkreten Problem irgendein Registry-Key anders gesetzt ist als bei den anderen Clients. Gerade im Zusammenhang mit Verschlüsselungsstufen (TLS 1.1, 1.2, 1.3) hat MS gerne Keys durch Updates temporär geändert, um Kulanzzeiten zu geben. Bei einer Neuinstallation greifft sowas dann eben nicht mehr.

Schönen Gruß und viel Erfolg,
@Snowman25
Mitglied: DerWoWusste
DerWoWusste 15.06.2022 um 15:10:27 Uhr
Goto Top
Moin.

Gerade im Zusammenhang mit Verschlüsselungsstufen (TLS 1.1, 1.2, 1.3) hat MS gerne Keys durch Updates temporär geändert
Welche Keys?
Mitglied: DerWoWusste
DerWoWusste 15.06.2022 um 15:38:13 Uhr
Goto Top
Habe es nun getestet mit dem Windows, was er auch hat (20H2 frisch installiert).
Ergebnis:
Verknüpfung zu \\server.dom\share\ läuft! (ebenso getestet: file://server.dom@SSL/share - läuft nicht "Netzwerkpfad nicht gefunden" )
Mitglied: Snowman25
Snowman25 15.06.2022 um 15:40:40 Uhr
Goto Top
Zitat von @DerWoWusste:

Welche Keys?

Kamm's dir gerade nicht nachschauen, aber mWn war das z.B. bei den PrinterNightmare-Patches so. Da stand's auch in der Patchbeschreibung. Bei den Patch RollUps wird sowas aber typischerweise garnicht erwähnt.

Ich nehme an, du hast die folgenden TechNet-Artikel schon durch?

https://social.technet.microsoft.com/Forums/windowsserver/en-US/c8102938 ...
https://social.technet.microsoft.com/Forums/windows/en-US/9f202c46-1baf- ...
https://social.technet.microsoft.com/Forums/en-US/c66c3168-114d-4e03-afc ...

Die letzten beiden drehen sich um Win7/8.1, sollten aber trotzdem applikabel sein.
Auf dem Windows Server sind alle Updates installiert und TLS 1.1 bzw. 1.2 ist auch aktiviert?

Schönen Gruß,
@Snowman25