Windows Mobile 6.5 an Exchange-Server 2010 anbinden

marc-1303
Goto Top
Guten Tag

Seit 2 Tagen versuche ich erfolglos mit meine HTC HD2 (ROM 3.14.407.2 GER) den Exchange-Server zu erreichen.
Die Kommunikation beginnt, der Status "Ordner synchronisieren" wird angezeigt. ich gehe also mal davon aus, dass
bei den Einstellungen alles in Ordnung ist.

Dann bricht aber ActiveSync ab und gibt den Fehlercode bzw. Unterstützungscode 0x86000C09 ab.
In diesem Fall ist Unterstützung ein grosses Wort. Bei Microsoft findet sich nichts zu diesem Code.

Die einzige brauchbare Seite ist diese: https://serverdata.peopleandtechnology.net/support/kb/default.asp?id=216 ...
Ganz zuunterst wird erklärt wie man den Fehler behebt.
Wenn ich aber im Exchange auf mein Postfach gehe und Mobiltelefone verwalten will ist dort keines in der Liste.
Edit: Auch wenn ich mich in OWA anmelde finde ich kein Telefon in der Liste. Edit Ende.

Ich könnte mir auch vorstellen, dass es mit dem SSL-Zertifikat zu tun hat. Nur finde ich keine gute Anleitung, wie
ich das SSL-Zertifikat des Servers auf mein HTC bringe.

Hat einer schon die selbe Erfahrung gemacht?

Grüsse
Marc

Content-Key: 165997

Url: https://administrator.de/contentid/165997

Ausgedruckt am: 13.08.2022 um 10:08 Uhr

Mitglied: GuentherH
GuentherH 10.05.2011 um 20:31:33 Uhr
Goto Top
Hallo.

Nur finde ich keine gute Anleitung, wie ich das SSL-Zertifikat des Servers auf mein HTC bringe.

Das heißt, du hast das Zertifikat noch nicht installiert. Dann kann es auch nicht klappen.

Am einfachsten rufst du auf dem Windows Mobile OWA auf, und importierst dann das Zertfikat.

LG Günther
Mitglied: OOOmorpheusOOO
OOOmorpheusOOO 10.05.2011 um 21:16:22 Uhr
Goto Top
Hallo Marc

erst einmal eine Frage, wie versuchst du den exchange zu erreichen (interne und externe url - haben beide den gleichen Namen?)

lg
Mitglied: marc-1303
marc-1303 10.05.2011 um 21:20:03 Uhr
Goto Top
Hallo Günther

Genau das habe ich heute am frühen Abend gemacht. Allerdings hat sich leider nichts geändert.
Immer noch die selbe Meldung.

Ich habe dann einen Test-User angelegt und konnte fehlerfrei auf diesen Account verbinden.
Das Problem scheint also bei meinem Benutzerprofil zu liegen.
Wie gesagt, ich müssten (laut Unterstützungs-Code) das Mobiltelefon entfernen.
Entweder im OWA oder in der Exchange-Verwaltung. In beiden Fällen wird aber kein
Mobiltelefon angezeigt das entfernt werden könnte.

Mit der Erfahrung mit dem Test-User werden ich wohl meinen Account neu anlegen.
Erscheint mir einfacher als endlos nach Fehlern zu suchen.

Gruss
Marc
Mitglied: ollembyssan
ollembyssan 10.05.2011 um 23:04:58 Uhr
Goto Top
Hallo,

nun ja, es kann am Zertifikat liegen, muss es aber nicht.
Wenn Du ein selbstsigniertes Zertifikat benutzt, dann bringt es auch nichts dies zu importieren.
Entweder Du installierst eine interne Zertifizierungsstelle und lässt Dir von dieser ein entsprechendes Zertifikat ausstellen oder Deine Firma kauft sich ein solches Zertifikat. Das importieren auf dem Mobilgerät bringt erst etwas, wenn es sich um kein selbstsigniertes Zertifikat handelt. Dann musst Du auch nicht das Zertifikat des Exchange Servers importieren, sondern das der Zertifizierungsstelle.

Deshalb ist es auch nicht richtig was Günter geschrieben hat, wobei ich weiß, dass er es so meinte und nur falsch formulierte!

Ich denke allerdings, dass auf Dich ein nicht jedem bekanntes Problem zutrifft:

Schau einmal hier nach:
http://www.sperrgebiet.org/2010/12/exchange-2010-activesync-http-500-in ...

Hier wird die Lösung beschrieben, deshalb bekommst Du wahrscheinlich auch nicht die Mobilen Endgeräte im AD angezeigt, falls sonst alles richtig konfiguriert ist.

Du kannst aber zuvor in den Logs des IIS nachsehen "C:\ inetpub\logs\LogFiles\...", welche Fehlermeldung beim Zugriff auf Exchange Active-Sync angezeigt wird.

Gruß
Stephan
Mitglied: marc-1303
marc-1303 11.05.2011 um 06:55:05 Uhr
Goto Top
Guten Morgen Stephan

Zum Zertifikat. Es ist ein "echtes" Zertifikat, von einer Zertifizierungsstelle. Dieses habe ich bereits auf dem Handy installiert wie beschrieben.
Ich konnte anschliessend auch fehlerfrei mit dem neu angelegten Test-Account verbinden.

Wenn ich auf der AD-Verwaltung die Einstellungen so treffe wie in dem Link beschrieben finde ich bei meinem User-Account kein Unterordner mit dem Namen
"ExchangeAciveSyncDevices". Sehr wohl findet sich dieser Ordner aber bei zwei Usern, welche auch erfolgreich ihre Mobilephones am Server anmelden konnten.

Mir bleibt wohl wirklich nur, meinen User-Account neu aufzusetzen.

Gruss
Marc
Mitglied: ollembyssan
ollembyssan 11.05.2011 um 08:11:38 Uhr
Goto Top
Hallo Marc,

nein, das ist nicht die Lösung, das Aufsetzen des Users, zudem bereit diese Vorgehensweise zzgl. Probleme bei der Aufslösung des Empfängers etc.

Sind denn die Berechtigungen auch dementsprechend wie im Link beschrieben gesetzt bzw. hast Du dieses überprüft?

Hast Du in die Logfiles des IIS geschaut, um den Fehler zu analysieren?

Das kannst Du tun, indem Du dich mit dem Mobilen Endgerät mit dem Exchange verbindest, danach in die Logfiles, wie oben von mir beschrieben, einen Blick wirfst und Dir den ausgegeben Fehler im Bereich "Exchange Active-Sync" für Deinen Users ausfindig machst!

Gruß
Stephan
Mitglied: marc-1303
marc-1303 11.05.2011 um 08:42:02 Uhr
Goto Top
Hallo Stefan

Danke für die Hilfe. Deine Hartnäckigkeit hat's gebracht.
Beim ersten Mal habe ich die Checkbox für vererbbare Berechtigungen... nicht drin gehabt. So hat's natürlich nichts geholfen.

Ich habe eben das erste Mal erfolgreich mit dem Exchange-Server verbunden.

Wenn's nicht so früh am Morgen wär würd ich wahrscheinlich die Korken knallen lassen.

Liebe Grüsse
Marc
Mitglied: ollembyssan
ollembyssan 11.05.2011 um 11:14:01 Uhr
Goto Top
Hallo,

super!, wusste ich doch face-wink

Gruß
Stephan