markus.angerer
Goto Top

Windows Server 2008R2 Datensicherung und Wiederherstellung

Hallo,

ich hab mal eine Frage bei der ich hoffe dass mir jemand einen Denkanstoss geben kann wie ich da weiterkomme:

Wir haben
1. in unserer Zentrale einen Windows Server 2008R2 Server mit einem Active Directory und einer Oracle Datenbank.
2. ebenfalls in der Zentrale steht noch ein Exchange 2010 Server.
3. In der Filiale die mit VPN angebunden ist steht nochmal ein 2008R2 DC damit im Fall einer Netzwerkunterbrechnung dort noch eine Anmeldung möglich ist.

Alle Server werden mit dem Windows eigenen Backup gesichert.

Jetzt wollte ich mal einen Restore des DCs aus der Zentrale auf einer ansonsten ungebrauchten Hardware testen die nicht am Netzwerk hängt. Da die Hardware fast identlich ist funktioniert das auch erstmal, aber dann kann ich auf der Kiste quasi nichts machen weil - so erklär ich mir das - er sich zuerst mit dem 2. DC replizieren möchte um wieder up-to-date zu sein. Seh ich das richtig? Das kann ich natürlich nicht zulassen weil der wiederhergestellte Server im Moment ja nur eine Kopie ist die es nicht geben sollte.

Wenn meine Vermutung richtig ist kann ich doch auch davon ausgehen dass das Active Directory Backup funktioniert hat und wenn es echt wäre würder er sich replizieren und ich hab an der Stelle erreicht was ich wollte.

Wie könnte ich dem jetzt klarmachen dass er die Replizierung vergessen soll und einfach in dem veralteten Zustand losarbeiten soll? Ich würde mich gern noch an der Oracle DB anmelden um zu sehen dass auch die ordentlich läuft. Das klappt aber scheinbar nicht weil ich keine funktionierende DNS Auflösung hab da diese im Active Directory abgelegt wurde. (Das ist alles eine Vermutung aufgrund der diversen Fehler- und Warnmeldungen. Bitte berichtigt mich wenn Ihr denkt dass ich hier falsch liege).

Um den 2. DC auch wiederherzustellen fehlt mir die Hardware und es würde mir ja wahrscheinlich auch nichts bringen weil dann hab ich halt zwei Maschinen die auf eine Replizierung warten, oder?

Vielen Dank für jeden Hinweis schon mal im Vorab!
Gruss, Markus

Content-Key: 281804

Url: https://administrator.de/contentid/281804

Printed on: March 1, 2024 at 04:03 o'clock

Member: emeriks
emeriks Sep 02, 2015 updated at 14:07:59 (UTC)
Goto Top
Hi,
das hat nix mit der Replikation des 2. DC zu tun.
Ich gehe davon aus, dass der DC auch DNS-Server ist und sich selbst als 1. DNS-Server eingetragen hat?

Falls nein: Dem "Clone" fehlt dann der DNS-Server, weil Du ihn ja offline vom produktiven Netz betreibst. Diesen müsstest Du dann auch noch improvisieren.

Falls ja: Der "Clone" hat an Sicherheit grenzender Wahrscheinlichkeit unmittelbar nach der Wiederherstellung nicht die IP-Adresse wie das Original. Das liegt daran, dass die Netzkarte des "Clone" für die wiederhergestellte Installation "neu" ist und deshalb nicht die IP-Konfiguration der originalen Adresse bekommt. Wenn dem so ist, dann musst Du Dich 1x als DER Administrator anmelden. Das kann ne Weile dauern, bis das nach dem Neustart möglich ist und die Anmeldung kann auch ne Weile dauern. Dann der Netzkarte entweder die alte IP-Adresse geben oder als 1. DNS-Server die am "Clone" gültige eintragen. Danach nochmal neu booten. Dann sollte es gehen.

E.
Member: markus.angerer
markus.angerer Sep 02, 2015 updated at 14:18:44 (UTC)
Goto Top
Hi Emeriks,

Guter Hinweis, da bin ich am Anfang auch drauf reingefallen aber das hab ich dann bemerkt und behoben (und leider in meinem Text oben schon wieder vergessen).
Der Server hat nach dem Restore manuell wieder seine ursprüngliche IP bekommen und wurde neu gestartet. Es ist so wie Du dachtest: Der Server ist auch DNS und hat sich selbst 1. DNS eingetragen. Keinen Weiteren weil ich im Moment denke dass es mir ausreicht wenn er seinen eigenen Namen kennt. Es ist ja sonst eh niemand in dem selben "Netzwerk".

Das mit dem dauern bei der Anmeldung ist auch richtig vermutet. Beim Ersten mal aber auch bei allen folgenden Malen bei denen IP und DNS bereits angepasst waren.

Gruss, Markus
Member: goscho
goscho Sep 03, 2015 updated at 06:22:30 (UTC)
Goto Top
Moin
Zitat von @markus.angerer:
Das mit dem dauern bei der Anmeldung ist auch richtig vermutet. Beim Ersten mal aber auch bei allen folgenden Malen bei denen IP
und DNS bereits angepasst waren.
Das liegt ganz einfach daran, dass bei der Anmeldung der DNS-Server gesucht wird, dieser aber noch nicht gestartet ist.
Dieses Verhalten ist relativ normal, wenn der einzige (oder alle) DC(s) ausgeschaltet wurde(n).
Hier ein paar Tipps zur DNS-Konfiguration in AD-Umgebungen
Member: markus.angerer
markus.angerer Sep 04, 2015 at 16:10:45 (UTC)
Goto Top
Danke euch, ich hab mir die Kiste über's Wochenende mal mit nach hause genommen und fang nochmal von vorne an. Diesmal stell ich noch einen Router mit dazu der auch als DNS fungieren kann und zusätzlich einen Weg ins Internet ermöglicht. Mal sehen ob es dann besser funktioniert...

Gruss + Schönes Wochenende, Markus
Member: goscho
goscho Sep 07, 2015 at 09:08:14 (UTC)
Goto Top
Zitat von @markus.angerer:

Danke euch, ich hab mir die Kiste über's Wochenende mal mit nach hause genommen und fang nochmal von vorne an. Diesmal stell ich noch einen Router mit dazu der auch als DNS fungieren kann und zusätzlich einen Weg ins Internet ermöglicht.
Das ist nicht zielführend, wenn du dem DC als 1. DNS-Server einen Router einträgst.
Dort gehört ein weiterer vollwertiger DNS-Server rein. Das könnte ein 2. DC sein oder ein Linux-DNS-Server.

Ansonsten ist es auch kein wirkliches Problem, bei Reboot des einzigen DC etwas länger zu warten. face-wink
Member: schmitzi
schmitzi Sep 07, 2015 at 23:52:44 (UTC)
Goto Top
Hi,

ich glaube, normalerweise immer sich selber als DNS-Server eintragen
(wenn der DomainController mit DNS-Dienst ist), und der Rest kommt per AD-Synch.
Hilfsweise kann man natürlich den/einen anderen DomainController als DNS-Server einstellen,
dann "finden" die sich am Anfang besser.

nacht
Member: markus.angerer
markus.angerer Sep 08, 2015 at 09:17:44 (UTC)
Goto Top
Genau das ist ja mein ursprüngliches Problem gewesen dass ich keinen AD Sync machen kann weil es kein echter Restore ist sondern nur ein Test. Daher dürfen die anderen DC davon nichts mitbekommen.

Aufgrund der obigen Antworten bin ich nur inzwischen mehr zu der Überzeugung gekommen dass es wohl eher ein DNS denn ein AD Problem ist das mich daran hindert mich an dem PC ordentlich anzumelden.
Die Wartezeit beim lokalen Anmelden am Server erklärt sich mit dem fehlenden/noch nicht gestarteten DNS recht gut und stört mich eigentlich nicht weiter weil ich einfach mal davon ausgehe dass das im Fall eines echten Restores sich über vorhandene andere DNS und den dann auch erfolgenden AD Sync regelt.

Was mir momentan mehr sorgen macht ist dass der DNS Server im Eventlog meldet er erst nach dem erstmaligen Sync wieder zur Verfügung stehen wird (die genaue Meldund weiss ich dummerweise nicht mehr auswendig und im Moment hab ich die Installation komplett vermurkst. Ist schön wenn man am Domain Controller mal einfach so alles ausprobieren kann).
Der nicht vorhandene DNS sorgt dann wiederum dafür dass meine Oracle DB keinen Zugriff erlaubt. Ich würd jetzt einfach dem Server gern sagen: Vergiss die Synchronisierung und arbeite einfach los damit ich prüfen kann ob meine Oracle Sicherung auch wirklich verwendbar ist.

Kann es sein dass das wonach ich suche "Authoritative Restore" heisst? Damit ein einzelner DC nach einem Restore wieder loslegt ohne ggf. auf die anderen zu warten?

Gruss, Markus
Member: emeriks
emeriks Sep 08, 2015 at 09:26:21 (UTC)
Goto Top
Kann es sein dass das wonach ich suche "Authoritative Restore" heisst? Damit ein einzelner DC nach einem Restore wieder loslegt ohne ggf. auf die anderen zu warten?
Nein!
Das ist was anderes. Dabei geht es darum, dass man einen DC in den AD-Wiederherstellungsmodus versetzt, einen alten Systemstatus wiederherstellt, und dann - immer noch im Wiederherstellungsmodus - bestimmte Objekte, welche im wiederhergestellten Stand noch nicht gelöscht sind, "authorisierend wiederherstellt". Anschließend bootet man diesen DC normal und er wird diese Objekte wieder auf alle anderen DC replizieren.

Dein Problem ist offensichtlich der "normale" AD-"Inseleffekt".
Member: markus.angerer
markus.angerer Sep 08, 2015 at 09:35:29 (UTC)
Goto Top
Hab grad mal nach "AD Inseleffekt" gegoogelt und einen langen, älteren Eintrag von Dir gefunden. Danke für das Stichwort, da werd ich mich gleich mal weiter schlau machen...

Viele Grüsse, Markus
Member: schmitzi
schmitzi Sep 08, 2015 at 16:02:06 (UTC)
Goto Top
Hat die Kiste (die jetzt alleine auf der Insel ist) den GlobalCatalog an ?
(AD-Sites->Site->Servers-->DeinServer->NTDS-Settings)
Gruss
RS
Member: markus.angerer
markus.angerer Sep 08, 2015 at 16:57:37 (UTC)
Goto Top
ja. Zumindest hatte sie das vor dem Backup, ob sie das nach dem Restore immer noch hat muss ich prüfen sobald er wieder läuft. Sollte sie aber haben.