Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Applet startet nicht

Mitglied: rene640

rene640 (Level 1) - Jetzt verbinden

19.07.2006, aktualisiert 22.08.2006, 7594 Aufrufe, 1 Kommentar

Hallo!

Hab vor kurzem ein kleines Applet geschrieben. Wenn ich es in der IDE(NetBeans) starte funktioniert es einwandfrei. Doch versuche ich es im Browser zu starten so erscheint ein leeres Applet. Wenn ich die Java-Konsole öffne steht dor folgendes:

java.lang.reflect.InvocationTargetException
at java.awt.EventQueue.invokeAndWait(Unknown Source)
at NewJApplet.init(NewJApplet.java:19)
at sun.applet.AppletPanel.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.NoClassDefFoundError: org/netbeans/lib/awtextra/AbsoluteLayout
at NewJApplet.initComponents(NewJApplet.java:47)
at NewJApplet.access$000(NewJApplet.java:11)
at NewJApplet$1.run(NewJApplet.java:21)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)


Kenn mich leider mit Java nicht so gut aus. Kann mir jemand helfen??

mfg Rene
Mitglied: MartinSchmid
22.08.2006 um 11:11 Uhr
Ein bisschen spät, aber vielleicht hilfts auch jemandem anderen:

Caused by: java.lang.NoClassDefFoundError: org/netbeans/lib/awtextra/AbsoluteLayout

Das sind die Tücken von Java. Die Bibliotheken die bei deiner IDE dabei sind sind bei deinem Browser längst nicht verfügbar.

NoClassDefFoundError heißt dass die VM das Class-file nicht findet. Andere Klasse benutzen oder das class-file mit ins jar-archiv geben sollte hier Abhilfe schaffen.

mfg Martin

P.S. Es ist schon lange her, dass ich mit JAVA was hatte.
Bitte warten ..
Ähnliche Inhalte
Java
Java Deployment-Rulset Applet blockiert
Frage von adminstJava1 Kommentar

Hallo zusammen Wir setzen bei uns ein Deployment-Rulset für Java ein. Ich habe die id Location hinzugefügt und auf ...

Java
Java Applet Cache Manager
Frage von hpw2Java2 Kommentare

Hallo Kollegen, ich bin auf der Suche nach einem Java Applet Cache Manager. Um eine Hipath 4000 Telefonanlage administrieren ...

Windows 10

PowerShell Applet Export-StartLayout ohne Ausgabe?

Frage von maddocWindows 103 Kommentare

Hi Leute. Möchte meinen Windows 10 Clients ein einheitliches Startmenü und Taskleiste geben. Doch die Probleme fangen schon ganz ...

Webbrowser

Firefox startet nicht

gelöst Frage von erikroWebbrowser9 Kommentare

Moin, versucht eine Benutzerin den FF (aktuelle Version 65 unter Windows 7 aktueller Stand) zu starten, dann bekommt sie ...

Neue Wissensbeiträge
Windows Installation

Windows Install ISO mit übergroßer Install.wim auf FAT32 übertragen

Tipp von Lochkartenstanzer vor 4 TagenWindows Installation11 Kommentare

Moin Kollegen, Viele von euch werden sicher aus praktischen Gründen nicht nur DVDs oder "virtuelle" CD-Laufwerke (Zalman, IODD) zum ...

Datenschutz

Gehe zurück auf Los, ziehe keine 4.000 Mark. E-Privacy (erstmal) gescheitert

Information von certifiedit.net vor 5 TagenDatenschutz

Webbrowser

Firefox 71 verfügbar mit Picture in Picture Funktion

Information von sabines vor 5 TagenWebbrowser2 Kommentare

Die neue Firefox Version 71 unterstützt, zunächst nur für Windows, Picture in Picture. Damit kann ein Video in einem ...

E-Mail
SPF beim Versenden testen
Tipp von StefanKittel vor 7 TagenE-Mail3 Kommentare

Hallo, wenn man einen SPF für einen Exchange, oder anderen Mail-Server, konfigiruert muss man das ja auch testen. Ganz ...

Heiß diskutierte Inhalte
Windows Server
Netzwerk Planung Homeoffice
Frage von siopoqruipWindows Server17 Kommentare

Hallo, ich plane zurzeit ein kleines Netzwerk. 5-8 User jeder mit eigenem Laptop (Lenovo T590) Windows 10 Professional Homeoffice ...

MikroTik RouterOS
Mikrotik Router empfehlenswert?
gelöst Frage von matze2090MikroTik RouterOS16 Kommentare

Hallo, ich würde gerne mir Mikrotik anschauen. Reicht dieser Router zum erstmal Test? Er Kostet ca 23€. Ich habe ...

LAN, WAN, Wireless
KMU - WLAN Access Point ohne Cloud-Zwang gesucht
Frage von PalpatineLAN, WAN, Wireless14 Kommentare

Hallo, ich suche Access Points in der Preisklasse 200-300 €. Ich habe mir bereits den HPE Instant AP 15 ...

Router & Routing
Mikrotik CRS305 4Port SFP+ Router-Switch, VMWare und Fritzbox (Netzwerk Internetproblem)
Frage von SickcultureRouter & Routing13 Kommentare

Auf der Suche nach Antworten im Netz kommt man unweigerlich auf eure Seite und die deutsche Mikrotik Blog Seite. ...