Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Archlinux - Manjarno 17.06 - HyperV - kein FullHD

Mitglied: ms1970

ms1970 (Level 1) - Jetzt verbinden

19.12.2017 um 16:34 Uhr, 1310 Aufrufe, 13 Kommentare

Hallo,

bisher hatte ich jede Linux Version (Debian, Ubuntu, Fedora usw.) mit dem bewährten:

sudo nano /etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=hyperv_fb:1920x1080"

und dann

sudo update-grub

sudo reboot

dazu gebracht, im FullHD Modus zu laufen.

Aber bei Archlinux scheint es nicht zu funktonieren.

Wenn ich die Zeile ändere und dann

sudo update-grub

eingebe, meckert er wegen dem "splash".

Lasse ich es weg, scheint er es zu machen, (keine Fehlermeldung) aber nach einem reboot habe ich immer noch nur 1154*864 Pixel.

Habe schon fast alle Kompinationen durch.

Ist bei Archlinux / Manjarno irgendwas anders, oder muss noch was installiert werden?

Viele Grüße

Maik
Mitglied: BassFishFox
19.12.2017, aktualisiert um 20:55 Uhr
Hallo,

Pruefe mal ab, ob Arch das Dingens
video=hyperv_fb:1920x1080
ueberhaupt so unterstuetzt wenn Du ohne diesen Treiber hier.
https://www.archlinux.org/packages/?name=xf86-video-fbdev
unterwegs bist.

Wenn Du den Treiber hast, ist bei Dir "RemoteFX 3D Video Adpater" installiert? Wenn ja, lass es mal weg.

BFF
Bitte warten ..
Mitglied: ms1970
21.12.2017 um 16:29 Uhr
Hallo,

vielen Dank für die Antwort.
Ja, es war "RemoteFX 3D Video Adapter" aktiviert. Hatte dieses Menü vorher noch nie gesehen. Leider hat das deaktivieren nicht den gewünschten Erfolg gemacht.

Ich habe eine NVIDIA GeForce GT 610 im Windows 10 Hostsystem.

Die Auflösung ist immer noch max. 1154*864 Pixel. Keine Ahnung warum ausgerechnet diese Auflösung.
Auf Archlinux habe ich noch keine Erfahrung. Wie würde ich denn den "xf86-video-fbdev" installieren?

Das System läuft sonst genauso wie es sollte, alles funktioniert, bis auf die doofe Auflösung.
Ich muss gestehen, das auf den anderen Linux Distros immer Gnome und oder KDE installiert war.
Hier ist es "nur" xfce. Macht das einen Unterschied?


VG
Maik
Bitte warten ..
Mitglied: BassFishFox
LÖSUNG 21.12.2017, aktualisiert 22.12.2017
Hallo,

https://wiki.archlinux.de/title/X

Also dann so :

01.
pacman -S xf86-video-fbdev
Hier ist es "nur" xfce. Macht das einen Unterschied?

Nicht wirklich, solange in der verwendeten Distro bei xfce eventuell kein "xf86-video-fbdev" mit dabei ist. Und das nicht Vorhandensein bei Arch Linux kann ich mir vorstellen.


BFF
Bitte warten ..
Mitglied: ms1970
22.12.2017 um 10:15 Uhr
Hallo,
vielen Dank schon mal. Konnte die Datei installieren, hat aber leider nichts gebracht. Alles unverändert.

mj17-1rc1 - Klicke auf das Bild, um es zu vergrößern

Hab es mit und ohne hyperv-remotefx - Klicke auf das Bild, um es zu vergrößern

versucht.

Mir ist nur gerade aufgefallen, das es die Manjarno Version 17.1 RC1 ist. Nicht die 17.06
Hab auch KDE installiert, aber das nützt auch nichts.
Seltsam.
VG
Maik
Bitte warten ..
Mitglied: ms1970
22.12.2017 um 10:17 Uhr
Die Bezeichnung Datacenter2012 ist falsch. Es ist ein normales Windows 10 Pro.
Ich bin nicht als root eingeloggt, habe ich evtl. nicht alle Rechte?
VG
Maik
Bitte warten ..
Mitglied: ms1970
22.12.2017 um 10:35 Uhr
Unter Ubuntu 17.10 mit den gleichen HyperV Einstellungen heißt der Treiber der Grafikkarte:

Gallium 0.4 on llvmpipe (LLVM 4.0, 128 bits)

Dort funktioniert es.
Bitte warten ..
Mitglied: BassFishFox
22.12.2017 um 14:36 Uhr
Hallo,

Hyper-V und Linux habe ich noch nie eingesetzt. Einfach nicht noetig da ich mehr mit VMware zu tun habe.

Angeblich soll es mit Arch und Hyper-V gehen. Schreiben die Leute hier.
https://bbs.archlinux.org/viewtopic.php?id=195424

Finally rebuild grub configuration file, usually with the command:
01.
grub-mkconfig -o /boot/grub/grub.cfg
Hattest Du so bei Arch grub aktualisiert, weil Du schreibst ja
01.
sudo update-grub 
BFF
Bitte warten ..
Mitglied: ms1970
22.12.2017 um 15:10 Uhr
Hallo,
ich "fürchte" es ist zu spät, weil bei der Installation von Manjarno der RemoteFX 3D Video Adapter aktiviert war.
Ich weiß nicht, ob ich das wieder aus dem System entfernen kann.

Das System ist ganz frisch installiert.
Ich versuche es jetzt mal als neue VM zu installieren und lasse den RemoteFX 3D Video Adapter weg.

VG
Maik
Bitte warten ..
Mitglied: BassFishFox
22.12.2017, aktualisiert um 15:19 Uhr
Ok.

Wusste garnicht, dass Manjaro so PlugNPlay ist. Vielleicht muss ich ueber die Feiertage auch mal einen Blick darauf werfen.

Manch eine Distri wird immer etwas anders sich verhalten in einer VM, ist bei VMware nicht anders. Gerade dann, wenn es keine Open-VM-Tools fuer die Distri gibt bzw. die VMwareTools partout nicht wollen.

Schoenes WE.
BFF
Bitte warten ..
Mitglied: ms1970
22.12.2017 um 16:00 Uhr
ja, ist ja auch ein RC, wie mir eben erst aufgefallen ist.

Hab das Manjarno jetzt ohne "RemoteFX 3D Video Adpater" installiert.

Als ich die Original grub editierte, sah ich folgendes:

GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=ce2ea6a9-3bb2-4ff0-bdf8-f13e5a1d20b1"

Das war mir gar nicht aufgefallen.

Das ändern (GRUB_CMDLINE_LINUX_DEFAULT="video=hyperv_fb:1920x1080" ) hat dann auch nichts gebracht.

Nur beim booten fällt mir jetzt auf, das ganz oben eine Fehlermeldung steht, die ich aber kaum lesen konnte.

In der Log von /var/log/Xorg.0.log

v1 - Klicke auf das Bild, um es zu vergrößern


v2 - Klicke auf das Bild, um es zu vergrößern

Musste die Screenshots machen, leider kann ich per SSH noch nicht auf die Machine. Und die Zwischenablage funktioniert bei HyperV und Linux sogut wie nie.

Vielleicht gibt es wo ganz anders noch Möglichkeiten was einzustellen?

VG
Maik
Bitte warten ..
Mitglied: BassFishFox
LÖSUNG 22.12.2017, aktualisiert um 16:22 Uhr
Das

01.
resume=UUID=ce2ea6a9-3bb2-4ff0-bdf8-f13e5a1d20b1
hast Du doch sicherlich drin gelassen. Das ist fuer Hibernation wichtig. Und wie hast Du GRUB aktualisiert? Steht Dein Eintrag auch in der grub.cfg? Und ist der FrameBufferTreiber (xf86-video-fbdev) installiert?

Und die Zwischenablage funktioniert bei HyperV und Linux sogut wie nie.

Das ist warum ich bei VMware bin.

Achja, welche Version W10 hast Du? 1709 Build 16299.125?

BFF
Bitte warten ..
Mitglied: ms1970
22.12.2017 um 16:48 Uhr
Mir läuft die Zeit davon. Nur noch ein paar Minuten.
Dann kann ich erst am 2. Januar wieder weiter probieren.

xf86-video-fbdev hatte ich nicht installiert, weil ich die Funktion in HyperV abgeschaltet hatte.

Da ist noch was komisches passiert.

Als ich mit "sudo pacman -Syu openssh " openssh installiert habe, damit ich an die Logdateien evtl. mal ohne abtippen ran komme, wurde ich 2 mal gefragt, ob ich irgendwelche Pakete installieren wollte und hab 2 mal Ja getippt.

Dann hat die VM über 780 MB runtergeladen und alles mögliche u.a. Thunderbird installiert. Per SSH komme ich immer noch nicht auf die Machine. Vielelicht sollte ich bei Debian oder Fedora bleiben.


Meine Windows Version ist: [Version 10.0.17025.1000]

Wünsche Dir schöne Weihnachten und ein frohes Neues Jahr.
Bitte warten ..
Mitglied: BassFishFox
LÖSUNG 22.12.2017 um 18:25 Uhr
Lesen kannst Du auch zu hause.

xf86-video-fbdev hatte ich nicht installiert, weil ich die Funktion in HyperV abgeschaltet hatte.

Ohne diesen Treiber geht es nicht.

Vielelicht sollte ich bei Debian oder Fedora bleiben.

Warum nicht. Ich nehme auch nur Debian und zur Not ein Lubuntu. Die Serverlinge allerdings SuSE.

Version 10.0.17025.1000

Also etwas aeltere Insider. Egal.

Schoene Weihnachten und ein gesundes neues Jahr Dir auch.

BFF
Bitte warten ..
Ähnliche Inhalte
Hyper-V
HyperV Backup
gelöst Frage von PharITHyper-V7 Kommentare

Hallo allerseits, eine kurze Frage: Aufgrund welcher Kriterien entscheidet Ihr Euch (also hauptsächlich) für welche Backup Lösung mit HyperV? ...

Hyper-V
HyperV - Remotezugriff
Frage von schicksalHyper-V3 Kommentare

Hallo zusammen, kurzes Vorwort, ich habe einige Rechner mit Windows 10 1809 die bisweilen über den Hyper-V Manager Remote ...

Linux

Archlinux plant die i686 (32Bit) Unterstützung einzustellen

Information von mrtuxLinux

Hi Kollegen! Die Maintainer der Archlinux Distribution planen anscheinend die Unterstützung für die i686 (32Bit) Plattform einzustellen. Gründe für ...

Linux

Login Manager bei Linux Mint Cinnamon für ArchLinux?

Frage von WinLiCLILinux2 Kommentare

Hallo zusammen, ich bin gerade dabei für ArchLinux den LoginManager auszusuchen. Mit gdm als LoginManager habe ich noch den ...

Neue Wissensbeiträge
LAN, WAN, Wireless
OPNsense Captive Portal mit vordefnierten Voucher
Tipp von Crusher79 vor 7 StundenLAN, WAN, Wireless

Hallo, Ziel war es vorhandene Klienten-Daten (Nummer im System) und Kennwörter anzulegen. Voucher werden durch externes Programm in Papierform ...

Administrator.de Feedback
Entwicklertagebuch: Die nächste Version
Information von admtech vor 1 TagAdministrator.de Feedback6 Kommentare

Hallo Administrator User, vielleicht haben es einige User schon mitbekommen: Wir arbeiten aktuell an einer komplett neuen Version von ...

Windows Server

Active Directory ESE Version Store Changes in Server 2019

Information von Dani vor 4 TagenWindows Server

Moin, Last month at Microsoft Ignite, many exciting new features rolling out in Server 2019 were talked about. But ...

Exchange Server

Microsoft Extending End of Support for Exchange Server 2010

Information von Dani vor 4 TagenExchange Server5 Kommentare

Moin, After investigating and analyzing the deployment state of an extensive number of Exchange customers we have decided to ...

Heiß diskutierte Inhalte
Netzwerkgrundlagen
Zukunftsicheres Heimnetzwerk aufbauen
Frage von CRO-WarriorNetzwerkgrundlagen16 Kommentare

Hallo Leute. Ich bin dabei das Haus in Kroatien zu renovieren. Da hab ich jetzt die Möglichkeit alles so ...

Router & Routing
Anmeldung am Router von einer ext. IP?
Frage von BigSnakeyeRouter & Routing14 Kommentare

Hallo, ich habe gerade seltsames in meiner Fritzbox entdeckt. Plötzlich war die Verbindung unterbrochen - kein Internet. Also habe ...

Windows Server
Windows Domäne, SBS 2011, Anmeldung als Admin nicht mehr möglich
Frage von big-dummyWindows Server14 Kommentare

Hallo, vorab: ich habe nun leider keine Grundruhe mehr - die Folgen wären katastrophal. Was ist das Problem: Ich ...

KVM
Performance Verlust durch Virtualisierung
Frage von RalleoniusKVM12 Kommentare

Hallo zusammen, ich überlege meinen Server mit Debian, der als Webserver dient zu virtualisieren um eine 2te Maschine auf ...