Build 2004 Server und Client Partition Wiederherstellung?

dertowa
Goto Top
Hallo zusammen,

ich teste aktuell ein wenig mit dem aktuellen Build des Server 2004 und der passenden Clientversion.
Nun bin ich etwas verwirrt wie Microsoft sich das vorstellt.

Mir war beim Client in der Neuinstallation schon aufgefallen, dass vornweg in der Partitionierung beim Setup
nur noch eine 100 MB Partition angelegt wird, dann die 16 MB MSR?! und danach die Hauptpartition.

Nun gestaltet sich das nach dem Installationsabschluss wie folgt am Beispiel des Server 2004:
srv2004
Ich habe der VM abschließend einfach mal 10 GB weiteren Speicherplatz gegeben, Erweiterung ist nun
aber so nicht möglich, da die Hauptpartition eben nicht die letzte Partition ist.

Beim Server 2019, also 1809 war das noch problemlos, da die Wiederherstellungspartition vorn angelegt wurde:
srv1809

Am Clientsystem ist selbiges, bis 1909 alles wie Server 2019, aber 2004 identisch zum entsprechenden Server.

Selten dämlich, oder gibt es da einen nachvollziehbaren Grund?

Löschen kann ich die Partition ja via diskpart, aber muss die danach wieder angelegt werden?

Grüße
ToWa

Content-Key: 578101

Url: https://administrator.de/contentid/578101

Ausgedruckt am: 03.07.2022 um 03:07 Uhr

Mitglied: NordicMike
NordicMike 10.06.2020 um 12:43:36 Uhr
Goto Top
Wenn du bei der Partitionierung nicht auf weiter drückst und es selbst partitionieren lässt, kannst du die Partitionen selbst bestimmen. Hast du das mal ausprobiert?
Mitglied: dertowa
dertowa 10.06.2020 um 12:50:04 Uhr
Goto Top
Jap, dann wird die Wiederherstellungspartition im Gegensatz zu den vergangenen Versionen NICHT angelegt, ist aber dennoch nachher wie oben am Ende konfiguriert. :D
Mitglied: dertowa
dertowa 10.06.2020 um 12:54:47 Uhr
Goto Top
Ich überlege gerade ob ich die nagelneue Domain auf Basis von 2004 aufbaue, aber dies ist schon direkt ein Störgefühl. ace-sad"
Mitglied: NordicMike
NordicMike 10.06.2020 um 13:40:07 Uhr
Goto Top
Domain? Wenn du den Domain Controller als VM ausführst, kannst du ihm einfach ungesehen pauschal eine kleine 50GB VM geben, die wirst du nie erweitern müssen. Ich hoffe du hast nicht vor auf dem Domain Controller noch andere Dienste zu aktivieren. Du kennst ja unsere Sprüche, die wir 5x pro Tag hier posten: Ein DC ist ein DC und nur ein DC. Also plane noch eine zweite VM für die Dienste. Eine VM benötigt auch keine Wiederherstellungspartitionen, du hast ja Snapshots dafür, das es in Sekunden zurücksetzt, und auch ein Backup z.B. Veeam, das dir die VM wiederherstellt.
Mitglied: tech-flare
tech-flare 10.06.2020 aktualisiert um 14:03:54 Uhr
Goto Top
Warum denn ausgerechnet Server Build 2004 und nicht 1909?

Bei 2004 endet der Support eher.

Was erhoffst du dir von Build 2004 im Serverbereich?
Mitglied: dertowa
dertowa 10.06.2020 aktualisiert um 14:05:40 Uhr
Goto Top
Zitat von @tech-flare:
Was erhoffst du dir von Build 2004 im Serverbereich?
Naja wir haben eine SoftwareAssurance zu dem ganzen, von daher ist auch der Hyper-V Host 2004.
Es gibt ja durchaus einige Änderungen, weniger beim Domaincontroller schon klar, die Möglichkeit ist eben da.

Aber darum geht es ja gar nicht, ich würde einfach gern verstehen was da passiert.

Warum sieht es in der Installation so aus wie links und wenn der Core-Server fertig installiert ist, sind die Partitionen wie rechts?
install
srv2004

Ist ja auch so ohne dass ich die VHDX um 10 GB erweitert habe. ;)
Mitglied: NordicMike
NordicMike 10.06.2020 um 16:02:46 Uhr
Goto Top
Das wird dir nur Microsoft beantworten können. Nachdem das jedoch auf die .vhdx Datei keine Auswirkung hat, die diese komprimiert und den leeren 10GB Bereich gar nicht befüllt, ist es für dich als Benutzer auch weniger Relevant. Ich würde mir da keine Gedanken machen. Erst recht nicht, wenn es ein Domain Controller ist. Bei einem Applikationsserver musst du jedoch aufpassen, falls du den wirklich mal erweitern möchtest. Selbst da kannst du alles brav auf eine zweite Datenpartition spielen und die Bootpartition klein lassen. Aber auch da benötigst du keine Wiederherstellungspartition bei einem ordentlichem Backup. Es steht also nichts im Wege diese nachträglich zu löschen, wenn sie dich stört.
Mitglied: DerWoWusste
DerWoWusste 11.06.2020 um 11:34:02 Uhr
Goto Top
Du arbeitest nicht wie empfohlen mit GPT disks, sprich: du startest das Setup nicht als UEFI, sondern als MBR (sieht man an der Bezeichnung "Basisdatenträger")

Teste mal als UEFI, ich bin mir sicher, da wird sich alles normal verhalten.
Mitglied: dertowa
dertowa 11.06.2020 um 13:44:58 Uhr
Goto Top
Hmm würde ich bezweifeln, denn die VM ist als Gen 2 angelegt:
uefi

In den Einstellungen steht dann auch:
gpt

Die DVD-ISO ist ausm VLSC und die Anbindung ist standard:
dvd
Mitglied: DerWoWusste
DerWoWusste 11.06.2020 aktualisiert um 14:40:41 Uhr
Goto Top
Sorry, mein Fehler - Basisdtg. hat gar nichts mit MBR zu tun, *doh*
Ich werde jetzt ein 2004 installieren - mal sehen.
Bei 1903 passiert das unerwünschte Anlegen einer Partition hinter c: nicht.
Mitglied: dertowa
dertowa 11.06.2020 um 14:23:16 Uhr
Goto Top
Richtig, tritt nur bei Client und Server 2004 auf. face-smile
Mitglied: DerWoWusste
DerWoWusste 11.06.2020 um 14:41:12 Uhr
Goto Top
Ok, ich kann das bestätigen.
Mitglied: DerWoWusste
DerWoWusste 11.06.2020 um 14:43:45 Uhr
Goto Top
Dann viel Spaß beim Kampf mit dem MS Support.
Sonst bleibt dir entweder manuelle Partitionierung oder 1903 installieren und upgraden.
Mitglied: DerWoWusste
DerWoWusste 11.06.2020 um 15:05:06 Uhr
Goto Top
So, eine akzeptable Lösung: man lässt nicht Setup partitionieren, sondern macht es selbst, dazu muss man nur auf "Neu" im Partitionierungswizard klicken und auf OK (volle Größe wird beibehalten, alles funktioniert)!

Warum die eingebaute Automation anders arbeitet, bleibt wirklich MS' Geheimnis.
Mitglied: dertowa
dertowa 11.06.2020 um 15:05:11 Uhr
Goto Top
Zitat von @DerWoWusste:

Dann viel Spaß beim Kampf mit dem MS Support.

Ich schau mal was der Support für die 2004 Serverversion rausbringt.
Betrifft mich jetzt erstmal nur beim HyperV Coreserver, da ist mir das erstmal egal,
die C - Partition wird großzügig ausgelegt.
Beim Rest setz ich dann aber lieber vorerst auf die 2019 also 1809 und warte mal ab. :D

Nur bei den Clients ist das auch selten dämlich, sowas muss doch auffallen, oder installiert
das keiner mal frisch bevor das freigegeben wird? ace-sad"
Mitglied: dertowa
dertowa 11.06.2020 um 15:08:13 Uhr
Goto Top
Zitat von @DerWoWusste:
dazu muss man nur auf "Neu" im Partitionierungswizard klicken und auf OK (volle Größe wird beibehalten, alles funktioniert)!

Hmm nee, du siehst dann, dass er dir die Wiederherstellungspartition NICHT anzeigt.
Wenn die Installation fertiggestellt wird und man in der Datenträgerverwaltung schaut ist sie aber hinten existent. :D

Ich lasse die Automatisierung nie laufen, sondern klicke immer einmal auf "Neu". ;)
Mitglied: DerWoWusste
DerWoWusste 11.06.2020 aktualisiert um 15:26:56 Uhr
Goto Top
Wenn die Installation fertiggestellt wird und man in der Datenträgerverwaltung schaut ist sie aber hinten existent. :D
Nee, schau mal:
capture
Mitglied: dertowa
dertowa 11.06.2020 um 15:23:43 Uhr
Goto Top
Funny...
Unterschied zwischen deutsch und englisch?

Also bei meinem PC ist es so und auch in jeder VM die ich mit 2004 installiere.
PC wurde mit einem USB-Stick des MediaCreationTool frisch mit 2004 installiert,
die VM versorge ich mit dem VLSC Image.

Beides in der Installationsroutine mit "Neu" vor partitioniert, wo die Wiederherstellungspartition nicht ersichtlich ist, sondern nur:
  • EFI 100 MB
  • 16 MB
  • Rest der Festplatte

Nach der Installation sagt die Datenträgerverwaltung aber und das habe ich jetzt gerade noch mal frisch in einer VM probiert:
2004

Wohl gemerkt meine ISO ist auch ein neueres Build, aber die ist final aus dem VLSC?
Mitglied: DerWoWusste
DerWoWusste 11.06.2020 um 15:55:55 Uhr
Goto Top
Ich lach mich wech...
Dachte mir schon, dass du wegen der Versionsnummer ankommst... habe mein Setup gerade einfach noch einmal wiederholt - das gleiche gemacht und noch einmal (in einer VM mit neuer VHDX) und habe nun wieder das Selbe wie Du.
Race condition? Irgendwas riecht da sonderbar faulig.
Mitglied: dertowa
dertowa 11.06.2020 um 16:27:03 Uhr
Goto Top
Zitat von @DerWoWusste:

Ich lach mich wech...

So lustig find ich das gar nicht. :D
Aber so sind wir von der "akzeptablen" Lösung wieder weg und die 2004
ist mal wieder eine Version die für frische Installationen irgendwie nicht gedacht ist...
Mitglied: DerWoWusste
DerWoWusste 11.06.2020 um 16:54:29 Uhr
Goto Top
Du kannst 1909 Setup starten, partitionieren, abbrechen und dann 2004 installieren.
Mitglied: dertowa
dertowa 11.06.2020 aktualisiert um 16:58:44 Uhr
Goto Top
Hmm stimmt, das wäre noch ein möglicher, wenn auch unnötiger Workaround. face-smile